Jump to content

Ayuda Apagado snow leopard asus P5k-E wifi Ap?


elnorber
 Share

4 posts in this topic

Recommended Posts

wenas, tengo la placa base asus p5k-E wifi Ap funcionando en snow leopard pero no al 100% tal y como me gustaría a mí.

 

El principal problema es que no consigo que se apague el equipo, tengo que reiniciar, arrancar con windows 7 y apagar desde allí. Es una buena solución, pero algo molesta.

 

La placa base contiene lo siguiente:

 

- Dispone del chip P35/ICH9

- Jmicron JMB363 Pata y Sata controlador

- Targeta de red marvell 88E8056

- Tarjeta de red wifi asus (la tengo desactivada en la bios porque tengo otra tarjeta mejor)

- Sonido AD1988B

-Targeta grafica nvidia 8600 GTS instalada con EFIstring

- 6 gigas de Ram

 

Desde leopard, más concretamente iatkos v7 instalé snow leopard. Luego instalé myhack1,0 y puse en la carpeta extra/extensions los kexts corresponientes a mi placa base. En la carpeta extra, añadi mi archivo dsdt compilado en mi maquina, el smbios.plist y con uistaller la grafica a traves de efistring.

 

Por último con pfix arreglé los permisos y me autoconstruyó extensions.mkext. Reinicio y perfecto, todo funciona menos el apagado.

 

Ahora mismo tengo el sistema totalmente actualizado a 10,6,2.

 

Los kexts que tengo en la carpeta extra/Extension son:

 

captura2v.png

 

He probado añadiendo a la carpeta /extra/extensions los kexts NullCPUPowerManagement y SleeperEnabler para 10,6,2. Uso pfix para arreglar permisos y reconstruir extensions y el equipo no se apaga y el reposo no funciona (el reposo es algo que no uso así que me da igual)

 

No se si el apagado depende del smbios.plist, pero creo que no está del todo correcto.

<?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
 <plist version="1.0">
 <dict>
	  <key>SMbiosversion</key>
	  <string>MP31.88Z.00C1.B00.0802091544</string>
	  <key>SMmanufacter</key>
	  <string>Apple Inc.</string>
	  <key>SMproductname</key>
	  <string>MacPro3,1</string>
	  <key>SMsystemversion</key>
	  <string>1.0</string>
	  <key>SMserial</key>
	  <string>W87234JHYA4</string>
	  <key>SMexternalclock</key>
	  <string>333</string>
	  <key>SMmaximalclock</key>
	  <string>3000</string>
	  <key>SMmemtype</key>
	  <string>19</string>
	  <key>SMmemspeed</key>
	  <string>800</string>
	  <key>SMmemmanufacter_1</key>
	  <string>0xAD00000000000000</string>
	  <key>SMmemserial_1</key>
	  <string>0x00001020</string>
	  <key>SMmempart_1</key>
	  <string>0x48594D503131325336344350362D59352020</string>
	  <key>SMmemmanufacter_2</key>
	  <string>0xAD00000000000000</string>
	  <key>SMmemserial_2</key>
	  <string>0x00003021</string>
	  <key>SMmempart_2</key>
	  <string>0x48594D503131325336344350362D59352020</string>
	  <key>SMmemmanufacter_3</key>
	  <string>0xAD00000000000000</string>
	  <key>SMmemserial_3</key>
	  <string>0x00003021</string>
	  <key>SMmempart_3</key>
	  <string>0x48594D503131325336344350362D59352020</string>
	  <key>SMmemmanufacter_4</key>
	  <string>0xAD00000000000000</string>
	  <key>SMmemserial_4</key>
	  <string>0x00003021</string>
	  <key>SMmempart_4</key>
	  <string>0x48594D503131325336344350362D59352020</string>
 </dict>
 </plist>

 

Creo que está mal porque mi micro es un intel core 2 duo 6750 a 2,66 ghz.

 

Lo más probable, que el problema está en el DSDT que esté mal configurado o no del todo bien.

 

Aquí os subo mi DSDT por si tengo algo más o es necesario añadirle algo. Cabe decir que al compilar no me dio ningún error ni warnings y ponía 41 optimizaciones.

 

http://www.megaupload.com/?d=GKTDS1U4

 

Salu2 y gracias de antemano.

Link to comment
Share on other sites

Cuando snow leopard arranca, si a la hora de botear con chameleon elegimos -v modo verbose, vemos si algo falla cuando se inicia el sistema.

 

Como no consigo que el equipo se apague, me preguntaba si existe algun modo para que al apagar muestre algun mensaje de error para saber que es lo que falla para que el pc se quede con los ventiladores funcionando.

Link to comment
Share on other sites

  • 3 months later...

Buenas compañero. Me preguntaba si e puedes explicar o decir donde puedo saber como instalar la 10.6.2 en la misma placa que tienes (una P5K-E Wifi AP). Solamente he visto una explicación en ingles, y no me resulta nada cómodo traducirlo, ya que contiene demasiados tecnicismos.

 

Si quieres nos ponemos en contacto por messenger o skype.

 

 

Gracias de todos modos y un saludo.

Link to comment
Share on other sites

  • 5 weeks later...

 Hola

 

 

          <key>SMcputype</key>   

 

          <string>769</string>

 

Eso deberías agregar para que reconozca el procesador,pero en teoría es solo cosmética, o sea no afecta al funcionamiento.

 

Por lo del apagado prueba remplazar el openhaltrestart y el osxrestart (quitarlos de la carpeta extra) y poniendo el EvOreboot.kext (googlealo), Ejecutar Kext Utility (googlealo) reiniciar y después probar si apaga.

 

OJO todo es prueba error hasta encontrar los kexts que funcionen.

 

Y en cuanto al dsdt,aunque no tenga errores ni warnings igual hay que revisar ciertas cosas como por ejemplo que no haya alias en los cpus, y arreglar si es necesario las secciones HPETy RTC por lo menos.

 

Espero que te sea útil la info.

 

Saludos  ;)

 

 

 

  

Link to comment
Share on other sites

 Share

×
×
  • Create New...