Jump to content

Snow Leopard on ASUS P5QD Turbo


8 posts in this topic

Recommended Posts

Hi all!

I got motherboard Asus P5QD Turbo

[Lan Atheros AR8121, Sound VIA VT1708S]

+ Intel Pentium dual-Core E6300 2.8

+ Kingston DDR2 2Gb PC2-6400

+ Asus Nvidia GeForce EN9500 GT


First of all in BIOS I Disable ACPI 2, APIC.

I tried to install Universal Leopard 10.5.6; Universal Snow 10.6.2; - not loading install

tried iDeneb 1.5.1 (10.5.7)


language, DSDT patcher, Chameleon v2, CPUS=1, ACHI Fix, ICHx Fixed, AppleGenericPCATA.

install succesfully completed (was horribly long), but after reboot i see white screen with apple logo, below it - "loading"

and thats all... like an hour, nothing happens

Enable ACPI 2, APIC - nothing change.


Boot with -v

USBF:  0.590  AppleUSBEHCI[0x448e800]: unable to get filterInterruptEventSource
USBF:  0.591  AppleUSBEHCI[0x448e800]: :UIMInitialize - Error occurred (0xe00002be)
USBF:  0.627  AppleUSBEHCI[0x448e800]: unable to initialize UIM
USBF:  0.633  AppleUSBEHCI[0x448e800]: unable to initialize UIM
FireWire (OHCI) VendorID 1106 PCI now active, GUID 001e80001fe358; max speed s400.
USBF:  5.634  AppleUSBEHCI[0x448e800]: unable to initialize UIM
USBF:  5.635  AppleUSBEHCI[0x448e800]: unable to initialize UIM
ERROR: FireWire unable to determine securiti mode; defaulting full-secure.

after that every 5 minutes, add the string "Still waiting for root device"


KALYWAY Leo 10.5.1 - not loading install


Than tried to install retail Snow Leo.

Enable ACPI 2, APIC.

I restore image of a retail Snow Leopard DVD disk to my external HDD,

Use Empire EFI 1.085 to boot, after selected HDD see that:

"ACPI Table not found: DSDT.aml"


How can i Create dsdt.aml and insert it to image Leo on HDD, without any working mac os?


any advise?



Link to comment
Share on other sites

Ok, i finaly got it :)

Some "Guide" for Install Leopard on this configuration ^^


1. Download iATKOS v7

2. Burn image disk with low speed (~2.4x)

3. in BIOS

EXIT => Load Setup Defaults.

MAIN => Storage configaration => Configue SATA as AHCI.

ADVANCED => J-Micron ..... - Enabled; Controller mode - AHCI.


Exit & save.

5. load up iATKOS v7.

6. Open Disk Utility and format HDD to Mac OS Extended (Journaled) [MBR]. See its "Disk identifier" (go to File=>Get info) write down it. Close disk utility. Continue install

7. choose destination install. (it is important that you know "Disk identifier" which will install) click continue

8. Click "customize"

I put a checkmark in:

+ iATKOS v7 Main System

+ Bootloader: Chameleon v2

+ X86 Patches: /Extra directory; DSDT; Decrypters => AppleDecrypt; ACPI both; Disabler.

+ Drivers: VGA - Choose your own

System - SATA IDE => AHCI, JMICRON SATA/IDE; Sound => Voodoo HDA.

+ Post-Install Actions.

And click Install.

9. After Install do NOT REBOOT! Before that go to Utilities => Reset Password, and resets all passwords. than u may reboot.

10. oops we see some kernel panic) that ok. well, not really ok.. :P havent any idea why this happen

just ignore that)

11. reset u computer

12. in chameleon screen select section with installed mac os, and wrote "-v rd=Your Disk identifier" or "-v rd=diskXsY", where "X" - number of connected socket sata hdd with mac os, and "Y" - partition number (if there). for example "-v rd=disk0" or "-v rd=disk1s2" without quotes

(if somethng gone wrong and chameleon doesn't loaded just remove dvd)

if u still had "still waiting for root device" see u Disk identifier again or try

rdisk=/dev/diskXsY idlehalt=0 cpus=2(or 4) plaform=x86pc*

*where x86pc = AMD, acpi = Intel.

cross your finger and wait for the moment of truth)) :)

next screen u see - greeting screen.

Thats all, u have almost working MAC OS X 10.5.7. :D

i say almost becouse Shutdown, reboot & sleep doesnt work.

oh, one more thing..

a chameleon, in order not to write every time "-v rd=diskXsY",

go to Mac HDD / Library / Preferences / SystemConfiguration / com.apple.Boot.plist

need to add a single line

after <key>Kernel Flags</key>

add <string>-v rd=diskXsY</string>


Processor - recognized*

USB - works

Audio works

Video - works*

* - depend of u configuration


sorry 4 my English,

and commenting on established or not?


Link to comment
Share on other sites

  • 2 weeks later...

I'm really sorry to post this here, but I can't make a topic on my account. I just registered, and every time I try to make a topic, I get a board message, saying:

Sorry, you do not have permission to start a topic in this forum

If anyone can help, thanks a lot. Again, I'm sorry for posting this here.



Link to comment
Share on other sites

  • 1 month later...

I've got it two days ago. After some tricks with BIOS and DSDT, I've got SL10.6.3 Retail to working like a charm.

Shutdown/Sleep/Wake/Hibernate works OOB with LPC running. no need for 3rd party kexts like OHR, Evo.., or SleepEnabler, everything is working natively. :(


PS: only audio hasn't tested, because I use prof.soundcard.

Link to comment
Share on other sites

  • 4 weeks later...
  • 5 months later...

  • Create New...