Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Insanely Mac

HP Mini 210 HD Series. OSX Compatible?

69 posts in this topic

Recommended Posts

Hello everyone,


Im new here so sorry if I am posting in the wrong section of the forum. I just wanted to know if there are any support for the new HP Mini 210 HD series for OSX install.

HP Mini 210 HD



Intel® Atom Processor N450 (1.66GHz, 512KB) with Intel® Graphics Media Accelerator 3150

1GB DDR2 System Memory (1 Dimm)

160GB 7200RPM SATA Hard Drive

10.1" diagonal HD LED HP BrightView Infinity Widescreen Display (1366 x 768)

HP Mini Webcam

Wireless-G Card

3 Cell Lithium Ion Battery

5-in-1 integrated Digital Media Reader

Accessible memory slots: 1

Maximum Memory Expansion: 1GB

Ports: 3 USB Ports, RJ-45, VGA


I notice other netbooks can use more than 1gb of memory, if this netbook is able to run OSX, will it be slow? I will only be using this for basic computing and on the go online surfing, note taking, chatting. I already have a Mac Book Pro 13'' Unibody 2.56ghz, I just want something smaller for on the go purposes.


Dude, I'm sorry but I can't help you, I'm only posting to say you have one heck of a username xD

Share this post

Link to post
Share on other sites


i've also a hp mini 210-1020sl.

is there a FULL guide to install osx on this netbook?

with all the steps, the missing files, etc?


Share this post

Link to post
Share on other sites
Quick update-

Chickened out today and started over with a 10.5.1 install via the same method.

-NetbookMaker 0.8.4 wouldn't recognize my USB Leopard Installer, had to use 0.8.3.

-Installer would hang on the grey Apple logo, so switched to 32-bit mode "-legacy" at the Darwin screen

-WiFi now works like a dream

-Trackpad AND BUTTONS seem to be working fine

-Audio still not working, but I'm going to try some Kexts later today, will report back if I get it working

Share this post

Link to post
Share on other sites

Can somebody post the patched "AppleIntelGMA950.kext" and "AppleIntelIntegratedFramebuffer.kext modified to work with the GMA3150? I don´t seem to be able to patch them myself

Share this post

Link to post
Share on other sites

i can't get the graphics work even in 32 bit mode also i've got the <pci14e4,4315> already there but the WiFi not working


any solution ?


Please Help me!!

Share this post

Link to post
Share on other sites
I used the NetbookCD image that was linked above (originally meant for the Dell Mini series, I believe, but it worked for me). Burn that to disk, boot it, when it finishes coming up, hit F5 and wait for "Mac OS X Install DVD" to appear, highlight it, and then enter:


mach_kernel -v arch=x86_32


(The "arch=x86_32" flag seems to be required, since the version of Chameleon on there seems to want to boot the 64-bit kernel on 64-bit capable machines, except that it won't actually start it; the "-v" is for good measure, as occasionally it locks hard for me just before starting launchd, and I haven't figured out exactly why.)


Assuming everything went right, you should land at the OS X installer.


The process should be almost exactly what's here: http://osx.mechdrew.com/guides/nbi3.shtml


The minimum requirements listed there are all good, except that you can ignore the part about the GMA 500/950 - the system will boot in VESA mode for the system, which runs the GUI.


Booting for install:

- Make sure your DVD drive is plugged in, with the NetbookCD disk in the drive before you power up. (It needs to be in the drive before startup - otherwise, the BIOS won't recognize it as a bootable disk, and will skip to trying to boot the internal HD instead.) You also need an external mouse: the trackpad will work for pointing, but the buttons are non-functional.

- At the HP logo screen, hit ESC to get to the BIOS boot menu. Hit F9 to get to the startup disk options, and choose your DVD drive to boot from.

- Once the NetbookCD loads, you'll get a list of available drives to boot from. Eject NetbookCD and put in your OS X DVD. Hit F5 and wait a moment; "Mac OS X Install DVD" should appear.

- Highlight "Mac OS X Install DVD" (hit the right arrow as necessary); then type "mach_kernel -v arch=x86_32". Some messages will appear about files being loaded, and then you should start seeing messages from the OS X kernel. It might take a few minutes for the whole thing to finish loading. To make sure it hasn't locked up (and therefore you need to reboot and try again), wait for "ApplePS2Keyboard" to show that it's loaded (you'll see messages about it detecting a keyboard and a trackpad), and then try tapping the Caps Lock key; if it's LED doesn't turn on, it's frozen and needs to be rebooted.



The procedure is as listed under "Installing Mac OS X" on the linked page. At the end, it *will* claim that the install failed - you can safely ignore this message. The failure is caused by OS X not being able to tell it's firmware that it should boot from the installed drive, which doesn't matter because we still have to install the bootloader. Before you reboot, put the NetbookCD disk back into the drive.


First boot:

- Boot from the CD as was done under "Booting" above. When you get to the NetbookCD disk selection screen, choose the disk you installed OS X to and enter "mach_kernel -v arch=x86_32". It will boot off of the internal drive and bring up the OS X setup screen; the video won't play because there isn't an audio device as far as the system is concerned, yet.

- Follow the instructions in step 4; ignore the complaints from NetbookInstaller regarding there not being a set of extensions for your machine, and install the general extensions. No need to generate a DSDT.aml file - the system's DSDT works fine.

- Before rebooting, edit /Extra/com.apple.Boot.plist:

Find "<key>Kernel Flags</key>"; place "arch=x86_32 -v" into the "<string>" tag beneath it.

- Reboot.


Other setup:

For audio:

- Install VoodooHDA.kext into /Extra/AdditionalExtensions. and then run /Extra/UpdateExtra.app. Reboot and audio should work.

For wireless:

- Get IO80211Family.kext, Apple80211.framework from 10.5.x (I grabbed these from a 10.5 install DVD - the former in /System/Library/Extensions, the latter in /System/Library/PrivateFrameworks).

- Install IO80211Family.kext to /Extra/AdditionalExtensions. Edit /Extra/AdditionalExtensions/IO80211Family.kext/Contents/Plugins/AppleAirPortBrcm43xx.kext/Contents/Info.plist to add "pci14e4,4315" to the list of supported devices (look for "pci14e4,43", and add a similar line with the previous PCI ID to it).

- Run /Extra/UpdateExtra.app, and then reboot. On startup, you should see a message stating that it found your wireless adapter.

- To connect, run (from your 10.5 copy of Apple80211.framework) Apple80211.framework/Resources/airport '-I<your SSID>'. The AirPort control panel & menu extra seem to be useless - or at least, I haven't made them work correctly; the commandline tool there will get you connected, though.


Graphics acceleration can be gotten, somewhat, with the tweaks mentioned by dokuroishi, but the mouse cursor will be screwy (it appears as a block about 240x240, looking rather like uninitialized memory).


Sleep doesn't seem to work quite right - the system will attempt to sleep, but the only thing that gets powered down is the CPU; the display will turn to a faded sort of appearance (much like OS X on an actual Mac looks like when it's coming out of hibernate), but that's all I've gotten it to do. To get back out of that state, hit the power switch, at which point it'll instantly come back to being usable. However, the wireless doesn't come back up.


I installed Mac OS X Snow Leopard 10.6.0 successfully on my HP Mini 210-1018EG and everything seems to work... except graphics acceleration and Wifi (very bad!)


I looked for my Wifi chip and it's a Broadcom chip with the device ID 4357. I tried to add this device ID to the kext but nothing happend. There is no Airport symbol in the bar. Do you have another solution for me? If not, I think I'll buy a little USB Wifi adapter.

Share this post

Link to post
Share on other sites

Last edit: 1/12/10


Report so far (will edit as I go along):


HP Mini 210-1036VU

CPU: Atom N450

GFX: Intel GMA3150

LAN: Realtek 8102E/8103E

WLAN: Atheros AR9285

Distribution: iAtkos v3 - 10.6.3


I customized install settings following this youtube.


Install errors resolved:


1. EBIOS Device timeout: with correct MD5, I burnt and tried about 10 copies of the same distro before I changed the USB DVD-ROM in which case it worked immediately.


2. error boot0: fixed it here


What does NOT work so far:


Running 10.6.3 successfully so far but I have the following issues after an initial install.


1. Touchpad :police: : cannot click (but otherwise can move cursor). It just occurred to me that this problem is ridiculous: I could click during the installation but could not afterwards??


2. LAN [Fixed] -_- : Install package from here. See post made by Black Spider on 08/08/10


3. WLAN [Fixed] :( : Install kext from here


4. Sleep :blink: : will freeze sometimes if left idle for a long time. Investigating Meklort's NetbookInstaller

Share this post

Link to post
Share on other sites

Hi Guys!


I don't know what I'm doing wrong. I'm kind newbie on hackintosh but already have sucessfuly installed on my desktop, but in my HP Mini 210-2070NR it is not working.

I booted with NetbookCD and then change to SL DVD. One thing curious here is that is not showed to me the name "Mac OS X Install DVD" but "Apple_HFS". Then I enter the mach_kernel parameters and I receive the messages:

HFS signature is not present.

Can't find mach_kernel.

Can you help me?!



Share this post

Link to post
Share on other sites

I've tried iatkos 10.6.3 on my hp 210-1010sl, video no qe/qi, but it's not important for now...I can't compile a correct dsdt...I don't understand why...How can i solve it?

Share this post

Link to post
Share on other sites

I tried to install iATKOS but I'm receiving the message "usbf ehci controller unable to take control from bios". I search for this error and it seems that I have to disable Legacy USB Support at BIOS, but my BIOS does not have this option. Is there a way to disable it?

Share this post

Link to post
Share on other sites
I tried to install iATKOS but I'm receiving the message "usbf ehci controller unable to take control from bios". I search for this error and it seems that I have to disable Legacy USB Support at BIOS, but my BIOS does not have this option. Is there a way to disable it?


I am running into the exact same problem. I have the hp mini 210-2070 and i am running into the exact same error message when I use iATKOS. Is there a BIOS workaround like for the mini 311.


I have also tried using the NetbookCD 0.8.3 method, however I run into a HFS Signature was not present, can't find mach_kernel. This is with using the retial snow leopard disk.


Any help. i have been searching for days to help solve the problem. It seems that people are able to install on hp mini 210, but I am not sure how they are getting past the usbf ehci controller unable to take control from bios.


Thanks in advance for any help.

Share this post

Link to post
Share on other sites

Has anybody managed to get the Intel GMA3150 external monitor display working with snow leopard?


I have connected three different displays with no success, they flicker and then nothing displays at all, if I connect the screen sharing from another mac I can see in the display prefs that it is detected and allocated the correct resolution.


​Thanks to anyone who can possibly help.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.