Jump to content
InsanelyMac Forum
sh0rtbus

[Resolved] Compaq C770US Fan Issue

Recommended Posts

I have recently installed iATKOS v7 on my compaq c770US laptop with great success. I have the webcam, wifi, ethernet, sound, and video card working flawlessly. My only problem is my fan will not cool effectively. When the laptop gets too hot (around 80 degrees), the fan bursts to 100% for about 5 - 10 seconds. I have found a fix for this, however, it was created for leopard 10.5.1. After installing it my fan worked appropriately, however, now my mouse and keyboard do not function and I am asked to reboot on some boots. I was hoping someone could provide the changes made to each kext so that I may update the stock kexts. If there is an easier solution to this I would be grateful, I have not been able to locate one though. Thanks!

 

Edit: After booting with verbose I have found that the reason I am asked to reboot is because of my ApplePS2Controller.kext failing.

a.zip

Share this post


Link to post
Share on other sites
Advertisement

Success! After about 2 hours worth of work I have both my cpu and system fan working for leopard 10.5.8. I will post the updated kernel extensions when I finish updating the version information. All credit goes to Vanilla for the original creation of these kexts!

Share this post


Link to post
Share on other sites
Success! After about 2 hours worth of work I have both my cpu and system fan working for leopard 10.5.8. I will post the updated kernel extensions when I finish updating the version information. All credit goes to Vanilla for the original creation of these kexts!

 

DUUUUDE!!! Thank you so much, i'm on a Compaq 515 and this fixed my problem entirely. I had the same issure of the fan cutting on once about every couple of minutes at full blast for about 10-20 seconds then cutting off again. BTW, you noted that it worked in 10.5.8, does it also work in snow leopard?

Share this post


Link to post
Share on other sites
DUUUUDE!!! Thank you so much, i'm on a Compaq 515 and this fixed my problem entirely. I had the same issure of the fan cutting on once about every couple of minutes at full blast for about 10-20 seconds then cutting off again. BTW, you noted that it worked in 10.5.8, does it also work in snow leopard?

 

 

im trying to install iatkos v7 on my compaq 515, what driver should choose on the custumize section,, coz the insatallation went good but after reboot with the chameleon it says loading darwin and the screen went white an it reboot again over and over.... am i missing something??

 

soory for my bad english

 

compag 515 amd athlonX2 radeon3200 bios updateF.0c

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×