Jump to content
InsanelyMac Forum
williamwallace

[Guida] Installare Snow Leopard su Asus eeePC 1005HA

Recommended Posts

Advertisement
Nessuna novità a proposito della scheda wifi AR9285? Non ce la facciamo proprio a farla funzionare? E' un peccato...

 

ushio81 dovresti prima metterti in regola. Segui i link che ho in firma.

Grazie ;)

Share this post


Link to post
Share on other sites

La Atheros AR9285 non funziona con Mac OS X (né Leopard 10.5.x né Snow 10.6.x).

La montava anche il mio netbook Samsung N140 (vedi firma) e l'ho sostituita con una Dell 1397 che funziona perfettamente sia sotto Leo che sotto Snow.

Share this post


Link to post
Share on other sites

Prima di tutto vorrei ringraziarti per la guida, davvero ben fatta -_- ma, ahimè, ho un problema:

io volevo installare snow leopard sul mio 1005ha però avendo bisogno di un pc con OSX ho dovuto installare leopard, preparare il mio hard disk esterno (che uso al posto della penneta) e poi far partire l'installazione.

Tutto ok fino al momento cruciale: faccio partire l'installazione, quest'ultima avanza un po poi mi da l'errore della foto in allegato. Cosa posso fare?

Pensando che potesse essere l'hard disk, ne ho preso un'altro ma da sempre lo stesso problema, saranno ormai una decina di volte che tento ma non va.

Ho però notato che a volte l'errore lo da subito e altre volte è arrivato addirittura a metà caricamento...boh, non so che dire...

post-453132-1279965092_thumb.jpg

Share this post


Link to post
Share on other sites
Nessuna novità a proposito della scheda wifi AR9285? Non ce la facciamo proprio a farla funzionare? E' un peccato...

 

Con l'imminente aggiornamento 10.6.5 (ora in fase beta) la scheda wifi AR9285 funzionerà perfettamente,

per chi è - giustamente - impaziente, è stata estrapolata una kext che potete scaricare qui:

http://www.kexts.com/view/462-atheros_ar9285.html

La uso da circa un mese e funziona benissimo.

Si installa con kext helper oppure spostandola in System/library/Extension e ripristinando i permessi.

ps. Se non dovesse funzionare controllate se per caso avete installato AtherosFix.kext: se c'è cancellatela perché va a modificare alcuni parametri nel plist inibendo il regolare funzionamento della nuova kext.

Ora, dopo aver installato anche la kext che abilita ethernet (reperibile sempre su kexts.com) il nostro ha1005a funziona come un perfetto MacBook mini :) :) con il vantaggio di poter avere il dual boot con win 7 ultimate.

Share this post


Link to post
Share on other sites

l'ho installato sulla 10.6.0 della fidanzata ma non funge...ed atheros fix non c'è. Devo aggiornare a qualcosa di più recente?

Share this post


Link to post
Share on other sites
l'ho installato sulla 10.6.0 della fidanzata ma non funge...ed atheros fix non c'è. Devo aggiornare a qualcosa di più recente?

 

Dovresti aggiornare almeno alla 10.6.2, o se proprio non vuoi correre rischi aggiorna alla 10.6.3: su quest'ultima ti garantisco che funge perché l'ho testato di persona.

Share this post


Link to post
Share on other sites
Dovresti aggiornare almeno alla 10.6.2, o se proprio non vuoi correre rischi aggiorna alla 10.6.3: su quest'ultima ti garantisco che funge perché l'ho testato di persona.

 

ok perfetto, aggiornerò a 10.6.3 e ti farò sapere!

Share this post


Link to post
Share on other sites

Ho fatto un po' di pulizia, avevamo sporcato un "pochino". Ora direi che va meglio, semplice e conciso :)

Share this post


Link to post
Share on other sites
Con l'imminente aggiornamento 10.6.5 (ora in fase beta) la scheda wifi AR9285 funzionerà perfettamente,

per chi è - giustamente - impaziente, è stata estrapolata una kext che potete scaricare qui:

http://www.kexts.com/view/462-atheros_ar9285.html

La uso da circa un mese e funziona benissimo.

Si installa con kext helper oppure spostandola in System/library/Extension e ripristinando i permessi.

ps. Se non dovesse funzionare controllate se per caso avete installato AtherosFix.kext: se c'è cancellatela perché va a modificare alcuni parametri nel plist inibendo il regolare funzionamento della nuova kext.

Ora, dopo aver installato anche la kext che abilita ethernet (reperibile sempre su kexts.com) il nostro ha1005a funziona come un perfetto MacBook mini :thumbsup_anim::wacko: con il vantaggio di poter avere il dual boot con win 7 ultimate.

ciao ho cercato i driver per la lan, penso che sia Atheros AR8132, ma non ho trovato nulla. non è che mi dai il link, come hai fatto per wi-fi.

CIao grazie

Share this post


Link to post
Share on other sites
ciao ho cercato i driver per la lan, penso che sia Atheros AR8132, ma non ho trovato nulla. non è che mi dai il link, come hai fatto per wi-fi.

CIao grazie

Scusami, ma ho provato la wi-fi e non funziona ma penso perchè ho ancora la 10.6.0. ti volevo chiedere se sai un modo sicuro per fare un update anche se non posso andare oltre la 10.6.2, se ho capito bene. Ovviamente tempo fa segui la tua guida. Ciao

Share this post


Link to post
Share on other sites
ciao ho cercato i driver per la lan, penso che sia Atheros AR8132, ma non ho trovato nulla. non è che mi dai il link, come hai fatto per wi-fi.

CIao grazie

Eccolo:

http://www.insanelymac.com/forum/index.php...st&id=70195

 

Scusami, ma ho provato la wi-fi e non funziona ma penso perchè ho ancora la 10.6.0. ti volevo chiedere se sai un modo sicuro per fare un update anche se non posso andare oltre la 10.6.2, se ho capito bene.

 

Esatto, fino alla 10.6.2 la scheda non viene riconosciuta, quindi è inutile installare la kext per farla funzionare.

Per l'update scarichi dal sito Apple la combo update 10.6.2 e la installi. PRIMA di riavviare lanci netbookinstaller (non ricordo la versione, ma se prendi l'ultima va comunque bene), perché questo aggiornamento non ha più il supporto per Atom. Una volta fatto l'aggiornamento alla 10.6.2 puoi anche installare la 10.6.3 facendo semplicemente click su "aggiornamento software" dal menu della mela, ma a questo punto credo che ti installi addirittura la 10.6.4. A questo punto cerca l'ultima versione di netbookinstaller (quella che trovi sul sito di meklort, non quelle che trovi in giro) e scaricala. Riavvia, ma quando parte il bootloader premi un tasto qualsiasi, sotto seleziona l'icona di partenza di Snow Leopard e premi il tasto tab, ti si apre il terminale, scrivi: recovery=y. Quando ti appare la schermata di SL lanvi netbookinstaller: è importante aggiornare la cartella Extra, perché alcune kext sono cambiate. Ripara i permessi e riavvia. Fatto.

Eventualmente scaricati kext utility per rigenerare la cache delle kext e riparare i permessi quando installi nuove kext.

Se dovessi avere Kernel panic, riavvia n recovery mode e rimuovi SleepEnabler.kext. Modificando il dsdt il computer si spegne, va in sleep e si riavvia senza alcun problema.Oppure cerca la SleepEnabler per 10.6.4.

L'aggiornamento a 10.6.4 comporta un problema: non si riesce più a spegnere il Bluetooth dall'icona in alto o da syspref. Ci sono due strade per risolvere il problema: lavorare sulla versione di IOBleuetoothFamily.kext per 10.6.4, o patchare ulteriormente il dsdt. Per il momento non ci ho ancora messo le mani perché non lo trovo urgente, quindi non saprei dire qual è la strada migliore.

Share this post


Link to post
Share on other sites

adesso provo anche così,

per aggiornare le sto provando tutte ma non c'è versi, sempre e solo problemi,non si avvia MAI.

Share this post


Link to post
Share on other sites
Eccolo:

http://www.insanelymac.com/forum/index.php...st&id=70195

 

 

 

Esatto, fino alla 10.6.2 la scheda non viene riconosciuta, quindi è inutile installare la kext per farla funzionare.

Per l'update scarichi dal sito Apple la combo update 10.6.2 e la installi. PRIMA di riavviare lanci netbookinstaller (non ricordo la versione, ma se prendi l'ultima va comunque bene), perché questo aggiornamento non ha più il supporto per Atom. Una volta fatto l'aggiornamento alla 10.6.2 puoi anche installare la 10.6.3 facendo semplicemente click su "aggiornamento software" dal menu della mela, ma a questo punto credo che ti installi addirittura la 10.6.4. A questo punto cerca l'ultima versione di netbookinstaller (quella che trovi sul sito di meklort, non quelle che trovi in giro) e scaricala. Riavvia, ma quando parte il bootloader premi un tasto qualsiasi, sotto seleziona l'icona di partenza di Snow Leopard e premi il tasto tab, ti si apre il terminale, scrivi: recovery=y. Quando ti appare la schermata di SL lanvi netbookinstaller: è importante aggiornare la cartella Extra, perché alcune kext sono cambiate. Ripara i permessi e riavvia. Fatto.

Eventualmente scaricati kext utility per rigenerare la cache delle kext e riparare i permessi quando installi nuove kext.

Se dovessi avere Kernel panic, riavvia n recovery mode e rimuovi SleepEnabler.kext. Modificando il dsdt il computer si spegne, va in sleep e si riavvia senza alcun problema.Oppure cerca la SleepEnabler per 10.6.4.

L'aggiornamento a 10.6.4 comporta un problema: non si riesce più a spegnere il Bluetooth dall'icona in alto o da syspref. Ci sono due strade per risolvere il problema: lavorare sulla versione di IOBleuetoothFamily.kext per 10.6.4, o patchare ulteriormente il dsdt. Per il momento non ci ho ancora messo le mani perché non lo trovo urgente, quindi non saprei dire qual è la strada migliore.

grazie mille. Scusami ma ti volevo fare una precisazione. Ma se ho la 10.6.0, posso fare direttamente qualsiasi update o no? Inoltre mi dici quali opzioni dovrei segnare nel netbookinstaller?? Dovrei cercare adesso la 10.6.1 e poi di seguito sino alla 10.6.4. dimmi un pò. ciao grazie gentilissimo

Share this post


Link to post
Share on other sites
grazie mille. Scusami ma ti volevo fare una precisazione. Ma se ho la 10.6.0, posso fare direttamente qualsiasi update o no? Inoltre mi dici quali opzioni dovrei segnare nel netbookinstaller?? Dovrei cercare adesso la 10.6.1 e poi di seguito sino alla 10.6.4. dimmi un pò. ciao grazie gentilissimo

ciao sono arrivato ad aggiornarlo sino al 10.6.3 senza nessun problema di kp. Adesso non funziona l'audio e la wifi, anche se adesso almeno la wifi si vede come applicazione in networking, ma non riesce a collegarsi. Per caso avete qualche consiglio????

ciao

Share this post


Link to post
Share on other sites
ciao sono arrivato ad aggiornarlo sino al 10.6.3 senza nessun problema di kp. Adesso non funziona l'audio e la wifi, anche se adesso almeno la wifi si vede come applicazione in networking, ma non riesce a collegarsi. Per caso avete qualche consiglio????

 

Per l'audio: portati in System/Library/Extensions e cancella AppleHDA.kext, fai partire Kext Utility per ripristinare i permessi e rigenerare la cache. Ora con KextHelper installa voodooHDA.kext (cerca con Google perché non ho sotto mano il link :( ), già che ci sei prova ad installare anche voodoohda.prepfane: lo puoi fare da terminale o, molto più semplicemente estrai lo zip e ci clicchi sopra. Ti darà errore, ma non ti preoccupare, è normale con questa procedura. Il prepfane serve a potenziare un po' il volume. Riavvia: l'audio ora dovrebbe funzionare. In fondo al pannello delle preferenze di sistema troverai l'icona voodoo che ti consentirà di fare mille regolazioni all'audio se hai voglia di smanettare un po'.

Alternativa: installare invece di voodooHDA.kext, AppleHda.kext 10.6.3

WiFi: se hai seguito la procedura deve funzionare, controlla che il wifi sia attivato nel bios. L'installazione di IO80211Family.kext tramite kexthelper è l'ultimissima cosa che devi fare. Controlla di non avere atherosfix.kext (se c'è cancellala) e come al solito prima di riavviare fai partire kextUtility.

Fammi sapere.

ciao

Share this post


Link to post
Share on other sites
L'aggiornamento a 10.6.4 comporta un problema: non si riesce più a spegnere il Bluetooth dall'icona in alto o da syspref. Ci sono due strade per risolvere il problema: lavorare sulla versione di IOBleuetoothFamily.kext per 10.6.4, o patchare ulteriormente il dsdt. Per il momento non ci ho ancora messo le mani perché non lo trovo urgente, quindi non saprei dire qual è la strada migliore.

:(

Problema rapidamente risolto come indicato in questo post:

http://www.insanelymac.com/forum/index.php...t&p=1543028.

Nel topic è indicata nel dettaglio tutta la procedura. Per chi non ha dimestichezza con la modifica delle estensioni, allego la kext già modificata e funzionante per in nostro netbook, eccola :IOBluetoothFamily.kext.zip

Share this post


Link to post
Share on other sites
Per l'audio: portati in System/Library/Extensions e cancella AppleHDA.kext, fai partire Kext Utility per ripristinare i permessi e rigenerare la cache. Ora con KextHelper installa voodooHDA.kext (cerca con Google perché non ho sotto mano il link :( ), già che ci sei prova ad installare anche voodoohda.prepfane: lo puoi fare da terminale o, molto più semplicemente estrai lo zip e ci clicchi sopra. Ti darà errore, ma non ti preoccupare, è normale con questa procedura. Il prepfane serve a potenziare un po' il volume. Riavvia: l'audio ora dovrebbe funzionare. In fondo al pannello delle preferenze di sistema troverai l'icona voodoo che ti consentirà di fare mille regolazioni all'audio se hai voglia di smanettare un po'.

Alternativa: installare invece di voodooHDA.kext, AppleHda.kext 10.6.3

WiFi: se hai seguito la procedura deve funzionare, controlla che il wifi sia attivato nel bios. L'installazione di IO80211Family.kext tramite kexthelper è l'ultimissima cosa che devi fare. Controlla di non avere atherosfix.kext (se c'è cancellala) e come al solito prima di riavviare fai partire kextUtility.

Fammi sapere.

ciao

mi da un fastidio...mi funziona tutto tranne la wifi. Il simbolo della wifi compare su dock, ma non funge. Ma il file che è postato precedentemente vale anche per la 10.6.3 o solo per la beta 10.6.5.

ciaoo e tante grazie

Share this post


Link to post
Share on other sites
Ma il file che è postato precedentemente vale anche per la 10.6.3 o solo per la beta 10.6.5.

ciaoo e tante grazie

Funziona dalla 10.6.2 in poi. Hai controllato di non avere da qualche parte AtherosFix.kext?

Mi spieghi, per favore, passo per passo come fai l'installazione della kext per il wifi? Così magari individuiamo il problema.

Hai per caso sostituito il file dsdt.aml?

Ti riposto qui sotto la kext funzionante e testata.

IO80211Family.kext.zip

Share this post


Link to post
Share on other sites
Funziona dalla 10.6.2 in poi. Hai controllato di non avere da qualche parte AtherosFix.kext?

Mi spieghi, per favore, passo per passo come fai l'installazione della kext per il wifi? Così magari individuiamo il problema.

Hai per caso sostituito il file dsdt.aml?

Ti riposto qui sotto la kext funzionante e testata.

IO80211Family.kext.zip

Ciao, tutto ok, ho capito che il problem era nella mia connessione internet.Ora tutto ok. Resta un piccolo problemino che quando chiudo lo schermo o vado in stop, il computer non si avvia più, devo per forza riavviarlo con il pulsante power. Non ho voluto toccare il file dsdt.aml per non fare casino. Che pensi che possa essere?

CIao e tra parentesi che bello avere un eeepc che va via wifi. troppo comodo.

Share this post


Link to post
Share on other sites
Resta un piccolo problemino che quando chiudo lo schermo o vado in stop, il computer non si avvia più, devo per forza riavviarlo con il pulsante power. Non ho voluto toccare il file dsdt.aml per non fare casino. Che pensi che possa essere?

CIao e tra parentesi che bello avere un eeepc che va via wifi. troppo comodo.

La strada più semplice è modificare il dsdt: fai un backup di quello attuale, con DSDTE ne generi uno nuovo specifico per il tuo eeepc e lo provi, se va bene modifichi la sezione wake (se non ricordo male c'è un fix già pronto, devi soltanto fare copia&incolla): quando abbassi il lid dovrebbe andare in stop e per riavviarlo è sufficiente toccare un tasto qualsiasi. Se invece il nuovo dsdt ti crea problemi (ma non ne vedo il motivo) può sempre cancellarlo e recuperare quello vecchio che hai salvato.

L'alternativa è provare con sleepenabler.kext: dovresti cercare quella per 10.6.4, a qualcuno funziona benissimo, ma sinceramente non l'ho provata.

ps: la modifica al DSDT comporta uno sfasamento dei tasti Fn (per diminuire la luminosità bisogna premere Fn+Ins), però c'è un'applicazione che consente di attribuire ai tasti funzione i comandi che preferiamo, perciò si può assegnar ad ogni simbolo il suo comando. Non l'ho provata perché non mi serve, ma mi dicono funzioni benissimo.

Share this post


Link to post
Share on other sites

Ragazzi! Ciao!

Sono passati mesi dai miei ultimi tentativi di installare osx sul mio 1005HA e intanto ho comprato un macbook! Ora ci vorrei riprovare perchè non riesco a fare a meno di osx...

Vedo che sono stati fatti dei passi in avanti.. mi date qualche dritta?

Guide da seguire? quale versione installare? ideneb o altro?

 

Grazie in anticipo.. ;)

Share this post


Link to post
Share on other sites

Qualcuno ha poi provato sul 1008ha? Io sto scegliendo un netbook da acquistare anche in base alla compatibilità con SL, e purtroppo il 1005ha non lo trovo più in vendita

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×