Jump to content
hnak

ApplePCIIDE.kext

49 posts in this topic

Recommended Posts

Advertisement

Is it possible to get a version for 10.4.11? I want to install it on a Power Mac G4, but I'm running a MacBook Air with 10.6 as my primary machine, so I can't build a 10.4 PowerPC distribution. :)

Share this post


Link to post
Share on other sites
I have just uploaded 10.5 build.

merry christmas!

I am trying to build on PowerMAC G4 running osx 10.5.8 I use Xcode V3. Few attempts, following the APPLE manuals, build is success ..... but when trying to use load kext the message is ApplePCIIDE.kext does not contain code for this architecture. When looking at target.info, which was modified, VAILD_ARCHS ppc, GCC_MODEL_TUNING G4, and ???? just can not remember ..... There are no kextutil, but found on the net that it comes with 10.6 OSX.

Could you please advise what parameters to be modified to get build on OSX 10.5.8 G4 ??? I think started going the loop by now ..... can not see trees in the forest.

 

Kind regards Kris

Share this post


Link to post
Share on other sites

I chose the build target as "Release_Leo" on Xcode 3.2.6, then added "ppc" to "ARCH" parameter and could start building for ppc, but could not compile as there are some undefined symbols in ppc architecture ( IODTAIOReg8, IOATAIOReg32 ) . You must modify the code to support ppc hardware.

 

Is it possible to get a version for 10.4.11? I want to install it on a Power Mac G4, but I'm running a MacBook Air with 10.6 as my primary machine, so I can't build a 10.4 PowerPC distribution. :(

You can optionally install 10.4u SDK with Xcode 3.2.6, though you must modify the code.

Share this post


Link to post
Share on other sites

Sorry for dragging on - it was a while ago now, and I was very busy with my telescope controller.

1. Modify or

#define IOATAIOReg32 .... as what ??????

#define IOATAIOReg8 ..... as what ?????

 

Is this the only mod required ??? I am not familiar with APPLE ideas of programming, simply not ISO compatible, nor GNUcc.

 

Sorry for being a bit ignorant but APPLE ideas for me are murky like waters in the pond.

 

Regards Kris

Share this post


Link to post
Share on other sites

Thank you for driver.

Siliconimage 0680 ata works fine in Lion except after wake there's error message"IOATA Controller device

blocking bus".

4hds are connected in master/slave mode.

ide bios 3.4

 

more test

I have os x in jmicronata and windows xp in silicon 0680, In case like this , You should connect Windows as master mode in primary channel, if not , even latest chameleons can not boot with ebios error 0x42.

Edited by kdtt

Share this post


Link to post
Share on other sites

Hi there,

Seems to work for everybody but me. I am on Dell Inspiron 545 running 10.6.6. System profiler does not show any PCI cards, eSATA drive is not recognized and the kext was loaded with Kext Utility in the System/Library/Extensions folder.

Share this post


Link to post
Share on other sites

Did you insert a card with one of the supported chips ?

The card seems to be right - VIA VT6421. Since this happened, I got a SATA (from the internal SATA port of the card) to eSATA cable and now the eSATA drive is working fine. It is not available for booting at the Chameleon splash window (as when the external HDD is connected with USB cable), but that is OK. So, the problem appears to be the eSATA port on the card itself, as it is not working under Windows XP as well.

Anyway, thanks for the help and for developing the kext!

Share this post


Link to post
Share on other sites

hello, my hackintosh finally recognized my ide dvd-rom after installing applepciide.kext so many thanks for this!

But there's another issue: i can write cds without a problem but when it comes to dvds when it starts writing for ex. an .dmg the light of the drive starts blinking for about 3-4 secs and then it stops and the procedure 'freezes' at 0%. (I ve been waiting for over half an hour)

Any help would be appreciated!

Thanks

Share this post


Link to post
Share on other sites

This kext v.1.03 is working for me in /System/Extensions  on Mavericks GM

(ATA DVD drive)

 

attachicon.gifApplePCIIDE.kext.zip

 

Good luck

For me with 10.9.1 doesn't work any more !

:(

Changed to Clover r2654 and 10.9.2 is ok now !

 

:thumbsup_anim:

Works on OSX 10.10 DP1 to 5 !  (Put in S/L/E)

 

Works on OSX 10.10.2 up to Beta 5 ! Injected by CLOVER !

:thumbsup_anim:

 

Works still on OSX 10.11 (Injected by CLOVER !)

:thumbsup_anim:

Share this post


Link to post
Share on other sites

Hi could someone re-up version 1.03 ? Thanks...

 

I second this!!! I can't use kernelcache with v1.01 (although it may be something else causing this issue...)

 

EDIT: was using a different kext, v1.01 works perfectly for me

Share this post


Link to post
Share on other sites

This kext v.1.03 is working for me in /System/Extensions  on Mavericks GM

(ATA DVD drive)

 

attachicon.gifApplePCIIDE.kext.zip

 

Good luck

Thank you,the only things make my JMB363 PIONEER DVD-RW  DVR-118L works on 10.9.5 in /Volumes/EFI/EFI/CLOVER/kexts/10.9

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×