Jump to content
InsanelyMac Forum
scwhar

Chameleon 2 RC4

Recommended Posts

Take the link under the DONATE button.

 

Dont forget to donate, when you have found a job :-)

 

caiowa

 

I did follow the link, it only takes me back to the 'Donate' page. Thinking that might be an issue with the browser (firefox on linux) I also tried:

wget <link to Chameleon-2.0-RC4-r684-bin.tar.gz>

but that only fetches the html page. So something's definitely wrong with the link.

 

Also, can someone point me to directions as to which of the files in Chameleon need to be dd into the Leopard 10.5.8 install partition (call it Macintosh).

 

I have a working 10.5.8 install that is booted via grub and PC EFI v10.1. I'm doing some disk swaps, replacing old IDE disks with a new 1 TiB SATA one, so I want to make sure that Macintosh is bootable. I'll be doing this from linux so can't use the package installer.

 

Thanks again!

Share this post


Link to post
Share on other sites
Advertisement
Attached you can find the actual version RC4. I loaded it just now from the developer side.

 

regards

caiowa

 

Thanks!! I'll look at the README to see if that answers my questions about a manual install via dd. Will post if I have questions...

Share this post


Link to post
Share on other sites

Does the Chameleon team not build an normal install app which does all with normal GUI ?!

No problem if only needed to update the boot file - but what when you need to install it on an blank HD ?!

Share this post


Link to post
Share on other sites
Does the Chameleon team not build an normal install app which does all with normal GUI ?!

No problem if only needed to update the boot file - but what when you need to install it on an blank HD ?!

 

3 very simple commands is all you need, an installer would only make sense to me if it was able to set some things up in the boot.plist simply by checkboxes. thats the harder part

Share this post


Link to post
Share on other sites

3 very simple commands is all you need, ..../quote]

 

I dont think dd and fdisk commands are simple - they can be dangerous for newbies !

Also newbies can be wrong with the /dev/rdiskxyz names !

Share this post


Link to post
Share on other sites
Also newbies can be wrong with the /dev/rdiskxyz names !

diskutil list gives the information needed, an exampel for the synthax is given in the manual that comes with the bootloader. sure it's not as simple as an installer but it's not that hard compared with the synthax needed in the boot plist wich is not so well documented. i would be in favour for a installer that comes with more options. and no, i don't know how to make one myself

Share this post


Link to post
Share on other sites

Is anyone still running a dual boot 10.5/10.6 setup?

 

when I boot 10.6 Chameleon will load /Extra/Extensions and /Extra/10.6/Extensions

when I boot 10.5 Chameleon will only load /Extra/Extensions but ignore /Extra/10.5/Extensions

 

I've tried w/mkexts and w/out mkext and the behavior remains the same. Seems the only fix is to move my kexts into /S/L/E

 

anyideas?

Share this post


Link to post
Share on other sites
I dont think dd and fdisk commands are simple - they can be dangerous for newbies !

Also newbies can be wrong with the /dev/rdiskxyz names !

 

I'm 100% agree with this....although I'm not a newbie, and I've run diskutil list before I installed chameleon manually, diskutil can gives a wrong information sometimes. In my case I'm certain that my SL are listed as disk1s2 at that moment(although it was usually disk0s2 before), but when I'm applying chameleon boot sector to it, it broke my data storage drive, luckily it was fixable using chkdsk under windows, cause ntfs have a backup of the boot sector, but it was scary when it happened first, and I try to not rush into things that might actually worsened the condition..

Share this post


Link to post
Share on other sites

I am having problems with this Release, i guess cause of:

 

"Added radekg’s HFS filesystem fix to handle 2GB+ file sizes."

 

I could boot and wake-from-disk when i had two harddrives in my system. I had to remove the second harddrive. Now, the bootloader hangs at the Cham-Boot Screen after selecting the boot partition. The Chameleonpicture is shown and a line saying "loading HFS+ File Systemconfiguration.plist" is visable, then the system freezes.

 

The only way to boot was to copy the PCEFI 10.5 boot file back :(

 

Can someone reproduce this?

Share this post


Link to post
Share on other sites
I put together a few unofficial installers for the newest versions of Chameleon- AsereBLN's 1.1.7 RC4 mods and rekursor's RC5pre6 here:

http://tonymacx86.blogspot.com/2010/02/cha...-installer.html

 

As well as one for netkas' PC-EFI 10.6- released today.

http://tonymacx86.blogspot.com/2010/02/pc-...pported-by.html

 

Hope this helps! :)

 

I used your installer for the RC5-pre and it installed just fine. Two questions tough.

 

First, can you point to any doc for the new options etc..

 

And, second, how do I change back to the Theme I had been using? Not that I don't appreciate your red apple, but, since my Boot.plist does not appear to have been changed I don't know why it is using your default theme.

Share this post


Link to post
Share on other sites
I put together a few unofficial installers for the newest versions of Chameleon- AsereBLN's 1.1.7 RC4 mods and rekursor's RC5pre6 here:

http://tonymacx86.blogspot.com/2010/02/cha...-installer.html

 

As well as one for netkas' PC-EFI 10.6- released today.

http://tonymacx86.blogspot.com/2010/02/pc-...pported-by.html

 

Hope this helps! :)

 

THANKS !

I read in yoor blog that the DSDT,aml (most will have) must now stay in /EXTRA and not in / (root) ?

Also, please note that you will need to move your DSDT.aml to the /Extra folder instead of the root folder. Or you can specify DSDT='path to your DSDT.aml' in com.apple.boot.plist.

 

Does this also be a must for all other newer "clones" of PC EFI 10.5 / 10.6 ?

(http://prasys.co.cc/ prays offerts also an newer Chameleon Clone since yesterday)

Not loading DSDT.aml may be an problem - so good to know which realeses need that in /EXTRA and which not.

Share this post


Link to post
Share on other sites
Hi guys

 

You might want to try Dr Hurt's Windows friendly Chameleon RC5 pre-release8 installer

http://www.insanelymac.com/forum/index.php...t&p=1404132

 

WOW - has an PrefPane for much ++ things too ! GREAT+ MUCH THANKS

 

 

Q: The function to set the startvolume will set that partition active (to change boot from). GREAT. no more FDISK by hand needed.

Also there is an function to swap HD 0 1 or 2 if the list in that window isnt the list of OS X.

And now my ???: The list in the chameleon start volume TAB is correct , meaning same as Diskutil . But the active is my OSX_Snow_Leopard (1,1), second listed in that window list.

In which case is that HD 0 1 needed ? For my understanding i dont need that swap option but unsure.

 

HINT to DEVS: Would be really nice if they check (by fdisk call) which partition is current active and mark that somehow as active in that Volumes list. So that we can see which is current active.

 

Screenshoot of that new Prefpane with Chameleon RC5 Pre8: You can see, that that dev of the prefpane even LOCALIZED ist already - PERFECT!!!

Bildschirmfoto_2010_02_06_um_19.35.42.jpg

Share this post


Link to post
Share on other sites

I really like this. I had always tried to rely on some older version and Lizard to make changes to boot behavior. Now the Preference Pane is included. Also most importantly, Netflix's Silverlight works properly. What a job from Dr. Hurt + BlackOSX.

BTW, Dr. Hurt, I hope your earn an A in your second year of med school and your grade in this forum has always been A+ anyway.

Share this post


Link to post
Share on other sites

I just tried the installer from Dr. Hurt for the Chameleon2 RC5-pre. It ran fine but on re-boot my system stalled waiting for the root device. It did not do that with Chameleon2 RC4 or the one a few posts earlier by tonymacx86.

 

I tried to boot using rd=disk0s3 but the boot process went into a loop with messages that it found disk0s3 but could not mount it. Thankfully, my SL pre-boot DVD works :D

 

I agree with mitch_de - the prefpane is GREAT! I just hope I can resolve the waiting for root device problem.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.



×