Jump to content
InsanelyMac Forum
hardknoxni69a

(Guide) How To Install Snow Leopard Retail On AMD PC OsX86

Was The Guide A Success  

86 members have voted

  1. 1. Was The Guide A Success

    • Hell Ya Thanks Man
      39
    • Yes Had To Mod A Little Though
      20
    • Could Not Get To Work :-(
      18
    • Complete Disaster
      10


Recommended Posts

Advertisement

You are awesome man! I finally got it to boot today with a little tweaking -v maxmem=4096 busratio=20 -f ! Awesome guide man thank you so much!

 

Gateway DX4300-03

AMD Phenom x4 95750

Foxconn A7GM-S [Foxconn RS780] (Northbridge: AMD RS780 soutbridge:SB700)

ALC888s

1GB Radeon HD 4650

Share this post


Link to post
Share on other sites

Hoping to install 10.6.2 on my HP Pavilion tx2500z cto using the hazar method... just curious... but have you been able to get native res out of your Radeon HD 3200 I know it's possable to get it with the ati hd framebuffer kext but it has not worked consistantley for me in 10.5.6...

Share this post


Link to post
Share on other sites
Hoping to install 10.6.2 on my HP Pavilion tx2500z cto using the hazar method... just curious... but have you been able to get native res out of your Radeon HD 3200 I know it's possable to get it with the ati hd framebuffer kext but it has not worked consistantley for me in 10.5.6...

Hazard's install disc will not even start up on my machine i get the halt that includes flashing lights on my keyboard...

Share this post


Link to post
Share on other sites

HELP, HELP, HELP!!!

 

I were done everything @hardknoxni69a said in manual but my instalation always stuck at copyng files from SL Retail DVD to Snow HDD partition at some HP printer files (always and always at that point)...!!!

 

What to do???

 

:D:( :( :( :(

 

My iDeneb v1.6 10.5.8 instalation is PERFECTLY WORKING on my AMD comp!!!

Share this post


Link to post
Share on other sites

Hi. I have a working iPC Leopard 10.5.6 on my PC. I followed this guide to install Snow Leopard.I replaced the original OSInstall.mpkg with the one from Hardnox folder. When I try to run it I get this.

 

errorfw.png

 

Any help would be greatly appreciated.

 

Config

AMD Phenom 9950 Quad Core

4 GB DDR2 800 Mhz

Nvidia nForce Networking Controller

Intel High Defenition Audio

Nvidia GeForce 8800GT (dual cards)

TSSTcorp DVD-RW

Motherboard Gigabyte GA-M750SLI-DS4

Share this post


Link to post
Share on other sites

I'm on a tx2540br. iDeneb 1.6 Lite runs almost perfecly in my machine... I tried this guide for SL but with no success.

 

The only way I could run Snow Leopard in my system was with myHack and a pendrive, but I can't get Wi-Fi to work...

 

Any suggestions? I've already tried the guide for Broadcom (script thing) :blink:

 

Besides, full resolutions works (Radeon HD3200), touch, LAN, and bluetooth also.

Share this post


Link to post
Share on other sites

Hello. I’ve spent the last two days trying to get Snow Leopard working my my pc. I currently have Leopard 10.5.8 running through iDeneb 1.6 Lite.

 

I’ve followed the instructions to the letter and I can get through the install fine, but when I go to boot from the chameleon screen, I get a screen that tells me I must restart my computer (in different languages).

 

If I type in various boot commands, such as:

 

-v (-v.JPG)

 

-v busratio=20 (-vbusratio=20.JPG)

 

 

-v -F cpus=4 fsb=200000000 maxmem=4096 (-v-Fcpus-4fsb=200mmaxmem=4096.JPG)

 

I get slightly different frozen screens (attached). I'm not sure if they're kernel panics.

 

 

 

Can someone help me move forward? I'm at a loss (and pulling all my hair out).

 

 

My specs are as follows:

 

 

 

Motherboard: Gigabyte GA-870A-UD3 [ACPI Suspend Type set to S3(STR)]

 

Processor: AMD Phenom II X4 965 Black Edition

 

Memory: 4GB (2GB x2) A-Data Gaming Series DDR3 1600

 

Video Card: ATI Radeon HD 5770 1GB GDDR5 w/ one DVI port

 

WLAN: Encore ENLWI-N Wireless PCI Card w/Ralink Drivers (Works on 10.5.8)

 

LAN: Realtek 8111D chip –on board (Haven’t tested yet)

 

Audio: Realtek ALC892 codec - on board (Works on 10.5.8 with VoodooHDA kext)

 

All hard drives and DVD drive are SATA and HDD’s are set to AHCI.

 

 

 

Just for the hell of it, I tried changing my hard drive to IDE and installing this since my iDeneb install was on an IDE drive and i got the kernel panic screen attached as well (IDEInstall.JPG).

 

 

 

 

I feel like I'm close!!!!

post-641712-1279238241_thumb.jpg

post-641712-1279238276_thumb.jpg

post-641712-1279240008_thumb.jpg

post-641712-1279240152_thumb.jpg

Share this post


Link to post
Share on other sites

Thank you, your guide was successfull, except for that point:

 

Step 8. Run **DSDT Patcher** from the **DSDT** folder. In the patcher for OS options select Darwin/Mac OS X and for patcher options select Apply DSDT To... MAKE SURE YOU SELECT YOUR SNOW PARTITION/DRIVE. Then Patch.

 

It gave me error, "failed to patch".

 

But all seems run great, also compo update to 10.6.2.

Share this post


Link to post
Share on other sites
Thank you, your guide was successfull, except for that point:

 

Step 8. Run **DSDT Patcher** from the **DSDT** folder. In the patcher for OS options select Darwin/Mac OS X and for patcher options select Apply DSDT To... MAKE SURE YOU SELECT YOUR SNOW PARTITION/DRIVE. Then Patch.

 

It gave me error, "failed to patch".

 

But all seems run great, also compo update to 10.6.2.

yes..same as mine..DSDT shows an error but it works well once rebooted

Share this post


Link to post
Share on other sites

Finally i can open OSInstall.mpkg with Pacifist(because i have jas tiger 10.4.8 installed) but after i press "Install on another Disk" i have a small window which says "Extracting files" and here the loading bar freeze.I let it about 3 hours but nothing.

 

My configuration : Amd turion 64 x2// 2.1 MhZ // 2GB RAM

Ati x1250// HDD ATA 160GB.

 

What should i do ?

Thanks.

Share this post


Link to post
Share on other sites

Hey Bro worked! Finally after struggling for months trying to get any type of MAC OS X to work in Hp Pavilion dv4 AMD Turion X2 laptop.

 

WIFI and SOUND worked right out of the installation! Thank you.

 

Will try the update to 10.6.2 and hope that everything goes smoothly

Share this post


Link to post
Share on other sites
Finally i can open OSInstall.mpkg with Pacifist(because i have jas tiger 10.4.8 installed) but after i press "Install on another Disk" i have a small window which says "Extracting files" and here the loading bar freeze.I let it about 3 hours but nothing.

 

My configuration : Amd turion 64 x2// 2.1 MhZ // 2GB RAM

Ati x1250// HDD ATA 160GB.

 

What should i do ?

Thanks.

 

 

try installing it in a SATA HDD..i've got error when i use ATA.

Share this post


Link to post
Share on other sites

Thanks for the guide.. my laptop boots the snow leopard install.. but the keyboard and track pad dont work.. i am typing this on my ia7 install of leopard. Can I somehow copy the files from here to the snow install and get it to use those drivers for the keyboard and track pad?

Share this post


Link to post
Share on other sites

never mind.. i just used the ia7 disc and installed the ps2 driver and network drivers from there and its running right now with the new update

Share this post


Link to post
Share on other sites

My installation runs fine on all counts, and all parts, but when i boot i get "smc smcSMCinabadstate Error" message, in verbose, then it goes to a grey screen. The mouse pointer is there, and i can move it around with my mouse, but nothing else shows up? did i miss something?

Share this post


Link to post
Share on other sites

Great guide!

 

Got SL installed on my MSI 785G-E65 pretty easily. Had to make some adjustments to the original guide but otherwise it was a piece of cake.

 

Thanks for this and kudos!

Share this post


Link to post
Share on other sites
Guide To Install Snow Leopard On AMD!!!

 

I figured I would make a guide on how to install Snow Leo on AMD because after tons of different guides that didn't work I finally got the trick. I managed to get my HP TouchSmart Tx2-1020us (AMD Turion-x2 Ultra64) and others up and running so I would like to share with all you frustrated users dying to get your hands on some Snow.

 

FOLLOW THE GUIDE EXACTLY! CONTINUE AT YOUR OWN RISK! I TAKE NO RESPONSIBILITY IF YOU MESS UP YOUR PC!

Things You'll Need..

 

* First thing first and probably the most important, you'll need a working install of Leopard 10.5.x on your PC already. ------(Google - iAtkos is a good OsX86 Distro)

 

* Original .DMG of Snow Leopard(v.10A432)(Make it writable - Will need to edit .DMG)

 

* An empty partition or drive with at least 10GB free space

 

* Download Required HardKnox Files for installation from Here (HardKnox.zip) (Files in the guide with **xxxx** around them will be coming from the HardKnox Folder!!!)

 

TAKE A BREATH THAT'S THE EASY STUFF LETS HAVE SOME FUN NOW!!!

 

Step 1. Mount the Snow.DMG file, then go to Disk Utility and save a writeable .DMG file to your desktop or where ever you prefer. Un-Mount the Read-Only .DMG and Mount the new writeable .DMG, After you have the new Snow .DMG Mounted open the image so it brings you to the menu(Picture of Leopard with install and two folders). DO NOT CLICK INSTALL!!!. While the image is open click Go In the Top Menu Bar and select GO TO FOLDER.. then type "/Volumes/<Mounted Snow Leopard Install Disk>/System/Installation/Packages

 

Step 2. Copy the **OSInstall.mpkg** from the HardKnox Folder and replace the one in your mounted Snow DMG. It's located in folder we previously brought up ("/Volumes/<Mac OS X Install DVD>/System/Installation/Packages").

-- If you haven't done so previously CREATE A PARTITION OR DRIVE WITH A VALID FILESYSTEM FOR YOUR OS. Use Disk Utility to choose an empty Partition or Drive then select ERASE with the OS Ex Journaled option.

 

Step 3. After the format, make sure the permissions of the partition/drive are correct by running the following commands in the terminal:

 

-->sudo -s

 

-->chown 0:0 /Volumes/<Name Of New SNOW Drive>

 

Step 4. Finally Let's Get Working. Run the "OSInstall.mpkg" file you replaced earlier in the Packages folder from the SNOW install .DMG. DON'T GO CRAZY CLICKING AWAY make sure you change the installation drive to the new SNOW drive and customize the install by removing all the PRINTERS LANGUAGES AND FONTS.As many people say go get a coffee or something, because install will probably take around 20 minutes to finish.

 

CONGRATS!!! That wasn't hard was it. BUT YOU ARE NOT DONE YET SO DO NOT RESTART!!!

 

Step 5. Run **Chameleon RC2** MAKE SURE YOU CHANGE INSTALL LOCATION TO NEW SNOW PARTITION/DRIVE!!! When that completes go into the **Chameleon RC3 Folder** then into the i386 folder and copy the **BOOT** file.

 

-- Run **ShowAllFiles** and select "SHOW", now you need to replace the boot file in the root directory of the new partition/drive with the **BOOT** file from the i386 folder.

 

Step 6. Now we need to delete a few files and copy a few files in order to make a successful boot, so you need to navigate to the root of the new Snow partition/drive and go to the /Extra then /Extensions folder and trash the "Disabler.kext", now go back to the root and go to the folder called /System then /Library then the /Extensions folder while here we also need to trash the "AppleHPET.kext" and "AppleIntelCPUPowerManagement.kext". So in total 3 kext's should now be trash!! Ok while we are in this /System/Library/Extensions Folder Copy the 7 Files inside the **Snow Kexts Folder** and place them in the current /Extensions folder that we are currently in. So you should be adding: AppleACPIPS2Nub.kext, fakesmc.kext, NullCPUPowerManagement.kext, OpenHaltRestart.kext, PlatformUUID.kext, VoodooHDA.kext and VoodooPS2Controller.kext to the /System/Library/Extensions folder.

 

Step 7. Copy the **Kext Utility** to your current desktop, then copy the /Extra/Extensions folder from your new SNOW partition/drive to your current desktop. Now drag the new Extensions folder on your desktop OVER the newly copied **Kext Utility** app to open and repair the permissions of that /Extensions Folder. When the **Kext Utility** app finishes it creates a new Extensions.mkext on your desktop. Navigate to the Root of your Snow partition/drive go in the /Extra Folder and delete the old /Extensions Folder and Extensions.mkext. Once you complete that, copy the new /Extensions Folder and Extensions.mkext from your desktop and place into your /Extra folder on your New SNOW partition/drive.

--If you would like a little less clutter amongst your files you can now run **ShowAllFiles** again and chose HIDE if you wish to get rid of all the hidden files.

 

Step 8. Run **DSDT Patcher** from the **DSDT** folder. In the patcher for OS options select Darwin/Mac OS X and for patcher options select Apply DSDT To... MAKE SURE YOU SELECT YOUR SNOW PARTITION/DRIVE. Then Patch.

 

Step 9. Copy **smbios.plist** and place in the /Extra Folder off of your SNOW root directory, while in this directory copy your com.apple.boot.plist file to your current desktop, open the file on your desktop inside the text there is "mach_kernel" add .test7 to the end of the two words so it should now look like "<string>mach_kernel.test7</string>" once you have done so save the file. Return to the /Extra folder where you received the com.apple.boot.plist file from and delete the old com.apple.boot.plist file then copy the new file from your desktop and put it in the folder where it originally came from. Once you are done that, copy **mach_kernel.test7** and place it in your SNOW partition/drive root directory.

 

Step 10. Now finally last step, all you need to do is repair the permissions for the SNOW Extensions folder. In order for it to repair you need to put the following commands into the terminal.

 

-->sudo -s

 

-->cd /Volumes/<Snow Leopard Installation>/System/Library/Extensions

 

-->chown -R root:wheel *

 

-->chmod -R 755 *

 

CONGRATS!!! You should now have a working copy of SNOW. When you restart choose SNOW when chameleon boot loader shows up. You should probably repair permissions through Disk Utility once you are in the OS(If for some reason the OS says you don't have the package installed for Repairing your permissions Navigate back to the Packages folder in the SNOW.DMG you installed from and install the BSD package). If your internet or sound doesn't work look around the web for a driver, remember SNOW IS MADE FOR A MAC not your PC so hopefully somebody else has already made a driver for your Hardware. I did not include details on Video cards just makes stuff more confusing and more likely for some errors but you can look up info about EFiStudio to add specific details to the com.apple.boot.plist file. So as of now you will be booting using generic drivers nothing fancy I am just trying to get you guys up and running. There are wonderful sites out there dedicated to helping us 0sX86 modders so join some and help the community grow. There are different kernel flags you can use to control the way your OS boots so for example to see exactly what your pc is loading while the OS boots while selecting the SNOW drive in chameleon type "-v" to enter verbose mode, "-x" for safe mode, there are many things you can do for 32-bit mode type "arch=x86_32", "-f", etc., look online for commands they can be helpful. If for some reason you don't boot up re-read the steps and follow EXACTLY!!. Use the -f -v commands first boot so you can know how things go that way you can see exactly what goes wrong if anything. PM me for any questions. GOOD LUCK!!

 

Combo Update to 10.6.2: Mac OS X v10.6.2 Update (Combo)

If For Any Reason You Can Not Get Working Please Ask For Help!!!PM Me!!!AIM:HardKnoxNi69a!!! That Is The Whole Point Of This OsX86 Community Is To Help Each Other Dominate The Computer World!!!!!

All You Have To Do Is Click A Button To Vote If This Was Helpful!!! Thanks!!! :D:(:D

 

 

 

 

great guide but i can't open this way /Volumes/<Mounted Snow Leopard Install Disk>/System/Installation/Packages any thoughts why? I get folder cannot be found

Share this post


Link to post
Share on other sites

Thanks so much worked great I just had to open the .dmg like this [/snow Leopard Install Disk>/System/Installation/Packages/] One problem I tried to upgrade to 10.6.5 now I cant boot. Has anybody had luck with 10.6.5??????? I did remove all kexts that I know won't work on AMD inside leopard.... Hope i don't have to reinstall:(

Share this post


Link to post
Share on other sites

Hello Glad to meet you other Insanely Mac users,

I just recently bought a MSI U230 laptop with AMD RS780MN + SB710 chipset and AMD Athlon Neo MV-40 1.6 GHz CPU.

I want to dual boot Windows 7 and Snow Leopard.

Are there any specific instructions for my install that someone can suggest?

Share this post


Link to post
Share on other sites

Can you please help me?

 

I cant install Chameleon RC2. After installation I get the error "There were errors with the installation. You may want to try installing it again". "The Installation failed. The Installer ecountered an error that caused the installation to fail. Contact the software manufacturer for assistance".

 

I even tried to repeat step 4:

Step 4. Finally Let's Get Working. Run the "OSInstall.mpkg" file you replaced earlier in the Packages folder from the SNOW install .DMG. DON'T GO CRAZY CLICKING AWAY make sure you change the installation drive to the new SNOW drive and customize the install by removing all the PRINTERS LANGUAGES AND FONTS.As many people say go get a coffee or something, because install will probably take around 20 minutes to finish.

 

But I got the same error again. Can you help me please? Thanks

Share this post


Link to post
Share on other sites

salve a tutti ho eseguito la guida penso correttamente ma all'avvio di snow mi si blocca nella schermata con la mela .... utilizzando -x -v il risultato non cambia ... potete aiutarmi?? per favore

Share this post


Link to post
Share on other sites

Great guide dude, after many months reading and trying I got SL on my system, it is an asus m2a-vm, I just have two points to fix and may be could get some help from you:

In bios sata mode as ahci, after the first boot, I did reboot and got smbios alert, the sata mode went back to ide mode, every time I reboot is the same problem, but I cant boot with ide mode. After install I cant get the leopard partition boot, it seems chameleon loose the kernel data, after select the partition to boot in chameleon, appears "cant find mach_kernel".If some one get the way to follow to fix it, any clue is wellcome.

Thanks a lot!!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×