Jump to content
Sign in to follow this  
Followers 0
sroddy

Compal IFL90/FL90 Snow Leopard Compatibility

6 posts in this topic

Recommended Posts

Hi everyone!

I have a fantastic Compal IFL90 and I'm really happy with it, although it had some issues from the beginning, and some new one introduced with snow leopard

 

ISSUES NEVER SOLVED:

- sleep with vanilla kernel (anyone could help?)

- LAN (some improvements now, i've solved it buying an external card)

- WLAN (solved it buying a dell compatible card)

- Trackpad not recognized as trackpad but as mouse

- External display never recognized

 

NEW ISSUES (snow leopard)

- Internal Bluetooth is not seen anymore in the regdump

- Internal microphone not working (using VoodooHDA.kext)

 

 

Someone can please help?

Share this post


Link to post
Share on other sites
Advertisement

Hi, for the LAN it's working with BCM5787 kext. But you need to launch a terminal with sudo tcpdump -i en0 to get the card working

 

i've got the same laptop and i wonder if you did make the Geforce 8600M GT fully work?

i mean with Quartz and full acceleration enabled

 

thanks

Share this post


Link to post
Share on other sites

hey!

 

i also have a compal fl90. everything works pretty well with sl 10.6.4 but except my soundcard. i tried several voodoohda.kext but i always get kernelpanic!!!

 

what .kext should i use for sound?

 

plz help

 

thx a lot

Share this post


Link to post
Share on other sites

Hi, I have also Compal fl90.

Im trying to instal Snow Leopard with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] (http://tonymacx86.blogspot.com/2010/04/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]-[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]-install-mac-os-x-on.html) but with no success.

 

It stuck on black screen, instalation didnt even start. I have ACHI on and Legacy USB support off.

Somebody with same notebook...how did you get SL installed?

 

Thanks

 

UPDATE:

 

I have successfully installed SE on my laptop!

The trick is:

TURN OFF Legacy USB Support in BIOS

Start OSX installation from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] with parameters: -x -v -cpus=1

 

External display is ok.

 

ISSUES SOLVED:

LAN / improved IONetworkingFamily.kext

Trackpad / VoodooPS2Controller.kext (you have to remove VoodooPS2Trackpad.kext from PlugIns directory inside this kext)

Battery icon / AppleACPIBatteryManager.kext

Sound / VoodooHDA.kext

wlan / im waiting for Broadcom BCM94311MCA

 

NOT SOLVED:

Sleep / im now trying to edit DSDT

Microphone / i dont have an idea what could be wrong with it:/

AppleACPIBatteryManager.kext.zip

IONetworkingFamily.kext.zip

VoodooHDA.kext.zip

VoodooPS2Controller.kext.zip

Share this post


Link to post
Share on other sites

anybody know how on earth you can install snow leo on the fl91? (gm965 w/ x3100) it runs a compatible chipset and leopard works fine. but snow leo is a complete no-go.

Share this post


Link to post
Share on other sites

Hello,

I've been trying to install SL 1.6.8 on compal JFL92. The DSDT tables are almost identical with FL90 / IFL90, so i assume that dsdt fixes are compatibile across the different models.

After a couple of DSDT fixes (adding _DSM and _PWR methods to devices EHC1 and EHC2) i managed to put the computer properly to sleep -- it would wake up immediately without the fixes.

Waking up is still buggy -- the internals power up ok (fan, drive etc) but the screen remains black, and i think the system hangs because i don't hear the sound when changing volume. Was anybody able to get past this issue?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×