Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
teateam

Patched mach_kernel 10.6.0 for Atom-based netbooks

347 posts in this topic

Recommended Posts

Teateam,

 

I updated to snow 10.6.2 and your kernel is working great on my d945gcfl2d mainboard. I can even go to 64 bit but my GMA950 won't let me change resolutions (stuck at 1024x768). I'm using DSDT.aml and 32 bit allows me to change resolution. Any ideas? Is there a way to patch AppleIntelIntegratedFramebuffer.kext to allow resolution change to 64 bit?

Share this post


Link to post
Share on other sites

My Atom N270 in EeePC 901 gets detected as Intel Core Solo. Will this have effects on my system performance?

 

Any way to get it recognized properly?

Share this post


Link to post
Share on other sites

Hi,

 

 

 

Newbee and just unboxed an MSI 120U. I installed 10.5.4 (everything appears to work)but cannot find the correct procedure to update it to 10.6.2. Can some help me out?

 

 

 

Thanks... ;)

Share this post


Link to post
Share on other sites
A-ha. I have it too (use as home media-server and torrent box). I use 10.6.2 in 32-bit mode - work all, include sleep.

 

Hi there Teateam,

 

thnx for the patched mach-kernel works great under 10.6.2 (x32 & x64)

I have one question about some usb problems after updating to 10.6.2 & kernel

Running a Asrock ion 330 pro and using a usb bootloader to get the system running for now.

Installing 10.6.0 went fine with usb 2.0 and no usb error's, but after updating to 10.6.2 and the new kernel, usb 2.0 isn't working anymore (ehci error).

The problem is that i don't know if it's the kernel or the 10.6.2 update.

Without a 2.0 usb drive connected at boot, 2.0usb is working normal.

 

thnx for the help

 

T

Share this post


Link to post
Share on other sites

I know it will sound teh most stupid question ever, but I can live with this :P.

 

- I have a EEETop 1602 /Atom CPU, with 10.6.0 plain vanilla installed, I used Rebel EFI and my original SL disk.

 

I now that if I update the SL straight to 10.6.2 something will go wrong as our Apple friends dropped the support for the ATOM CPU.

 

I also know that there is a patched KErnel that will restore the ATOM support so....

 

How do I do upgrade??? I did read around and it came out I would need to do the following

 

1. Download zip to Desktop; 2. Unzip by double click; 3. Open Terminal.app; 4. sudo -s; 5. Enter your root password; 6. cd /; 7. mv mach_kernel mach_kernel_1062; 8. cp ~/Desktop/mach_kernel /; 9. chown 0:0 mach_kernel; 10. Reboot.

 

BUT...... do I do it on the 10.6.0 kernel to prepare it for the 10.6.2 upgrade or do I need to update first and than run this procedure, and..., if I update to 10.6.2 will I be able to follow the procedure ??

 

Thanks in advance for your kind replays folks,

 

Frank

Share this post


Link to post
Share on other sites

Anyone have this working on an HP Mini 2140 yet?

 

I installed 10.6.0 without issue by using a Boot-132 disk, Chameleon 2.0 RC3, a retail SL disk, and a preboot image from Eps over at myhpmini.com. Worked perfectly, so I figured I would take a stab at upgrading to 10.6.2.

 

I made a backup of the 10.0.0 kernel just in case, downloaded Teateam's kernel, and uses AppleIIGuy's install method, as to not over-write the Apple 10.2 kernel.

 

When booting from Chameleon, the default kernel is obviously useless, but trying to use Teateam's is causing a panic. The backup still works fine, but is of course still 10.0.0.

 

I looked into the preboot image that I'm using, and SleepEnabler isn't part of it, so I'm at a bit of a loss.

 

Any advice would be great. The system is still useable, so I will tinker around with it and see if I can figure it out.

 

Thanks.

Share this post


Link to post
Share on other sites

Ok,

So just to clarify, i *did not* have SleepEnabler installed in 10.6.0. I installed SleepEnabler for 10.6.2, and still get panics with the new kernel. Here's some screen shots: (Sorry if they're big, wanted to make sure you could read them)

 

First *without* SleepEnabler at all

Aphvd.jpg

 

 

Now *with* SleepEnabler for 10.6.2

v7SWF.jpg

 

 

These are the other kexts that I have loading in my preboot in Chameleon, it's probably one of them... Anyone know if any of these need to be removed or updated?

 

106_2140_Bluetooth.kext - com.microsoft.driver.LegacyBroadcomUSBBluetoothHCIController (2.2f18)

106_27AE_Graphic.kext - com.microsoft.driver.Package (6.6.6)

106_AppleACPIThermal.kext - com.apple.driver.AppleACPIThermal (1.0.5)

106_VoodooHDA.kext - com.microsoft.driver.Package (6.6.6)

2140_106_System.kext - com.microsoft.driver.Package (6.6.6)

2140_UUID.kext - com.free.driver.UUID (1.0d1)

27AE_AppleIntelGMA950.kext - com.apple.driver.AppleIntelGMA950 (6.0)

27AE_AppleIntelIntegratedFramebuffer.kext - com.apple.driver.AppleIntelIntegratedFramebuffer (6.0)

AppleACPIBatteryManager.kext - com.apple.driver.AppleACPIBatteryManager (1.0.15)

ClamshellDisplay.kext - com.superhai.driver.ClamshellDisplay (1.0.1)

dsmos.kext - com.apple.dsmos (1.0d1)

EpDisabler.kext - net.osrom.kext.Disabler (1.0.1)

IOAudioFamily.kext - com.apple.iokit.IOAudioFamily (1.7f16)

IOGraphicsFamily.kext - com.apple.iokit.IOGraphicsFamily (2.0)

IONDRVSupport.kext - com.apple.iokit.IONDRVSupport (2.0)

Natit.kext - com.dmweb.Natit (1.0d1)

OSvKernDSPLib.kext - com.apple.kext.OSvKernDSPLib (1.3)

VoodooHDA.kext - org.voodoo.driver.VoodooHDA (0.2.1)

VoodooPower.kext - com.superhai.driver.VoodooPower (1.2.3)

VoodooPS2Controller.kext - org.voodoo.driver.PS2Controller (1.1)

VoodooPS2Keyboard.kext - org.voodoo.driver.PS2Keyboard (1.1)

VoodooPS2Mouse.kext - org.voodoo.driver.PS2Mouse (1.2)

VoodooPS2Trackpad.kext - org.voodoo.driver.PS2Trackpad (1.1)

 

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Ok, I'm an idiot.

 

Maybe next time I'll do some digging around, and actually read the panic message, on my own before just asking for help...

 

The preboot image I downloaded for the system was still using dsmos, I switched it out for Fakesmc 2.5 and it worked right away.

 

Thanks for the new kernel Teateam :(

Share this post


Link to post
Share on other sites

hey i recently updated but got a kernel panic because of somthine like sk.triaxisXXXXX.kext (cant tell you the real name because the grey box that tells me to restart is blocking the screen...

so i got a kernel panic with every mach_kernel (the first, the updated and the original) so i am now on the 10.0.0 kernel (i removed sleepenabler completely) from 10.6.1 but now i dont have any resolution (just scarry 800x600) and no sound and so on.

 

could you help me?

got an eeepc 1000h so atom n270 ..

 

(would be nice if someone with eeepc could share his/her Extra folder with kexts.. so my lil hackintosh could run again :))

 

EDIT: solved it by myself... it was the sleepenabler.kext ... with the 10.6.2 version installed it now works for me on kernel 10.2.0 very very well done! thanks indeed

Share this post


Link to post
Share on other sites
I get the following kernel panic, I had to use my phone to take the picture.

 

I made it back into osx, I installed an eval version of MacDrive and was able to copy the original kernel back in.. (luckily i dual boot)

 

I searched for any type of log entries but I'm not seeing any.. if you know where I should look for info, I'll be happy to post log files.. I would really like to get this working so i can upgrade

 

This is an MSI WIND U100, Atom CPU N270 @ 1.60 GHz, 2GB RAM running snow leopard 10.6.1 (vanilla install)

 

ss1m.jpg

ss2kf.jpg

i suffer same probleme ...the blog is mindblowing but when this error we get the exictment level is down...pls help me also

Share this post


Link to post
Share on other sites
<br />1. Download zip to Desktop<br />2. Unzip by double click<br />3. Open Terminal.app<br />4. sudo -s <br />5. Enter your root password<br />6. cd /<br />7. mv mach_kernel mach_kernel_1062<br />8. cp ~/Desktop/mach_kernel /<br />9. chown 0:0 mach_kernel<br />10. reboot<br />

 

I guess you have to exchange kernels after the 10.6.2 update but before reboot as the machine won't boot with the stock kernel. I just wonder whether you have any other option after updating to 10.6.2 except clicking on "restart". Correct me if I'm wrong but I remember system updates like that - all you can do is click on the restart button and that won't work. So do you have to boot in single user mode and perform some tricks?

I can't try it myself as I just think of buying an Asrock ION 330 HT.

Share this post


Link to post
Share on other sites

Just run Terminal.app before run update. After update finish, don't press "restart". Go to your Terminal and do all you need.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×