Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
teateam

Patched mach_kernel 10.6.0 for Atom-based netbooks

347 posts in this topic

Recommended Posts

on my acer one AOA 150 it just dont work...

i use patched kerel... and when i restard de machine i just reboot again and again...

anyone knows something?

 

 

solved.... i have dual boot with windows 7 and mac drive 8... i boot windwos and put he mach_kernel on the root of my Mac OS X HDD and that it...

 

officialy works on acer one AOA 150

Share this post


Link to post
Share on other sites
@carpathian01

 

Can you give some more info? Is it simply replacing the 10.6.0 mach kernel for this modified one after updating to 10.6.2? What about the other kexts to be replaced by example the powersave kext?

 

I just modified the actual XNU kernel source code and release built the i386 and x86_64 versions of the mach_kernel. Then you just replace your mach_kernel after updating to 10.6.2 with the one I provided. All its doing is making mac os x recognize your atom cpu, so you will still need the proper kext for your system.

Share this post


Link to post
Share on other sites
I have the same problem. I am new at this. Can you please, show me how to boot with my old kernel and remove sleepenabler.kext and install the new 10.6.2 . Thanks

 

Please let me know if Someone helps you as I need it too! :)

Jens24

Share this post


Link to post
Share on other sites

Can anyone tell about how smoothly applications run??

 

Safari going ok, what about videos on YouTube?

Can you actually run iMovie, and make a movie with out frustrating lag?

playing music on iTunes?

 

What about photobooth, anyone with an internal camera being able to access the cam in OS X?

 

 

I wanna know of these things before i consider doing something like this.

: ]

Share this post


Link to post
Share on other sites
4094605037_05936b1a55.jpg

 

I make patch, test it please.

Download Link here.

Original russian article here.

Google translated page here.

 

Nice work. I don't know why Apple waste the effort of trying to break hackintosh...whatever they can do, somebody can and will undo.

Share this post


Link to post
Share on other sites

I have the same sleepenabler KP as msimac...

Unfourtinately I have no way to access a osx install to work around with the files, so im limited to using transmac via windows (i have yet to figure out how to mount my SL disk as RW via ubuntu). I tried using the updated sleepenabler kext, and i get the same KP... i also tried removing it all together and booting with -f (which still yielded a sleepenabler KP). I'm obviously forgetting to do something (updating something or clearing the caches? iono) or I am not removing the right kext. Any Ideas?

Share this post


Link to post
Share on other sites
I have the same sleepenabler KP as msimac...

Unfourtinately I have no way to access a osx install to work around with the files, so im limited to using transmac via windows (i have yet to figure out how to mount my SL disk as RW via ubuntu). I tried using the updated sleepenabler kext, and i get the same KP... i also tried removing it all together and booting with -f (which still yielded a sleepenabler KP). I'm obviously forgetting to do something (updating something or clearing the caches? iono) or I am not removing the right kext. Any Ideas?

 

You need to boot a install cd or usb stick

Share this post


Link to post
Share on other sites
4094605037_05936b1a55.jpg

 

I make patch, test it please.

Download Link here.

Original russian article here.

Google translated page here.

 

Have you tried to run VMware Fusion 3.0 I have the same system and with the mach_kernel 10.6.1 and 10.6.0 VMware install Crashes my system, My alternate fix was to install the voodoo 9.5.0 kernel but I can't get it to install properly.

Share this post


Link to post
Share on other sites
Here we go, Apple just released the sources of 10.6.2:

 

sources

 

Please pardon an ignorant :thumbsup_anim: question from an OSX86 n00b (with decent Linux experience, though). Which source package contains the mach_kernel files?

 

Here we go, Apple just released the sources of 10.6.2:

 

sources

 

Please pardon an ignorant :dev: question from an OSX86 n00b (with decent Linux experience, though). Which source package contains the mach_kernel files?

 

Edit: I'm admitting what an incredibly dense question that was. xnu

Share this post


Link to post
Share on other sites

Hi, any chance you can make one for 10.5.8 kernel of you can send me instructions on how to do hex edit the mach_kernel and I'll try to do it. Thanks.

Share this post


Link to post
Share on other sites
Hi, any chance you can make one for 10.5.8 kernel of you can send me instructions on how to do hex edit the mach_kernel and I'll try to do it. Thanks.

10.5.8 work with vanilla kernel. Only in 10.6.2 Apple remove Atom support.

Share this post


Link to post
Share on other sites
10.5.8 work with vanilla kernel. Only in 10.6.2 Apple remove Atom support.

 

Thanks for the reply. I have a d945gclf2 with Atom 330. With 10.5.8 (and 10.5.7) kernel, it only works with hyperthreading disabled or using cpus=3. A complete hyperthreading on 10.5.8 kernel would be great. Thanks.

Share this post


Link to post
Share on other sites
A-ha. I have it too (use as home media-server and torrent box). I use 10.6.2 in 32-bit mode - work all, include sleep.

 

Wish I could upgrade to snow but not sure on what to use. I downloaded hazard's but I get errors so I'm sticking with 10.5.8. I would appreciate it if you can make hyperthreading for that kernel. Also a list of your kext on snow would be appreciated along with the settings. Thanks.

Share this post


Link to post
Share on other sites

Hi All, I'm wondering if anyone has had experience with a "Velocity Netboox M10" getting Leopard or even Snow Leopard to work. It has the same specs basically as the mini 10v

 

 

 

Intel 945 (great for hackintosh)

 

Realtek and Via ethernet and wireless (i think probs with wireless and OS X if not mistaken)

 

Processor is an Aton N270

 

I have a bootable Flash disc made for a Dell mini 10 and it installed fine on it, but when I try to boot I just see the Apple logo and it never goes any further but the specs are the same as the Dell mini as far as chipset and graphics.

 

Thoughts??

 

Thank you! much Appreciated!! Want to hackintosh this and the dell was sosooooooooo easy itwas silly. I have a retail Leopard disc as well but same result.

 

 

 

Lane

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×