Jump to content
superviza

HP Mini 311 - Support Questions/Requests

1,497 posts in this topic

Recommended Posts

Advertisement
Hi,

 

I've installed everything and everything's fine, except for WIFI.

I'm completely mad reading tens of forum pages and trying to figure out what to do.

 

Please, correct me if I'm wrong:

1. There is no way to make stock WIFI card work in either WLAN or WWAN slot;

2. Stock card is in WLAN half-height slot by default. Bluetooth is on this stock half-height card too;

3. I can move stock half-height card to WWAN full-height slot and Bluetooth will remain working (no antenna required for Bluetooth);

4. I can buy Dell 1510 half-height WIFI card and put it to WLAN half-height slot and connect it to stock antenna that's supposed to be connected to WIFI card in WLAN slot;

5. After everything above I'll have my Mini 311 with either Bluetooth and WIFI working.

 

In case there's nothing wrong in my items, I guess I'm missing BIOS reflashing and 20-pin tapping thing, am I?

 

I feel I can comment on this now, as I got my Bluetooth card.

 

1. No stock wifi won't work.

 

2. If you got Bluetooth as part of your 311 the bluetooth is in the WIFI card (I can't confirm this as mine doesn't have default bluetooth).

 

3. don't know about this, except that yes- bluetooth needs and antenna to be decent I think

 

4. Yes

 

5. Don't Know

 

I added bluetooth to my 311 by getting a Dell 370 card and getting one antenna linked in the first post from ebay to install in the full size slot. I have a Dell half height N card in the half height slot (have not modified it yet to be an Apple card as that is a little over my head). Then I installed the 370 package here from the forum and BLAM- working wireless and bluetooth..

Share this post


Link to post
Share on other sites
I don't quite understand what card models are you talking about.

Ebay search for "atheros N wireless" gives plenty of cards for $20-$30.

 

This was posted by andnet:

 

http://cgi.ebay.com/Atheros-AR5BXB61-802-1...1d#ht_986wt_939

 

It's only $6, after 40% off. I need someone here to confirm that this one works. Thanks.

 

*the model of this card is Atheros AR5BXB61

Share this post


Link to post
Share on other sites
Thanks for the quick reply! Going to let you know if this is going to work..

 

The Ralink drivers can be downloaded here: http://www.ralinktech.com.tw/support.php?s=3 if other people want to fix their wireless simply.

don't worry it works 100%. I have one.

 

Weird issue guys: My external HDD 3 partitions (Snow leopard install - fat32 - fat32)

 

only the snow leopard install partition is recognized, and when I go under disk utility the other partitions are given weird names and greyed out. When I attempt to repair it fails. They show up on the Windows 7 partition so I don't know whats wrong. I've tried reformatting

Share this post


Link to post
Share on other sites

This isn't exactly installation related.

 

I was messing around with the dock today; placing it on the side, hiding it, changing magnification. After I put it back on the bottom and made it show up, it turned to a black rectangle exactly how it is on the side. I'm not sure how I can restore it back to the default.

Share this post


Link to post
Share on other sites

Hi, I am new to this forum, thank you for all the support and instructions, this method is much easier and functional than Netbook installer, my Hp Mini 311 is 99.9% working, I just need to fix the boot loader. When the hard disk starts it shows the bootloader (verbose I think) I have looked and I can't seem to find an easy option to fix this. Chameleon maybe? Please advice, I am sorry if am not using the right wording. Thank you.

Share this post


Link to post
Share on other sites

I think im dead in the head, the BCM94321 is supported. that card came with my mini. can someone explain really fast how it works thanks. ive been under a rock for a while

Share this post


Link to post
Share on other sites
This isn't exactly installation related.

 

I was messing around with the dock today; placing it on the side, hiding it, changing magnification. After I put it back on the bottom and made it show up, it turned to a black rectangle exactly how it is on the side. I'm not sure how I can restore it back to the default.

 

Seems I can remember that happened to me once, but it was very brief and I think I just rebooted the system and it was fine when it came back up. Plus I always make a backup of my systems to external hard drives just for times like this. BTW, I keep the dock on the left side of my netbooks, just seems like a better place for it. HTH

 

Hi, I am new to this forum, thank you for all the support and instructions, this method is much easier and functional than Netbook installer, my Hp Mini 311 is 99.9% working, I just need to fix the boot loader. When the hard disk starts it shows the bootloader (verbose I think) I have looked and I can't seem to find an easy option to fix this. Chameleon maybe? Please advice, I am sorry if am not using the right wording. Thank you.

 

I believe this was done on purpose as it allows sleep to work. It can be disabled, but you have to modify the Boot.plist file which resides in the hidden EFI partition. It is not recommended to change this setting. HTH

Share this post


Link to post
Share on other sites
don't worry it works 100%. I have one.

 

Bought myself another one, a Sitecom nano adapter, works great! But Im just curious about the following:

 

These wireless adapters work with drivers from the manufacturer, i.e. a 'driver' and a utility. Is there possibly a way to let OS X see the adapter as a "real" Airport? Because I need some functions which de utility doesn't have... Thanks!

Share this post


Link to post
Share on other sites
Bought myself another one, a Sitecom nano adapter, works great! But Im just curious about the following:

 

These wireless adapters work with drivers from the manufacturer, i.e. a 'driver' and a utility. Is there possibly a way to let OS X see the adapter as a "real" Airport? Because I need some functions which de utility doesn't have... Thanks!

I actually hadn't thought about making it "real aiport." Seems like a good idea. http://www.mvixusa.com/support/index.php?_...kbarticleid=133

 

will try that myself later. let me know how it goes

Share this post


Link to post
Share on other sites

@theprotho

 

Hi, I used the HF3 version, and after i did a clean install, everything went well but when the mini boots a bunch of white letters on a black background shows very slow until it loads SL. is there a way and instructions in how to fix this or get a GUI?

 

Thank ypou.

Share this post


Link to post
Share on other sites
@theprotho

 

Hi, I used the HF3 version, and after i did a clean install, everything went well but when the mini boots a bunch of white letters on a black background shows very slow until it loads SL. is there a way and instructions in how to fix this or get a GUI?

 

Thank ypou.

 

The white text is called Verbose mode. This allows sleep to function on the 311 properly; and stability. It removes key components to the system if disabled. The next time you install a hotfix it will enable Verbose mode.

Share this post


Link to post
Share on other sites
The white text is called Verbose mode. This allows sleep to function on the 311 properly; and stability. It removes key components to the system if disabled. The next time you install a hotfix it will enable Verbose mode.

 

@jfally

"The next time you install a hotfix it will enable Verbose mode"

 

Meaning that if I run the package that came with the HF4 would show the apple logo while booting?

Share this post


Link to post
Share on other sites
@jfally

"The next time you install a hotfix it will enable Verbose mode"

 

Meaning that if I run the package that came with the HF4 would show the apple logo while booting?

 

Meaning exactly what jfally said.

 

Please take the time to read before asking this has been explained very recently by me and others... It gets hashed and rehashed over and over again.

 

Do you feel it is a better use of our time explaining something to you what you could have just read a few pages back in depth?

 

Sorry to light you up here but you are not the first or the last who will do this.

Share this post


Link to post
Share on other sites
@jfally

"The next time you install a hotfix it will enable Verbose mode"

 

Meaning that if I run the package that came with the HF4 would show the apple logo while booting?

 

Wrong. Installing a pkg. would enable Verbose booting, causing no GUI bootloader to appear.

 

Enabling the GUI is completely up to you. However, nearly everyone including myself would strongly recommend that you stick to the default Verbose booting procedure.

Share this post


Link to post
Share on other sites
Meaning exactly what he said.

 

Please take the time to read before asking this has been explained very recently by me and others... It gets hashed and rehashed over and over again.

 

Do you feel it is a better use of our time explaining something to you that you could have just read a few pages back in depth?

 

Sorry to light you up here but you are not the first or the last who will do this.

 

 

Honored to be addressed by you. I totally agree with you, you guys probably spend a big amount of time, re-answering questions. I stumbled upon this thread 4 days ago and i got my mini 311 3 days ago, i was able to understand and do: flash Bios to v.04, tape 20th pin on full pci card and booting from the release but i am still reading simultaneously, from the oldest post to the newest currently on 15th page and from the newest post to the oldest, currently on 45th page. but i could not find that conversation. sorry about that. Is there a way to do Linked topics and then we dive into that? Such as Wifi, Bluetooth, Sleep etc, topics. thanks for all the help theprotho, U taking donations?

 

Wrong. Installing a pkg. would enable Verbose booting, causing no GUI bootloader to appear.

 

Enabling the GUI is completely up to you. However, nearly everyone including myself would strongly recommend that you stick to the default Verbose booting procedure.

 

Ok, how I enable GUI?

Share this post


Link to post
Share on other sites

Hi,

 

Since it's been removed from the package now, can I ask where to get the HP default wallpaper?

 

Thanks,

Share this post


Link to post
Share on other sites
Honored to be addressed by you. I totally agree with you, you guys probably spend a big amount of time, re-answering questions. I stumbled upon this thread 4 days ago and i got my mini 311 3 days ago, i was able to understand and do: flash Bios to v.04, tape 20th pin on full pci card and booting from the release but i am still reading simultaneously, from the oldest post to the newest currently on 15th page and from the newest post to the oldest, currently on 45th page. but i could not find that conversation. sorry about that. Is there a way to do Linked topics and then we dive into that? Such as Wifi, Bluetooth, Sleep etc, topics. thanks for all the help theprotho, U taking donations?

 

If the thread search function worked it would be easy however it doesn't.

 

Removing the -v switch from the com.apple.boot.plist file within the EFI partition would get you the Apple logo on boot but prevent you from waking from sleep and cause a bit more corruption you system failed to wake. Upon a kernel panic in Mac OS it's journaled file system rarely protects your data and you will see messages like "removed 12 files and 3 directories" on boot each time it KPs on resume. Its up to you, you aren't the first or last that may try it, feel like your system is now corrupt and end up reinstalling.

 

No donations here... Its best to keep a safe distance around these places.

Share this post


Link to post
Share on other sites
Hi,

 

Since it's been removed from the package now, can I ask where to get the HP default wallpaper?

 

Thanks,

 

I don't have a copy available right now but I'm sure one of the folks could provide that...

 

If not then I could upload one tomorrow.

 

Anybody tryed my method? It's work for you or not?

 

I'm intrigued and have tried it in the past for the 4353 (supervisa and I back in October...) with little luck then. But I really hope folks do give it a go.

 

To anyone willing to work with it:

 

Use DSDTSE to edit the DSDT.aml installed in the EFI partition.

 

I am using a Dell rebranded to Apple 432b right now but may give it a go again.

 

Good post.

Share this post


Link to post
Share on other sites

I'm not sure whether this method works for 4353 (maybe some edit needed), but it must to work on 4315 - because it's working with the same card on my laptop (Fujitsu Siemens V3205).

 

Who can give my ioreg from HP mini 311 with BCM943224 card?

Share this post


Link to post
Share on other sites
I'm not sure than this method works for 4353 (maybe some edit needed), but it must to work on 4312 - because it's working with the same card on my laptop (Fujitsu Siemens V3205).

 

 

Technically it should work (with the appropriate values of course) for any card supported by the driver since the actual info the driver is filtering by is the sub vendor and sub id after the ven id and dev id.

 

In fact Apple is using the 4353 in its current Mac Book Pro line...

 

I have a working solution right now so I haven't put any more effort in on that front.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×