Jump to content
Sign in to follow this  
Followers 0
Jamesisnotonfire

World of Warcraft Installer won't open.

2 posts in this topic

Recommended Posts

Hey guys, for the last 3 days now I've been trying to find a fix or solution so that I can open the world of warcraft installer and install the game. I've tried the disks and the clients from the website.

When I click to open installer.app nothing happens, dosnt open.

I have tried the Rosetta fix and there is still no luck and I'm a little frustrated I can't get it to work.

If anyone has a solution to my problem, please post, will be much appreiciated.

 

Thanks in advance,

James

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×