Jump to content

[How To] recover a deleted software raid

10 posts in this topic

Recommended Posts

unfortunately I deleted one of my softraid´s by mistake in disk utilty. of course I did have a backup of the disk but not including my work of the last week :(


if this happens to you or the partition table is damaged for some reason - this guide is a possible solution:


1. don´t try any experiments - you could loose all your data

2. get the recovery tool "r-studio for mac"

this app has a possibility to rebuilt the raid as a virtual disk. all you need is to remember the order of the

disks and the stripe size you used with this raid before.

3. open r-studio and click on raid in the menu. choose "Virtual Block Raid"

4. choose the 2nd partitions labeled Apple_Raid_offline and drag and drop them in the right order on the new created

device. you won´t need the "efi" or the "boot osx" partitions.

5. now you still can change the order of the disks on the right side and apply.

6. define the stripe size and apply. apple default is 32 - if you use the wrong one it will end up with recovered unusable

files, but the data on the disks won´t be touched. so it´s possible to try different settings without any further damages.

7. if it worked a new partition will appear - now recover!


this way I was able to recover the whole data from the raid 100% - even with names, folders and the complete structure.

the price of r-tools is around 80 bucks and was one of my best investments ever! it´s worth every cent :)

Share this post

Link to post
Share on other sites
Thanx mate, you're the hero of my day.


Got my data back with your tip.


Have a nice day bro :D


OMG.....I didn´t see this post sice mid june....too much travelling


happy to hear that it helped you :)

Share this post

Link to post
Share on other sites

I´d like to reanimate this topic.

My question to peach-os is what kind of RAID he is talking about. I´m trying to figure out a way to repair a RAID 0 which I accidently resolved via diskutility. The disks are untouched and found by diskutil as follows:



diskutil list



0: GUID_partition_scheme *2.0 TB disk0

1: EFI 209.7 MB disk0s1

2: Apple_RAID_Offline 2.0 TB disk0s2

3: Apple_Boot Boot OSX 134.2 MB disk0s3



0: GUID_partition_scheme *1.0 TB disk1

1: EFI 209.7 MB disk1s1

2: Apple_HFS CK 999.9 GB disk1s2



0: GUID_partition_scheme *2.0 TB disk2

1: EFI 209.7 MB disk2s1

2: Apple_RAID_Offline 2.0 TB disk2s2

3: Apple_Boot Boot OSX 134.2 MB disk2s3


diskutil listraid

No AppleRAID sets found



The RAID disks are found and marked offline, is there any chance to put them together again or rescue the data as peach-os described??

I tried iPartition (not changing anything on that disks), it even found the Name of the lost volume an its correct size.


I appreciate any hint that could help. I asked the german support for r-studio and they said, that r-studio is not capable of repairing RAIDs.

I´m a bit confused now....

Share this post

Link to post
Share on other sites

hahahaaaaa...........how stupid is that ??? that great raid functionality of r-studio was the reason i did spend 70 bucks for it.....wow - great support ;)

I had exactly the same situation as you with raid0 - r-studio working 100%.


to check that is very easy: the trial version will let you see the files but not recover - just test it. what you need to know is what block size you used - the default is 32


P.S: I speak german if it helps

Share this post

Link to post
Share on other sites

Thanks for replying so fast.

My hopes are growing... I will try the r-studio trial version tomorrow and post the result.

I would appreciate your help with the upcoming procedure.


P.S.: MeinEnglisch ist zwar nicht so schlecht, aber ich freue mich auch auf eine Antwort auf Deutsch. :wink2:

Share this post

Link to post
Share on other sites

Today I tried R-Studio Demo. No matter what block size and number of rows it always finds the same amount of data.

It shows the original structure but all indicated original folder files say 0 Bytes. Data files seem to be of correct size.

Before I buy the software I would like to be sure not to recover empty files.


I tried to add a screenshot here, but it didn´t work.

Share this post

Link to post
Share on other sites

give me some time . I will check that for you with my r-studio version and compare it to the demo.

Share this post

Link to post
Share on other sites

Well, I just purchased R-Studio. I was not able to recover the original folder structure, but a l l f i l e s with original names. I found them in a thousands of numbered folders and it took a couple of hours, but there were no losses. :-))


Thanks again peach-os!


I´m still wondering if it´s possible to recover the RAID with its original structure or even "mount" the virtual RAID.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.