Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
zazman

Sharing soundtrack pro AU plugin with Logic express ?

5 posts in this topic

Recommended Posts

I use soudtrack pro UB and there is inside a great Audio Unit plugin : Space Designer,

a great physical modeling reverb with many presets : i'd like to use it into logic express UB.

 

When I use Logic express 7.2.1 UB, i can't find the Space Designer plugin in the AU manager window of logic :

 

Is there a thing to do to incorporate this plugin into the AU environnment of Logic ?

A location to declare or a file to copy into the /libray/audio/plugins/apple.... ????

 

In the same time, when I lauch Logic, all is working good but i've just an error message

when the environment is lauched saying can't find HUI module (error -43) ????

 

Any idea about this error ? Has something to do with the soundtrack plugins ?

 

(there is no problems to lauch the others AU plugins and the garageband plugins/sounds into logic.

the logic plugins lauch correctly into soundtrack pro too)

 

-> Or simply a limit of logic express capability / logic pro ?

 

Thanks a lot.

Share this post


Link to post
Share on other sites

nobody has this problem ? do you have been able to share your plugins between soundtrack pro and logic

express/pro ? or nobody tried to share plugins ? (i don't speak about garageband) ?

Share this post


Link to post
Share on other sites

If the plugin is not in one of the few predefined locations that Logic is looking for it in, then no, it wouldn't show up. If it already is in one of those places, or you've told Logic exactly where it is, then it's probably an architecture issue. My guess would be that your build of Logic and Garageband are unibins and this space reverb au is probably PPC....does that sound correct?

 

I only suggest this may be the problem because the PPC AUs and VSTs I have won't show up at all in the unibin of Ableton, but unibin plugins work great.

Share this post


Link to post
Share on other sites

Thank for your post fOzf8,

 

The space designer plugin is really an UB one because it's working into sountrack pro UB :

a ppc plugin would not work, and also, the space designer pluggin is shipped/installed within the soundtrack pro UB package !

 

I think it's more likely a folder location problem, because this is an Audio Unit plugin....

Share this post


Link to post
Share on other sites

As I understand it Space designer is not an Audio Unit, therefore it won't be compatible with other programs. Logic express and pro both come with lots of effects and instruments included, but I don't think any of them are audio units.

 

They even have different file extensions. An audio unit is .component whereas the logic only files end with .res

 

I have tried coping the .res files into logic express with no luck, makes me wonder though what kind of modification would be required to make a .res file read like a component.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Did you tried use ACPIBatteryManager.kext for the Battery? And for brightness you can use IntelBacklight  Both created by @RehabMan 
    • I have put it into clover drivers 64uefi folder on Yosemite thru High Sierra which allows me to edit my High Sierra disk if needed in Yosemite system.   There is no functionality of apfs in other versions but it does allow other clover bootloaders and systems to recognize the HS apfs drive or open it for inspection.   If you don’t have it you can’t see your HS drive or access it in another macOS version.
    • Hi! Is it possible to get codec AD1981 running with AppleHDA on HP Compaq 8710w? It works nicely with VoodooHDA. Speakers and HP are switching automatically.  Internal and HP mic also work - no switching in SysPref but it works when mic is plugged in and internal mic works when hp mic is unplugged.   It has same weird pathmap - connected directly:  Playback: nid=5 [pin: Speaker (Analog)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001 nid=6 [pin: Headphones (Grey Left)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001   But inputs are really weird. There are 5 nodes from input to HP mic/Internal mic nid=4 [audio input] | + <- nid=21 [audio selector] [src: mix] bindSeq=00000003 | + <- nid=12 [audio mixer] [src: mix] bindSeq=00000003 | + <- nid=30 [audio selector] [src: mic] bindSeq=00000001 | + <- nid=8 [pin: Microphone (Grey Left)] [src: mic] bindSeq=00000001 + <- nid=31 [audio selector] [src: monitor] bindSeq=00000002 | + <- nid=24 [pin: Microphone (Analog)] [src: monitor] bindSeq=00000002 Can pathmap like that even work with AppleHDA? What codec should I patch? I tried patches from AD1984 but no luck.    These are manually patched verbs: 00571c10 00571d01 00571e17 00571f90 00570C02 00671c20 00671d10 00671e21 00671f03 00771cf0 00771d00 00771e00 00771f40 00871c30 00871d10 00871e81 00871f03 00971cf0 00971d00 00971e00 00971f40 00a71cf0 00a71d00 00a71e00 00a71f40 01671cf0 01671d00 01671e00 01671f40 01771cf0 01771d00 01771e00 01771f40 01871c40 01871d01 01871ea0 01871f90 01971cf0 01971d00 01971e00 01971f40   Codecgraph and linux codecdump attached. Thx for any help or suggestions.              codec.txt 2.svg codec.txt
    •   Yes, 'cause APFS log is coming before clover boot screen.


×