Jump to content

[GUIDE] Retail Snow Leopard Install on Asus EeePC 1000HE


441 posts in this topic

Recommended Posts

Trackpad Problem.

 

Trackpad Preferences (Synaptics Trackpad, is this the correct?) don´t work, mouse preferences are controlling the trackpad.

 

Help!!!!

 

Thank's

 

Have a look here and here ; both solutions do not work for me...

If you decide to experiment, you must have a USB mouse and keyboard handy and do not forget to update mkext and clear up cashes.

Let us know.

Hello,

 

install the VoodooHDA.prefpane just unzip and run file it will install in System Preferences.

Then go to System Pref's VoodooHDA and check the level's for Speaker, set PCM and Output Gain to max.

 

Good Luck

 

Carlos

Thanks, but after install of VoodooHDA, when I open, it says : Error, can't get registry-entry path. And when after I try to set gain to max, it says : Error Can't open IO Service.

Any other idea ?

Thanks,

Abee

Thanks, but after install of VoodooHDA, when I open, it says : Error, can't get registry-entry path. And when after I try to set gain to max, it says : Error Can't open IO Service.

Any other idea ?

Thanks,

Abee

 

voodoohda.prefpane need voodoohda.kext installed to work.

Install the file voodoohda.kext then you don´t get the error!

 

You can do this with either with kexthelper or just copy it over the orginal and then run kext utility.

 

(Follow the guide, get the files and tools - link's for download)

Tell if work's!

 

Thanks, but after install of VoodooHDA, when I open, it says : Error, can't get registry-entry path. And when after I try to set gain to max, it says : Error Can't open IO Service.

Any other idea ?

Thanks,

Abee

 

Let me quote the guide:

 

"4-Copy this extra folder to the root of the OS X drive and let it overwrite all files. I have updated this with voodoohda.kext that works with the voodoohda.prefpane that you will need to get the mic working."

Hi

 

My Asus 1000HE is booting with a external USB disk!

 

How to make it boot from my internal hard drive?

 

Thank you

Download SuperDuper! from http://www.shirt-pocket.com/SuperDuper/ and install it to "Finder -> Applications" when booted from the external HDD.

 

Launch SuperDuper! Choose "Copy: [your external HDD] to: [your internal HDD] using: Restore - all files". Make sure it is from the external TO the internal and not the other way around. Then press "Copy Now".

 

When finished, rerun NetbookInstaller but this time choose the internal HDD from the drop down list and only choose "Install Chameleon 2 RC3". Nothing else. Press "Install".

 

When finished, copy, paste and overwrite this folder to the root of your internal HDD.

Hi, i have Eee PC 1000H ... with AirPort card, installed Mac OS X 10.5.7 Retail, FULLY WORKING, i think that, this guide work for me too, or not? ... please tell me. I Have 1000h, not 1000he... Thank You

 

 

Hi, i have installed Snow Leopard with this guide and works everything except the mic, but when i updated to 10.6.1 mi web cam is out, and my mic doesn't work.

 

 

 

the last instalation that i'd made in my eeePC 1000h was iatkos v7 with enik's method and every thing is running ok.

Download SuperDuper! from http://www.shirt-pocket.com/SuperDuper/ and install it to "Finder -> Applications" when booted from the external HDD.

 

Launch SuperDuper! Choose "Copy: [your external HDD] to: [your internal HDD] using: Restore - all files". Make sure it is from the external TO the internal and not the other way around. Then press "Copy Now".

 

When finished, rerun NetbookInstaller but this time choose the internal HDD from the drop down list and only choose "Install Chameleon 2 RC3". Nothing else. Press "Install".

 

When finished, copy, paste and overwrite this folder to the root of your internal HDD.

Thank's for your reply and usefull info; Worked perfect!!

 

Trackpad Question:

 

My trackpad don't recognize anymore Touch with two fingers for Right Click...

 

Two finger Scroll-OK

 

Options in the Trackpad Pref.pane don´t cause any effect... only mouse.

 

 

Any ideia? Thank's

And yeah. Thanks for a great guide (and post by jojitsu)!

 

Everything is fully working (sleep/sd card reader/multi touch/ethernet/bluetooth/fn-keys etc.)

 

Though I replaced the stock wifi card with a brand new chinese Dell 1390. My little-sisters 1000HE now have native AirPort in the menubar as on a real mac. No more fugly "WirelessUtilityCardbusPCI" app. $12 bucks on eBay & free worldwide shipping! :P

 

(Later I realized that I should have bought the Dell 1505, for about the same price, which gives you 300 Mbps 802.11n instead of 54 Mbps 802.11g. But the Dell 1390 works flawlessly and she probably couldn't spot the difference anyway. :D )

Have a look here and here ; both solutions do not work for me...

If you decide to experiment, you must have a USB mouse and keyboard handy and do not forget to update mkext and clear up cashes.

Let us know.

Thank's! Didn´t work work for me too.

 

I Reeinstall original Kext from this guide, every thing working (except adjust setting's in PrefPane for Trackpad, but working)

 

-Working perfect with Wireless Apple Keyboard and Mouse! (Bluetooth)

-Working perfect with USB Keyboard and mouse from my very old iMac (first generation model)

 

Really feel like I have a New Mac!!!

Hi,

 

Followed the installation guide on a seagate usb drive from existing MAC, everything worked except I couldn't boot/recognize the usb drive when i plug it into the 1000H. All BIOS settings were good, select boot priority to usb drive, boot drive order to usb seagate drive, etc.

 

finally found this post on making the drive active.

 

http://www.insanelymac.com/forum/index.php?showtopic=22844

 

Was able to boot into OSX Snow Leopard after making the active drive change.

 

Thanks to OP for the guide!

Has anyone updated 1000he to 10.6.2 - is everything working after this update?

 

Rgds

 

ATTENTION ALL!! DO NOT UPDATE TO 10.6.2 UNTILL FURTHER NOTICE.

 

I am looking for solutions and I will post any working fixes as soon as I find one. If you find one feel free to post it. I suggest making a good backup or clone of your drive before attempting to update.

I did the upgrade, but not before making a backup of the partition with SL on it. I also made a copy of the kernel:

 

cd /

sudo cp mach_kernel mach_kernel_bk

 

After the upgrade, I got instant kernel panic. Starting with the backup-kernel worked flawless!

(In the chameleon boot-screen type the name of the kernel you want to start, mach_kernel_bk)

 

Testing now if there's more stuff broken...

I did the upgrade, but not before making a backup of the partition with SL on it. I also made a copy of the kernel:

 

cd /

sudo cp mach_kernel mach_kernel_bk

 

After the upgrade, I got instant kernel panic. Starting with the backup-kernel worked flawless!

(In the chameleon boot-screen type the name of the kernel you want to start, mach_kernel_bk)

 

Testing now if there's more stuff broken...

 

Can anybody post mach_kernel and mach_kernel.ctfsys?

 

Thanks!

Great guide. Thanks for all your work. My eee is working great now, with one exception. The dreaded netflix DRM error 8152. My understanding from this thread:

 

1. http://www.infinitemac.com/f57/snow-leopar...rm-error-t3846/

2. http://www.insanelymac.com/forum/lofiversi...hp/t114349.html

 

Is that there needs to be another device-properties hex string added to the boot plist for the ethernet device. There are a whole bunch of strings in the existing boot plist, which is in the /Extra folder not the

/Library/Preferences/SystemConfiguration/com.apple.Boot.plist.

 

Can you clarify a few things?

1. Can I use the procedure in #2 to generate a hex string for my device and add it to the existing boot plist?

2. Does the boot file in /Extra get used instead of the one in /Library/xxx ?

Great guide. Thanks for all your work. My eee is working great now, with one exception. The dreaded netflix DRM error 8152. My understanding from this thread:

 

1. http://www.infinitemac.com/f57/snow-leopar...rm-error-t3846/

2. http://www.insanelymac.com/forum/lofiversi...hp/t114349.html

 

Is that there needs to be another device-properties hex string added to the boot plist for the ethernet device. There are a whole bunch of strings in the existing boot plist, which is in the /Extra folder not the

/Library/Preferences/SystemConfiguration/com.apple.Boot.plist.

 

Can you clarify a few things?

1. Can I use the procedure in #2 to generate a hex string for my device and add it to the existing boot plist?

2. Does the boot file in /Extra get used instead of the one in /Library/xxx ?

 

 

1. Yes you should be able to do that.

2. I think there both used. But all I can suggest is get the hex string you need and experiment with it. See if it works in either or... I don't use netflix so have never ran into that issue. And as always before experimenting make a backup. :-)

 

Good Luck. Let us know how it goes.. and what you did...

hi,

i'm very new to the OSX86 and i'm very interested in trying installing the snow leopard on my Asus EeePC 1101HA and i was wondering if there any body did try it? or wants to try it so we can work together ? it's very new to me and i will need help understanding the steps .. it will be great if there's anyone who is interested in trying with me as a group.

please help !

thanks

I changed my mind and will not be doing this. I am really happy with my hackintosh now and don't want to mess it up just to get netflix working.

 

1. Yes you should be able to do that.

2. I think there both used. But all I can suggest is get the hex string you need and experiment with it. See if it works in either or... I don't use netflix so have never ran into that issue. And as always before experimenting make a backup. :-)

 

Good Luck. Let us know how it goes.. and what you did...

Steps I took to update from 10.6.1 to 10.6.2:

 

Before updating first backup your kernel. If you forget this, your 1000HE won't start.

 

open terminal:

sudo -s
  cd /
  cp mach_kernel mach_kernel_1061
  chown 0:0 mach_kernel_1061

 

Install 10.6.2

 

After the reboot, you have to boot from the backup kernel. When you're in the chameleon bootloader type the name of the kernel you want to start. In this example it's mach_kernel_1061. You'll see what you type in the bottom of the screen.

 

After your 1000HE is booted, you're running 10.6.2 with the 10.6.1 kernel. Now we're going to install the patched Atom kernel (this kernel tells OSX your Atom is an Intel core solo processor).

 

Download the kernel from the forum:

Patched mach_kernel 10.2.0 for Atom-based netbooks, Dirty bithack

 

Unzip this download to the desktop.

 

Unfortunately one of the installed kext can't work together with this new kernel, so you'll need to replace the SleepEnabler.kext too.

 

Download SleepEnabler 10.6.2 from the forum:

SleepEnabler for 10.6.2, (Only for Kernel 10.2.0)

 

Unzip this download to the desktop too.

 

Now we're going to install the new kernel. In terminal type the following commands:

sudo -s
cd /
mv mach_kernel mach_kernel_orig1062
cp ~/Desktop/mach_kernel /
chown 0:0 mach_kernel
chmod 644 mach_kernel

 

Now we're going to install the new SleepEnabler.kext.

Open the Finder and go to /Extra/GeneralExtentions.

Remove SleepEnabler.kext

Copy the SleepEnabler.kext from your desktop to /Extra/GeneralExtentions

Rebuild the kext cache in /Extra with the program UpdateExtra in the folder /Extra.

 

After a few minutes your system is ready to boot from the new kernel. Reboot your system, in Chameleon type -f to rebuild all the kext and enjoy!

Hey guys,

 

I've finally got everything up and running on my SL ! Thanks for all the tips!

 

I'm now trying to hook up the EeePC to my external monitorl, but I have some issues. Whenever I plugged in the external monitor to the VGA port on the EeePC, the entire SL desktop will get 'corrupted' and I couldn't see anything.

 

Does anyone have the same issue as well? Thanks!

Hey guys,

 

I've finally got everything up and running on my SL ! Thanks for all the tips!

 

I'm now trying to hook up the EeePC to my external monitorl, but I have some issues. Whenever I plugged in the external monitor to the VGA port on the EeePC, the entire SL desktop will get 'corrupted' and I couldn't see anything.

 

Does anyone have the same issue as well? Thanks!

 

The same with me, but only when I selected the option to see the same image in booth monitors...

 

in the monitor pref´s, set to use 2 monitores. If you set to see the same image in the EeePC and the external monitor, only works if you use the max resolution of EeePC. I also get the SL destop "corrupted" when selected higher resolution.

 

With 2 monitores I can adjust the correct resolution for the external monitor...

 

Try a lower resolution for your EeePC monitor before plug the external monitor, so you can see and make adjustments

 

Good luck!

Hi,

 

just installed SnowLeopard following this guide. Worked quite well but 2 things are still a little problematic. My 1000HE always thinks it is on Battery power, even if no battery is inserted. Is it possible that OSX can recognize what power it is actually using?

Also the keyboard is not working correctly. I'm on a japanese EeePC but the keyboard layout is always US, even with Kotoeri selected and there is no "Japanese Layout"

 

Is it possible to resolve these problems, and is it possible to turn off the trackpad?

×
×
  • Create New...