Jump to content
Rocco18

Extensa 5220 Snow-Leo Grafik

37 posts in this topic

Recommended Posts

Hallo zusammen,

Ich bin neu hier im Forum, und habe gleich eine Frage an die Experten:

Ich besitze ein Notebook von Acer, Extensa 5220, vielseitig gelobt für

Hack-Install.

Da habe ich auch schon Erfolg zu verzeichnen; 10.5.6 läuft wunderbar.

Nach Anleitung vom Forum.

Jetzt habe ich mich an Snow-Leo rangetraut, geht auch soweit, aber....

bei der Version 10.5.6 habe ich eine gute Bildschirmauflösung 1280x800x32 mit QE/CI

und durchsichtigem "Top-Bar" also oben die Leiste.

bei Sno-leo geht das leider nicht, da fehlt wohl der richtige "Treiber"

oder kext wie das heisst bei OSX.

Hat jemand von euch schon sowas installiert....Snow-Leo auf Extensa ?

Die Grafikkarte ist eine X3100 integriert.

mein Durchforsten der Foren hat mir keine "Erleuchtung zu kommen lassen"

Könnte mir bitte jemand helfen?

 

Danke

Rocco18

Share this post


Link to post
Share on other sites
Advertisement

Die Intel x3100 hab ich mit diesen Treibern komplett zum laufen bekommen, :whistle: in vielen Fällen reicht es auch die natit.kext zu installieren. Probiers mal!! Bei meinem Lenovo N200 hats super geklappt. :P nur für SL hab ich noch keine Lösung gefunden... bin noch dran...

 

Intel x3100 Grafik treiber

Share this post


Link to post
Share on other sites
Die Intel x3100 hab ich mit diesen Treibern komplett zum laufen bekommen, :( in vielen Fällen reicht es auch die natit.kext zu installieren. Probiers mal!! Bei meinem Lenovo N200 hats super geklappt. :( nur für SL hab ich noch keine Lösung gefunden... bin noch dran...

 

Intel x3100 Grafik treiber

Unter Leopard 10.5.6 läuft es bestens.

Mein Problem ist Snow-Leopard, hatte ich doch in meinem Post erwähnt.

Share this post


Link to post
Share on other sites
wenn du snow leo im 32(i386) modus laufen lässt kannst du die alten treiber verwenden

Danke Nexos !!

jetzt geht es wie ich es mir wünsche:

Ich habe nochmals neu installiert....

und nur im 32bit-Mode gestartet, da geht die Auflösung auf Anhieb, mit QE/CI

keine Änderungen an den Grafik-Kexten gemacht(OOB)

Update auf 10.6.1 klappt auch einwandfrei.

Suppiie

 

Sleep works

Restart works

Sound works

Wifi works

Shutdown works

Share this post


Link to post
Share on other sites

Hallo Rocco18,

 

ich habe mein Extensa 5220 wunderbar via Boot-CD mit 10.5.6 laufen lassen. Nun probiere ich schon seit Tagen mein System SL-fähig zu machen. Ich lese unheimlich oft, dass man die DSDT Datei an den Rechner anpassen muss um Audio, Grafik, Sleep etc. aktivieren zu können. Wie hast du SL auf Deinem Rechner installiert? Mit DSDT oder ohne? Bei mir wird jedes Mal mein BIOS zurückgesetzt - wieder ein Punkt der für DSDT spricht... Wäre es Dir möglich Deine gemachten Einstellungen step by step zu offenbaren? Das wäre mir eine große Hilfe. Vielen Dank!

Share this post


Link to post
Share on other sites

Damit dein Bios nicht mehr zurückgesetzt wird und falls du kein DSDT Patch hinbekommst, solltest du dir die AppleRTC.kext in /E/E installieren.

Share this post


Link to post
Share on other sites
Hallo Rocco18,

 

ich habe mein Extensa 5220 wunderbar via Boot-CD mit 10.5.6 laufen lassen. Nun probiere ich schon seit Tagen mein System SL-f�hig zu machen. Ich lese unheimlich oft, dass man die DSDT Datei an den Rechner anpassen muss um Audio, Grafik, Sleep etc. aktivieren zu k�nnen. Wie hast du SL auf Deinem Rechner installiert? Mit DSDT oder ohne? Bei mir wird jedes Mal mein BIOS zur�ckgesetzt - wieder ein Punkt der f�r DSDT spricht... W�re es Dir m�glich Deine gemachten Einstellungen step by step zu offenbaren? Das w�re mir eine gro�e Hilfe. Vielen Dank!

Ich bin so froh dass alles klappt, eigentlich weis ich es gar nicht mehr genau.....

Ich versuch es mal zu rekonstruieren.

1) meine org. Platte mit 10.5.8 habe ich ausgebaut, und in ein 2,5" Gehäuse gebaut, mit USB-Anschluss.

2) In den Acer habe ich meine "alte" Platte(Reserve) mit 10.5.6 wieder eingebaut.

3) Das SnowL-Image(10A432) habe ich von meinem iMac auf die 10.5.8-Platte kopiert.

4) Jetzt habe ich von der 10.5.8er Platte per USB das System gebootet.

5) Dann nach der von @NEXOS beschriebenen Methode das SL-Image gemountet und auf die "alte" eingebaute Platte installiert.

Chameleon2 RC3 installiert... Die erwähnten kexte installiert, auf die Rechte achten,

und wichtig in der Boot.plist das Bootflag i386 setzen, also 32bit-Mode.

per default wird im 64bit-Mode gestartet, aber kein QE/CI

wie schon erwähnt halte dich bitte genau an die Anleitung von Nexos, die ist SUPER...

6) DSDT installieren

7) in die Boot.plist habe ich noch die UUID meiner Platte eingetragen.

So nun sollte das Acer von selbst booten....Snow-Leopard ... Hurra

Ich hoffe das ist einigermassen verständlich, Umgang mit Editoren, Terminal sowie Kommandos, setze ich voraus.

Ich persl. habe einige Linux-Kenntnisse.

 

viel Erfolg

Share this post


Link to post
Share on other sites

Hi!

 

Vielen Dank für die schnellen Antworten! Ich wollte mich erst wieder melden, nachdem ich weiter rumprobiert habe - das geht jetzt schon einige Stunden :)

 

wäre es möglich mir deine dsdt.aml zukommen zu lassen?

Share this post


Link to post
Share on other sites

Hallo!

 

Habe auch SL auf dem 5220 installiert, allerdings mit einigen Einschränkungen:

 

- Sound fehlt, VoodooHDA wird im Profiler zwar als geladen angezeigt, aber es herrscht trotzdem Stille

- kein LAN (BCM5787M), im 32Bit-Modus wird Ethernet als vorhanden angezeigt, komme aber nicht online

- bei VoodooBattery wird in der (Finder)Menüleiste das Batteriesymbol mit einem "X" dargestellt: es wäre

angeblich kein Akku installiert

 

Der Rest ist i.O. (alles OoB):

 

- Grafik mit QE (X3100)

- WLan

usw.

 

Was mich besonders erstaunt, dass der Sound nicht geht, obwohl die kext geladen wird.

Habt Ihr bessere Erfahrungen gemacht?

Share this post


Link to post
Share on other sites

Wie hast du die Grafik zum laufen bekommen? Ich hab ein Lenovo N200 mit X3100 und bei mir steht da "keine kext geladen" ich krieg das QE nicht aktiviert. WLAN funktioniert mit BCM4312 modul, das intel modul kommt wieder rein wenn projekt camphor fertig ist. :robot:

 

 

 

Ach ja, sound geht auch auf dem N200 unter SL, mit dem selben Treiber der auch unter Leopard funktionierte

Share this post


Link to post
Share on other sites

@teletoby:

 

Habe die gleiche Erfahrung wie Rocco18 gemacht: Die X3100 läuft im 32-bit-Modus ohne Änderungen an der Installation( siehe Post #6)

 

Die Sound-Kexts aus Leopard werde ich nochmal testen...

Share this post


Link to post
Share on other sites

Also das mit dem SL im 32bit Modus muss ich mal testen ob das funzt... aber wo liegt das problem eigentlich das es im 64bit Modus nicht funzt?

Share this post


Link to post
Share on other sites

Angeblich soll seit update 10.6.2 GMA X3100 auch im 64-bit Modus laufen. Allerdings, ich bekomme es nicht hin ;)

 

Zum Sound: VoodoHDA braucht man nicht, nur HDA Intel.

Share this post


Link to post
Share on other sites
Angeblich soll seit update 10.6.2 GMA X3100 auch im 64-bit Modus laufen. Allerdings, ich bekomme es nicht hin ;)

Was hast du schon probiert?

Share this post


Link to post
Share on other sites

Hm. Ich habe 10.6. installiert und das geht einwandfrei mit 32bit aber 64bit natürlich nicht x3100.

Einwandfrei heißt: grafik, sleep, batteryanzeige und die meisten fn-keys.

Dann habe ich neuinstalliert 10.6.2. hazard.

Außer mit den Sachen, die man nicht Auschalten kann, noch mit: Apple HDA, Apple ACPI, Dings Flip, Voodoo Battery, Voodoo Monitor, Voodoo Power, SMBios, UUID.

Beim Booten mit -legacy also 32bit geht nur der external screen, nicht der laptop lcd. Das nervt.

 

Booten unter 64bit hängt: es kommt kein Desktop, nur im safemode kommt dieser.

 

Habe die dsdt erstellt und modifiziert mit diesem Einträgen: http://www.projectosx.com/forum/index.php?showtopic=763

Doch das hat keine Veränderung gebracht.

Ich habe keinen weiteren Bootloader installiert, außer grub2. Der hat allerdings eine if-then Schleife: /Extras/DSDT.aml laden, wenn vorhanden,

doch bin ich mir nicht sicher, ob er es wirklich tut.

Helfen würde mir eine dsdt vom extensa 5220, da könnte ich nachschauen, wie der LCD definiert ist.

 

Werde mal eine dsdt ohne lcd-einträge erstellen, wenn das keine negative Veränderung bringt, funktioniert grub2 nicht.

Share this post


Link to post
Share on other sites

GMAX3100 ist der stock driver 10.6.2 und lt. About this mac 64-bit fähig. Der Treiber mit FB ist nur 32bit fähig.

 

Gibt es sowas, wie lsmod, um zu sehen, welche kext geladen werden?

Share this post


Link to post
Share on other sites
Gibt es sowas, wie lsmod, um zu sehen, welche kext geladen werden?

kextstat

 

Ich glaube, das ist richtig so. Die Info findet man jedenfalls häufiger. Ist das bei dir anders?

Die Version Nummer gleich?

Share this post


Link to post
Share on other sites

Nein, die Revisionen sind unterschiedlich. Habe meine kextstat im 32bit Modus angehangen, da kann man die Nrn. ablesen. Melde mich wieder, wenn ich weiß, ob grub die dsdt ignoriert und evtl. anderen Bootloader nach-installiert habe. Muß erstmal schauen, wie das geht.

kexts.txt

Share this post


Link to post
Share on other sites

   85	0 0x35e8e000 0x17000	0x16000	com.apple.driver.AppleIntelGMAX3100FB (5.1.8) <84 73 14 13 11 7 5 4 3 1>

 

Es ist von Leopard.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×