Jump to content
InsanelyMac Forum
ixxxion

Radeon HD 5870 / HD 5850

Recommended Posts

my father have give me his ati hd 4850, but after that i've inserted it system go in kernel panic with this kexts:

 

com.apple.atiradeonx2000

com.apple.iopcifamily

com.apple.iondrvsupport

com.apple.iographicsfamily

 

I've read many methods to make functionally this cards but unsuccesfully...can you help me please?? have you perfect and precise guide?? thanks a lot!!!

Share this post


Link to post
Share on other sites
Advertisement

Back on topic (and first post here)

 

I can confim that my ATI 5870 does not work on my hackintosh. I read earlier in the post that you can get at least 1024x768 res if you set the graphics enabled to 'No' . I changed this setting and i still am having the same problem. Am I doing something wrong?

 

To be more specific, I load up and get to the Chameleon boot menu, I choose to boot mac os x and the screen goes blank, and the graphics card's fan fires up to 100% (very loud infact).

 

I have an old x1900gt that does work so I will be investigating the post at the link below to sort out a temporary dual graphics card solution.

 

http://www.insanelymac.com/forum/index.php?showtopic=139016

 

Slightly off topic: Can I get my x1900gt to jump up to my monitors native resolution at 1900 ?

Share this post


Link to post
Share on other sites

If anyone does get this card working please post. I have been thinking of upgrading my video card and now I am having second thoughts.

Share this post


Link to post
Share on other sites
If anyone does get this card working please post. I have been thinking of upgrading my video card and now I am having second thoughts.

 

I managed to get the 5870 working. I just realised, if i have my [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] CD inserted (that runs chameleon) it doesnt work.

 

However, i am only gettin 1024x768 resolution. I read here that you can mod the rom to achieve native resolution http://www.insanelymac.com/forum/index.php...11294&st=20 but i have no idea how to do it.

 

Also I researched into an EDID override hack will report back.

 

If anybody can help me get to native resolution on this card I would be very grateful.

Share this post


Link to post
Share on other sites

is most likely that you didn't actually got the 5870 working, and what you are getting is plain vesa mode

to say that it is working, you should at least be able to access full resolution, and even better if you get QE/CI

Share this post


Link to post
Share on other sites

Heyyo,

 

10.6.4 officially came out, doesn't break anything that 10.6.3 didn't.. and yes, didn't add anything new to us folks with ati everest/redwood videocards (no ati 5000 series anything).

Share this post


Link to post
Share on other sites
is most likely that you didn't actually got the 5870 working, and what you are getting is plain vesa mode

to say that it is working, you should at least be able to access full resolution, and even better if you get QE/CI

 

You can always just mod the BIOS and get native res that way, that's how I got my HD5870 to 1920x1200. The guide's somewhere in the tutorial section.

Share this post


Link to post
Share on other sites
I managed to get the 5870 working. I just realised, if i have my [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] CD inserted (that runs chameleon) it doesnt work.

 

i have an HD5830 but I have the same problem (black screen, blinking monitor light after chameleon)

how did u manage to get screen back up again?

I already removed [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and placed SL disc in there as per the instructions.

Share this post


Link to post
Share on other sites

Heyyo,

 

With me [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.0 and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.0 didn't work for chameleon, installed that and had to install a newer version of chameleon.

 

I used the Dr. Hurt one that tonymacx86 has in the blog:

http://www.insanelymac.com/forum/index.php...p;#entry1404132

Share this post


Link to post
Share on other sites

i have a ati 5850 twin frozr and it will boot one screen at least no problem, but no hardware acceleration, im going to try to get double screen at least through some cable downgrading but is anyone working on a home brewed kext for this? or are we all just waiting?

 

for mac currently i swap out a gfrc 9800gt which is pretty much 1/20th the power lol but hey it works when i need accel for now...

 

i can still exchange it, but until nvidia comes out with N470GTX twin frozr im not gonna go out and do the work, btw, somone got GTX470 normal version working, i downloaded the package but i dont remember off the top of my head where the post is. so if youre going for 400 series, id go for 470, second best in benchmark so far so im guessing youll be ok

Share this post


Link to post
Share on other sites
You can always just mod the BIOS and get native res that way, that's how I got my HD5870 to 1920x1200. The guide's somewhere in the tutorial section.
JJJohan, link, please!!
Diebuche's know how & bios analyzer here

Greetz

Share this post


Link to post
Share on other sites
Diebuche's know how & bios analyzer here

Greetz

 

I read that post before and it does not tell you how to modify the bios. It just talks about the analyzer program.

 

I need some help on modifying the bios for my ati 5870 please so I can run in native resolution. I can then refer to the post you linked to above for what values to change.

 

JJJohan can you please write the steps on how you managed to do it please, or a link to the tutorial?

 

Just an udate:

Just looked all over in the tutorials forum. Can't find anyting about modding the bios for a graphics card anywhere.

 

So I have been googling around, could I use something like this?

 

http://www.techpowerup.com/rbe/

 

That looks like something that we can use to easily mod the card to run in native resolution. I will have a go at this after work tonight and report back. I will still be interested to hear JJJohan's process though...

Share this post


Link to post
Share on other sites

Can someone please link to me how I can get Mac OS X working on a ATi 5850? Many talked about it, but I have no idea where you found it. I am very eager to get it :angel:

My processor is an Intel i5 if it's important.

 

I don't care about the resolution, I saw some tuts on have to fix it, I can try it out :)

 

Thank you VERY much in advance

Share this post


Link to post
Share on other sites

Heyyo,

 

Stalkr, try [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.0 Supported. Worked fine for me. You will need a legitimate retail copy of Snow Leopard. :angel:

 

http://tonymacx86.blogspot.com/

 

Worked fine for my i3-330M and ATi Radeon HD 5650 Mobility.. just the resolution is low and no framebuffer or QE/CI so no 3D graphics and stuff.

Share this post


Link to post
Share on other sites

so, IT'S NOT WORKING

there are NOT 5000 working at this time

only way to get display is vesa mode

Share this post


Link to post
Share on other sites
so, IT'S NOT WORKING

there are NOT 5000 working at this time

only way to get display is vesa mode

according to Anval bootloader post in this forum, there are 2 5800 series card listed as supported.

 

I tried to ask exactly what was supported,. what card exactly,. accelerated etc, but no answer still.

Share this post


Link to post
Share on other sites
Heyyo,

 

Stalkr, try [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.0 Supported. Worked fine for me. You will need a legitimate retail copy of Snow Leopard. :D

 

http://tonymacx86.blogspot.com/

 

Worked fine for my i3-330M and ATi Radeon HD 5650 Mobility.. just the resolution is low and no framebuffer or QE/CI so no 3D graphics and stuff.

 

I tried both with USB, CD, set boot priority to CD, USB, HD. I tried to boot manually into CD and USB, but it does not see the CD/USB. It's like it ignores it and boot right up in Windows S:

 

How can I fix this problem, I can record a little clip to show you what I mean..

 

Thank you VERY much in advance

Share this post


Link to post
Share on other sites

Heyyo,

 

Hmm, you should just be able to burn the iso to a dvd and boot to [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Supported.. and you should get a menu. If that fails then you can try to use Win32 Imager to mount the image to a usb flash drive. For my tower I did needed to use two USB drives. A small one to boot to [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Supported, and a second for snow leopard since it didn't like my DVDRW drive on either the jMicron controller or my Intel SATA controller which has my windows 7 64bit install but in RAID0 on 4 HDD's.

 

https://launchpad.net/win32-image-writer/+download

Share this post


Link to post
Share on other sites
http://forums.macrumors.com/showthread.php?t=958191

 

YESYESYESYES!!!!! Radeon 5xxx drivers in the new Mac Mini version of 10.6.4! Netkas already has them and is working on getting them working! If you have a Radeon 5000 series card then get your butts over there and lend a hand in testing!

 

We're almost there!

 

Great, I've headed over to macrumours and have offered to lend a hand with testing and will report back here.

Share this post


Link to post
Share on other sites
Great, I've headed over to macrumours and have offered to lend a hand with testing and will report back here.

 

 

I do wanna help too, but how can I test if it works?

Please help me, as I am interested in getting it worked myself, just like so many else S:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×