Jump to content
InsanelyMac Forum
Zenith432

VMware SVGA II display driver for OS X, v1.2.5

Recommended Posts

Note for people who install Darwin Tools from Fusion 4.0.1 on the guest - Do not install the VMsvga2 guestd patches over this version of the tools. They're incompatible. I'm working on an update to the guestd patches. In the meantime, it's not possible to get fit-guest under VMsvga2 with Darwin Tools 4.0.1. If you must have fit-guest, use VMware's driver VMwareGfx from 4.0.1 in the guest.

 

First i've just installing Lion, i've found a great tutorial and i must say that with

 

unlockers for vmware the process is near that an out of the box installation, so thanks you so much.

 

Actually im 10.7.1 100% vanilla with vmware 5.0.0 darwin.iso

 

I've just installed VMsvga2 and its an huge graphic improvement so 'Zenith432' great work ...

 

For desktop effect, the one that boring me is the new fullscreen mode ... Even after the VMsvga2 1.2.3 installed, the effect is still slowww, is it a 3d effect of a memory problem or anything else ?...

 

my cpu is an i7 m640 with a quadro fx 880M just for information..

 

And i'm waiting too the updated guest patch for newer darwin iso.

 

Great work again !

Share this post


Link to post
Share on other sites
Advertisement

I've completed the guestd patches for Fusion 4.x and uploaded to the Display section of VMsvga2 Files on Sourceforge.

 

Sources are available under sources.

The uninstall.sh script in the root folder there has also been updated.

 

The installer contains guestd patches for Darwin Tools 4.x, 3.x and 2.0.6. I've only tested the installer on top of Tools 4.x, so if anyone tries the new installer on Tools 3.x and it doesn't detect them, please let me know. I had some trouble finding a good test to differentiate between Tools 3.x and Tools 4.x.

 

The latest resolutionSet.dylib patch (for Fusion 4.x) works with both VMsvga2 and VMwareGfx. So if you install VMsvga2, patch the tools, and later choose to revert to VMwareGfx, fit-guest should continue to work with VMwareGfx without a reinstall of Tools 4.x.

 

 

For desktop effect, the one that boring me is the new fullscreen mode ... Even after the VMsvga2 1.2.3 installed, the effect is still slowww, is it a 3d effect of a memory problem or anything else ?...
I'm not sure what you mean.

  • There are some glitches during Lion startup when the screen resolution gets changed from the boot resolution of 1024x768 to the resolution set from the previous boot. I haven't had time to analyze the sequence of events that takes place there.
  • Lion has some new window animations that make opening windows slower. This article describes how to disable them and make opening new windows faster. Large scale animations only perform well if QE/CI is present [which it isn't in a virtual machine.]
  • You should set the guest VRAM to at least 32MB with VMsvga2
    svga.autodetect = "FALSE"
    svga.vramSize = "33554432"

    I have longstanding plans to eliminate this memory requirement, but haven't gotten around to implementing them.

Share this post


Link to post
Share on other sites
I'm not sure what you mean.

 

I was talking of the new Maximizing effect, when an app like safari goes fullscreen,

 

the effect is really slow and can't manage to disable it.

 

... I've try to put more memory like 33554432 or 133554432 but that doesn't change anything...

 

By the way, the new guest patch work great with Lion, well done :-)

Share this post


Link to post
Share on other sites
I was talking of the new Maximizing effect, when an app like safari goes fullscreen,
I see what you mean. That's one whopping animation, because it slides the entire screen off to the left and then zooms the window. I couldn't find a way to disable it ;)

There's no way to increase performance of animations like that without QE/CI. QE/CI uses the GPU - which has specialized parallel processors to arbitrarily map textures on the faces of any 3D mesh. This functionality can be used to make planar texture mapping a lot faster too. So on a mac with QE/CI animations look decent. Without it, it's all rendered one pixel at a time by the CPU...

Share this post


Link to post
Share on other sites
I see what you mean. That's one whopping animation, because it slides the entire screen off to the left and then zooms the window. I couldn't find a way to disable it ;)

There's no way to increase performance of animations like that without QE/CI. QE/CI uses the GPU - which has specialized parallel processors to arbitrarily map textures on the faces of any 3D mesh. This functionality can be used to make planar texture mapping a lot faster too. So on a mac with QE/CI animations look decent. Without it, it's all rendered one pixel at a time by the CPU...

 

Hum that's so bad... apple application contains more and more effect like that,i don't know how vmware will manage that with vmware fusion... to provide at least a correct user experience

Share this post


Link to post
Share on other sites

There are some Problems with the SVGA 1.2.3 in Lion under Workstation 8.

 

http://www.insanelymac.com/forum/index.php?showtopic=268579

 

Does anybody here have a Lion system that is running under Workstation 8 which does not have performance issues on the upper half of the screen, or is this a general problem?

Share this post


Link to post
Share on other sites

VMsvga2 v1.2.4

 

FYI, I uploaded VMsvga2 v1.2.4 to sourceforge. It has an improved handling of fit-guest/autofit-guest based on new code in VMwareGfx 4.x. For people who make use of the fit-guest feature, I suggest installing this, as the switch to the custom resolution is a lot less clunky than before. It still takes a few seconds on Lion, but is reasonably fast on Snow.

 

The installer is for Snow & Lion. Link is in post #1.

 

Changelog from 1.2.3 to 1.2.4

  • Added display modes 1152x720, 2560x1440.
  • Smoother mode changes when using fit-guest/autofit-guest.
  • Alpha Cursor conversion optimized with MMX.
  • Log levels for vmw_log_fb are 1 - 3.
  • Supports 256-byte EDID.
  • Checks admin privilege for vmware-tools-daemon when doing [auto]fit-guest.
  • Limits [auto]fit-guest resolution to maximum supported by host.
  • Supports Surface-to-Surface copy-blit in Accelerator.
  • Improved screen grab function to eliminate an intermediate copy.
  • Restrict creation of surfaces to WindowServer.
  • Discontinued support for OS X Leopard.

Share this post


Link to post
Share on other sites

How do you get autofit to work?

 

I'm having problems getting it too work

 

I am using vmware workstation 7.1.4 on windows 7

 

And I'm using the legacy kernel and the mac os x version is 10.6.6

Share this post


Link to post
Share on other sites

Hello,

I'm using SnowLeo with qemu/kvm under linux because it's very reactive but there is no much driver so I look at yours.

VMMouse is working well as it but there is also a reverse engenering vmw-svga.bios and a minimal "driver" in qemu/kvm:

 

https://github.com/avikivity/qemu/blob/mast...hw/vmware_vga.c

 

My goal was to use this minimal driver to gain acces to various resolution and why not HW cursor.

 

If you read the code you will see there is not so much code implemented and SVGA_CMD_DEFINE_ALPHA_CURSOR is missing, meaning I'm not able to use the hardware cursor with the vmwsga2 mac os driver.

 

Adding the code for SVGA_CMD_DEFINE_ALPHA_CURSOR in the qemu driver should not be a lot of work but given all run well with linux guest I doubt this will done soon.

 

What I've done is : in qemu source:

 

diff --git a/hw/vmware_vga.c b/hw/vmware_vga.c
index 354c221..3690f3a 100644
--- a/hw/vmware_vga.c
+++ b/hw/vmware_vga.c
@@ -988,10 +988,10 @@ static void vmsvga_update_display(void *opaque)
     * Is it more efficient to look at vram VGA-dirty bits or wait
     * for the driver to issue SVGA_CMD_UPDATE?
     */
-    if (s->invalidated) {
-        s->invalidated = 0;
+    //if (s->invalidated) {
+    //    s->invalidated = 0;
        vmsvga_update_screen(s);
-    }
+    //}
}

 

and in vmwsvga2 change in the file vmw_options_fb.h :

 

VMW_OPTION_FB_FIFO_INIT 0x02U //0x01U
VMW_OPTION_FB_REFRESH_TIMER 0x01U // 0x02U

 

and use vmw_options_fb=1 as a workaround cause I need my screen to refresh but I can't validate FIFOInit... with this I'm able to resize and the cursor is visible.

 

All this to point you to the qemu code ( don't know if you're interested) and to say thanks.

Share this post


Link to post
Share on other sites

Great work Zenith!

 

I've been trying to figure out a way to use Mac OS X on my laptop ever since I gave up my macbook pro for a g73jh. Thanks to your brilliant work I'm now able to use Mac in vmware.

 

Now I have a question:

Since practically every GPU supports OpenGL nowadays couldn't the function calls to the GPU by the operating system be directed straight to the GPU on the host system without any sort of interference?

 

I was thinking that if we created an extension of sorts for the VMWare workstation host couldn't we develop a driver that would direct the calls to the GPU. I'm not really a programmer but logically thinking I thought this could be possible. Another thought that occurred to me was that Apple already provides the drivers for various GPUs; on such systems would it be possible to allow the system to access the GPU of say the i5-HD3000 series GPUs since Apple already natively supports it?

 

I have already read the thread on enabling QE/CI in VMWare and that it would require VMWare's own contribution but I thought that this may also be a viable solution.

 

Only thinking logically here, no sort of experience with programming except designing a quadratic equation solver in a command prompt interface with C++.

 

Thanks for the great work! Keep it coming.

Share this post


Link to post
Share on other sites

I have a question as to Garageband. Does Garageband use QE/CI?

 

I just successfully got it working and I grew curious cause I thought it was impossible.

 

unledqhb.png

Share this post


Link to post
Share on other sites
I've completed the guestd patches for Fusion 4.x and uploaded to the Display section of VMsvga2 Files on Sourceforge.

 

The installer contains guestd patches for Darwin Tools 4.x, 3.x and 2.0.6. I've only tested the installer on top of Tools 4.x, so if anyone tries the new installer on Tools 3.x and it doesn't detect them, please let me know. I had some trouble finding a good test to differentiate between Tools 3.x and Tools 4.x.

 

Zenith432,

 

Thank you for your great work.

 

Unfortunately, The 'Autofit Guest' is not working for me even after I install latest guestd patches. Tested with both VMsvga2 1.2.3 and 1.2.4.

 

I am running a fresh install of Mac OS X Snow Leopard 10.6.3 updated to 10.6.8 with VMware Tools from VMware Fusion 3.1.3 on VMware Workstation 7.1.5.

 

VMware Tools from VMware Fusion 4.0.2 did not work well with Mac OS X Snow Leopard 10.6.8 on VMware Workstation 7.1.5, so I stayed with 3.1.3.

 

Best regards,

 

@

Share this post


Link to post
Share on other sites
I am running a fresh install of Mac OS X Snow Leopard 10.6.3 updated to 10.6.8 with VMware Tools from VMware Fusion 3.1.3 on VMware Workstation 7.1.5.

 

VMware Tools from VMware Fusion 4.0.2 did not work well with Mac OS X Snow Leopard 10.6.8 on VMware Workstation 7.1.5, so I stayed with 3.1.3.

If you installed 4.0.2 and then 3.1.3 on top of it, this may be a problem with the guestd_patches installer. There's a separate patch for 3.1.3 and 4.0.2. It tries to differentiate the two by looking for a file called vmmemctl in /Library/Application Support/VMware Tools. This file exists in 4.0.2, but didn't exist in 3.1.3. Look in this directory and see if there are files there with memctl in them. If so, remove them.

When running the guestd_patches installer, do a custom install and check if there's a check mark next to the right version (3.x or 4.x). If it installs the 4.x patch for 3.x (or vice versa), the patch won't work.

 

 

Does Garageband use QE/CI?
I'm not sure. There's no way to be sure without running it in a debugger and seeing if it calls CGLChoosePixelFormat specifying that it should return only GPU-assisted OpenGL drivers. It's possible for an application to display all of its graphics using classic Quartz-2D (no QE needed), and only specific windows using hardware OpenGL. So yes, it may be that just one sub-window in an application doesn't work (this is the case with Aperture I believe.)

Share this post


Link to post
Share on other sites

Hi,

 

I finally got 10.7.2 working properly in my Vmware Player 4.

 

But I am extremely confused do I need this driver v1.2.4 or should I stick with the vmware tools installed from darwin401.iso

 

And if it is required, do I uninstall the Vmware Tools using the same installer in Darwin401 files, as it says uninstall Vmware Tools.

 

What exactly should I do?

 

Quite Confused?

 

Thanks,

 

Flynn

Share this post


Link to post
Share on other sites
Hi,

 

I finally got 10.7.2 working properly in my Vmware Player 4.

 

But I am extremely confused do I need this driver v1.2.4 or should I stick with the vmware tools installed from darwin401.iso

 

And if it is required, do I uninstall the Vmware Tools using the same installer in Darwin401 files, as it says uninstall Vmware Tools.

 

What exactly should I do?

 

Quite Confused?

 

Thanks,

 

Flynn

Flynn,

 

Leave the darwin.iso (401) installed, all should work fine, Zenith's 1.2.4 driver may add some enhanced performance, but can be installed as well as the VMware Tools.

Share this post


Link to post
Share on other sites
Flynn,

 

Leave the darwin.iso (401) installed, all should work fine, Zenith's 1.2.4 driver may add some enhanced performance, but can be installed as well as the VMware Tools.

 

Thank you again....I do see some smooth animation when moving mouse in dock...with 1.2.4.

 

I appreciate your help.

Share this post


Link to post
Share on other sites

Hey,

 

I don't know where exactly to post this question, but I believe it is relevant to this thread.

 

I have Video Driver v1.2.4 installed with Vmware Tools from Darwin OS 401 (Lion 10.7.2), but I am seeing some items in browser/or full page transparent. I have attached a screenshot.

 

I am at loss of words on how this is happening...it is cool to see transparency, but it is making surfing hard, as I can't see the page.

 

Check out the screen shot - I went to a link from engadget to Gmail's blog page, and voila it is blank. I even saw this problem when going to support.apple.com. I am seeing this transparency all over the place, but it is random sites

 

Any ideas on what is going on?

 

Thanks,

 

Flynn

 

post-912027-1320252481_thumb.png

Share this post


Link to post
Share on other sites

Another question to my previous post.

 

I am unable to see any youtube videos...I assume it is due to hardware acceleration? any workarounds on this. Technically anything with Flash is out...

 

I have tried it in Safari, Firefox and Chrome and even install the Flash package.

 

Thanks,

 

flynn

Share this post


Link to post
Share on other sites
Another question to my previous post.

 

I am unable to see any youtube videos...I assume it is due to hardware acceleration? any workarounds on this. Technically anything with Flash is out...

 

I have tried it in Safari, Firefox and Chrome and even install the Flash package.

 

Thanks,

 

flynn

flynn,

 

There was a problem with flash, requring an earlier version, have a dig around the InsanelyMac forum, I will have a look as well, it may be relevant?

Share this post


Link to post
Share on other sites
If you installed 4.0.2 and then 3.1.3 on top of it, this may be a problem with the guestd_patches installer. There's a separate patch for 3.1.3 and 4.0.2. It tries to differentiate the two by looking for a file called vmmemctl in /Library/Application Support/VMware Tools. This file exists in 4.0.2, but didn't exist in 3.1.3. Look in this directory and see if there are files there with memctl in them. If so, remove them.

When running the guestd_patches installer, do a custom install and check if there's a check mark next to the right version (3.x or 4.x). If it installs the 4.x patch for 3.x (or vice versa), the patch won't work.

Zenith432,

 

I took a snapshot before installing VMware Tools from VMware Fusion 4.0.2 and reverted to it before installing 3.1.3, so there are no files from 4.0.2 in /Library/Application Support/VMware Tools.

 

I just tried to install VMsvga2 1.2.4 and latest guestd patches on Mac OS X 10.6.8 with VMware Tools 3.1.3 again, and 'Autofit Guest' is still not working.

 

I installed VMware Tools from the darwin.iso inside VMware-Fusion-3.1.3-416484-light.dmg:

VMware-Fusion-3.1.3-416484-light.dmg\2.hfs\VMware Fusion\Install VMware Fusion.app\Contents\Resources\Install VMware Fusion.mpkg\Contents\Packages\com.vmware.fusion.tools.darwin.pkg\Contents\Archive.pax.gz\Archive.pax\.\Library\Application Support\VMware Fusion\isoimages\darwin.iso

 

The guestd_patches installer showed 3 options:

Patch for VMware Tools from Fusion 4.x, Skip, 16k

Patch for VMware Tools from Fusion 3.x, Install, 16k (Checked)

Patch for VMware Tools from Fusion 4.x, Skip, 696k

 

This is the results of running uninstall.sh afterwards:

Removing receipts for old package ids

VMsvga2.kext detected.

1) yes

2) no

3) quit

remove? 1

Forgot package 'net.osx86.vmsvga2SnowLeo.pkg' on '/'.

Forgot package 'net.osx86.guestd_patches_2.pkg' on '/'.

/bin/rm -rf /System/Library/Extensions/VMsvga2.kext

/bin/rm -rf /System/Library/Extensions/VMsvga2Accel.kext

/bin/rm -rf /System/Library/Extensions/VMsvga2GA.plugin

If you've patched VMware Tools daemon for use with VMsvga2 and you'd

like to return to using VMware's display driver, you should reinstall

VMware Tools. This script neither removes the patch nor restores the

original VMware Tools daemon.

 

Best regards,

 

@

Share this post


Link to post
Share on other sites

Forgive me if this is a completely stupid question, but do I need the driver and tools patch if guest autofitting and shared folders are already working correctly?

 

I created my Lion VM on a Mac under Fusion 4.01, and installed the tools there, and verified everything worked. I then just copied the whole VM folder to my Win7 x64 system, installed VMWare Workstation 7.14, ran the unlocker, and opened the VM. Everything seems to be working. Does this driver have notable performance improvements? Did I just luck out that everything works?

Share this post


Link to post
Share on other sites
I have Video Driver v1.2.4 installed with Vmware Tools from Darwin OS 401 (Lion 10.7.2), but I am seeing some items in browser/or full page transparent. I have attached a screenshot.
Which version of VMware host are you running? If running Workstation 7.x, try adding the line

svga.enableScreenObject="TRUE"

to your VMX file.

Could you please post your VMware.log file when you get these transparencies? It's a bug in the screen-to-memory blitter used during window motion, but it shouldn't be happening on recent versions. It may happen with Workstation 6.5.x.

As a workaround, you can either

  • boot with Kernel Flags "vmw_options_fb=3". This will disable the accelerator and make VMsvga2 work like VMwareGfx. or...
  • uninstall VMsvga2 and install VMwareGfx (from VMware Tools).

 

 

I just tried to install VMsvga2 1.2.4 and latest guestd patches on Mac OS X 10.6.8 with VMware Tools 3.1.3 again, and 'Autofit Guest' is still not working.
It sounds like you have everything installed right. The only other thing I can think of, is go to Edit->Preferences->Display in VMware Workstation and make sure "autofit guest" and "full-screen autofit guest" are enabled.

Share this post


Link to post
Share on other sites

hi!

 

i'm new in this forum. my problem is, that

 

i can't install vmware display driver v1.2.4 on a vmware with mac osx lion with a windows 7 host system.

 

 

ERROR msg:

 

"VMware SVGA II Display Driver v1.2.4 can't be installed on this disk. This package requires OS 10.6 or later.

 

BUT

 

It's lion (10.7) I have no idea, what I'm doing wrong.

 

 

thanks for any help!!!

Share this post


Link to post
Share on other sites
hi!

i'm new in this forum. my problem is, that

i can't install vmware display driver v1.2.4 on a vmware with mac osx lion with a windows 7 host system.

 

ERROR msg:

 

"VMware SVGA II Display Driver v1.2.4 can't be installed on this disk. This package requires OS 10.6 or later.

 

BUT

 

It's lion (10.7) I have no idea, what I'm doing wrong.

thanks for any help!!!

I can only think this is your guestOS setting in your VMX file, not being set to "darwin11" or "darwin11-64".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×