Jump to content
andrean

ATI Mobility RADEON HD 2600 HELP

100 posts in this topic

Recommended Posts

Tried with kalyway 10.5.2 model Psae6e toshiba.after installing agp package it will not boot. With -x-v-f it seems to stop booting at "ATY" don't remember exactly.I did not delete anything from extensios n didn't repair permisions.which method did u use to boot with retail DVD? The link u posted has 3-4 wAys.Can't post more I am on iPhone n it is hard to write many things

Share this post


Link to post
Share on other sites
Advertisement
So by that I assume it worked yes?

 

 

no. not work, (black screen)

 

but this morning "XxX 10.5.6 final v2" version I tried. I chose hd 2600 pro pcie as Video card drivers. After installation I opened with-v-x command. More I did the installation. -v -s command after the reset at the open and I deleted all the ATI drivers. when loading the desktop, i install your's kexts. I opened the system VGA port external monitor. its work!!

 

But internal monitor showed a black screen again. Somehow I could not solve the cause.

Share this post


Link to post
Share on other sites
no. not work, (black screen)

 

but this morning "XxX 10.5.6 final v2" version I tried. I chose hd 2600 pro pcie as Video card drivers. After installation I opened with-v-x command. More I did the installation. -v -s command after the reset at the open and I deleted all the ATI drivers. when loading the desktop, i install your's kexts. I opened the system VGA port external monitor. its work!!

 

But internal monitor showed a black screen again. Somehow I could not solve the cause.

 

 

As dumb as it sounds, just keep messing around with it now. Keep playing with it. Thats the only way I found out I could get this thing to work for me.

 

Let me know when it working internal. Try the AGP drivers too for the 2600 pro / XT, I'm pretty sure that the key to the whole deal.

Share this post


Link to post
Share on other sites

hi friends, i tryied the follow procedure and it works for me, i have a Asus F3Sa with Ati Mob HD2600. (id 9581)

 

installed hd2600 agp package

installed AppleACPIEC.kext

installed RadeonHD.kext (10-28-2009 edited info.plist set to false HardwareMouse)

installed Natit.kext

 

rebooted with "-s" single user and delete ATI* extensions

rebooted again then internal lcd worked fine.

but sometime system hang..

 

so i tryied it whit chamaleon rc2/vanilla and chamaleon/voodoo system versione 10.5.8 and 10.5.6

 

 

best regard

Share this post


Link to post
Share on other sites

This method has been tested for the installation of Vanilla. (Retail MacOSX Leopard 10.5.6)

 

First of all 'hackmymac' and 'ipowertech' many thanks... This tutorial is built upon what they write.

 

USB installation methods. Installation requires:

 

1. A running MacOSX

2. 8 gb USB memory (minimum)

3. 1 CD (boot_132)

4. External USB keyboard

5. Leopard 10.5.6 retail dvd or disc image

6. From the following link to download the CD iso, cd boot-132, and burn. (I choose contains extra kexts)

http://www.insanelymac.com/forum/index.php?showtopic=113288

7. M2600HD_Packs

http://www.mediafire.com/?rw3z2dzygqq

 

 

 

Let our computer plug usb keyboard. We need its..

First, prepare installation's usb in working macosx.

Applications> Utilities> Disc Utility

 

Lets choose USB. Click Partition button. select 1 partition. Click 'Option' key and pressing the 'GUID Partition' option. USB name and press 'Apply' .

 

we need to transfer Leopard image from CD (or dmg) to USB.

-click 'Usb' on the left side of the Disc Utility.

-Click 'Restore' (right tab)

-Let us choose 'Source' to the original Leopard DVD, 'Destination' section choose the USB.

Uncheck 'erase destination'.

Click'Restore'. This process takes 30 minutes..

 

After we had prepared USB, start installation

 

Insert Boot-132 cd, and boot from its.

-Press 'enter' key when Darwin boot screen (boot: )

-Second screen select cd or harddisk. Here, the corresponding number of us in the media will be a boot being asked to enter. You will need to write 81 or 82. In this way we will have selected USB to boot.

Written against the screen USB name . we write '-v-x' as the boot parameter in this screen. . (-x command will enable us to see graphical desktop).

 

After complete your installation, restart your computer. (Note: ignore error message(if).)

 

** Important ** until we will install Chameleon Bootloader, should open with 'Boot-132' cd

 

** Important ** always unplug Installation's USB ****

 

 

boot from boot-132 cd..

 

**Extract M2600HD_Packs to your desktop. It include 3 folders (package_for_graphics_card, misc_pkgs, tools)**

 

Settings for Graphics Card: (ONLY QUARTZGL, NO CORE IMAGE / QUARTZ EXTREME, We will wait for ci / qe)

 

** Important ** This steps' order is very important during these packages installation.

 

'package_for_graphics_card' folder

1. Install ATI Radeon HD 2600XT AGP 10.5.6 - 10.5.x.pkg package. But do not restart.

2. Install AppleACPCIEC.kext and NATIT.kext with 'kextHelper' in 'tools' folder

 

Note: NATIT.kext is a key kext for graphics card. if you are going to try another drive will definitely need to reinstall this kext.

 

3. Install RadeonDump and RadeonHD.kext in 'RadeonHD' folder with 'kextHelper' .

 

- Reboot with '-s' single user

 

The opening screen are:

/ sbin / mount-uw /

cd / System / Library / Extensions

rm-R ATI *

reboot

 

System is switched on the screen resolution 'System Preferences> Display' you can set up. (1280 x 800)

 

Bootloader Setup and Extra Kexts

 

Install Chameleon-2.0-RC2-let r640.pkg in 'tools' folder . 'customize' section uncheck 'Extra> Kexts' (additional kexts later). However, at this stage not at reset. copy from extra kexts within 'tools' folder to 'Extra > Extentions' installed system disk.

 

Now we can boot from the disc.

 

** ** For QuartzCL

 

run OSX86tools program in 'tools' folder. click 'Enable / DisableQuartzGL' button. Follow the instructions. Reboot.

 

Misc. hardware

 

sound card:

install 'voodoohda.pkg' in 'misc_pkgs' folder

 

Battery:

install battery.pkg' in misc_pkgs' folder '

 

Laptop keyboard:

install 'ps2.pkg' in misc_pkgs' folder

 

** This tutorial was written for the Toshiba Laptop A200 with Ati Radeon Mobility HD 2600. Device ID: 9581 **

 

I hope also ci / qe problems will be solved one day..

Share this post


Link to post
Share on other sites

Sweet work dude. Nice improvements. I'm not that good at explaining what I did/do, cause I forget stuff.

 

I'm working on a boot cd that you can just throw in the drive and allow you to vanilla install write off the original DVD. It'll take awhile, due to my wife about ready to drop with my new borns.

 

Do you think its worth putting these methods in a new sticky post section?

 

Can we get more people who have tested this to post their response / ideas / results please!!!!!!!

 

thoughts?

 

Its good to have a working Hacbook now.

Share this post


Link to post
Share on other sites

yes my friend.

as a constant subject of these teachings take place in the forum would be very good. but I do not know how to do. Can you do it?. Important, that people try, and they may be tested.

 

Can you help me for sticky thread? (Are you make it?) (Sorry my english :))

Share this post


Link to post
Share on other sites

hi everybody, i'm trying to play a movie with VLC but it shows a black screen only, this depend of QE/CI ? i also setup a OpenGL output in VLC video settings but nothing changed...

so quicktime work ok, and divxplayer chrashes on video loading..

 

???

 

bye

Share this post


Link to post
Share on other sites

Ok thanks i will try it later, although i think it is a qe/ci problem, because my webcam is recognized, can be powered on, but has no image/black image. Webcams need hardware acceleration right? Anyway, i would be glad if someone could tell me where to start looking ways for enabling qe/ci. Someone made it, in another post, but with no backlight. can we try the same way? thanks

Share this post


Link to post
Share on other sites

hi friend, i trying some experiments with ATIRadeonX2000.kext... i don't understand the connection beetween qe/ci and framebuffer. now we can use a framebuffer "RadeonHD" without hardware acceleration just delete form S/L/E/ATIRadeonX2000.kext/.... ATIRadeonX2000 binary executable. this allow use all internal display resolution with OpneGL and Software CI..

in my case, if i put back ATIRX2000 my internal display still work again, it still switchs on, but it does not syncronize with video signal. the image on display appaire distorted and scrolled, but i can see a mouse movments and some confused images, probably windows open or auto wallpeaper change.

what it mean??

ATIX2000 disable the RadeonHD framebuffer and use own one?? it's possible ti enable a RadeonHD framebuffer during use a ATIX2000 accelerator??

 

best regards

Share this post


Link to post
Share on other sites

ok, i answer by myself, ReadonHD framebuffer drive works standalone, that mein it doesn't need other driver or extensions, like ATINDRV or NATIT or ATIRadeonX..... if you look inside RadeonHD yoi can see it imlpement a Open GL 2D engine that not support QE and CI hardware acceleration.

so now my attention turn on ATY_Lamna framebuffer, i try to disassemble this Driver and i find some interesting information. It has come Properties you can set by info.plist, i can see some functions refered to LVSD TVout CRT and framebuffer. i thinkg is possible to do something playing with this driver for enable full hardware acceleration.

 

best regards.

Share this post


Link to post
Share on other sites

Let me know what you've done, I was looking elsewhere for a fix. I will help where I can.

 

Something interesting but, I did manage to get full QE/CI support on my card on external only, but the card was labeled as a 2600xt under system profiler using this....

 

http://redirectingat.com/?id=292X457&u..._cards.pkg.html

 

What to next?

Share this post


Link to post
Share on other sites

Ok, i try to understand what framebuffer and core image accelerator works. if i want use a RadeonHD for QE and CI i have implemet the 3d and quarz functions into the RadeonHD source then recompile the kext with xcode, but it isn't a silmple jobs for me. so i trying to setup natit configuration and framebuffet plugin for lsvd internal display interface. my idea is to read RadeonHd framefubber info then set ATY_lamna in same way, using internal display with right resolution. if it is possible, ATIRadeonX2000 should works right i mean.

about info into system profiler, that is only a string readed fron natit info file, you can change it replacing a Name Descripton of you Device ID in a natit info.plist.

now i tryied to install standard HD2600 package without replace any files, and it works fine with external VGA display on my Mob HD2600 fully accelerated QE CI and 512 VRAM. in this case the internal display automatcly switch Off on driver loading, but this is already knows.

So now i edit a natit framebuffer plugin "ATY_Lamna" and set some property to enable LVSD output, the internal display still on during a driver loading but it shows a confused image with good mouse pointer.

i mean is possible to find a right config of Lamna plugin to enable internal display acceleration.

 

so but i'm beginner and i don't know if my hypothesis is correct...

Share this post


Link to post
Share on other sites

Dude that sounds good. I'm liking every bit of it. But right know I have to crash close to 11pm in Aus.

 

I will play with it tomorrow night after work.

 

I'm liking where your heads at!!

Share this post


Link to post
Share on other sites

hi, i did some other tests... ATY_Lamna has a LVDS driver function, now i have understand how i can use it.

parallel, RadeonHD framebuffer work with ATIRadeonX2000 acceleration but loadin ATI Acc it changes the pixel frequncy that cause a lcd display bad sync. but qe and ci work...

now it possible to patch Ati X2000 to lock it on a sigle reframe frequncy or set ATY_Lamna to use LVDS output connection.

 

any ideas ???

Share this post


Link to post
Share on other sites

hi, ipowertech,

 

i have a question.

how to enable ci / qe for external monitors (which packages, kext, etc) . i can't. keynotes doesn't works with RadeonHD.

 

thanks..

Share this post


Link to post
Share on other sites

Nimes, try this mate. It seem to work for external output only.

 

http://rapidshare.de/files/47335568/Enable..._cards.pkg.html

 

I have it working on mine, but it labels the card a ATI HD2600 XT ??? Go figure.

 

any who, i'm working on several files to get from here back to internal. IOgraphics, and ATY_lamma are the majors with a couple more I'm just toyin with.

 

Enjoy!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×