Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
smilenkovski

Snow Leopard on HP 6720s

166 posts in this topic

Recommended Posts

Hi!

Put the file dsdt.aml into Extra folder in root of Snow HDD and tell us (I suppose that all the files of blackch are copy to the appropiate folders and extensions.mkext is in Extra folder too. Bye

 

 

Hi,

 

Yes I have the dsdt.aml file both in the Snow HDD Root and in the Extra Folder,

 

I have copied all files from blackch to the appropriate folders and yes i have the extensinos.mkext in the extra folder once permissions etc and reset using mkextMaker

 

i notice smilenkovski suggested removing the IOATAFamily.kext. from System>Libary>Extensions

 

from the look of the instruction you have to replace the original one in this path with the one from blackch Extra folder.

Share this post


Link to post
Share on other sites

Hi all

 

just a quick update for you, i have tonight tried again to follow the instructions on htis and still getting the same kernel panics as before todo with AppleIntelCPUPowerManagment

 

if anyone can help, i would really really appriciate it

 

i took these pictures to see if any of you can assist :

 

1.JPG

 

 

 

2.JPG

 

3.JPG

 

4.JPG

Share this post


Link to post
Share on other sites
Maybe you should try non modified video kexts. Download this version from here and use kextutility to install...

Hello smilenkovski:

The first, sorry for not knowing. I tell you:

The steps that I taken were:

I copy the kext file to the folder Snow/Extras / Extensions. I Drag & Drop this folder to kextutility. Restart the PC (does not work neither arch=i386 or with arch = i386-v because I have the same kernel panic, but I restarted with arch = i386-x-fy and I have the desktop well but with the resolution of 1024x768). I must say that the video kext from the original installation are in System / Library / Extensions I have not deleted, should I do? .To install the kext, I'm doing well???. Thank you very much again for your time.

Share this post


Link to post
Share on other sites

DO NOt copy kexts into any folder. Just drag them to kextutility like files. Remove video kexts from Extra folder.

And of course you can check the link blackch is suggesting.

Good luck.

Share this post


Link to post
Share on other sites
DO NOt copy kexts into any folder. Just drag them to kextutility like files. Remove video kexts from Extra folder.

And of course you can check the link blackch is suggesting.

Good luck.

Hello again:

I've completed the first three steps again. I installed the HD on the PC. I installed the kext with kextutility (without copying any kext to any directory). I rebooted with arch = i386 and leaves the gray screen pc shut down and restart. I tried the boot with arch = i386-x-f and neither does: it appears gray screen again shut down and restart. What am I doing wrong?. I am desperate. Help please.

Share this post


Link to post
Share on other sites

I have made everything like u did...but when i inserted the Hard drive inside the 6720s it wasn't booting... it was like this:

 

_

 

 

and i putted the boot stuff and all that in the right place.-- why did this happened? :x

Share this post


Link to post
Share on other sites
I have made everything like u did...but when i inserted the Hard drive inside the 6720s it wasn't booting... it was like this:

 

_

 

 

and i putted the boot stuff and all that in the right place.-- why did this happened? :x

Like what?

 

Hello again:

I've completed the first three steps again. I installed the HD on the PC. I installed the kext with kextutility (without copying any kext to any directory). I rebooted with arch = i386 and leaves the gray screen pc shut down and restart. I tried the boot with arch = i386-x-f and neither does: it appears gray screen again shut down and restart. What am I doing wrong?. I am desperate. Help please.

at JLINSANELYMAC

Just checking. It seems that you can't install SL at all? I tough that you have already done before but you had video problems only. Never mind , just carefully follow the guide and it is almost impossible to fail. We have same computers O.K?

Share this post


Link to post
Share on other sites

Hi, smilenkovski!

Firstly, I wanna sad "Big Thanks!!!" for your theme. In AppleLife.ru I created theme about installing Mac OS X 10.6 on HP Compaq 6720s. It's in Russian, but important ideas and solutions are understandable.

So, I have a problem with USB. Modifed IOPCIFamily.kext in S/L/E. USBBusFix=Yes isn't help for me. Kernel log:

Feb  3 23:11:01 localhost kernel[0]: USBF:	  1.781   AppleUSBEHCI[0xffffff80053f3000]: unable to get filterInterruptEventSource
Feb  3 23:11:01 localhost kernel[0]: USBF:	  1.782   AppleUSBEHCI[0xffffff80053f3000]::UIMInitialize - Error occurred (0xe00002be)
Feb  3 23:11:01 localhost kernel[0]: USBF:	  1.812   AppleUSBEHCI[0xffffff80053f3000]::start unable to initialize UIM
Feb  3 23:11:01 localhost kernel[0]: Got boot device = IOService:/AppleACPIPlatformExpert/C003@0/AppleACPIPCI/C3E5@1F,2/AppleICH8AHCI/C10E@0/IOAHCIDevice@0/
AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/Hitachi HTS542516K9SA00 Media/IOFDiskPartitionScheme/Untitled 1@1
Feb  3 23:11:01 localhost kernel[0]: BSD root: disk0s1, major 14, minor 1
Feb  3 23:11:01 localhost kernel[0]: Kernel is LP64
Feb  3 23:11:01 localhost kernel[0]: AppleIntelCPUPowerManagement: initialization complete
Feb  3 23:11:01 localhost kernel[0]: USBF:	  7. 20   AppleUSBUHCI[0xffffff8024fb7000]::start unable to initialize UIMUSBF:   7. 20   AppleUSBUHCI[0xffffff8024fb1000]::start unable to initialize UIM

If I try to booting with -f parameter, then all working very well.

BlackCH posted from his theme about DSDT:

The most important thing is that fixes the IRQ conflicts between HPET and USB. Now you can load AppleIntelCPUPowerManagement.kext without loosing USB, therefore you can start using native SpeedStep (yes, it works).

Is it solution for me?

Sorry for my English :)

Share this post


Link to post
Share on other sites

Hi Vlad.

I saw you article on SL on HP 6720s. I can understand a bit of Russian because I'm macedonian and our languages has the same root, slavic root. It is very nice article but, at the end of the article you are saying that sound, sleep don't work. If you follow the procedure from my guide you should have sound and sleep working. You wouldn't be happy with the temperature of your laptop but if you follow juanerson guide on temps you can solve that problem too.

Glad to help.

P.S.

I'm not using my HP 6720s several months because my daughter is using for school so I have rare opportunities to check things on it.

Share this post


Link to post
Share on other sites

Hey finally made it xP it boots changed the kext that was making the kernel panic (dual boot with windows7 and macdrive8 help xP)

 

but when i install the kext's with kext helper...when i reboot the laptop...it stays still i cant remember if it showed kernel panic or not..but im fully tired of trying to get the right kexts...so to make it fast i ran the osxtools application and checked my laptop specs, cuz i think they are a little bit diferent from urs HP6720s here it is:

 

(by the way the wireless isnt working, and i think my 6720s doesnt has bluetooth at least in windows i dont have.)

 

00:00.0 Host bridge [0600]: Intel Corporation Mobile GME965/GLE960 Memory Controller Hub [8086:2a10] (rev 0c)

 

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller [8086:2a12] (rev 0c)

 

00:02.1 Display controller [0380]: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller [8086:2a13] (rev 0c)

 

00:19.0 Ethernet controller [0200]: Intel Corporation 82562GT 10/100 Network Connection [8086:10c4] (rev 03)

 

00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 03)

 

00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03)

 

00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)

 

00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)

 

00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 03)

 

00:1c.4 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 [8086:2847] (rev 03)

 

00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)

 

00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)

 

00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)

 

00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)

 

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)

 

00:1f.0 ISA bridge [0601]: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller [8086:2815] (rev 03)

 

00:1f.1 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 03)

 

00:1f.2 SATA controller [0106]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller [8086:2829] (rev 03)

 

10:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g [14e4:4315] (rev 01)

 

waiting for reply thks.

 

EDIT: Finally made everything work. except for video kexts..didnt understanded how to do it..and when i unplug the charger it gives me a kernel panic...and it takes about 10 minutes i dont if it is because of the low bat..got to check it. I REALLY NEED HELP ON THE VIDEO CARD KEXTS..waiting for reply..

Share this post


Link to post
Share on other sites
Did you try with my video kexts? If not, download it from post #50 on previous page. We have same video adapter, it should work.

 

 

Thnks it fully worked xP before i was having a few kernel panics...while working...if it happens again ill take a snapshot and put it here...but wow it is awsome :) can i update to 10.6.2? will there be any problems...? (i guided myself in this forum: http://www.applelife.ru/topic/21618-hp-compaq-6720s/ , the one that vlad created)

 

and by the way the usb isnt working :) geez why? and i think it may be the cause of the kernel panics...when i try to put and usb i i leave it there for about 5 min..puff kernel panic.-- help on that plz...

 

waiting xP

 

EDIT:

 

Kernel panic:

 

foto0120w.jpg

 

I Found out now that it is only because of the usb's and the entry for SD card...how to fix it?

Share this post


Link to post
Share on other sites
Thnks it fully worked xP before i was having a few kernel panics...while working...if it happens again ill take a snapshot and put it here...but wow it is awsome ;) can i update to 10.6.2? will there be any problems...? (i guided myself in this forum: http://www.applelife.ru/topic/21618-hp-compaq-6720s/ , the one that vlad created)

 

and by the way the usb isnt working ;) geez why? and i think it may be the cause of the kernel panics...when i try to put and usb i i leave it there for about 5 min..puff kernel panic.-- help on that plz...

 

waiting xP

 

EDIT:

 

Kernel panic:

 

foto0120w.jpg

 

I Found out now that it is only because of the usb's and the entry for SD card...how to fix it?

those up there aint probs anymore..now the big deal is that i changed the bootloader..and aparently it {censored}ed up the kexts for the graphics and the usb stuff..i think the usb started working when i putted the DSDT from BlackOH.

So how to fix this huge and anoying non-sense?

Share this post


Link to post
Share on other sites

Hi, Clearly according to the image your problem (KP) is caused by the extension voodoobattery.kext, you can see that? Now, the solution is delete it from System/Library/Extensions and put the AppleACPIbatteryManager(x32) from my signature in /Extra/Extensions/, rebuilt the hybrid (x32-x64) cache Extensions.mkext (/Extra) with kext utility 2.4.2 by cVaD, and restart for test. And you are right, using the DSDT.aml for your machine (laptop I think) is the "only way" to obtain USB functionality in Snow Leopard, at least its my case. Bye.

Share this post


Link to post
Share on other sites

Hi juanerson!

Nice to see you in this thread. Thanks for helping people here. It seems that you are the most advanced hp 6720s hackintosh maker and it is very useful for non experienced users to have you here.

Share this post


Link to post
Share on other sites

juanerson thnks for the reply,

 

in you signture it says that u are using the RC4...when i installed it..everything else was working..the usb stuff and video kexts werent working.. i tried to (re)make things and..nop so now im reisntalling everything because the piece of {censored} isnt booting anymore xD and make everything right.. but one question... How did u putted the bootloader? did it {censored} up with ur stuff? or it went clean?

 

 

 

EDIT: I updated today and...it didnt worked that well..a kernel panic in the voodoops2.kext then i deleted it and rebooted and another kernel panic on dsmos.kext...now what? delete dsmos and try to reboot?

 

Edit2:no more help needed SD card enabled too..everything working.^^ (used the voodoo kext for that) and by the way Thank U all :'D b cool xD

Share this post


Link to post
Share on other sites
Maybe you should try non modified video kexts. Download this version from here and use kextutility to install...

 

Hi, smilenkovski.

 

 

I've got it. I installed your files and finally the resolution good. I´ll follow everything else. Thank you very much again.

Share this post


Link to post
Share on other sites

Hey all i wanted to install SL on my Laptop HP dv4 1131x specs below,I am having problems with understanding how to patch my DSDT as i am doing the OSX restore etc on my friends MBP!

How can i patch my dsdt on windows?

 

Also when i create the USB i know i need to go in to diskutlites and click restore but what do i do about the Kexts and other files how do i get them onto the USB drive....

 

HP DV4-1131tx=

 

Core2Duo T5800 (2.0Ghz) , 800Mhz FSB, 3GB RAM, Intel PM45, ICH9-M, NVidia 9200M GS, Realtek 8168c network, Broadcom 4315 wireless, IDT Audio

 

 

Thank you.

Share this post


Link to post
Share on other sites

Hi.

For patching dsdt in windows follow this thread. You'll find guide and software for patching there. Best place on internet on that issue. You can use my guide for installing kexts but it involves removing the HD from the laptop installing SL on some other Mac or hackintosh running SL than putting it back. I'm not experienced on installig SL on laptop using usb. There is a info on that in blackosx guide on installing SL here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×