Jump to content
Konami®

PC EFI V10.3 Released by Netkas

49 posts in this topic

Recommended Posts

Can somebody please post compiled original 10.3 (pci1) boot file? Thank you. -_-

for that simple download original 10.3 boot file from Netkas site - thats default pci1!

Its shown as an booter_10.1 link.

Share this post


Link to post
Share on other sites
Advertisement
iMacDeck:~ cvad$ ioreg -l | grep -15 AppleACPIPCI | grep UID
     | | |   "_UID" = "0"
 iMacDeck:~ cvad$

 

Thanks for the grep correction, it saved me some time wondering why the original command was returning nothing.

Share this post


Link to post
Share on other sites

make

make embedtheme

 

I used those 2 commands to compile but I lost the PCEFI 10.3 Graphical User Interface. It boots and goes straight to the Darwin list selection view.

 

I picked up the boot file from Sym/i386/boot. Is this correct?

 

Also, I have a laptop and -pci0 and -pci1 does not seem to make a difference. In both cases, it boots the exact same way.

Share this post


Link to post
Share on other sites

some small tips for building.

 

add THEME=name to your build line ie ... make clean && make embedtheme THEME=bullet to embedd the bullet theme.

 

add pngcrush to your path ie /usr/local/bin and the png graphics will be optimised before embedding to reduce space used.

 

bs0d.

Share this post


Link to post
Share on other sites

Thanks Netkas, Graphicsenabler and EthernetBuiltIn finally works with your PC EFI 10.3 :)

 

Im going to get a new Graphics Card tomorrow. If all works as expteced it's just old-out new-in :D (Will be a Gigabyte GV-NV96TSL with passive cooling, old one is 7600GT)

Share this post


Link to post
Share on other sites

plz help me i cant understand how to install pc efi 10.3....i hav installed chameleon 2rc3 and hav changed boot file with new downloaded from netkas ...my com.apple.Boot.plist i same as i was using in chameleon 2rc2 snow supported it is configured in this way

 

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>Graphics Mode</key>

<string>1440×900x32</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>arch=i386</string>

<key>Timeout</key>

<string>5</string>

<key>device-properties</key>

<string>cd0300000100000001000000c10300001500000002010c00d041030a000000000101060000010

101060000007fff04003a000000400032002c0068007700730065006e0073006f0072002d00700061

00720061006d0073002d00760065007200730069006f006e000000080000000000000222000000400

032002c006400650076006900630065005f0074007900700065000000120000004e5644412c677075

2d64696f64650e0000004e00560050004d00000020000000010000000000000000000000000000000

000000000000000000000001e00000072006f006d002d007200650076006900730069006f006e0000

00090000003331373261100000004e00560043004100500000001800000004000000000003000c000

000000000070000000022000000400032002c002300730069007a0065002d00630065006c006c0073

000000080000000000000022000000400030002c006400650076006900630065005f0074007900700

0650000000b000000646973706c6179100000006d006f00640065006c0000001a0000004e56494449

41204765466f726365203936303020475414000000400030002c006e0061006d00650000001200000

04e5644412c446973706c61792d4120000000400032002c0063006f006d0070006100740069006200

6c0065000000160000004e5644412c73656e736f722d706172656e7414000000400031002c006e006

1006d0065000000120000004e5644412c446973706c61792d4212000000400032002c007200650067

00000008000000000000021c0000006400650076006900630065005f0074007900700065000000100

000004e5644412c4765466f72636520000000400031002c0063006f006d0070006100740069006200

6c00650000000e0000004e5644412c4e564d616326000000400032002c00230061006400720065007

30073002d00630065006c006c007300000008000000000000010e0000006e0061006d00650000000f

0000004e5644412c506172656e7422000000400031002c006400650076006900630065005f0074007

9007000650000000b000000646973706c617920000000400030002c0063006f006d00700061007400

690062006c00650000000e0000004e5644412c4e564d6163220000005600520041004d002c0074006

f00740061006c00730069007a0065000000080000000000002036000000400032002c006800770063

00740072006c002d0070006100720061006d0073002d00760065007200730069006f006e000000080

000000000000214000000400032002c006e0061006d00650000001100000073656e736f722d706172

656e74</string>

</dict>

</plist>

 

 

plz tell me what shud i do further or what changes shud i do in com.apple.Boot.plist

thx in advance

Share this post


Link to post
Share on other sites

Graphicsenabler and EthernetBuiltIn are working fine using PCI0 with an Asus P6T Deluxe V2 motherboard onboard LAN and Asus EN7300GT graphics card though they aren't showing at "PCI devices" on System Profiler, does this happen to anyone else?

Share this post


Link to post
Share on other sites

Pc efi 10.3 works fine for me.

Before I was using GFX strings, but no need for them anymore.

The only reason I tried graphics enabler is because I had a few seconds of display problems when display woke from sleep.

 

PS: boot file of chameleon RC3 did not work (Ethernet recognized, but not video).

Just swapped it with 10.3 and there it was "OSX86 in all it's glory"

 

First time I say this (still I often thought about it) but well, good job Netkas :D

 

Now I'd like to know why RC3 didn't work, is it beacuse of this PCI root thing?

Share this post


Link to post
Share on other sites
plz help me i cant understand how to install pc efi 10.3....i hav installed chameleon 2rc3 and hav changed boot file with new downloaded from netkas ...my com.apple.Boot.plist i same as i was using in chameleon 2rc2 snow supported it is configured in this way

 

...

 

plz tell me what shud i do further or what changes shud i do in com.apple.Boot.plist

thx in advance

 

Does your system work? What are you trying to accomplish? In order for someone to help you with what you "should" do we need to know what problem you are having. If you want to know what to put in com.apple.Boot.plist then you could start with reading the Chameleon documentation and then ask a more specific question.

 

regards

Share this post


Link to post
Share on other sites
Now I'd like to know why RC3 didn't work, is it beacuse of this PCI root thing?

 

Probably, because you got it working with PCEfi 10.3 that has PCI root=1 as default option and Chameleon 2 RC3 uses 0 as default.

Share this post


Link to post
Share on other sites

I tried different options

USBBusFix = yes

USB high speed and are recognized only 1 time out of 10: why?

 

P5W DH enabled legacy usb = auto and EHCI Hand-off = enable.

 

The usb only work if the file AppleHPET.kext gate.

Share this post


Link to post
Share on other sites
Any chance somebody could upload netkas pci 10.3 the download link on his site is currently not working

 

thanks

PC-EFI_V10.3.zip ~492KB

http://www.mediafire.com/?tzlyhieybyl

- boot_PC-EFI-V10.3_PCI0.zip <-- for default PCI0, recompiled by mitch_de

- boot_PC-EFI-V10.3_PCI1.zip <-- original by Netkas. default PCI1, for PCI0 boot with: -pci0

Share this post


Link to post
Share on other sites
PC-EFI_V10.3.zip ~492KB

http://www.mediafire.com/?tzlyhieybyl

- boot_PC-EFI-V10.3_PCI0.zip <-- for default PCI0, recompiled by mitch_de

- boot_PC-EFI-V10.3_PCI1.zip <-- original by Netkas. default PCI1, for PCI0 boot with: -pci0

 

 

Hi All,

 

I get KP pertaining to EFIRuntime.kext and NVRam.kext if i use EFI 10.3

Chameleon 2 RC3 is working fine.All i did was to rename the old boot file and copied the attached boot file to root partition.

i have HP dv6114 tx laptop with Intel Core Duo@1.6Ghz

 

Kindly Suggest.

Share this post


Link to post
Share on other sites
I tried different options

USBBusFix = yes

USB high speed and are recognized only 1 time out of 10: why?

 

P5W DH enabled legacy usb = auto and EHCI Hand-off = enable.

 

The usb only work if the file AppleHPET.kext gate.

 

morfy, have a look at the hardware (other) thread on projectosx. Slice's IOPCIFamily.kext did it for me (in leopard) but he made a snow leo version too.

Share this post


Link to post
Share on other sites
Hi All,

 

I get KP pertaining to EFIRuntime.kext and NVRam.kext if i use EFI 10.3

 

Kindly Suggest.

 

I dont use BOTH -not in my 10.5 not in 10.6 !

I delete them since 10.4 time .

For my knowledge they are both not needed on OSX86 systems / may give problems if installed.

 

but it would be nice if someone with good (real!) OSX backgound can tell us more of those 2 .kext.

Share this post


Link to post
Share on other sites
I dont use BOTH -not in my 10.5 not in 10.6 !

I delete them since 10.4 time .

For my knowledge they are both not needed on OSX86 systems / may give problems if installed.

 

but it would be nice if someone with good (real!) OSX backgound can tell us more of those 2 .kext.

 

 

i deleted the efiruntime kext and now,it boots perfectly.No more KP.

Thanks for pointing out that they are not needed.

i used the boot file compiled by you.

works perfectly.

:(

Share this post


Link to post
Share on other sites

I can't start in 32 bit mode with pc efi v10.3. Which is the kernel flag I have to use?

 

Thank in advance

Share this post


Link to post
Share on other sites

Thanks,

now with pcefi v10.3 i can boot in 32 bit mode with this flags

 

<key>Kernel Flags</key>

<string>-pci0 arch=i386</string>

 

best regards

(sorry for bad english)

Share this post


Link to post
Share on other sites
To find you pciroot value, use this osx terminal command:

ioreg -l | grep -15 “AppleACPIPCI\ ” | grep UID

 

That doesn't return me anything.

I get

 

Last login: Tue Oct 13 20:51:46 on ttys000

HTPC-2:~ appleiiguy$ ioreg -l | grep -15 “AppleACPIPCI\ ” | grep UID

HTPC-2:~ appleiiguy$

Share this post


Link to post
Share on other sites

You will find 0 or 1 for PCI root also using the IOREGISTRY EXPLORER, select IODevice tree and look for PCI.

Attached my GA-EP35 - i have PCI 0 - so i need an patched EFI PC version (default pci 0) or must use -pci0 with orig. version.

 

HINT: New version 10.4 out, also patched here. Look at the 10.4 thread.

Bild_386.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×