Jump to content
spakk

Snow Leopard- Treiber Probleme gelöst, System auf 10.6.1 geupdatet

19 posts in this topic

Recommended Posts

Hi @ll

 

ich habe kürzlich IDeneb V 1.3 10.5.5 auf meinem Laptop installiert. Alle Treiber bis auf Grafik und Netzwerk (ohne Funktion). Kann mir jemand die passenden Treiber geben? Ich habe überall gesucht, leider bis jetzt ohne Erfolg.

Ziel ist es wenn OS X 10.5.5 einwandfrei funktioniert dann Snow Leopard drauf zu spielen.

Die snow Leopard DVD habe ich mir bereits zugelegt.

 

Mich würde mal Eure Meinung interessieren

 

 

Meine Hardware:

 

CPU: Intell Pentium Dual Core T4200 mit 2x 2000 MHz

RAM: 4 GB DDR2 667 MHz

Grafik: Intel DMA X4500 M 475 MHz (nur 1280x768 pixel)

HDD: Western Digital 320 GB- SATA (OK)

Optische Laufwerk: LG HL-DT-ST DVDRAM GT20N SATA (OK)

Netzwerk: ATHEROS AR8132 PCI-E 10/100 Mbit (bisher noch nicht gebraucht)

LAN: Broadcom 802.11g 54 Mbit (OK)

Sound: Realtek ALC272 HD Audio (läuft nicht besonders gut)

Web CAM: 640x480 (OK)

Bildschirm TFT 15,4 Zoll Auflösung 1366x768, 16:9

Share this post


Link to post
Share on other sites
Advertisement

Für LAN gibt es keinen Treiber. Bei der Graka das selbe, aber du kannst die Auflösung hinbekommen. Erstens würde ich mit Chameleon 2 RC3 die Auflösung ins Boot plist als Graphic Mode eingeben, wenn es nich geht, dann den X3100 FrameBuffer für deine Graka mit ID einstellen, so müsstest du wenigstens die Möglichkeit für verschiedene Auflösungen bekommen. WLAN, welche ID hat die?

Share this post


Link to post
Share on other sites
Für LAN gibt es keinen Treiber. Bei der Graka das selbe, aber du kannst die Auflösung hinbekommen. Erstens würde ich mit Chameleon 2 RC3 die Auflösung ins Boot plist als Graphic Mode eingeben, wenn es nich geht, dann den X3100 FrameBuffer für deine Graka mit ID einstellen, so müsstest du wenigstens die Möglichkeit für verschiedene Auflösungen bekommen. WLAN, welche ID hat die?

 

vielen Dank für deine Prompte Antwort, riws

 

wo kann ich die ID ermitteln?

 

Share this post


Link to post
Share on other sites

Nachdem ich DPCIManager geöffnet habe, erhalte ich folgende Informationen:

 

8086:2a42 Intel Corporation ERROR: Unknown Device

 

8086:2448 " 82801 Mobile PCI Bridge

 

8086:2919 " ERROR:Unknown Device

 

8086:2934 " USB UHCI Controller

 

8086:2935 " USB UHCI Controller

 

8086:2936 " USB UHCI Controller

 

8086:2939 " USB UHCI Controller

 

8086:293a " USB EHCI Controller

 

8086:2937 " USB UHCI Controller

 

8086:293c " USB EHCI Controller

 

8086:2940 " PCI Express Port 1

 

8086:2942 " PCI Express Port 2

 

14e4:4315 Broadcom Coporation BCM4310 USB Controller

 

8086:2944 Intel Cor. PCI express Port 3

 

1969:1062 Attansic Technology Cor. ERROR Unknown Device

 

8086:2929 Intel Cor. Mobile SATA AHCI Controller

 

8086:293e " HD Audio Controller

 

8086:2930 " SMBus Controller

 

8086:2a43 " ERROR: Unknown Device

 

8086:2a40 " ERROR: Unknown Device

 

 

 

Ich hoffe das diese Angaben brauchbar sind @riws

Share this post


Link to post
Share on other sites

WLAN ist dann wohl 14e4:4315 Broadcom Coporation BCM4310. Die ID ist wohl nicht in Treiber vorhanden und musste den selber zu fügen. Starte Terminal:

sudo su

nano /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/Info.plist

Suche nach IONameMatch, dort ist eine Liste mit verschidenen ID's, ändere eine ins pci14e4,4315 und speichern. Neustart.

Share this post


Link to post
Share on other sites
WLAN ist dann wohl 14e4:4315 Broadcom Coporation BCM4310. Die ID ist wohl nicht in Treiber vorhanden und musste den selber zu fügen. Starte Terminal:

 

Suche nach IONameMatch, dort ist eine Liste mit verschidenen ID's, ändere eine ins pci14e4,4315 und speichern. Neustart.

vielen Dank riws , hast mir wieder mal aus der sch.. geholfen - W-LAN funktioniert.

 

 

nach deinen Angaben erhielt ich im Terminal ein leeren (ohne Inhalt) TAB. Ich bin dann Manuell unter /System/Extensions/ und habe dort mit der Rechten Maus-Taste die IO80211Family.kext mit "Paketinhalt zeigen" angeklickt neues Fenster öffnet sich und dort unter /Contents/Plugins/ dort war meine "AppleAirPortBrcm4311.kext.bak" abgelegt, diese als "AppleAirPortBrcm4311.kext" geändert und gespeichert. Zum Schluss die Info.plist mit dem TextEditor geöffnet und nach "IONameMatch" gesucht und die Änderungen "pci14e4,4315" vorgenommen, gespeichert und Neustart. W-LAN funktioniert super

 

Ich habe abschließend noch eine Frage riws.

 

Ich hab mir gestern abend auf eine andere Partition snow leopard installiert. Da es gestern ziemlich spät wurde konnte ich die feinheiten nicht abschließen, daher werde ich im anschluss die änderungen vornehmen bezügl. W-LAN und Sound und Laptop-Kyboard etc.

 

Mir ist nur aufgefallen das snow nicht besonders schnell ist wie es überall hoch gepriesen wird, woran liegt dass? oder habe ich etwas falsch gemacht?

 

ich bin für jeden ratschlag dankbar

 

thx

Share this post


Link to post
Share on other sites
Weil die Graka ja nicht geht. CPU macht da sehr viel da es die Aufgaben des GPU's macht.

 

thx, hätte eigendlich selber drauf kommen müssencensored.gif

Share this post


Link to post
Share on other sites

auf der 2. Partition läuft Snow Leopard, dort habe ich nach o.Angaben die Anpassung vorgenommen, leider krieg ich die W-LAN nicht Aktiv gesetzt. Alles andere funktioniert, Sound ist nicht berauschend vieleicht hat jemand einen passenden Treiber für mich?

Für nen Lösungsvorschlag bin ich sehr Dankbar :unsure:

 

Danke im Vorraus

Share this post


Link to post
Share on other sites

So, dank 'Kext Utility v2.3.2' ist mein W-LAN Problem bereinigt. Ich habe vorhin mir von der apple.com das Aktuelle Update 10.6.1 gesaugt und installiert, vor dem restart noch einmal 'Kext Utility v2.3.2' drüber laufen lassen- restartet . das system ist dann ohne murren gleich beim ersten mal gestartet.

by :)

Share this post


Link to post
Share on other sites

So, hier die Beschreibung wie ich mithilfe einer bereits installierte Mac OS X 10.5.5 (1. Partition) " Snow Leopard" erfolgreich auf die 2. Partition installiert habe

Was wird benötigt:

1. Ein laufendes Betriebssystem Mac OS X 10.5

2. Eine freie Partition

3. Eine Snow Leopard DVD oder eine Image-Datei

4. Einen Ordner den man sich auf dem Mac OS X 10.5 Desktop den man z.B.

"Extras" benennt mit folgenden Dateien:

 

Chamelion 2.0 RC3 r658

OSX86 Tools Utility

Kext Utility 2.3.2.dmg

Hidden File Settings 1.0.dmg

EFI v 10.1

fakemac.kext für SL

DSMOS.kext für SL

NullCPUPowerMangement.kext

PlattformUUID.kext

Battery.pkg

Disabler.kext

AzailaAudio.pkg

Voodoops2Controller.pkg

Beta decrypter for 10a421a 32_64.pkg von netkas.org

 

Rechner starten Mac OS X 10.5 booten

 

1. Festplatten-Dienstprogramm öffnen, die freie Partition auswählen und als 'Snow

Leopard' benennen und den FestplattenInhalt löschen aktivieren.

 

2. Die "Mac OS X Snow Leopard.DMG" auf dem Desktop ziehen oder von der

DVD aus mit Doppelklick starten, ein Fenster mit den Inhalt der "DMG-Datei"

wird angezeigt. Tastenkombination "Shift+ALT+G" gedrückt halten, ein weiteres

Fenster öffnet sich 'gehe zum Ordner' dort muss folgendes stehen: /Mac OS X

Install DVD/System/Installation/Package/ sollte es nicht dort stehen so müsst Ihr

das ergänzen die Eingabe bestätigen. Der Ordner /Package/ mit den Inhalt wird

angezeigt, dort sucht Ihr die "OSInstall.mpkg" mit Doppelklick die Installation

starten, Lizenz akzeptieren, die Partition "Snow Leopard" auswählen und

danach "Anpassen" anklicken, dort die nötigsten Treiber auswählen wie z.B. "

die Drucker für diesen Mac". Unter "Language Translation" German auswählen.

"X11" auswählen und die Installation bestätigen. Wenn die Installation abgeschlossen ist, auf keinen Fall den Rechner Neustarten!

3. Auf dem Desktop (Mac OS X 10.5) den Ordner "Extras" öffnen und dort die

Chamelion.pkg starten und als Ziel-Partition "Snow Leopard" auswählen und

installieren.

 

4. Hidding file Settings 1.0.dmg öffnen und ins Ziel-Partition "Snow Leopard"

installieren.

 

5. Die Partition "Snow Leopard" öffnen und ins /Volumes/Leopard Snow/ die dort befindliche "boot" Datei löschen und durch die in den Ordner auf dem Desktop befindliche "EFI V10.1" ersetzen

 

6. battery.pkg Doppelklick und ins "Snob Leopard"-Partition Installieren.

 

7. Beta decrypter for 10a421a 32_64.pkg mit Doppelklick und ins "Snob Leopard"-Partition Installieren.

 

8. Voodoops2Controller.pkg mit Doppelklick und ins "Snob Leopard"-Partition

Installieren.

 

9. OSX86Tools Utility Doppelklick öffnen dann auf "Install Kext" drücken, Fenster

öffnet sich dort sucht man sich den "Extras" - Ordner der auf dem Desktop

abgelegt ist, Ordner öffnen und "Disabler.kext" auswählen und auf "Snow

Leopard" -partition auswählen und installieren. Nach der Installation nicht

Neustarten! - Nach und nach die benötigten Kexte wie oben beschrieben installieren. Abschließend die "OSX86 Tools" ohne Neustart schließen.

 

10. Die "Snow Leopard" -Partition öffnen und ins /Library/Preferences/

SystemConfiguration/ die "com.apple.Boot.plist" mit Doppelklick öffnen und um

folgendem Eintrag erweitern :

 

Timeout

5

 

Danach speichert Ihr diese Datei auf Eurem Desktop und nimmt das Häkchen unten vor dem Hinweis "if no extension is provided,use ".txt" heraus. danach verschiebt Ihr die auf dem Desktop befindliche "com.apple.boot.plist" ins /Library/Preferences/SystemConfiguration/

 

11. Zum Schluss installiert Ihr aus dem "Extras"-Ordner (auf dem Desktop) die "Kext

Utility 2.3.2-dmg" in "Snow Leopard" -Partition und startet die "Kext Utility 2.3.22"

wenn alles OK ist dann das System Neustarten-

 

Ubdate auf Mac OS X 10.6.1

 

auf die " apple.com" gehen und die Aktuelle Update Version downloaden. Lt. Angaben einiger User sollte man nicht über die Softwareaktualisierung das Update saugen (ich habe es nicht ausprobiert), da anscheinend einige während oder nach der Aktion einen kernel Panic erfahren mussten. bevor man den Rechner Neustartet unbedingt den 'Kext Utility v2.3.2' drüber laufen lassen, wenn alles Ok ist - dann denn Rechner Neustarten.

Mein Rechner lief gleich ohne Kernel Panic oder Wartezeit problemlos sauber hoch.

Share this post


Link to post
Share on other sites

Hi,

kannst mir mal bitte sagen, wo ich die ganzen Dateien herkriege??

Bin seit ner Stunde am rumsuchen, aber find nichtmal die hälfte!

Share this post


Link to post
Share on other sites
Hi,

kannst mir mal bitte sagen, wo ich die ganzen Dateien herkriege??

Bin seit ner Stunde am rumsuchen, aber find nichtmal die hälfte!

Hi jannomag

 

 

hab dem fusselwooow unter: http://www.insanelymac.com/forum/index.php?showtopic=187980

 

das erklärt und ihm die links gegeben.

den Rest musst du dir unter google oder hier im forum suchen max 5-10 min habe ich dafür gebraucht

  

Share this post


Link to post
Share on other sites

Danke...

hab jetzt 10.5.5 drauf.

Wenn ich über die OSInstall.pkg auf meine 2. Partition auf der Mac Platte installiere, dann kommt am Ende folgende Meldung:

Die Installation ist fehlgeschlagen.

Das Installationsprogramm konnte einige Dateien nicht in "/Volumes/SL" installieren.

Wenden Sie sich an den Hersteller.

 

Woran liegt das?

Ist das so richtig??

Share this post


Link to post
Share on other sites
Danke...

hab jetzt 10.5.5 drauf.

Wenn ich über die OSInstall.pkg auf meine 2. Partition auf der Mac Platte installiere, dann kommt am Ende folgende Meldung:

Die Installation ist fehlgeschlagen.

Das Installationsprogramm konnte einige Dateien nicht in "/Volumes/SL" installieren.

Wenden Sie sich an den Hersteller.

 

Woran liegt das?

Ist das so richtig??

 

du musst die OSInstall.mpkg aktivieren!! und folge der Install Hinweise die ich aufgeschrieben habe 

Share this post


Link to post
Share on other sites

Habs jetzt hinbekommen - musste die Druckertreiber abhaken.

 

Allerdings startet SL net!

Wenn ich bei Chameleon meine SL Partition auswähle, dann lädt Darwin kurz und dann kommt der Bootscreen.

Kurz darauf kommt folgendes Bild:

sqe3out3.jpg

 

Einen direkten Fehler konnte ich nicht herausfinden.

ich habs einmal nach deiner Anleitung gemacht und einmal nach der:

http://www.insanelymac.com/2009/08/how-to-...-pc-hackintosh/

Share this post


Link to post
Share on other sites

Ich hab da ein ähnliches Problem, SL fährt hoch, und ich kann auch kurz was wachen und nach ca 30 - 40 sekunden kommt ein Kernel Panic und BSD zeigt irgendwas mit Windowserver, und das Touchpad funzt unter SL auch nicht, ach ja der Voodoo PS2 Controler funzt auch erst nachdem ich diverse Kexte hinzu installiert habe (sl_hda_PS2) Ach ja und die Graka wird auch nicht in der richtigen Auflösung gefahren... 1024x768, lässt sich aber auch nicht ändern...

 

 

 

 

 

 

 

 

 

Hardware

Lenovo 3000 N200

Intel Core 2 Duo 2,16 GHz

Broadcom WLAN (funktioniert)

Intel GMAX3100 Grafik

SL_PS2_HDA.zip

Share this post


Link to post
Share on other sites
Hi @ll

 

ich habe kürzlich IDeneb V 1.3 10.5.5 auf meinem Laptop installiert. Alle Treiber bis auf Grafik und Netzwerk (ohne Funktion). Kann mir jemand die passenden Treiber geben? Ich habe überall gesucht, leider bis jetzt ohne Erfolg.

Ziel ist es wenn OS X 10.5.5 einwandfrei funktioniert dann Snow Leopard drauf zu spielen.

Die snow Leopard DVD habe ich mir bereits zugelegt.

 

Mich würde mal Eure Meinung interessieren

 

 

Meine Hardware:

 

CPU: Intell Pentium Dual Core T4200 mit 2x 2000 MHz

RAM: 4 GB DDR2 667 MHz

Grafik: Intel DMA X4500 M 475 MHz (nur 1280x768 pixel)

HDD: Western Digital 320 GB- SATA (OK)

Optische Laufwerk: LG HL-DT-ST DVDRAM GT20N SATA (OK)

Netzwerk: ATHEROS AR8132 PCI-E 10/100 Mbit (bisher noch nicht gebraucht)

LAN: Broadcom 802.11g 54 Mbit (OK)

Sound: Realtek ALC272 HD Audio (läuft nicht besonders gut)

Web CAM: 640x480 (OK)

Bildschirm TFT 15,4 Zoll Auflösung 1366x768, 16:9

 

Hi sagt Mal was ist das für ein Laptop? :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×