Jump to content
Arial

[Guide] Enable Native NTFS Read/Write in Snow Leopard

30 posts in this topic

Recommended Posts

http://forums.macrumors.com/showthread.php?t=785376
http://discussions.apple.com/thread.jspa?threadID=2146750

 

Guide: Enable Native NTFS Read/Write in Snow Leopard

 

I am sure many of you heard that Snow Leopard was supposed to have native read/write for NTFS partitions.

Apple supported NTFS R/W in older SL builds but I guess decided to not to go with it for some reason, however support is still present.

For this, you need to modify your /etc/fstab file to mount NTFS partitions for read and write.

 

  1. Uninstall NTFS-3G/Paragon if installed.
    .
  2. Open Terminal
    .
  3. Type
    diskutil info /Volumes/volume_name


    and copy the Volume UUID (bunch of numbers).
    Alternatively, you can get it from Disk Utility > Info
     
    SL_NTFS-RW_2009-09-14_41815AM.png
     
    .

  4. Backup /etc/fstab if you have it (NOT fstab.hd), shouldn't be there in a default install.
    .
  5. Type
    sudo nano /etc/fstab


     

  6. Type in
    UUID=paste_the_uuid_here none ntfs rw


    SL_NTFS-RW_2009-09-14_43614AM.png
    .
    OR

    LABEL=volume_name none ntfs rw


    SL_NTFS-RW_2009-09-14_41405AM.png
    .
    Repeat for other NTFS partitions on next line.
    .

  7. Save the file [Ctrl+O] and [Enter/Return] then Exit [Ctrl+X]
    .
  8. Reboot.

After reboot, NTFS partitions should natively have read and write support.

This works in both 32 and 64-bit kernels. Support is quite good and fast, it even recognizes file attributes such as hidden files.

 

 

SL_NTFS-RW_2009-09-14_42050AM.pngSL_NTFS-RW_2009-09-14_41645AM.png

Share this post


Link to post
Share on other sites
Advertisement
Apple supported NTFS R/W in older SL builds but I guess decided to not to go with it for some reason, however support is still present.

 

Before you use this feature, you might want to consider why Apple might have disabled this support. A couple of possibilities spring to mind. One is legal -- perhaps they were afraid that enabling this feature would open them up to patent violation charges. Another is technical -- they might have discovered bugs in their NTFS implementation that could cause data loss, crashes, or other problems. Of course, even if the reason was the latter, it's conceivable that Apple's NTFS implementation is better than that in NTFS-3g or Paragon; Apple might have higher standards than those of these other projects/companies. Still, the mere possibility of a filesystem driver causing data loss would make me use the relevant driver with caution. Personally, I wouldn't activate this support on a Windows boot partition, only on shared data partitions, and then only if the partition(s) in question is/are backed up frequently.

Share this post


Link to post
Share on other sites

hmm that doesn't seem to work for me. Any ideas? I get this: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35

Share this post


Link to post
Share on other sites
hmm that doesn't seem to work for me. Any ideas? I get this: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35

 

Just based on the error text, I'd double-check the UUID string. Those strings and mind-numbingly long, so mistyping one is easy. Even if you used a cut-and-paste operation to copy it, your mouse might have slipped, dropping or adding a character or two and resulting in an incorrect entry.

Share this post


Link to post
Share on other sites

maybe you should tell, that this feature is not finished yet.

 

There have been several reports that it screws up partitions.

So use on your own risk! This feature was disabled by Apple for a reason!

Share this post


Link to post
Share on other sites

Maybe someone can help me. I can't read from this drive now. It shows no files, or directories. I typed in UUID=FA62631C-6B5F-445F-AA44-BAF03ADF612F none ntfs rw

after going to sudo nano /etc/fstab

I save it and rebooted.

I need this drive working. TIA

:(

It says it could not find disk when I type diskutil info /Volumes/New Volume

Here is what I get:

 

 

Device Identifier: disk2s1

Device Node: /dev/disk2s1

Part Of Whole: disk2

Device / Media Name: Untitled 1

 

Volume Name: New Volume

Escaped with Unicode: New%FF%FE%20%00Volume

 

Mounted: Yes

Mount Point: /Volumes/New Volume

Escaped with Unicode: /Volumes/New%FF%FE%20%00Volume

 

File System: NTFS

Type: ntfs

Name: Windows NT File System (NTFS)

 

Partition Type: Windows_NTFS

Bootable: Not bootable

Media Type: Generic

Protocol: SATA

SMART Status: Verified

Volume UUID: FA62631C-6B5F-445F-AA44-BAF03ADF612F

 

Total Size: 200.0 GB (200047329280 Bytes) (exactly 390717440 512-Byte-Blocks)

Volume Free Space: 2.5 GB (2510020608 Bytes) (exactly 4902384 512-Byte-Blocks)

 

Read-Only Media: No

Read-Only Volume: Yes

Ejectable: Yes

 

Whole: No

Internal: No

Share this post


Link to post
Share on other sites
Before you use this feature, you might want to consider why Apple might have disabled this support. A couple of possibilities spring to mind. One is legal -- perhaps they were afraid that enabling this feature would open them up to patent violation charges. Another is technical -- they might have discovered bugs in their NTFS implementation that could cause data loss, crashes, or other problems. Of course, even if the reason was the latter, it's conceivable that Apple's NTFS implementation is better than that in NTFS-3g or Paragon; Apple might have higher standards than those of these other projects/companies. Still, the mere possibility of a filesystem driver causing data loss would make me use the relevant driver with caution. Personally, I wouldn't activate this support on a Windows boot partition, only on shared data partitions, and then only if the partition(s) in question is/are backed up frequently.

 

 

Good job! You're right.

Share this post


Link to post
Share on other sites

I did it and it worked! I should back up everything though Just to be safe!

 

Gugin, for it to work rename your NTFS volume to something without spaces, just call it 'volume' or something. Worked for me

 

Cheers.

 

Maybe someone can help me. I can't read from this drive now. It shows no files, or directories. I typed in UUID=FA62631C-6B5F-445F-AA44-BAF03ADF612F none ntfs rw

after going to sudo nano /etc/fstab

I save it and rebooted.

I need this drive working. TIA

;)

It says it could not find disk when I type diskutil info /Volumes/New Volume

Here is what I get:

 

 

Device Identifier: disk2s1

Device Node: /dev/disk2s1

Part Of Whole: disk2

Device / Media Name: Untitled 1

 

Volume Name: New Volume

Escaped with Unicode: New%FF%FE%20%00Volume

 

Mounted: Yes

Mount Point: /Volumes/New Volume

Escaped with Unicode: /Volumes/New%FF%FE%20%00Volume

 

File System: NTFS

Type: ntfs

Name: Windows NT File System (NTFS)

 

Partition Type: Windows_NTFS

Bootable: Not bootable

Media Type: Generic

Protocol: SATA

SMART Status: Verified

Volume UUID: FA62631C-6B5F-445F-AA44-BAF03ADF612F

 

Total Size: 200.0 GB (200047329280 Bytes) (exactly 390717440 512-Byte-Blocks)

Volume Free Space: 2.5 GB (2510020608 Bytes) (exactly 4902384 512-Byte-Blocks)

 

Read-Only Media: No

Read-Only Volume: Yes

Ejectable: Yes

 

Whole: No

Internal: No

Share this post


Link to post
Share on other sites
I did it and it worked! I should back up everything though Just to be safe!

 

Gugin, for it to work rename your NTFS volume to something without spaces, just call it 'volume' or something. Worked for me

 

Cheers.

Yeah, quite unstable. I disabled it after trying it out for a while.

Share this post


Link to post
Share on other sites
I did it and it worked! I should back up everything though Just to be safe!

 

Gugin, for it to work rename your NTFS volume to something without spaces, just call it 'volume' or something. Worked for me

 

Cheers.

 

Awesome! I removed the drive and stuck it in a borrowed xp pc. Checkdisk found and fixed some problems. I renamed the drive "volume" and put it back in my hackintosh. It works now.

 

Thanks to everyone who contributed!

Share this post


Link to post
Share on other sites
Yeah, quite unstable. I disabled it after trying it out for a while.

 

How did you disable it? After I got my drive working again it reverted to non readable.

Share this post


Link to post
Share on other sites
How did you disable it? After I got my drive working again it reverted to non readable.

 

Delete the /etc/fstab. That was where the entries were made to enable it in the first place.

Share this post


Link to post
Share on other sites
Delete the /etc/fstab. That was where the entries were made to enable it in the first place.

 

You're awesome. Thanks!

Share this post


Link to post
Share on other sites
Not work on my system :)

10.6.1

It should work if you follow the instruction in post 1. Unless your NTFS partition is dirty (check your /var/log/kernel.log), in that case, you have to fix it by booting to windows and do a chkdsk /f <drive>.

 

As mentioned, this method of mounting ntfs is unstable and may not be reliable. IMO, using MacFuse is a better way. If your system is 64bit, you can now use 64bit MacFuse with ntfs-3g to get r/w enabled on your NTFS partition.

Share this post


Link to post
Share on other sites

I have used /etc/fstab for some time to prevent the mounting of my Win7 partition. One thing I would point out is the warning found in the beginning of that file - just for those who are interested.

#
# Warning - this file should only be modified with vifs(8)
#
# Failure to do so is unsupported and may be destructive.
#

and for those that might wish to prevent mounting of NTFS partitions, this is the line I use.

UUID=B098187A-D82D-448E-95F6-929E788462D6 none  ntfs ro,noowners,noauto

Obviously, you ned to change the UUID to match your partition.

Share this post


Link to post
Share on other sites

WARNING!

 

I have just got all my NTFS Disks corrupted using this metod. I think Apple disabled this future for a reason. I have som very valuable data on those disks.

Anyone know to fix it or get my data back?

 

BEWARE PEOPLE!

 

 

EDIT: This is very strange cuz in Mac i cant see anything on disks and windows 7 says they are corrupted. But booting in Ubuntu is EVERYTHING NORMAL and i can access the disks without any problem!

Now i can just copy my data from corrupted disks to other disks.

Share this post


Link to post
Share on other sites

Download NTFS Mounter

 

http://ntfsmounter.com/

This utility relies on a Snow Leopard feature to write to NTFS volumes. It is NOT compatible with Leopard (10.5.x) and never will be.

 

You must install the application to use it : simply drag the application icon from dmg package file to your application folder.

 

If you have any issue or if you find a bug, you can contact me directly by mail: fabien at jakimowicz dot com.

 

greetings to all

Share this post


Link to post
Share on other sites
......

Anyone know to fix it or get my data back?

 

Try plugin in to XP and right click on the disk and do a "error-checking"

 

It should ask you to reboot and while rebooting in DOS (kind of) screen drive will be checked (for several hours) and recovered files will be copied in to Found000 folders.

Share this post


Link to post
Share on other sites
I have just got all my NTFS Disks corrupted using this metod. I think Apple disabled this future for a reason. I have som very valuable data on those disks.

Anyone know to fix it or get my data back?

 

 

My deepest sympathy to you AFG-Hack-Master.

 

I've gone through the same.

 

Bid a goodbye to your data.

 

I've lost about 150+GB of data... with using the native NTFS.kext for read-write by editing the fstab file.

 

My bad.

N

My bad luck.

 

For just one try.... try using Easy Recovery Professional...

When I used Leopard and I had messed up the partition table, it could recover my 750GB HDD completely...

 

[but not this time around... Windows 7 check disk (chkdsk command) ruined everything big time.] :D

 

-Regards,

 

Freaky Chokra.

Share this post


Link to post
Share on other sites

i read somewhere that apple actually disabled this feature because even tho mac can flawlessly read and write on NTFS drive.. when u plug that drive back to windows, it will notice that something is corrupted...

and to answer the guy up there.. i did have the same problem as you.. and no.. i can not retrieve the data back..

nothing i did can restore the lost file..

the file is there.. i can search for it.. i just can't open it..

on my case.. the file was an excel spreadsheet..

i opened it with Office for mac 2008..

saved it..

and opened it back from windows..

Share this post


Link to post
Share on other sites
i read somewhere that apple actually disabled this feature because even tho mac can flawlessly read and write on NTFS drive.. when u plug that drive back to windows, it will notice that something is corrupted...

and to answer the guy up there.. i did have the same problem as you.. and no.. i can not retrieve the data back..

nothing i did can restore the lost file..

the file is there.. i can search for it.. i just can't open it..

on my case.. the file was an excel spreadsheet..

i opened it with Office for mac 2008..

saved it..

and opened it back from windows..

 

 

Good to have tried and failed... other wise there are many others who simply give up.

 

I didn't at first ... when it happened the first time.... but the second time around .. God knows what kinda driver Apple Inc. has the programmers forced to develop, that it corrupts the entire MFT of that partition.

For those inundated, MFT = Master File Table. means teh File allocationTable like in FAT/FAT32.

 

 

I still have the chkdsk log file ..493 KB log file where it lists out the sector, and the 8.3 file naming ocnvention of htef iles it "fixed" -> which it didn't and messed up big time.

 

Hence, I lost 150+ GB of data ... and that included my work project files and advanced study material / projects that were almost due for submission.

 

Since that Day, I used NTFS-3G +Macfuse 64 bit compiled by a good samaritan @ google code pages.

 

And always take a Save As .. or back upon my 8GB pen drive of such stuff then move it in Windows.. when I boot to play games in it.

 

 

There was another thread for this... and I have posted several warnings there too...

I wish people would see the consequences of things before they take the "plunge".

 

Coz in reality the NTFS.kext gives the fastest data throughput (100-150 MBps) while moving data, but ... at the world's biggest risk.

 

Not only the copied or moved data will be corrupted, but the entries of existing data on that partition too will be corrupted.

 

That said I rest my Case.

 

-Regards,

 

Freaky Chokra

Share this post


Link to post
Share on other sites
Coz in reality the NTFS.kext gives the fastest data throughput (100-150 MBps) while moving data, but ... at the world's biggest risk.

 

 

Freaky Chokra

 

True :)

Share this post


Link to post
Share on other sites

This is really behaving wacky for me. I tried using the UUID for my boot camp partition on my internal HD, and it worked fine. I substituted the UUID for that of the brand new MyBook Mac Edition drive that I got for christmas, after freshly formatting it to NTFS, and it isn't working. I tried formatting my 5th gen iPod as NTFS too, and it refused to work with it. It looks like this isn't working with external drives for some reason.

 

Weird part is, this used to work on my old external drive...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×