Jump to content
InsanelyMac Forum
Trauma!

BootCDMaker

Recommended Posts

;) this is really lame! Didn't saw that one coming...

oh well, one more to add to the blacklist.. shame...

 

Thanks again for the app, Trauma :)

Both app and resulting iso working fine. In fact, these pre-boot CD's are the only boot solutions i can trust atm

as a rescue booter, since i can't make a USB booter out of Chameleon/PC-EFI that works properly since rc2.

 

Edit reason: ..to cut a bit on the "drama" :P

Edited by Azimutz

Share this post


Link to post
Share on other sites
Advertisement

Software updated to version 1.6.1

 

New Bootloader, Chameleon RC3 patched with PCEFI 10.5. No new features in this release, that's mostly a bug fix update :

 

1. Fixed a bug who was preventing GraphicsEnabler to work properly, thx to stellarolla who has noticed that bug.

 

2. BootCDMaker will also check if you've made a bad configuration to prevent GraphicsEnabler and or EthernetBuiltin injection to fail.

 

3. I've also improved the legacy ISO part, no more EBIOS errors in this mode too.

 

4. And now every features of the software should work fine with spaces in paths names.

 

5. New bootloader.

Share this post


Link to post
Share on other sites

Hi Trauma,

 

does your site have some kind of restriction? I can't access it.

 

darwinx86.org. 1715 IN A 213.186.33.87

 

Could you provide a mirror download link?

 

Thanks.

Share this post


Link to post
Share on other sites
Software updated to version 1.6.1

 

New Bootloader, Chameleon RC3 patched with PCEFI 10.5. No new features in this release, that's mostly a bug fix update :

 

1. Fixed a bug who was preventing GraphicsEnabler to work properly, thx to stellarolla who has noticed that bug.

 

2. BootCDMaker will also check if you've made a bad configuration to prevent GraphicsEnabler and or EthernetBuiltin injection to fail.

 

3. I've also improved the legacy ISO part, no more EBIOS errors in this mode too.

 

4. And now every features of the software should work fine with spaces in paths names.

 

5. New bootloader.

 

 

Trauma,

 

I have been trying for weeks to boot up from CD with no success until i ran into yours, i 1st try the regular CD maker, it

 

didn't work, then i try Legacy and Voila it boot up SL beautifully, i haven't install it yet, because i have to move some of

 

my files but it seems to work great with Legacy CD, i will post the result once i have it installed. I have tried so many

 

different method and wasted so many cd, nothing work on my system but this, I currently have snow running but i use

 

the usb method. Once again thank you for your hard work.

 

For other folks, who want to try this, if you have the same hardware spec as the one in my sig if the regular Boot CD

 

doesn't work for then I suggest you should give the Legacy CD a try.

Share this post


Link to post
Share on other sites

Hi trauma,

first of all thanks a lot for your fantastic application: I've tryed BootCD Maker with both Leopard and Snow Leopard and it works fine for me (Asus P5Q and Gigabyte EP35).

 

I would ask you if it's possible to customize in some way the theme directory, putting i.e. translated instruction or other background...

 

Thanks a lot,

APCTK.

Share this post


Link to post
Share on other sites

Hi Everyone,

 

 

 

Thanks for your great work and contribution. I’ve been reading for the past two months in this forum and all I managed was a 10.5.7 install from the usual distros! I bought an SL retail DVD now and although Trauma’s app looks great, I had no success with your method.

 

 

 

I used a dsdt.aml (created only to fix RTC0), an smbios, a kernel flag cpu=1 -f and only three kexts from di524up (first post page) as standard and I tried all possible combinations between:</SPAN>

 

1st. mach_kernels of .432, .voodoo (Voodoo Based XNU 980 v2) and .voodoo (Voodoo.alpha3),

 

2nd. “arch” i386 and x86_x64 options (the only ones available in my Leopard installation) and

 

3rd. The “Make CD” and “Make Legacy CD” options.

 

 

The hardware is a P5WD2 Premium (socket 775) with a P4 (@3.2), 4GB Ram, 2 x nvidia 8400 GS, 2 x HDDs, DVD RW, that all worked with 10.5.7 except the onboard firewire.

 

 

So I end up with two situations and that is with mixed combination of the above.

 

 

1st. The Chameleon with a grey backround for ever (more than 45 minutes) or

 

2nd. The message:

 

 

panic(cpu 0 caller 0x0043E213): “Unable to find driver for this platform: \”ACPI\”.\n”@/Users/doobz/Desktop/XNU/xnu-1228.15.4/i…(the rest of it is not within the screen)…kit/Kernel/IOPlatformExpert.cpp:1411 and another seven lines of numbers.

 

 

Anyone understands this and is willing to give me some help please?

 

 

Many Thanks,

 

 

Deanoh

Share this post


Link to post
Share on other sites

---Edited---

Reason : succes :rolleyes:

----------------------------

Thanx a lot for your BootCD Maker...it really works !!! (see my sig) .... thx

Share this post


Link to post
Share on other sites

Nice app, but i have couple of questions.

 

1) If i want to update the bootloader, do i have to replace both of those files?

screenshot20101014at025.png

 

2) After creating the iso, i'd like to add a folder with Chameleon installer and couple of kexts.

Is it possible to resize the iso somehow, in order to free up some space on it for additional files?

 

Thanks in advance.

Share this post


Link to post
Share on other sites
1) If i want to update the bootloader, do i have to replace both of those files?

for chameleon "cdboot"

for isolinux(legacy) "boot"

 

2) After creating the iso, i'd like to add a folder with Chameleon installer and couple of kexts.

Is it possible to resize the iso somehow, in order to free up some space on it for additional files?

 

Use "isodir"

mald0n20101013s221026.png

 

add whatever you want

and then create the cd

mald0n20101013s221040.png

 

:)

mald0n20101013s222724.png

 

I use this

Chameleon RC5, kernel 10.4.0, Extensions.mkext...

http://www.mediafire.com/?bv0h7443sbex83i

Share this post


Link to post
Share on other sites

Now i have another two questions:

 

Is it necessary to put mach_kernel in it, shouldn't it automatically load the kernel from retail DVD?

 

And if i want to activate Graphics Enabler - do i have to write it in the Extra boot.plist only, or the one inside Preboot.dmg, or both?

 

I've seen people doing it differently, some prefer to do it this way:

	<key>GraphicsEnabler</key>
<string>Yes</string>

And some prefer to put it in Kernel Flags like this:

	<key>Kernel Flags</key>
<string>GraphicsEnabler=Yes</string>

What's the right way of doing it?

Share this post


Link to post
Share on other sites
Now i have another two questions:

 

Is it necessary to put mach_kernel in it, shouldn't it automatically load the kernel from retail DVD?

I never tested to work without the kernel

if it does work

you will not have a full support

an example is the processor "Core i"

these processors is fully supported on 10.6.4(10.4.0)

Snow Retail 10.6 or 10.6.3, has no such support

:unsure:

 

And if i want to activate Graphics Enabler - do i have to write it in the Extra boot.plist only, or the one inside Preboot.dmg, or both?

Use Automatic graphics injection and and Save settings

mald0n20101014s124032.png

<key>GraphicsEnabler</key>
<string>Yes</string>

 

 

--> bootcd/Extra/Preboot.dmg/Extra/com.apple.boot.plist :(

Share this post


Link to post
Share on other sites
How do change the initial boot screen with my own set of default icons?

 

isodir/Extra/Themes/default/...

Share this post


Link to post
Share on other sites

Thank you MaLd0n. I spoke too soon. I was on 1.6. I got the latest now and it is sweet.

It lets me enjoy my own boot screen. Too many kexts loaded. I will have to make another CD with only minimal kexts since I run Vanilla.

Share this post


Link to post
Share on other sites

this is awesome, I've been wanting to make a custom BCD for my AMD setup for snow leopard for sometime, thx for this!

 

note: it's for an phenom on an xfx nforce btw, I've already made a successful boot 132 BCD for 10.5.8

Share this post


Link to post
Share on other sites
This is actually really convient and easy to use. If I'm correct in saying this, this could be used to create a bootcd to install SL on an AMD machine with the right kernel. :D

 

did you make one for AMD successfully yet?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • I guess having pre{max-height: 500px;overflow: auto;} in CSS was too much for IPS Devs' tast.  Until an admin has hands on this, you still can use stylish plugin to accomplish it.     In fact, it is pretty easy than it appears - Just apply a simple click on the codebox (it will highlight it), then 'delete' key.
    • all the possible frequencyes i have added seems to work fine at the moment, i have added a lot of different frequencyes to support better all kinds of professional applications, inclunding strange sampling rates and goes from 8khz up to 176.4 khz, unfortunately 192 khz does not seems to work even on cards which should support it like the audigy rx, but other frequencyes just works fine and at the moment i have tested only the sound blaster audigy rx and the audigy sb0090 (1st gen audigy) and i can confirm that all the frequencyes from 8khz up to 176.4 khz does work on that card, so i think that such frequencyes should work on all the audigy 2, 2sz, 4 cards as well, tomorrow i will test with my sound blaster live! cards and i will let you know, but here are also some photos (pro tip: use cmd + alt/opton + 4 and then press space to make a screenshot of a single window):
    • Guy's if something happened, this is most likely Admins and Moderators are working there, yes we still need some things to be done, but if it's still not yet, it's because of time or something we don't know, we just have to be patient! Slow things is just because they are working in the same time, patience for that problem is good, and loading things, but apparently now is good, for me these things I've accounted them yesterday and this morning, but now they are gone. For the missing things like the Old insanelymac and theme, please we need them, and excuse my ignorance!
    • Good evening to all. So, I have an external 1TB seagate HD and it always reads normally, but now when I plug it into my HACK it just does not read, it does not even appear on the disk utility. The light always turns blue from the HD without blinking. However I plugged it into windows, on a macbook and it worked normally. I already formatted my hack but it did not work. Thank you in advance for the help and sorry my bad english   my kexts: AppleALC.kext FakeSMC.kext IntelGraphicsFixup.kext IntelMausiEthernet.kext Lilu.kext WhateverGreen.kext VoodooHDA.kext USBInjectAll.kext NvidiaGraphicsFixup.kext   GTX 1080 Windforce core i5 7º generation 8gb Ram H170M Plus BR    
    • WOL packet is reaching the machine from LAN and from WAN (set with port forwarding), tested with "nc -l -u 9".


×