Jump to content
NeXtor

[Guida] Installare SnowLeopard 10.6 ORIGINALE con il Boot-132

206 posts in this topic

Recommended Posts

Al limite ne ho una usb da attaccare al volo.

Posso usare gli stessi kext che ho usato per Leopard per "installare" le periferiche?

Altra cosa, scusami, la mia scheda video viene riconosciuta credo tramite il dsdt.aml che ora ho nella root dell'hd...per quello come faccio? Riutilizzo lo stesso semplicemente rimettendolo li o mi serve anche altro tipo il mio com.apple.boot? Posso riutilizzare lo stesso identico?

Se usi gli stessi kext o programmi di leopard rovini tutto...cè una guida con dei kext che lavorano a 64 bit

Share this post


Link to post
Share on other sites
Advertisement

PERFETTO...TUTTO IN 64 BIT...GRAZIE MILLE.

riconosciuto hd ethernet web cam mic bluetut..

L'unica è la scheda video...non ho capito dalla guida come farla riconoscere..mi spieghi??e anche l'audio non lo riconosce..però sto cercando..dev essere il apple hda kext

Share this post


Link to post
Share on other sites
QUI potete trovare una serie di Kext 32/64 bit

 

grazie ai kext postati da NeXtor, sono riuscito a preparare un cd di boot adatto alla mia scheda madre, aggiungendo i kext per il chipset. Ora l'installazione dal DVD riesce a partire e il software di installazione vede anche gli HDD. Naturalmente ho attivato l'AHCI cosi' come consigliato qui.

 

Nella mia installazione Leopard Retail, avevo l'AHCI disabilitato.

 

Vorrei chiedere a NeXtor:

 

1) I kext nel link precedente (inclusi AppleViaAta, AppleIntelPIIAta, etc) sono a 32 o 64 bit ?

 

2) I kext installati da SNOW LEOPARD sono a 32 o 64 bit ?

 

3) Non e' in alcun modo possibile effettuare l'installazione senza AHCI ?

 

4) Snow Leopard ha ancora bisogno del file APPLESMBIOS ? Questa cosa la sto chiedendo perche' nella vecchia installazione (Leopard Retail) usavo una versione modificata di APPLESMBIOS posto nella cartella EXTRA di CHAMELEON. PEr cui mi domando: quelli che hanno gia' installato SNOW LEOPARD stanno utilizzando una versione modificata di APPLESMBIOS oppure quello originale APPLE ?

 

Grazie

Share this post


Link to post
Share on other sites
grazie ai kext postati da NeXtor, sono riuscito a preparare un cd di boot adatto alla mia scheda madre, aggiungendo i kext per il chipset. Ora l'installazione dal DVD riesce a partire e il software di installazione vede anche gli HDD. Naturalmente ho attivato l'AHCI cosi' come consigliato qui.

 

Nella mia installazione Leopard Retail, avevo l'AHCI disabilitato.

 

Vorrei chiedere a NeXtor:

 

1) I kext nel link precedente (inclusi AppleViaAta, AppleIntelPIIAta, etc) sono a 32 o 64 bit ?

 

2) I kext installati da SNOW LEOPARD sono a 32 o 64 bit ?

 

3) Non e' in alcun modo possibile effettuare l'installazione senza AHCI ?

 

4) Snow Leopard ha ancora bisogno del file APPLESMBIOS ? Questa cosa la sto chiedendo perche' nella vecchia installazione (Leopard Retail) usavo una versione modificata di APPLESMBIOS posto nella cartella EXTRA di CHAMELEON. PEr cui mi domando: quelli che hanno gia' installato SNOW LEOPARD stanno utilizzando una versione modificata di APPLESMBIOS oppure quello originale APPLE ?

 

Grazie

 

1) Sono tutti compatibili sia 32bit sia 64bit.

2) come la prima risposta.

3) Teoricamente e praticamente è possibile, l'unico intoppo è trovare il kext giusto per il riconoscimento...ora posto il + completo che tengo così puoi provare se vuoi...

4) non necessita di nulla in + di quello che trovi segnato nella guida...gli unici files "non originali" che il sistema utilizza sono quelli che gli installi in Extra/Extensions...

AppleIntelPIIXATA.kext.zip

Share this post


Link to post
Share on other sites

grazie per la tua risposta. Il kext che hai postato lo dovrei usare per provare il chipset ICH9R con l'AHCI disabilitato ? Inoltre, il kext che hai postato adesso e' diverso da quello che ho utilizzato e preso a quel link visto precedentemente ?

 

.......vorrei capire bene la storia dell'APPLESMBIOS. Tu hai installato SNOW LEOPARD ? Non hai usato (in EXTRA/EXTENSIONS) nessun APPLESMBIOS modificato ?

 

Forse faccio sempre le stesse domande ma e' solo per il fatto che vorrei capire bene prima di proseguire con i test.

 

Grazie

Share this post


Link to post
Share on other sites

non serve nessun applesmbios o smbiosefi che sia ecc ecc...riconosce tutto solo

 

il kext che ho postato dovrebbe farti riconoscere i dischi SATA impostati come IDE, i due file sono diversi....dovresti provare e farci sapere....

 

io col mio ho provato e funziona....quello del sito non l'ho provato...

Share this post


Link to post
Share on other sites
non serve nessun applesmbios o smbiosefi che sia ecc ecc...riconosce tutto solo

 

il kext che ho postato dovrebbe farti riconoscere i dischi SATA impostati come IDE, i due file sono diversi....dovresti provare e farci sapere....

 

io col mio ho provato e funziona....quello del sito non l'ho provato...

 

ho aggiunto il kext AppleIntelPIIAta al cd, ma al boot si resetta continuamente (disattivando chiaramente l'AHCI). Mi chiedo una cosa, aggiungendo questo kext, forse dovrei parallelamente cancellarne qualcuno dall'iso ? Qual'e' il kext per il riconoscimento del chipset ?

Share this post


Link to post
Share on other sites
Io l'ho installato tramite boot 132 ma non da dvd, visto che dava problemi, direttamente da un HD o chiavetta USB!

Quindi funziona, almeno in parte per me!

 

P.S.

naturalmente io ho fleshato il bios della scheda madre P5KC con quello della P5KR per avere i controller in AHCI!

 

Come hai fatto per la chiavetta?

Per leopard avevo fatto pure io la chiavetta di boot ma ora non ricordo come si fa:D

 

Mi sai dare un aiutino??

 

 

Grazie

Share this post


Link to post
Share on other sites
Questa guida per installare SnowLeopard 10.6 Originale tramite il BOOT-132 è stata testata su ASUS P5K Deluxe/WiFi Ed. con HDD SATA AHCI e controller Jmicron DISABILITATO

 

Occorrente:

1) DVD di SnowLeopard 10.6

2) Il file cdboot.iso e il Bootloader Chameleon 2.0RC2 con alcuni files Extra da aggiugere scaricabile da QUI.

 

Come installare:

Masterizzate con qualunque programma su qualunque OS in un CD-RW (va bene anche un CD normale) il file cdboot.iso

Riavviate il sistema, quindi avviate dal lettore CD vi troverete nella schermata del bootloader chameleon. Estraete il CD, inserite il DVD di SnowLeopard e premete F10: a questo punto dovrebbe riconoscere il DVD. Quando lo riconosce come "Mac OS X Install DVD" digitate -v e premete INVIO.Adesso inizia il caricamento del DVD di SnowLeopard, pazientate ci vorrà un po'.

 

Arrivati alla schermata della scelta della lingua scegliete la vostra e proseguite.

Dopo che "Installer di Mac OSX" si è caricato andate su Utility, quindi su Utility Disco.

 

1) Inizializzate l'HDD su cui volete installare SnowLeopard con mappa partizioni GUID e con formato "Mac OS Esteso (Journaled)" e nome "SnowOSX" o come preferite.

 

2) Adesso uscite dal programma Utility Disco, proseguite l'installazione fin quando non vi chiede di selezionare il disco: naturalmente scegliete quello che avete predisposto per l'installazione. Personalizzate l'installazione come preferite.

 

Avviate l'installazione, attendete la fine quindi cliccate su Riavvia o aspettate 30 secondi.

(Se vi da un errore generico alla fine, non preoccupatevi)

 

Al riavvio togliete il DVD, reinserite il CD di boot e avviate dal lettore

A questo punto selezionate il disco dove avete installato SnowLeopard e digitate -v seguito da INVIO.

Se tutto è andato a buon fine il vostro felino bianco dovrebbe avviarsi!

 

Installiamo "Chameleon-2.0-RC2-r640.pkg" presente nel PACK scaricato prima, DESELEZIONANDO EXTRA.

 

Ora avviate il programma "ShowAllFiles", presente nel PACK, e cliccate su SHOW.

Sostituite il file "boot" presente nella partizione dove avete installato SnowLeopard con quello presente nel PACK scaricato.

 

Inserite nella cartella "Extensions" che si trova nella cartella "Extra" che a sua volta sta nella partizione di SnowLeopard, i KEXT presenti nel PACK scaricato.

 

Avviate "Terminal" e date:

 

sudo su
inserite la password e scrivete:
cd /Extra
cd Extensions
chown -R root:wheel *
chmod -R 755 *

 

Modificate la stringa

 

<key>PlatformUUID</key>
<string>00000000-0000-0000-0000-000000000000</string>

che sta nel file Info.plist contenuto nel Kext PlatformUUID.kext

 

inserendo quella della vostra partizione di snowLeopard, che potete ricavare da Utility Disco col tasto destro del mouse sulla partizione di snowleopard e cliccando su Informazioni.

 

Per quanto riguarda la scheda Marvell 88E8056 fate questo da terminale(Se non avete una Marvell 88E8056, tralasciate questo punto):

 

sudo su
INSERISCI LA PASS
nano /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleYukon2.kext/Contents/Info.plist

cerca e cambia: <key>Yukon-88E8053</key>
in: <key>Yukon-88E8056</key> (<-- cambia il "53" in "56")

cerca e cambia: <string>0x436211AB</string>
in: <string>0x436411AB</string> (<-- cambia il "62" in "64")

cerca e cambia: <string>Yukon Gigabit Adapter 88E8053 Singleport Copper{:content:}lt;/string>
in: <string>Yukon Gigabit Adapter 88E8056 Singleport Copper{:content:}lt;/string> (<-- cambia il "53" in "56")

premi: ctrl+x
premi: Y
premi: INVIO

ora scrivi:

cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins

kextload AppleYukon2.kext

 

Ora editate il file com.apple.boot.plist presente nella cartella EXTRA inserendo la stringa efi della vostra scheda video ecc....

 

riavviate con -f -v , la prima volta per sicurezza e per controllare se ci sono problemi.

Gustatevi SnowLeopard perfettamente funzionante.

 

Con questa installazione sul pc che ho in firma ho ottenuto un sistema perfetto, AUTOAVVIANTE a 64bit

 

INFORMAZIONI GENERALI

1) Kext Fondamentali: AppleIntelIntegratedFramebuffer.kext, fakesmc.kext, IOAHCIBlockStorageInjector.kext, IOGraphicsFamily.kext, NullCPUPowerManagement.kext, PlatformUUID.kext

2) Kext per tastiera e mouse PS2 (altrimenti inuti per periferiche non PS2): AppleACPIPS2Nub.kext, VoodooPS2Controller.kext

3) Kext chipset: i kexts presenti nel PACK sono stati testati su P5K Deluxe/WiFi Ed. e sono funzionanti su SATA AHCI, quindi dovrebbero essere funzionanti su tutte le schede con chipset P35-ICHx

 

Come modificare cdboot.iso per il riconoscimento del vostro chipset

(nel caso non venga riconosciuto e Utility Disco non trova l'HD):

NB: avete bisogno di OSX già installato.

 

Sotto OSX copiate la cartella cdboot presente nel PACK scaricato prima sulla scrivania di OSX.

Nella directory Extra troverete com.apple.boot.plist che potete modificare a vostro piacimento inserendo la stringa per il riconoscimento della vostra scheda video ecc....

troverete anche il file Preboot.dmg, cliccateci sopra 2 volte, ora trovate la directory Extra/Extensions nella quale potete inserire i kext compatibili con il vostro Controller.

 

quando avete finito, smontate l'immagine e da terminale date questi comandi:

 

sudo su
INSERITE LA PASS
cd desktop
hdiutil makehybrid -o cdboot.iso cdboot/ -iso -hfs -joliet -eltorito-boot cdboot/cdboot -no-emul-boot -hfs-volume-name "SLboot132" -joliet-volume-name "SLboot132"

 

in questo modo avrete creato, nella directory Desktop del vostro OSX il file cdboot.iso che potete masterizzare.

 

Ciao NeXtor

sono riuscito ad installare Snow grazie al tuo aiuto ma ho ancora il problema della chiavetta wifi che non funziona (Ralink RT2870)..dopo svariate provo ho scoperto la causa: il kext corrispondente non è compatible a 64BIT e Snow mi parte SOLO a 64!!

Infatti dopo un boot con -v -x32 ecco che mi scrive:

 

post-403021-1252393820_thumb.png

 

Ho provato anche a beccare l'errore specifico del kext Ralink ma in quel caso lo schermo non va in pausa e quindi non è che l'immagine sia venuta un granchè bene:

 

Questa guida per installare SnowLeopard 10.6 Originale tramite il BOOT-132 è stata testata su ASUS P5K Deluxe/WiFi Ed. con HDD SATA AHCI e controller Jmicron DISABILITATO

 

Occorrente:

1) DVD di SnowLeopard 10.6

2) Il file cdboot.iso e il Bootloader Chameleon 2.0RC2 con alcuni files Extra da aggiugere scaricabile da QUI.

 

Come installare:

Masterizzate con qualunque programma su qualunque OS in un CD-RW (va bene anche un CD normale) il file cdboot.iso

Riavviate il sistema, quindi avviate dal lettore CD vi troverete nella schermata del bootloader chameleon. Estraete il CD, inserite il DVD di SnowLeopard e premete F10: a questo punto dovrebbe riconoscere il DVD. Quando lo riconosce come "Mac OS X Install DVD" digitate -v e premete INVIO.Adesso inizia il caricamento del DVD di SnowLeopard, pazientate ci vorrà un po'.

 

Arrivati alla schermata della scelta della lingua scegliete la vostra e proseguite.

Dopo che "Installer di Mac OSX" si è caricato andate su Utility, quindi su Utility Disco.

 

1) Inizializzate l'HDD su cui volete installare SnowLeopard con mappa partizioni GUID e con formato "Mac OS Esteso (Journaled)" e nome "SnowOSX" o come preferite.

 

2) Adesso uscite dal programma Utility Disco, proseguite l'installazione fin quando non vi chiede di selezionare il disco: naturalmente scegliete quello che avete predisposto per l'installazione. Personalizzate l'installazione come preferite.

 

Avviate l'installazione, attendete la fine quindi cliccate su Riavvia o aspettate 30 secondi.

(Se vi da un errore generico alla fine, non preoccupatevi)

 

Al riavvio togliete il DVD, reinserite il CD di boot e avviate dal lettore

A questo punto selezionate il disco dove avete installato SnowLeopard e digitate -v seguito da INVIO.

Se tutto è andato a buon fine il vostro felino bianco dovrebbe avviarsi!

 

Installiamo "Chameleon-2.0-RC2-r640.pkg" presente nel PACK scaricato prima, DESELEZIONANDO EXTRA.

 

Ora avviate il programma "ShowAllFiles", presente nel PACK, e cliccate su SHOW.

Sostituite il file "boot" presente nella partizione dove avete installato SnowLeopard con quello presente nel PACK scaricato.

 

Inserite nella cartella "Extensions" che si trova nella cartella "Extra" che a sua volta sta nella partizione di SnowLeopard, i KEXT presenti nel PACK scaricato.

 

Avviate "Terminal" e date:

 

sudo su
  inserite la password e scrivete:
  cd /Extra
  cd Extensions
  chown -R root:wheel *
  chmod -R 755 *

 

Modificate la stringa

 

<key>PlatformUUID</key>
  <string>00000000-0000-0000-0000-000000000000</string>

che sta nel file Info.plist contenuto nel Kext PlatformUUID.kext

 

inserendo quella della vostra partizione di snowLeopard, che potete ricavare da Utility Disco col tasto destro del mouse sulla partizione di snowleopard e cliccando su Informazioni.

 

Per quanto riguarda la scheda Marvell 88E8056 fate questo da terminale(Se non avete una Marvell 88E8056, tralasciate questo punto):

 

sudo su
  INSERISCI LA PASS
  nano /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleYukon2.kext/Contents/Info.plist

  cerca e cambia: <key>Yukon-88E8053</key>
  in: <key>Yukon-88E8056</key> (<-- cambia il "53" in "56")

  cerca e cambia: <string>0x436211AB</string>
  in: <string>0x436411AB</string> (<-- cambia il "62" in "64")

  cerca e cambia: <string>Yukon Gigabit Adapter 88E8053 Singleport Copper{:content:}lt;/string>
  in: <string>Yukon Gigabit Adapter 88E8056 Singleport Copper{:content:}lt;/string> (<-- cambia il "53" in "56")

  premi: ctrl+x
  premi: Y
  premi: INVIO

  ora scrivi:

  cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins

  kextload AppleYukon2.kext

 

Ora editate il file com.apple.boot.plist presente nella cartella EXTRA inserendo la stringa efi della vostra scheda video ecc....

 

riavviate con -f -v , la prima volta per sicurezza e per controllare se ci sono problemi.

Gustatevi SnowLeopard perfettamente funzionante.

 

Con questa installazione sul pc che ho in firma ho ottenuto un sistema perfetto, AUTOAVVIANTE a 64bit

 

INFORMAZIONI GENERALI

1) Kext Fondamentali: AppleIntelIntegratedFramebuffer.kext, fakesmc.kext, IOAHCIBlockStorageInjector.kext, IOGraphicsFamily.kext, NullCPUPowerManagement.kext, PlatformUUID.kext

2) Kext per tastiera e mouse PS2 (altrimenti inuti per periferiche non PS2): AppleACPIPS2Nub.kext, VoodooPS2Controller.kext

3) Kext chipset: i kexts presenti nel PACK sono stati testati su P5K Deluxe/WiFi Ed. e sono funzionanti su SATA AHCI, quindi dovrebbero essere funzionanti su tutte le schede con chipset P35-ICHx

 

Come modificare cdboot.iso per il riconoscimento del vostro chipset

(nel caso non venga riconosciuto e Utility Disco non trova l'HD):

NB: avete bisogno di OSX già installato.

 

Sotto OSX copiate la cartella cdboot presente nel PACK scaricato prima sulla scrivania di OSX.

Nella directory Extra troverete com.apple.boot.plist che potete modificare a vostro piacimento inserendo la stringa per il riconoscimento della vostra scheda video ecc....

troverete anche il file Preboot.dmg, cliccateci sopra 2 volte, ora trovate la directory Extra/Extensions nella quale potete inserire i kext compatibili con il vostro Controller.

 

quando avete finito, smontate l'immagine e da terminale date questi comandi:

 

sudo su
  INSERITE LA PASS
  cd desktop
  hdiutil makehybrid -o cdboot.iso cdboot/ -iso -hfs -joliet -eltorito-boot cdboot/cdboot -no-emul-boot -hfs-volume-name "SLboot132" -joliet-volume-name "SLboot132"

 

in questo modo avrete creato, nella directory Desktop del vostro OSX il file cdboot.iso che potete masterizzare.

 

Ciao NeXtor

sono riuscito ad installare Snow grazie al tuo aiuto ma ho ancora il problema della chiavetta wifi che non funziona (Ralink RT2870)..dopo svariate provo ho scoperto la causa: il kext corrispondente non è compatible a 64BIT e Snow mi parte SOLO a 64!!

Infatti dopo un boot con -v -x32 ecco che mi scrive:

 

post-403021-1252393820_thumb.png

 

Ho provato anche a beccare l'errore specifico del kext Ralink ma in quel caso lo schermo non va in pausa e quindi non è che l'immagine sia venuta un granchè bene:

 

post-403021-1252394003_thumb.png

 

Qualcuno sa darmi delle indicazioni?

Share this post


Link to post
Share on other sites

Installazione riuscita perfettamente, non mi installava la RC2 di chamaleon e quindi ho messo subito la rc3.

 

Ora devo sistemare i vari kext visto che non ho capito bene quali mi servono per la mia p5q deluxe.

Come fatto con leopard credo che non utilizzerà la cartella extra/extensions ma installerò tutto direttamente nella cartella di sistema.

 

Audio ok

Lan ok

video da sistemare

Time machine da testare

 

per il resto ora non mi viene in mente nulla.

Share this post


Link to post
Share on other sites

Eccoci, buongiorno a tutti.

Dunque, grazie alla guida e agli strumenti messi a disposizione da NeXtor sono riuscito ad installare il Felino Bianco sul mio notebook. L'installazione è andata liscia, al termine mi ha dato l'errore generico di cui si parla nella guida ma, come c'è scritto, l'ho ignorato e poi è partito.

Ho riutilizzato il mio com.apple.boot.plist e il mio file DSDT.aml per il video e questo pare funzionare perfettamente o comunque come prima sotto Leopard (vedi img 1).

La velocità del processore e la RAM non sono riconosciute perfettamente, mi dice che ho un 2,33GHz Sconosciuto e 4GB DD2-667MHz quando in realtà ho un Core2Duo 2,26GHz e 4GB DDR3-1066MHz (vedi img 2 e 3).

Il sistema pare partire a 64bit (vedi img 4).

 

Per il momento non mi funziona ancora nulla, i kext per la P5K ovviamente non vanno bene per la mia scheda, a parte credo quelli delle periferiche PS2 che mi fanno funzionare Tastiera e Trackpad, ora devo cercare quelli per le mie periferiche. A tal proposito: come si fa ad installarli? Basta metterli nella cartella Extra/Extensions/, riparare i permessi e riavviare con -f -v? Non si usano più KextHelper o OSX86Tools? Se qualcuno sa dove potrei trovarli mi faccia un fischio, intanto io cerco in giro.

Una nota per la scheda di rete: io ho una Marvel Yukon 2 88E8055, nella guida si parla di modificare l'info.plist per fare funzionare la 88E8056 modificando di dati della 88E8053, sono andato a vedere e ho notato che i dati della mia scheda ci sono già, ma non viene riconosciuta ugualmente...che devo fare?

 

Terza ed ultima richiesta: pare che il mio BIOS non tenga salvate le impostazioni dell'AHCI, io lo metto Enabled manualmente, ma ad ogni riavvio si rimette in AUTO con ciò che ne consegue, ovvero SL non parte. Da pc spento, quando accendo e faccio partire la prima volta mi si riavvia appena compare la schermata grigia con la mela e al successivo riavvio si pianta sulla schermata grigia dando l'errore Still Waiting for Root Device (l'AHCI si è rimesso in AUTO, probabilmente disabilitato), quindi devo forzare lo spegnimento, riaccendere, entrare nel BIOS, risettare l'AHCI Enabled e poi parte tutto...qualcuno ha idea del perchè succeda questo? Ho installato la versione del Chameleon che ha fornito NeXtor nel suo pacchetto, dite che conviene mettere la RC3, può dipendere da questo?

 

Grazie mille a tutti, scusate se mi sono dilungato un po' :D .

 

IMG 1: post-353189-1252411307_thumb.png IMG 2: post-353189-1252411512_thumb.png

IMG 3: post-353189-1252411503_thumb.png IMG 4: post-353189-1252411518_thumb.png

Share this post


Link to post
Share on other sites
Eccoci, buongiorno a tutti.

Dunque, grazie alla guida e agli strumenti messi a disposizione da NeXtor sono riuscito ad installare il Felino Bianco sul mio notebook. L'installazione è andata liscia, al termine mi ha dato l'errore generico di cui si parla nella guida ma, come c'è scritto, l'ho ignorato e poi è partito.

Ho riutilizzato il mio com.apple.boot.plist e il mio file DSDT.aml per il video e questo pare funzionare perfettamente o comunque come prima sotto Leopard (vedi img 1).

La velocità del processore e la RAM non sono riconosciute perfettamente, mi dice che ho un 2,33GHz Sconosciuto e 4GB DD2-667MHz quando in realtà ho un Core2Duo 2,26GHz e 4GB DDR3-1066MHz (vedi img 2 e 3).

Il sistema pare partire a 64bit (vedi img 4).

 

Per il momento non mi funziona ancora nulla, i kext per la P5K ovviamente non vanno bene per la mia scheda, a parte credo quelli delle periferiche PS2 che mi fanno funzionare Tastiera e Trackpad, ora devo cercare quelli per le mie periferiche. A tal proposito: come si fa ad installarli? Basta metterli nella cartella Extra/Extensions/, riparare i permessi e riavviare con -f -v? Non si usano più KextHelper o OSX86Tools? Se qualcuno sa dove potrei trovarli mi faccia un fischio, intanto io cerco in giro.

Una nota per la scheda di rete: io ho una Marvel Yukon 2 88E8055, nella guida si parla di modificare l'info.plist per fare funzionare la 88E8056 modificando di dati della 88E8053, sono andato a vedere e ho notato che i dati della mia scheda ci sono già, ma non viene riconosciuta ugualmente...che devo fare?

 

Terza ed ultima richiesta: pare che il mio BIOS non tenga salvate le impostazioni dell'AHCI, io lo metto Enabled manualmente, ma ad ogni riavvio si rimette in AUTO con ciò che ne consegue, ovvero SL non parte. Da pc spento, quando accendo e faccio partire la prima volta mi si riavvia appena compare la schermata grigia con la mela e al successivo riavvio si pianta sulla schermata grigia dando l'errore Still Waiting for Root Device (l'AHCI si è rimesso in AUTO, probabilmente disabilitato), quindi devo forzare lo spegnimento, riaccendere, entrare nel BIOS, risettare l'AHCI Enabled e poi parte tutto...qualcuno ha idea del perchè succeda questo? Ho installato la versione del Chameleon che ha fornito NeXtor nel suo pacchetto, dite che conviene mettere la RC3, può dipendere da questo?

 

Grazie mille a tutti, scusate se mi sono dilungato un po' :D .

 

IMG 1: post-353189-1252411307_thumb.png IMG 2: post-353189-1252411512_thumb.png

IMG 3: post-353189-1252411503_thumb.png IMG 4: post-353189-1252411518_thumb.png

 

Per quanto riguarda l'installazione dei kext, puoi copiarli nella cartella Extra/Extensions e riparare i permessi avviando poi la prima volta con -f -v per controllare, se alcuni non te li carica come succede a me con il kext VoodooHDA, inseriscili in /System/Library/Extensions e ripara anche li i permessi, oppure(se installi in /System/Library/Extensions/) puoi utilizzare i soliti tools...

 

per quanto riguarda la marvell prova a dare questo da terminale:

 

sudo su
INSERISCI LA PASS
cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/
kextload AppleYukon2.kext

 

poi vai nelle preference di sistema e vedi se te l'ha caricata...

 

per quanto riguarda il bios, potresti avere il problema che stanno riscontrando gli utenti che posseggono le gygabyte, e per risolvere bisogna modificare alcune stringhe nel DSDT.aml, o meglio, nel DSDT.dsl che poi dovrai compilare da terminale...ma ribadisco, la risoluzione del problema che trovi in giro è testata sulle gygabyte, per la tua non ti so dire al momento.

Share this post


Link to post
Share on other sites

e io come faccio ad attivare il qe sulla mia 9200 m gs??? con isx86 tools ho impostato la risoluzione e basta..

un altra cosa non mi vede il microfono

Share this post


Link to post
Share on other sites
Per quanto riguarda l'installazione dei kext, puoi copiarli nella cartella Extra/Extensions e riparare i permessi avviando poi la prima volta con -f -v per controllare, se alcuni non te li carica come succede a me con il kext VoodooHDA, inseriscili in /System/Library/Extensions e ripara anche li i permessi, oppure(se installi in /System/Library/Extensions/) puoi utilizzare i soliti tools...

 

per quanto riguarda la marvell prova a dare questo da terminale:

 

sudo su
INSERISCI LA PASS
cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/
kextload AppleYukon2.kext

 

poi vai nelle preference di sistema e vedi se te l'ha caricata...

 

per quanto riguarda il bios, potresti avere il problema che stanno riscontrando gli utenti che posseggono le gygabyte, e per risolvere bisogna modificare alcune stringhe nel DSDT.aml, o meglio, nel DSDT.dsl che poi dovrai compilare da terminale...ma ribadisco, la risoluzione del problema che trovi in giro è testata sulle gygabyte, per la tua non ti so dire al momento.

 

Grazie mille NeXtor, gentilissimo come sempre. La procedura da Terminale l'ho già provata ma non ha avuto successo, magari più tardi riprovo, al momento ho fatto un casino e mi sa che mi tocca ripulire tutto e ricostruire le partizioni poi ritenterò un'installazione pulita. Per il momento grazie, tornerò a stressarvi tra un po' ;) .

Share this post


Link to post
Share on other sites

Sono arrivato ad un buon punto con snow leopard per la mia configurazione.

 

Ho aggiunto l'efi per la scheda video, ma nelle informazioni di sistema non mi da il QE e CI attivi, qualcuno sa consigliarmi qualche strada?

 

Per l'efi string ho scaricato un file .plist per la mia scheda e poi aggiunto l'hex ricavato nel boot.plist.

 

 

Inoltre invece della RC2 di chameleon ho messo la 3.

 

Mentre invece non ho sostituito il file boot nella cartella di sistema, è obbligatorio farlo? Vedo che mi si avvia cmq snow.

 

Grazie

Ciao

Share this post


Link to post
Share on other sites

primo tentativo con una p5kr non è andato a buon fine....dopo ci riprovo...ma non so nemmeno le differenze tra la mia e questa della guida!

2 cose:

- cos'è l'efi della scheda video?

- dove trovo la RC3?

 

secondo voi devo procurarmi altri kext per la mia?

Share this post


Link to post
Share on other sites
Sono arrivato ad un buon punto con snow leopard per la mia configurazione.

 

Ho aggiunto l'efi per la scheda video, ma nelle informazioni di sistema non mi da il QE e CI attivi, qualcuno sa consigliarmi qualche strada?

 

Per l'efi string ho scaricato un file .plist per la mia scheda e poi aggiunto l'hex ricavato nel boot.plist.

 

 

Inoltre invece della RC2 di chameleon ho messo la 3.

 

Mentre invece non ho sostituito il file boot nella cartella di sistema, � obbligatorio farlo? Vedo che mi si avvia cmq snow.

 

Grazie

Ciao

era necessario con la vecchia versione....ma in questa, nuova e compatibile con snow, c'è già....

Share this post


Link to post
Share on other sites

Ciao a tutti,

io possiedo una p5k-e wifi ap, e questa guida dovrebbe quindi andar bene...

Ora, io ho fatto 2 giorni di prove prima di scrivere questo:

riesco ad avviare il disco di boot, e riesco anche a far cominciare il caricamento di snow leopard. Però qui c'è un problema: dopo la prima fase di avvio, in cui vengono caricate le kext, tutto sembra procedere liscio. Scrive, scrive, scrive, tutto senza errori, almeno a quanto riesco a capire o a vedere... Arriva in fondo al caricamento, al momento in cui dovrebbe avviare la GUI, ma lascia lo schermo spento, senza mandare segnale video. Io per scrupolo ce l'ho lasciato per più o meno due ore e mezzo, ma è rimasto nero.

Però devo dire un'altra cosa... non solo lascio il jmicron attivo, ma avvio mac os x da un lettore cd collegato al jmicron, visto che è un lettore dvd pata, e sulla mia scheda madre tutte le porte pata sono gestite dal jmicron...

Ho anche un masterizzatore SATA collegato al controller intel ich9r impostato su AHCI, ma non mi riesce ad avviare lo Chameleon RC3... Semplicemente il pc arriva a fare il boot da masterizzatore, comincia a leggere il cd, e poi trova dei settori che non riesce a leggere.. prova almeno una decina di volte a rileggere i settori che non riesce a leggere, poi sembra abbandonare, e lascia delle righe in cui c'è scritto che ha caricato il file Preboot.dmg... poi riprende degli errori in altri 2 settori differenti, infine smette di dare errori, fermando tutto... anche in questo stato ci dev'essere stato per una mezz'oretta.

Quindi, riesco ad avviare il CD solo con un lettore... anche il lettore però prende degli errori: comincia a leggere il cd, poi da degli errori iniziali come il masterizzatore negli stessi settori, che però sembra ignorare, carica e monta il file DMG, e poi parte la GUI dello Chameleon 2...

Quindi scambio i dischi, premo f10 (o f5), metto il flag -v, e premo invio... peccato che appunto poi resti fermo...

Ho fatto tanti tentativi, inizialmente con la iso scaricata direttamente. Poi ho cambiato un po' di kext, ho dovuto inizialmente aggiungere il jmicronata altrimenti snow leopard dava "Still waiting for root device", poichè non riusciva ad accedere al lettore DVD... dopo aver messo la kext per il jmicron ho tolto AppleIntelIntegratedFramebuffer.kext, visto che da quel che ho capito serve per schede video integrate intel, che non ho.

Poi ho tolto il VoodooHDA.kext e l'ho sostituito con AppleHDA, proveniente dal Taruga_ad1998_rev4 installer, che sto usando su Leopard (ma che non so se sia adatto per snow leopard... so solo che non ha dato alcun errore nella fase di boot, o almeno di tutte le volte che ho provato non sono mai riuscito a vederlo).

Anche così non sono riuscito a sfangarla, quindi ho provato a creare delle efi strings per la mia scheda video, e visto che c'ero anche per la scheda di rete, che ho aggiunto nel com.apple.boot.plist nella cartella cdboot/Extra (nella stessa cartella del file DMG).

Anche così nulla...

Ho provato quindi a rimuovere la kext IOGraphicsFamily.kext, ma anche questa volta sono rimasto fermo...

E quindi ho terminato rivolgendomi a voi.

Altra cosa: quando avvio snow leopard, compare una scritta della kext NVDANV50HAL che dice di essersi caricata correttamente...

Io ho una GTX260 core 216, e su leopard ho sempre usato i driver per la GTX285 evga + injector di netkas... non so proprio più cosa pensare, se non che snow leopard abbia integrati dei driver nvdia che vengono caricati per la mia scheda video...

Qualcuno sa darmi una dritta, o semplicemente una nuova strada da seguire... qualsiasi cosa... tanto ora mai sono due giorni che batto la testa nei pali... prima il mast.., poi jmicron, poi sk grafica... anche solo per cambiare palo contro cui battere :D

Ciao e grazie a tutti dell'aiuto.

 

 

EDIT: mi son dimenticato: naturalmente tutte le volte che facevo una modifica ricreavo la iso da zero con il comando hdiutil, e o ho usato due cd riscrivibili differenti.

Share this post


Link to post
Share on other sites
nel system profiler non uscirà Qe/Ci attivo o meno...se avete la barra superiore traslucida significa che sono attivi!

infatti non ho la barra traslucida...

Share this post


Link to post
Share on other sites

Dopo un paio di prove ho notato che gli unici file che servono per avviare il sistema sono il chamaleon e fakesmc.kext!

 

Qulacuno sa dire a cosa serve Il PatformUUID, e il NullCPUPowerManagement?

 

e se comporta qualcosa, che non mi sembra visto che il sistemasi avvia.

 

Neanche il file boot ho sostituito e si avvia!

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×