Jump to content
tseug

[GUIDE] Snow Leopard Vanilla Retail Guide for GA-P35-DS4 and other related boards

Did it work without issues?  

429 members have voted

  1. 1. Install check

    • Yes (GA-P35-DS4)
      165
    • No (GA-P35-DS4)
      43
    • Yes (Different MB)
      164
    • No (Different MB)
      57

785 posts in this topic

Recommended Posts

I'm having some troubles with the GA-P35-DS4 Snow Leopard Installer though.

 

It fails running the "postupgrade script for snowjob". Any thoughs?

 

I had this same error. Looking at the log I saw that the /Extra and /Extra/Extensions folders did not exist on my target disk.

 

I don't know if this is because I installed Chameleon as EFI instead of Standard or not. Maybe someone can look more in to it. Also, I haven't finished the install yet to see if selecting EFI is a problem in general. Will comment back in a bit.

Share this post


Link to post
Share on other sites
Advertisement

Yep the installer tseug provided assumes you don't install Chameleon to EFI partition. Probably wouldn't be too much to modify it to allow you to select EFI or Standard - I may look at it myself once I get everything setup.

Share this post


Link to post
Share on other sites
I had this same error. Looking at the log I saw that the /Extra and /Extra/Extensions folders did not exist on my target disk.

 

I don't know if this is because I installed Chameleon as EFI instead of Standard or not.

 

It is. If you don't follow the guide you're on your own :)

 

 

Yep the installer tseug provided assumes you don't install Chameleon to EFI partition. Probably wouldn't be too much to modify it to allow you to select EFI or Standard - I may look at it myself once I get everything setup.

 

The easiest way to install to EFI would be to install to standard first and then move over the stuff afterwards. I try not to include too many options because I don't want to have to test them.

 

I'm using patcher02beta5 is yours the same one?

 

No. Then again, who know? (a diff would tell you, of course, but that would almost be too easy :D)

Share this post


Link to post
Share on other sites
How do you run your DSDT patcher? Do I need ruby on rails installed?

 

You need to run it in the terminal. That is, type ./patcher.rb from within the patcher directory.

 

I added your boot file and now I can boot to 32bit & 64bit WOOT WOOT!!!

I was using Netkas v10.1 boot but I couldn't boot in 32bit only 64bit.

 

What version is your boot file and where is it from?

 

Thanks!

 

I got most of the kexts from here: http://www.insanelymac.com/forum/index.php?showtopic=182227

Share this post


Link to post
Share on other sites

Thanks Tseug for this Package.

I will try this soon.

Meanwhile, I did a successful installation of 10.6 on my own and started playing with it, and after installation of iLife 09, I had many problems and KP. :thumbsdown_anim:

I was wondering if you have ever experienced system crashes using 10.6 as delivered with your procedure ?

 

Thanks !

:blink:

Gloops92

GA-P35-DS4 Rev2.0 - NV 8800GTS

Share this post


Link to post
Share on other sites

Perfect install :thumbsdown_anim:

 

I've been installing on PC since 10.2, this was the first time I heard the music in the welcome movie.

Big big appreciation, well done, after so many installs, this one deserves my applause.

 

The whole process took 14 minutes.

 

 

For those of you that didn't understand, in step 11, the keys and hex are added to /Extra/com.apple.Boot.plist

(That's why you should keep the file open in the editor).

Share this post


Link to post
Share on other sites

First of all thanks for this tut - works great :(

 

After several guides, I tried this one and first time success - thank you.

 

MoBO: GA-EP45-DQ6

Proc: Q6600

 

Gerhold

Share this post


Link to post
Share on other sites
Can you put a screen from the System Info Categories Video ? I just wanna to see when QE/Ci is active .

Thx

post-28111-1252313306_thumb.png

Share this post


Link to post
Share on other sites

It seems I cannot generate a dsdt? Tried also with the standalone dsdt patcher same error No HPET Device found (RuntimeError)

 

Here's the ouput when I tried to use the stand alone. Strange because Hpet is enabled in BIOS as 64bit.

 

Intel ACPI Component Architecture
AML Disassembler version 20080926 [Oct  4 2008]
Copyright © 2000 - 2008 Intel Corporation
Supports ACPI Specification Revision 3.0a

Handling RTC Device...
Patched!
Handling RTC Device done
Handling HPET Device...
/Users/xx/Downloads/patcher/patcher.rb:264:in `patch_hpet': No HPET Device found (RuntimeError)
from /Users/xx/Downloads/patcher/patcher.rb:189:in `patch'
from /Users/xx/Downloads/patcher/patcher.rb:219:in `verbose'
from /Users/xx/Downloads/patcher/patcher.rb:189:in `patch'
from /Users/xx/Downloads/patcher/patcher.rb:184:in `patch'
from /Users/xx/Downloads/patcher/patcher.rb:344

 

I have attached the dsdt.dsl file.

dsdt.dsl.zip

Share this post


Link to post
Share on other sites
It seems I cannot generate a dsdt? Tried also with the standalone dsdt patcher same error No HPET Device found (RuntimeError)

 

I have attached the dsdt.dsl file.

 

I have created an update based on your dsdt (and other stuff). It should work now.

 

Guide updated.

 

Can you put a screen from the System Info Categories Video ? I just wanna to see when QE/Ci is active .

Thx

 

It is, but for some reason it does not show up in system profiler. However, ripple effect on dashboard (CI) and cube fast user switching (QE) works.

 

Hi,

At this moment i have 10.5.8, and want to do a clean install and use Snow Leopard.

I would like to buy a new harddrive, is a 1TB drive supported?

thnx

 

Although I have not tested it, I see no reason for 1 TB to not be supported, as long as it is SATA.

 

What should this look like

Put arch=x86_32 in kernel flags in /Extra/com.apple.Boot.plist. Keep the file open.

not sure what you mean by kernel flags

 

I've added a codebox to show you what I mean.

 

Guide updated.

Share this post


Link to post
Share on other sites
I have created an update based on your dsdt (and other stuff). It should work now.

 

Guide updated.

 

Tried again with the new installer.

 

Epic! worked first time. I'm writing this from 10.6.

 

Big thank-you tseug

Share this post


Link to post
Share on other sites
Thanks Tseug for this Package.

I will try this soon.

Meanwhile, I did a successful installation of 10.6 on my own and started playing with it, and after installation of iLife 09, I had many problems and KP. :unsure:

I was wondering if you have ever experienced system crashes using 10.6 as delivered with your procedure ?

 

Thanks !

:D

Gloops92

GA-P35-DS4 Rev2.0 - NV 8800GTS

 

I haven't had any crashes. I have iLife 09 installed, but I don't use it much at the moment. However, iMovie loaded up without problems.

 

Guide updated with succes stories on other boards.

Share this post


Link to post
Share on other sites
Hi,

At this moment i have 10.5.8, and want to do a clean install and use Snow Leopard.

I would like to buy a new harddrive, is a 1TB drive supported?

thnx

 

Not tried with snow, but with 10.5.8 no problem.

This computer is using a 1TB drive, leopard is on 1 partition of 180 GB MBR.

Regards.

Share this post


Link to post
Share on other sites

Will this install work from an imaged snow install disk using a 10.5.8 hackintosh to another sata drive in the case? Getting that "you must restart the computer" screen after the apple shows up with the light grey background> I did the image from a bought copy of snow. My dvd rom stopped working and dont have another sata one to throw in so I was using a .dmg file i created with the disk

Share this post


Link to post
Share on other sites
Will this install work from an imaged snow install disk using a 10.5.8 hackintosh to another sata drive in the case? Getting that "you must restart the computer" screen after the apple shows up with the light grey background> I did the image from a bought copy of snow. My dvd rom stopped working and dont have another sata one to throw in so I was using a .dmg file i created with the disk

 

Yes. That should work. You may have to repartition the drive? Make sure that "Ignore ownership on this volume" is not checked in Get Info on the target partition.

 

You can also restore the DVD to a partition and follow the steps as if you had installed SL. I've tested this on a 8 GB USB stick. Use the disk utility restore functionality. Make sure that the DVD is scanned prior to restoration by clicking Images->Scan Image for Restore... Otherwise it will fail.

 

In addition, if you boot up with '-v', You can see exactly what went wrong.

Share this post


Link to post
Share on other sites
I haven't had any crashes. I have iLife 09 installed, but I don't use it much at the moment. However, iMovie loaded up without problems.

 

Guide updated with succes stories on other boards.

 

Ok, I installed it again using your package and guide. No problem at install. But, after working for 15 minutes on SL, I had a System crash ;)

 

As I had 3 other hard disks mounted in my PC, I decided to disconnected all drives except SL.

And now it is stable so far ! :P

I think this can be related to Spotlight indexing other disks and running over weird files that would cause a crash ???

Anyway, I will keep going on my installation of apps and customization.

My goal is to have full 64bits running, so I will take a look at Bonjour with Realtek in the forums.

 

Thank you very much for your work.

 

Keep updating this thread for all GA-P35-DS4 owners ! We are a lot ;)

Share this post


Link to post
Share on other sites
Ok, I installed it again using your package and guide. No problem at install. But, after working for 15 minutes on SL, I had a System crash :blink:

 

As I had 3 other hard disks mounted in my PC, I decided to disconnected all drives except SL.

And now it is stable so far ! ;)

I think this can be related to Spotlight indexing other disks and running over weird files that would cause a crash ???

 

I don't know. It doesn't seem likely. You can prohibit spotlight from indexing the other drives by adding them to Privacy in spotlight preferences.

 

Anyway, I will keep going on my installation of apps and customization.

My goal is to have full 64bits running, so I will take a look at Bonjour with Realtek in the forums.

 

I've seen a hack using a patched ifconfig, but personally I'm fine with the 32 bit kernel.

Share this post


Link to post
Share on other sites

Success on a GA-P35-DS4! Thank you for your work, tseug.

 

I ran the installation from a separate partition with a SuperDuper copy of my previous 10.5.7 installation. I have a single disk, dual-boot setup with XP, so I installed to a GUID partition on a MBR disk. To do this, I used a modified OSinstall.mpkg which allows installation to an MBR disk - create your own using the guide linked in my signature. That resulted in a modified Snow Leopard install image (i.e., .dmg file) that I mounted to install from.

 

I have an ATI video card, so I didn't run step #11 assuming the result was tailored to nvidia cards - is that correct (wasn't exactly clear in the guide, I thought)? Consequently, I haven't applied any kexts for my video card, so I'm dealing with the default driver - subpar resolution, no dual dvi, etc. It appears the previous Bronya kexts I used are having difficulty with Snow Leopard - any suggestions would be appreciated.

 

EDIT: also need to add support for PS/2 keyboard, which is preferred over my cheap USB version. Previously used pcwiz command center, not sure if works for SL...

Share this post


Link to post
Share on other sites
Thanks for all the work that has gone into this...

 

I'm having some troubles with the GA-P35-DS4 Snow Leopard Installer though.

 

It fails running the "postupgrade script for snowjob". Any thoughs?

 

/Extra/Extensions folder must exist on the destination partition. If it does not (e.g. if you install Chameleon 2.0 RC3 manually), you have to create it prior installing the drivers package. It works perfectly for me on my P35-DS4, thanks tseug!

 

Tseug, does your package install some files to the system tree, or are all files stored in /Extra?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×