Jump to content
lunasol

Boot132 cdboot for Snow Leopard

186 posts in this topic

Recommended Posts

Advertisement
Any mistakes there?

 

Not a mistake but just mount it via finder and it will be writeable already. No need to convert it etc.

Share this post


Link to post
Share on other sites
Not a mistake but just mount it via finder and it will be writeable already. No need to convert it etc.

 

Ya, I finally realized that - after I went to the trouble of learning how to build it from scratch. Oh well, knowledge gained is never a waste ;)

Share this post


Link to post
Share on other sites

My friend with almost the same rig as mine (difference = mine has a 9600GT videocard and his have 2600HD one), but as before, when it's time to boot the GUI, blackscreen.

 

He was only able to boot it once, when deleted all ATI KEXTs but as his card is the same as a REAL MACPRO there must be something different to do.

Share this post


Link to post
Share on other sites
Can anyone provide a proper iso for a Dell D830 ? The lspci is in this post.

 

Thanks.

 

SL boot KPs with the Inspiron6400 iso.

 

if it KP's change your bios set up so that your hard drives are in a different mode

 

if it hangs. your graphics aren't working properly

Share this post


Link to post
Share on other sites
So after 5 pages, can this load a DSDT or not?

 

Thanks,

 

-Stell

 

It's quite possible I've put it in the wrong place (preboot.dmg/Extra) but mine does not appear to be loading - I'm getting the USB unloaded across sleep error that my DSDT fixes in Leopard and I'm getting a KP without nullcpu in the preboot which I don't need in Leopard so I would say mine is not being loaded. I would love to be proved wrong....

 

Regards,

SMF

Share this post


Link to post
Share on other sites
It's quite possible I've put it in the wrong place (preboot.dmg/Extra) but mine does not appear to be loading - I'm getting the USB unloaded across sleep error that my DSDT fixes in Leopard and I'm getting a KP without nullcpu in the preboot which I don't need in Leopard so I would say mine is not being loaded. I would love to be proved wrong....

 

Regards,

SMF

 

Without meaning to initiate a hi-jack, I would love to know about fixing the USB unloaded error. Could you send me a pointer or two when you get a chance?

Share this post


Link to post
Share on other sites
Without meaning to initiate a hi-jack, I would love to know about fixing the USB unloaded error. Could you send me a pointer or two when you get a chance?

 

PM sent

Share this post


Link to post
Share on other sites

I'm about to give this a shot but I need some help. My video card is the 8800gts and using efi studio it comes out to:

6e0200000100000001000000620200000d00000002010c00d041030a010000000101060
000010101060000007fff04000e0000004e00560050004d0000002000000001000000000000000000
000000000000000000000000000000000000220000005600520041004d002c0074006f00740061006
c00730069007a006500000008000000000000281c0000006400650076006900630065005f00740079
007000650000000f0000004e5644412c506172656e740e0000006e0061006d00650000000b0000006
46973706c617922000000400030002c006400650076006900630065005f0074007900700065000000
0b000000646973706c617922000000400031002c006400650076006900630065005f0074007900700
0650000000b000000646973706c6179100000006d006f00640065006c0000001b0000006e56696469
61204765466f72636520383830302047545320000000400031002c0063006f006d007000610074006
90062006c00650000000e0000004e5644412c4e564d616314000000400030002c006e0061006d0065
000000120000004e5644412c446973706c61792d4114000000400031002c006e0061006d006500000
0120000004e5644412c446973706c61792d4220000000400030002c0063006f006d00700061007400
690062006c00650000000e0000004e5644412c4e564d6163100000004e00560043004100500000001
800000004000000000003000c00000000000007000000001e00000072006f006d002d007200650076
006900730069006f006e0000002f0000006e5669646961204765466f7263652038383030204754532
04f70656e474c20456e67696e65205b4546495d

 

So I'm assuming this is the efi string. But what do I put in the Graphics mode string slot?

 

Anyone?

Share this post


Link to post
Share on other sites
I'm about to give this a shot but I need some help. My video card is the 8800gts and using efi studio it comes out to:

6e0200000100000001000000620200000d00000002010c00d041030a010000000101060
000010101060000007fff04000e0000004e00560050004d000000200000000100000000000000000
0
000000000000000000000000000000000000220000005600520041004d002c0074006f0074006100
6
c00730069007a006500000008000000000000281c0000006400650076006900630065005f0074007
9
007000650000000f0000004e5644412c506172656e740e0000006e0061006d00650000000b000000
6
46973706c617922000000400030002c006400650076006900630065005f007400790070006500000
0
0b000000646973706c617922000000400031002c006400650076006900630065005f007400790070
0
0650000000b000000646973706c6179100000006d006f00640065006c0000001b0000006e5669646
9
61204765466f72636520383830302047545320000000400031002c0063006f006d00700061007400
6
90062006c00650000000e0000004e5644412c4e564d616314000000400030002c006e0061006d006
5
000000120000004e5644412c446973706c61792d4114000000400031002c006e0061006d00650000
0
0120000004e5644412c446973706c61792d4220000000400030002c0063006f006d0070006100740
0
690062006c00650000000e0000004e5644412c4e564d6163100000004e0056004300410050000000
1
800000004000000000003000c00000000000007000000001e00000072006f006d002d00720065007
6
006900730069006f006e0000002f0000006e5669646961204765466f726365203838303020475453
2
04f70656e474c20456e67696e65205b4546495d

 

So I'm assuming this is the efi string. But what do I put in the Graphics mode string slot?

 

Anyone?

 

Hey dude, you have to put your res in there

aka

<key>Graphics Mode</key>

<string>1680x1050x32</string>

 

just replace the 1680x1050 with you own max res

 

flash

Share this post


Link to post
Share on other sites

Ok, heres the update one. Feel free to tell me what I'm missing..

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>-arch=1386 -x32</string>
<key>SMBIOSdefaults</key>
<string>No</string>
<key>Rescan</key>
<string>Yes</string>
       <key>device-properties</key>
       <string>6e0200000100000001000000620200000d00000002010c00d041030a010000000101060000010
101060000007fff04000e0000004e00560050004d0000002000000001000000000000000000000000
000000000000000000000000000000220000005600520041004d002c0074006f00740061006c00730
069007a006500000008000000000000281c0000006400650076006900630065005f00740079007000
650000000f0000004e5644412c506172656e740e0000006e0061006d00650000000b0000006469737
06c617922000000400030002c006400650076006900630065005f00740079007000650000000b0000
00646973706c617922000000400031002c006400650076006900630065005f0074007900700065000
0000b000000646973706c6179100000006d006f00640065006c0000001b0000006e56696469612047
65466f72636520383830302047545320000000400031002c0063006f006d007000610074006900620
06c00650000000e0000004e5644412c4e564d616314000000400030002c006e0061006d0065000000
120000004e5644412c446973706c61792d4114000000400031002c006e0061006d006500000012000
0004e5644412c446973706c61792d4220000000400030002c0063006f006d00700061007400690062
006c00650000000e0000004e5644412c4e564d6163100000004e00560043004100500000001800000
004000000000003000c00000000000007000000001e00000072006f006d002d007200650076006900
730069006f006e0000002f0000006e5669646961204765466f726365203838303020475453204f706
56e474c20456e67696e65205b4546495d</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1680x1050x32</string>
       <key>Legacy Logo</key>
       <string>Yes</string>		
</dict>
</plist>

Share this post


Link to post
Share on other sites
if it KP's change your bios set up so that your hard drives are in a different mode

 

if it hangs. your graphics aren't working properly

 

I get KP with the cdboot, and hangs with some older boot-132 discs.

 

I have tried both ATA and AHCI modes in the bios setup.

Share this post


Link to post
Share on other sites

I see alot of posts about changing ATA and AHCI modes to fix the problem with the AppleIntelPIIXATA kernel panic. I also see alot of posts of using other methods (like using the Netkas fix or deleting the IOATAFamily from Snow Leopard. There are also many other methods out there that I won't get into.

 

The bottom line:

 

None of these methods work with certain platforms (especially with platforms that have "one" ATA controller (primary).

 

Why don't we get the source for the IOATAFamily and fix the AppleIntelPIIXATA problem...instead of all these "Shaky Jake" (fly-by-night workarounds).

 

Sound like a good idea?

 

-Nihilator

Share this post


Link to post
Share on other sites
I get KP with the cdboot, and hangs with some older boot-132 discs.

 

I have tried both ATA and AHCI modes in the bios setup.

 

i've added support for everything that exists for snow leopard right now :(

sorry man.

Share this post


Link to post
Share on other sites

Good morning,

 

I was able to boot Snow Leopard with AHCI enabled.

 

What do I need to add (kext) to the iso to try to boot with AHCI disabled ? I found some AppleIntelPIIAta kext but by adding them the computer always reboots.

 

When I add AppleIntelPIIAta, do I need to delete something (kext) in the iso so the system can boot with AHCI disabled ?

 

Thanks

Share this post


Link to post
Share on other sites

Hello people,

Is someone who has made a 132-SL boot CD and having the Asus P5K-VM mobo? I can't pass the: "Still waiting for root device" line. I need some kext(s) for ICH7-9, in the Extra/Extensions folder, but I don't know what. Please, explain me as I am noob in this. Any help is greatefully appreciated.

Thanks in advance.

Share this post


Link to post
Share on other sites

Hi,

 

I created a cd as described in the first post the only kext I added was VoodooHDA (0.2.2 beta). When I insert the SL dvd chameleon shows the dvd as Apple_HFS and when i press enter to boot the dvd it says it can't find mach_kernel. I also used this SL dvd for my MacBook and it's running fine so it's not my SL dvd. Specs are below and I'm currently on 10.5.8. Can someone tell me what I've done wrong?

Share this post


Link to post
Share on other sites
Technically this isn't really boot-132, its cdboot. cdboot and boot-132 are completely different. Although, they perform similar tasks, just a clarification. ;)

With the 'NEW' RC3 release, boot WILL make a very nice boot 132 cd with isolinux, menus etc.

If my testing goes according to plan, big things ARE a coming...

Share this post


Link to post
Share on other sites
Hi,

 

I created a cd as described in the first post the only kext I added was VoodooHDA (0.2.2 beta). When I insert the SL dvd chameleon shows the dvd as Apple_HFS and when i press enter to boot the dvd it says it can't find mach_kernel. I also used this SL dvd for my MacBook and it's running fine so it's not my SL dvd. Specs are below and I'm currently on 10.5.8. Can someone tell me what I've done wrong?

 

.......insert the SL dvd and press F10, you will see "OSX install DVD".......then you can press ENTER.

 

Let me know...

Share this post


Link to post
Share on other sites

Gonna try it now thanks!

 

Edit: Got still waiting for root device error adding chipset driver to the cd now..

Share this post


Link to post
Share on other sites
Ok, heres the update one. Feel free to tell me what I'm missing..

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>-arch=1386 -x32</string>
<key>SMBIOSdefaults</key>
<string>No</string>
<key>Rescan</key>
<string>Yes</string>
       <key>device-properties</key>
       <string>6e0200000100000001000000620200000d00000002010c00d041030a010000000101060000010
101060000007fff04000e0000004e00560050004d000000200000000100000000000000000000000
0
000000000000000000000000000000220000005600520041004d002c0074006f00740061006c0073
0
069007a006500000008000000000000281c0000006400650076006900630065005f0074007900700
0
650000000f0000004e5644412c506172656e740e0000006e0061006d00650000000b000000646973
7
06c617922000000400030002c006400650076006900630065005f00740079007000650000000b000
0
00646973706c617922000000400031002c006400650076006900630065005f007400790070006500
0
0000b000000646973706c6179100000006d006f00640065006c0000001b0000006e5669646961204
7
65466f72636520383830302047545320000000400031002c0063006f006d00700061007400690062
0
06c00650000000e0000004e5644412c4e564d616314000000400030002c006e0061006d006500000
0
120000004e5644412c446973706c61792d4114000000400031002c006e0061006d00650000001200
0
0004e5644412c446973706c61792d4220000000400030002c0063006f006d0070006100740069006
2
006c00650000000e0000004e5644412c4e564d6163100000004e0056004300410050000000180000
0
004000000000003000c00000000000007000000001e00000072006f006d002d00720065007600690
0
730069006f006e0000002f0000006e5669646961204765466f726365203838303020475453204f70
6
56e474c20456e67696e65205b4546495d</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1680x1050x32</string>
       <key>Legacy Logo</key>
       <string>Yes</string>		
</dict>
</plist>

 

@VIS,

 

you put arch=1386 instead of i386

Share this post


Link to post
Share on other sites

Ok now i've got still waiting for root device tried netkas' ICHx drivers for SL no result also searched but everyone who has still waiting for root device on SL hasn't got a solution yet.

Share this post


Link to post
Share on other sites

Hi everyone!

 

Is this working with IDE optical devices?

I have got one and its just restarting my PC over and over!

Works out of the box with SATA drive dough.

 

Is there a way to use this with IDE Drive?

Share this post


Link to post
Share on other sites
With the 'NEW' RC3 release, boot WILL make a very nice boot 132 cd with isolinux, menus etc.

If my testing goes according to plan, big things ARE a coming...

 

From the testing I did a bit earlier with Chameleon2-rc3 and the Preboot.dmg it appears to be doing some of the same function as isolinux. What is the difference? And, why not just use the Chameleon Preboot.dmg? Those questions are a desire to learn, not a critique or an objection.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×