Jump to content
InsanelyMac Forum
Azzo94

[GUIDA] Installare Snow Leopard Retail/GM su Asus F3S

Recommended Posts

Salve ragazzi, come tutti sanno adesso il forum �Æ’¨ pieno di guide su come installare snow leopard.

 

Oggi voglio proporvene una io che ho trovato OTTIMA per la famiglia del mio Notebook Asus.

 

Funziona tutto, ovvio no wi fi :D, tranne la scheda Video (solo su f3sv) dato che i drvier non vanno e non supporta le efi strings. (Ma ci sto lavorando).

 

Requisiti Fondamentali:

 

- File .iso di Snow Leopard (10A432 GM) o DVD di Installazione.

- Hard Disk vuoto formattato in GUID.

- Installazione Funzionante di Leopard da cui eseguire la guida.

- Il mio "PacchettAzzo" v2 (AGGIORNATO)(:D ) personalmente creato con i kext per Snow.

  • - Kext Verdi = Necessari per l'avvio del sistema.
     
  • - Kext Rossi = Drivers vari. (Non obbligatori e personalizzabili a seconda dell' HW).

_____________________________________________________

 

Formattare l'Hard Disk SNOW HD SNOW HD = Hard Disk formattato per Snow Leopard

 

- Aprire Disk Utility.

- Selezionare l' Hard Disk che volete utilizzare per SNOW.

- Selezionare la scheda Partizioni.

- Schema Partizione: 1 Partizione -> Chiamatela "SNOW HD"

- Cliccare su Opzioni e Selezioare GUID Partition Table ed infine Cliccare Applica e Partiziona.

 

xl9w74.jpg

 

Installazione:

 

- Montare la .iso oppure inserire il DVD nel drive.

- Chiudere tutte le finestre del Finder e premere "ALT+CMD (bandiera Winzozz)+G" e scrivere:

 

  • Volumes/Mac OS X Install DVD/System/Installation/Packages

 

16bm1z9.jpg

 

- Premere Invio ed aprire il file "OSInstall.mpkg" nella cartella che compare.

- Come drive di destinazione install. scegliere SNOW HD.

- Premere dunque AD HOC in basso e selezionare : "X11, Italiano in Languages". Il resto � a piacere.

- Adesso possiamo Installare.

 

155sbyr.jpg

 

__________________________

Ad installazione terminata andremo ad aprire UInstaller presente nel PacchettAzzo.

 

- Selezionare in alto SNOW HD:

  • - Boot Resolution: 1280x800 (A seconda del vostro PC)
  • - Timeout Boot: 5 Secondi
  • - EFI STRINGS per la vostra scheda video (Non necessario per chi non le supporta).
  • - Bootloader Chamaleon (Qualunque)
  • - Install KEXTS from HD e selezionare tutti quelli presenti in PacchettAzzo/KextVari

-Possiamo adesso premere Install, dare la password ed aspettare che finisca.

____________________________

 

- Aprite il file "Hidden Files" in App Utili di PacchettAzzo e selezionate "Show Files".

- Esplorate SNOW HD e sostituite il file .boot che trovate li con il file in "PacchettAzzo/Chamaleon".

____________________________

 

Benissimo, possiamo provare a riavviare il PC, premiamo ESC (O altri tasti che permettono di selezionare la perifericha da avviare) e selezioniamo l hard disk dove �Æ’¨ presente SNOW HD ed aspettiamo. Se non da nessun Kernel Panic (Non dovrebbe ;) avremo Snow Leopard funzionante.

 

Se l'audio non dovesse funzionare provveder�Æ’² a postarvi il nuovo kext.

 

AVVIARE IN MODALITA' BIT DIFFERENTI ALL' AVVIO INSERIRE: (Senza Virgolette)


  • 32 Bit : "-x32" o "arch=i386"

  • 64 bit : "-x64" o "arch=x86_64"

 

Spero che la guida sia stata di vostro gradimento, provveder�Æ’² SUBITO ad inserire le immagini.

 

Ecco come dovrebbe apparire il vostro Snow dopo aver seguito questa piccola guida:

snowfinescreen.jpg

 

UPDATE 1: Per riparare i permessi, vista l'impossibilit� baster� aprire l'applicazione Kext Utility in PacchettAzzo/App Utili direttamente da Snow Leopard, dare la password ed attendere.

 

UPDATE 2: Per risolvere il problema dei Drive visualizzati come Cartelle baster� rimontare la iso/reinserire il DVD, esplorare fino a Volumes/Mac OS X Install DVD/System/Installation/Packages (Vedi in alto come fare) ed installare il file BSD.pkg (Grx Williamwallace ;))

 

 

Grazie dell'attenzione. ~Azzo94 :D:P

Share this post


Link to post
Share on other sites
Advertisement

ciao Azzo94,

 

scusa l'intrusione nella tua guida...

dovresti correggere la dicitura x84_64 in x86_64...giusto per evitare possibili noie future :D

 

saluti

 

geminimac

Share this post


Link to post
Share on other sites

Allora Azzo..eccomi qui..il mio problema è questo. Io sto tentando da gionri di installare Leopard. Ho un processore AMD quindi ho seguito tutte le guide possibili immaginarie. Ho scaricato Leo4all, Kalyway 10.5.2 e iPc OSx86. Nessuno dei tre funziona. Kalyway quando gli do "-v" parte per poi fermarsi a "still waiting for root device"...e me lo ripete un sacco di volte. iPc mi è andato in kernel panic ti allego la foto.

 

L'unica cosa che non ho fatto è modificare il BIOS

post-481299-1252076142_thumb.jpg

Share this post


Link to post
Share on other sites

è un fisso e queste sono le caratteristiche :)

 

Processore AMD Athlon 64 X2 4000+;

Video NVIDIA GeoForce 6600 (256 MB) PCI-E;

Realtek HD Audio output;

HDD Maxtor 6L080P0 (76 Gb) (Windows XP), Unità #2 - ST340016A (37 GB) (vuoto);

Rete TP-LINK 11b/g Wireless Adapter, Ethernet

RAM 2 GB

Scheda Madre ALiveNF5

 

Uhm..senti.. la scheda madre?? Perchè puo variare il tutto dalla scheda madre!

 

 

Scheda Madre ALiveNF5-eSATA2+ (sinceramente...eSATA2+ non so cosa voglia dire)..

Share this post


Link to post
Share on other sites
Scusa avevo sbagliato.. comunque.. lo still waiting for root device l'hai dopo l'installazione o prima?

 

prima...e si ripete in continuazione...dopo un po' mi sn stufato e ho resettato tutto per poi scriverti a te

Share this post


Link to post
Share on other sites

mmm.. da quello che vedo è un problema veramente da Hard Disk..non saprei.. c'è che era un problema di Hard Disk gia lo sapevo..ma ....mm.. aspettiamo un mio amico che dovrebbe darti una mano!

 

Che purtroppo gli "wait for root device" non sono così semplici da risolvere!

Share this post


Link to post
Share on other sites
Guest freemaximus

Complimenti per i kext e la guida!!!! diciamo che io non ho seguito al 100% la tua guida ma mi sono limitato a prenderne quello che mi serviva ovvero il pacchetto kext e la parte di guida inerente l'installazione con l'Uinstaller. Io ho scaricato la snowOSX presente sui torrent, masterizzata, installata su sata mbr e fin qui tutto ok, al primo riavvio un bel kernel panic legato ai kext ioatafamily, e acpi, decido dunque tramite una partizione di leo funzionante di eliminare tutti i kext che servono a Snow per funzionare e sostituirli con il tuo pacchetto appunto azzo seguendo quella parte di guida, al riavvio snow si è avviato e ho potuto vedere la presentazione di mac osx con l'audio, ce da dire che prima di installare su disco ho provato ad installare su usb 8gb, ma sempre poi con messaggio still waiting root device non so se puo' servire d'aiuto a qualcuno. Avviato snow mi sono accorto che tutto funziona alla perfezione video,lan (installato attansicL2), wifi, audio avvolte a scatti, riavvio spegnimento molto lento(risolto con reimpostazioni usb nel bios) infine ho aggiornato alla 10.6.1 e tutto è andato bene........

Share this post


Link to post
Share on other sites

Salve ragazzi,

mi unisco alla discussione dato che ho un asus non molto differente dal vostro.

Attualmente ho messo snow su un hd esterno, sono a buon punto, ma ho avuto non pochi problemi.

I nuovi chamaleon non mi funzionano su Hd esterno. Faccio appena in tempo a leggere "boot.." e poi si riavvia fisso.

Ho dovuto mettere 1.0.12 col file boot trovato a corredo. Nessuno ha avuto il mio stesso problema???

Ho dovuto sostituire ioatafamily altrimenti KP fisso.

Riguardo l'audio ho provato anche io il kext voodo e non è affatto male.

Comunque visto che l'anno scorso ero riuscito a far andare la 660vd mi ci sono rimesso a lavorare e... insomma qualcosa ne è uscito.

Ho modificato ulteriormente il kext per 10.5.6 e mi pare funzioni molto bene.

Prima avevo o solo cuffie o solo microfono.

Adesso vanno entrambi e inoltre è visualizzato anche sotto system profiler.

 

Il kext per snow mi sta dando problemi che non riesco a risolvere ma comunque va sia cuffia che microfono.

Anche se il mic non ha controllo volume e risulta un tantinello basso.

Avvia anche con x64 con mia enorme sorpresa.

 

Se qualcuno li volesse provare mi farebbe un piacere. Sarei ben felice di sapere che funzionano anche su altri asus.

Il topic è QUI

 

Un po incasinato ma c'è tutto

Share this post


Link to post
Share on other sites

Chiedo scusa ma nell'istallazione non manca un compontente fondamentale tipo il boot-loader? Ho eseguito alla lettera la guida, tutto ok sono riuscito ad installare ma ovviamente ar riavvio dal disco di snow, schermata nera con cursore lampeggiante. Inserendo un CD con Chameleon 2 rc3 e avviando il disco di snow si avvia invece perfettamente.

Share this post


Link to post
Share on other sites

Riguardando il .txt che ho scritto prima di postare.. si ho saltato una riga nel copiarla!.. GRAZIE.. Cmq si serve un bootloader ;) Ti ringrazio ancora!...

 

Come ti trovi con snow? Funziona tutto?

 

Per ognuno che installa vorrei sapere quali driver ha usato per le proprie periferiche.. se interni al mio pacchetto o trovati in rete!

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×