Jump to content
InsanelyMac Forum
adamsweeting

Black screen when using EFI strings 8800GT 512MB

Recommended Posts

Hey people... Hope someone can help me out, I'm going mad here!

 

I've got a perfect vanilla 10.5.8 running on another harddrive...

Got Snow running good on a seperate harddrive, with sound, networking - just can't get hardware accelerated GFX.

 

Installed retail Snow using my 10.5.8 system, EFIv10.1, the usual extensions in /E/E

I am not using dsdt.aml..

 

GFX is working via software rendering, but as soon as I add EFI strings to the boot.plist in /E/E - the system boots, but I get a black screen. I know it's running coz I can get sounds, eject DVD tray via keyboard etc.

 

I've tried using EFI studio, UIinstaller, copying the hex from my 10.5.8 system = all don't work.

 

One thing I thought of was that a while ago when there was an issue with mouse jerking when a Quicktime update came out, I flashed my GFX card with a custom ROM that solved it.

I don't know if that would be the cause... because it works perfectly with EFI in 10.5.8

I also got the same result adding Natit.kext to /S/L/E

Share this post


Link to post
Share on other sites
Advertisement

Solved now.

 

I flashed my GFX with a vanilla ROM from the manufacturers website using nvflash. Then created my own custom EFI string using OSX Tools with DVI / DVI output.

 

All working properly now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×