Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

I'm doing something wrong...Kexts in 'Extra' not loading

2 posts in this topic

Recommended Posts

First, I have a working 10.5.8 install on my system /w Chameleon rc2 so I know that it at least works in Leopard. I installed Snow to a separate partition (my drive was already GUID parted) using the OSinstall.mpkg method, then installed PC EFI 10.1, patched my DSDT on the Snow drive, did smbios.plist, loaded efi strings for my NVIDIA card...all the usual.


Then I added kexts to Extra\Extensions, used Kext Utility to generate the mkext file. Reboot and always get kernel panics!


After awhile I noticed things like Netkas' FakeSMC not loading (Error: Can't load org.netkas.fakesmc), nor can it load sleepenabler.kext. I'm pretty sure NONE of my kexts in Extra are loading properly at this point, which explains why I'm getting panics - can anyone shed some light on what is going on?

Share this post

Link to post
Share on other sites

I really know very little about this, so take it with a grain of salt, but have you tried copying the kexts to the extra folder in the hidden .Chameleon folder. I was having a similar problem on my GAEP45UD3P. I tried the above and it didn't help. Ultimately I deleted all the Chameleon files on the root of the SL drive and reinstalled from my 10.5.8 drive to the SL drive and it worked.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.