Jump to content
InsanelyMac Forum
SA22C

Slow OpenGL performance in Snow Leopard

Recommended Posts

I've just checked Sims 3 under Snow Leopard and its git horrible performance. I hope Apple soon gets those Nvidia drivers better.

 

 

Maybe its possible to use the nvidia drivers from 10.5.7 under 32 bit?

 

 

Me too with Flatout !!!

:D

Share this post


Link to post
Share on other sites
Advertisement
Did the tests as mentioned above but failed 3.0. How come?

9800 GT using efi strings on SL

550 frames per sec

 

w6wqqq.png

 

I have an Asus EN8800GT 512.

Terrible performance compared to 10.5.8!! Haaaaa!

 

openGL.jpg

 

No solution yet? Maybe we should wait 10.6.2! ;)

 

EDIT: I have tried Xbench. For the OpenGL test i get 188 on 10.5.8 and 80 on 10.6.1...

Share this post


Link to post
Share on other sites

"Terrible performance compared to 10.5.8!! Haaaaa!"

What are the results (OpenGLExtensionsviewer - same Version!) in 10.5.8 if so much better than 10.6.1 ?

Share this post


Link to post
Share on other sites
"Terrible performance compared to 10.5.8!! Haaaaa!"

What are the results (OpenGLExtensionsviewer - same Version!) in 10.5.8 if so much better than 10.6.1 ?

 

I get 200 more frames (average) but test 3.0 still fails. Anyways, OpenGL apps (like Quick Look) work much better in 10.5.8!!

Ive almost got a perfect 64bit hackintosh, this is the last/only reason iam staying in 10.5.8 for now. Everything else is faster in 10.6.

Share this post


Link to post
Share on other sites

same issue here...

3.0 failed

 

but

 

 

10.6.1 same thing........

 

2zjhv9t.png

 

 

also have xfx 9800GT 512mb

 

23.png

 

compare my fps... what the hell ?

Share this post


Link to post
Share on other sites
oops... checked multysampe

 

34.png

 

still ~ 890 fps

 

U forgot to check "benchmark"

without it i get about the same....

 

still ur like 10-20 points higher... what install method did u use for your graphics card....???

 

3305xdc.png

Share this post


Link to post
Share on other sites

i used EFI strings..

 

 

<string>5e0200000100000001000000520200000d00000002010c00d041030a01000000010106000001
0101060000007fff04000e0000004e00560050004d000000200000000100000000000000000000000
0000000000000000000000000000000220000005600520041004d002c0074006f00740061006c0073
0069007a006500000008000000000000201c0000006400650076006900630065005f0074007900700
0650000000f0000004e5644412c506172656e740e0000006e0061006d00650000000b000000646973
706c617922000000400030002c006400650076006900630065005f00740079007000650000000b000
000646973706c617922000000400031002c006400650076006900630065005f007400790070006500
00000b000000646973706c6179100000006d006f00640065006c000000130000004765466f7263652
03938303020475420000000400031002c0063006f006d00700061007400690062006c00650000000e
0000004e5644412c4e564d616314000000400030002c006e0061006d0065000000120000004e56444
12c446973706c61792d4114000000400031002c006e0061006d0065000000120000004e5644412c44
6973706c61792d4220000000400030002c0063006f006d00700061007400690062006c00650000000
e0000004e5644412c4e564d6163100000004e00560043004100500000001800000004000000000003
000c00000000000007000000001e00000072006f006d002d007200650076006900730069006f006e0
00000270000004765466f7263652039383030204754204f70656e474c20456e67696e65205b454649
5d</string>
<key>Graphics Mode</key>
<string>1680x1050x32</string>	
<key>Timeout</key>
<string>5</string>

 

maybe its noobish to post an efi string from a different pc but anyhow... :/

Share this post


Link to post
Share on other sites

Thanx.... using ur efi string inadvertently fixed a problem i had with geekbench crashing on me

now it works!

My efi string looked nothing like yours..... i used aquamacs method

 

BTW OpenGL went up a couple points but nothing spectacular....

 

28u4nza.jpg

Share this post


Link to post
Share on other sites

I solved my Problem.

The DVI-Cable was in the DVI-Port 2 of my 9800GT.

I put it in the Port 1 and since that i don't have Performance-Problems anymore.

Share this post


Link to post
Share on other sites
I solved my Problem.

The DVI-Cable was in the DVI-Port 2 of my 9800GT.

I put it in the Port 1 and since that i don't have Performance-Problems anymore.

That's interesting. lol. I have one DVI port :)

Share this post


Link to post
Share on other sites

Sadly it has no effect here on what DVI-Port my display is connected...

 

This phenomenon is actually not specifically related to hackintoshes but to regular Mac systems as well:

 

http://forums.macrumors.com/showthread.php?t=778806

 

http://legacy.macnn.com/articles/09/08/29/....snow.leopards/

 

So it seems to be a "official" problem of Mac OS X 10.6(.1).

 

Maybe those who solved this problem by connecting the display to another DVI-Port could provide some benchmarks (before and after) to compare the results. Somehow I'm a little leery of that solution... :rolleyes:

 

Greetings,

Daniel

Share this post


Link to post
Share on other sites
holy {censored} that DVI port quick fix worked for me too... thanks heaps!!

Please check the xbech results before/after DVI port fix and post here! Thanks mate.

Share this post


Link to post
Share on other sites
I'd really be interested in viewing some ATI-results with this.

 

Anyone out there with a 48x0 to show off his/her results? :)

 

 

Here is mine with benchmark/multisample 4 - haven't tried any optimisation

 

and raw settings

 

From memory does appear to score lower than 10.5.8 but no longer have it

 

steve

post-383752-1253201534_thumb.png

post-383752-1253201589_thumb.png

Share this post


Link to post
Share on other sites
Please check the xbech results before/after DVI port fix and post here! Thanks mate.

 

there is no difference between before and after. both round about 100 points. (open gl test only)

but the effects (exposé, dock, quicklook) are definitely smoother.

Share this post


Link to post
Share on other sites
there is no difference between before and after. both round about 100 points. (open gl test only)

but the effects (exposé, dock, quicklook) are definitely smoother.

That all above use OpenGL , but the problem may NOT be in the OpenGL part !

So you didnt get so much less OpenGL speed benching OpenGL with OpenGLExtensionsviewer.

The 3 above use also other Frameworks which may have bugs or may get bad performance depending card vendor.

ATI Part in OpenCL Framework for example is unuseable (buggy) - Nvidia GPUs havent that problem.

Share this post


Link to post
Share on other sites
I solved my Problem.

The DVI-Cable was in the DVI-Port 2 of my 9800GT.

I put it in the Port 1 and since that i don't have Performance-Problems anymore.

 

It's performing a bit better using the other DVI port, but far from perfect (as in 10.5.8)...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×