Jump to content
blackosx

Bonjour Networking with Realtek drivers & ifconfig workaround for Snow Leopard

152 posts in this topic

Recommended Posts

I have just cleared the files from my system an re-installed with Realtek Bonjour enabler and bonour64 was installed to /Library/StartupItems/ and ifconfg was installed to /usr/local/bin/.

 

You can verify Bonjour is running by typing ifconfig in terminal and looking at the line beginning en0: (or whatever your active network is on). It will look something like this....

en0: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500

 

Read along the line and look for PROMISC. That shows it working.

 

This is what I get on my terminal

post-25748-1257042973_thumb.png

 

I have PROMISC :jerry: .

However still don't see ifconfig in /usr/local/bin/. :jerry:

My bin folder has a 'stop no entry' sign. What does the sign mean?

Thanks again for your help.

Have a nice day.

Profile_Hardware_Overview.tiff

Share this post


Link to post
Share on other sites
Advertisement
However still don't see ifconfig in /usr/local/bin/. :)

My bin folder has a 'stop no entry' sign. What does the sign mean?

Thanks again for your help.

Have a nice day.

/usr/local/bin/ is a system folder and you need admin rights to view it.

Using Terminal, type sudo ls -al /usr/local/bin then enter your password when prompted.

that will show you something like this...

total 128

drwx------ 3 502 wheel 102 31 Oct 18:13 .

drwxr-xr-x 6 root wheel 204 31 Oct 18:13 ..

-rwxr-xr-x 1 root wheel 62924 28 Mar 2009 ifconfig

Share this post


Link to post
Share on other sites

Z4g0r brought to my attention that Bit Shoveler has developed (is developing) a Realtek Snow Leopard kext which apparently activates promiscuous mode and works with the kernel in 64-bit mode. I quickly tried it from /E/E but had no success, but I am happy with the ifconfig workaround so I haven't tried since. Others have reported success with it so it's worth mentioning as another alternative.

You can find Bit Sholveler's work here.

Share this post


Link to post
Share on other sites
Z4g0r brought to my attention that Bit Shoveler has developed (is developing) a Realtek Snow Leopard kext which apparently activates promiscuous mode and works with the kernel in 64-bit mode. I quickly tried it from /E/E but had no success, but I am happy with the ifconfig workaround so I haven't tried since. Others have reported success with it so it's worth mentioning as another alternative.

You can find Bit Sholveler's work here.

 

The 32-bit R1000 from Psytar will only work in SLE, so give that a shot. I tried Bit Shoveler's 64-bit R1000 kext for Snow Leopard in SLE on my Gigabyte EP45-UD3P and it works perfectly! Whoohoo! :P

 

Update: Made an auto-installer, available here:

 

http://j.mp/3LM0Ep

Share this post


Link to post
Share on other sites

I got to say that this RealtekR1000SL.kext from weaksauce12's installer is the only one that works flawlessly in my 10.6.1, even I'm being in 32bit. Others would work, but after a while Bonjour would stop working and I had to reboot. Now after this kext my system is up for more than a day without any issues.

 

thanks weaksauce12 and to the author of the kext.

Share this post


Link to post
Share on other sites

Hi all,

 

Im running the ifconfig from the installer found on the first page on en1. Promisc is shown through terminal which seems all good.

Problem is i cant see the other windows computers on my network through finder?

Itunes sharing and smb sharing works and i can i see my hack from another windows computer.

Any work arounds for this?

 

If i am to use the new Realtek1000SL, how would i go about removing the ifconfig completely?

 

Cheers

Adam

Share this post


Link to post
Share on other sites
Hi all,

If i am to use the new Realtek1000SL, how would i go about removing the ifconfig completely?

 

Cheers

Adam

 

As root in Terminal rm -R /Library/StartupItems/NameOfItem then rm /usr/local/bin/ifconfig just do a ls -l /Library/StartupItems/ to find the NameOfItem to remove, if I remember it correctly it was Bonjour64 I think..

Share this post


Link to post
Share on other sites
Sonotone's had a look at the Bonjour ifconfig workaround and has kindly put together a package installer which does everything for you with regard to installing and automatically starting Daniel U Becker's ifconfig command.

 

This method doesn't use an Applescript, so there's no need to store a plaintext version copy of your password anywhere.

 

The installer installs the following....

• a folder named bonjour64 in /Library/StartupItems/ which contains bonjour64 startupitem and a StartupParameters.plist.

• ifconfig in /usr/local/bin/

The installer has options to install for an adapter using en0, en1 or en2.

 

If you are already using a previous setup of ifconfig then you can remove it.

 

All credits for this installer go to Sonotone and Daniel U Becker for his original work with ifconfig.

 

Just want to say thanks. This works for me and I can now use bonjour. Thanks.

Share this post


Link to post
Share on other sites

I think I've made a super mess of things. I'm trying to sort out the bonjour issue.

 

I started out with IONetworkingFamily.kext in my Extra/AdditionalExtensions folder which has the RealtekR1000.kext inside the Contents/Plugins folder of the IONetworkingFamily.kext

 

Bonjour didn't work, so I ran weaksauce's installer, and now I have RealtekR1000SL.kext in the S/L/E folder

 

That didn't work so I ran the ifconfig installer.

 

I wasn't sure how to properly remove the RealtekR1000.kext. So I just left it in there.

 

Now I know there are several things going on so I expected bonjour not to work.

 

Can anyone help me, or is it safe to assume that since I'm a noob, that I shouldn't have bothered messing with trying to get this to work in the first place?

 

My internet works fine, I'm typing this on the Hack now. Is this because the system is still using the IONetworkingFamily.kext in the extra folder, and thus all subsequent fixes had no effect?

Everything else seems to be running fine except sleep which I can live without.

 

I'm running 10.6.2 on a Gigabyte GA-EX58-UD5

My original post outlining my build is here

 

Thanks in advance for any branches thrown my way to pull me out of the quicksand.

Share this post


Link to post
Share on other sites
I think I've made a super mess of things. I'm trying to sort out the bonjour issue.

It's probably best if you can undo all the attempts you have tried and start afresh as only one of these fixes should be used, not a combination.

 

I see you used Cybex's Extra folder for your install which I guess is needed for your install. But does your onboard networking work without including the IONetworkingFamily.kext from Cybex's files? (Also, that IONetworkingFamily.kext is an older version and not the latest from 10.6.2). If it does work, then just try either sonotone's installer for ifconfig OR Bit Shoveler's kext, making a note of exactly what files are added/replaced etc, just in case it doesn't work so you can undo it.

Share this post


Link to post
Share on other sites
It's probably best if you can undo all the attempts you have tried and start afresh as only one of these fixes should be used, not a combination.

 

Thanks for the reply

Is the undo method simply dragging the Bit Shoveler kext and the IONetworkingFamily.kext to the trash? Is there an uninstall method for ifconfig?

Share this post


Link to post
Share on other sites
Thanks for the reply

Is the undo method simply dragging the Bit Shoveler kext and the IONetworkingFamily.kext to the trash? Is there an uninstall method for ifconfig?

Weaksauce's installer, I think, just installs RealtekR1000SL.kext in to /System/Library/Extensions/ so you should just be able to delete it. Try running without the IONetworking.kext you have added to your Extra/Extensions by removing that too.

 

To uninstall ifconfig you can delete the bonjour64 folder from /Library/StartupItems/, then remove ifconfig from /usr/local/bin/.

 

Then reboot.

Share this post


Link to post
Share on other sites
Weaksauce's installer, I think, just installs RealtekR1000SL.kext in to /System/Library/Extensions/ so you should just be able to delete it. Try running without the IONetworking.kext you have added to your Extra/Extensions by removing that too.

 

To uninstall ifconfig you can delete the bonjour64 folder from /Library/StartupItems/, then remove ifconfig from /usr/local/bin/.

 

Then reboot.

 

Removed RealtekR1000SL.kext (dragged it to the trash)

Removed IONetworkingFamily.kext from Cybex Extra folder (dragged that to the trash)

Removed Bonjour64 folder in /Library/Startupitems (dragged that to the trash)

Removed ifconfig (sudo rm /usr/local/bin/ifconfig)

 

rebooted

internet still works

 

Re-installed Realtek1000SL.kext with weaksauce installer

 

Rebooted

internet still works

No bonjour

 

Removed it again

 

Rebooted

internet still works

 

Installed ifconfig with soonotone's installer

 

rebooted

internet still works

no bonjour

 

Am I suppose to update boot caches. I'm not really sure what that means and I noticed the option when trying to install with DD's script the few times I tried getting my hack up and running before trying the lifehacker method. There were some different options and didn't know which to choose. Is this a necessary step in my case? If so, I would love to know the what where's and why's of updating the boot cache. Does it have anything to do with Extensions.mkext? Also do I need to repair permissions after that?

 

Weird thing is I seem to be able to connect to my wife's PC but not my imac.

 

See below

Thanks

Share this post


Link to post
Share on other sites

Disregard the previous post. I got it working. I removed everything blackosx said and I am using the ifconfig method. It didn't work because I had unplugged the ethernet cable from my system and re-attached it to (en1). I installed ifconfig to (en0). Got it sorted out, and it works so far. Thanks blackosx and sonotone! I'm still learnin. Thanks for your patience.

Share this post


Link to post
Share on other sites
Disregard the previous post. I got it working. I removed everything blackosx said and I am using the ifconfig method. It didn't work because I had unplugged the ethernet cable from my system and re-attached it to (en1). I installed ifconfig to (en0). Got it sorted out, and it works so far. Thanks blackosx and sonotone! I'm still learnin. Thanks for your patience.

You're welcome, and well done brokenjack :wacko:

Share this post


Link to post
Share on other sites

Blackosx,

 

I'm having problems with bonjour. I used Sonotone's bonjour installer to fix bonjour, just as you advised. It worked. However, from time to time bonjour stops working (so do Time Machine and file access over ethernet). I run ifconfig and I can se that when bonjour is not working en0 is running in simplex mode, not promiscuous mode. What may be causing en0 to lose promiscuous mode?

I think I didn't have problems with the ifconfig and script method. How can I remove the fix installed by Sonotone's package? Deleting bonjour64 folder from /Library/StartupItems/ and removing ifconfig from /usr/local/bin/ will do the job?

 

One more question: If I buy wifi hardware used in macbooks (BCM94322MC, for example) will I also have to use the bonjour fix?

 

Thanks.

 

PS. I've posted this questions in your EP45-DS3L thread. I think this is the right place, so I posted the questions again.

Share this post


Link to post
Share on other sites
PS. I've posted this questions in your EP45-DS3L thread. I think this is the right place, so I posted the questions again.

Hi jamonda, yes I saw it and have answered your question there. :unsure:

 

For the record: jamonda was using vmware which was resetting his ifconfig. He fixed it by using Sonotone's Bonjour Installer.

Share this post


Link to post
Share on other sites
..

In the meantime, I've tried the ifconfig method, but receive 'ifconfig: promisc: bad value'. I see another forum member is having trouble too, but I'm not talented with Terminal. Any help is appreciated. I'm specifically stuck on inserting the file path, but dummyproof details would be perfect.

 

What is happening is that there is an Apple-supplied inconfig binary (the one the system would normally use) and this one is not able to use the promisc flag. The tarball/package that is posted has its own recompiled ifconfig binary, that was specially rolled to have the promisc capability.

 

Here is the tarball of my bonjour directory. bonjour.zip

It lives @ /Extra/bonjour ... I couldn't get the loginhook command to work with the script, until I noticed that the paths and case (Bonjour vs bonjour) were different. If you see the message 'ifconfig: promisc: bad value', then it means that your script isn't seeing the special binary that was provided. You will have to adjust paths (or names) until you see that it is executing. You can alway try running the important line of the script in a terminal, by hand.

 

Works great for me now, once I got my paths adjusted. I didn't use the installer - I just installed it by hand.

 

 

BTW, I tried the Realtekr1000SL.kext that was mentioned in this (or another?) thread, but since it doesn't seem to support WakeOnLan, it is not a choice for me. (I often work upstairs from my nettop via ScreenSharing, and keep my HacPro asleep until needed - so I just wake it up with the WakeOnLan.app. )

Bottom line: I'm not using any special kext in /E/E or /S/L/E for the Realtek 8111C on my UD3L board, just my dsdt.aml, the bonjour+ifconfig script w/ loginhook. I have fully functional Bonjour, WakeOnLan and all expected network goodness.

 

I will be watching Realtek's progress towards an updated driver - hopefully it is just around the corner.

Share this post


Link to post
Share on other sites

Hi folks.

 

I have been following this thread closely over the last few days trying to get my onboard NIC working with Bonjour also as I have/had the same issues as a lot of others.

 

I am using a 32bit kernel and have not had any luck with any of the fixes except for Sonotone's fix, and even then it stops working after a few hours.

 

If I open up a terminal session and type 'ifconfig' it shows both 'PROMISC,SIMPLEX' as part of the status for en0. I didn't think you could have both, it was one or the other? Is this possibly part of the problem?

 

I do not have VMWARE installed and I do not have any special kexts loaded either, just a DSDT file for my EX58-UD5 and the Sonotone fix.

 

Thanks folks.

Share this post


Link to post
Share on other sites

Hi all,

 

Has anyone managed to use/test Wake for Network Access (not to be confused with WOL/WOMP).

 

Bit Shoveler's driver (thanks!) is excellent except for the fact that it (or OSX is telling it to) withdraws it's Bonjour advertisements before it goes to sleep. For WFNA, it should leave these advertisements alone, and just go to sleep. That way, a Bonjour Proxy Server can keep advertising them on behalf of the sleeping machine (as well as proxy ARP), and then wake the machine when another device tries to locate it (again using Bonjour).

 

I guess I ask the question because using Bit Shoveler's driver it doesn't work - when I trace the Bonjour/mDNS advertisements I see the machine withdraw (delete) its services as it goes to sleep.

 

Thanks

 

Scott

Share this post


Link to post
Share on other sites

Weaksauce's auto installer worked first time for me on a GA-EP45-UD3r running 10.6.3. Bonjour was driving me crazy until I found this thread. Thanks so much to all involved in fixing this!!! Bonjour is really important for me so not having this working would have been a nightmare!!

 

Edit: after looking a little closer, it would seem like the fix has really crippled my ethernet speeds. Transferring files at ~9MB/s over gigabit LAN now, where I was getting closer to 40MB/s previously. Looks like some further research is in order for me.....

 

Edit edit: and a quick trip into System Preferences to manually configure my Ethernet adapter to Tbase1000 was all that was needed to fix that little hiccup. I am now one really happy camper ;)

Share this post


Link to post
Share on other sites
Well, it is working for only couple of minutes... after that I think bonjour is crashing ..... still waiting for a working solution.

I have the same issue (( Nothing helps

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×