Jump to content
derpuma

Try to install SL on a GA-P35-DS3

166 posts in this topic

Recommended Posts

Advertisement

Are you using a legacyhda.kext in /Extra/Extensions?

 

This one works in Leopard for me. If it still doesn't work you can try to find a 64bit VoodooHDA.kext and dump it in /S/L/E.

 

The legacyhda.kext attached is the 3outs2in headphone kext, which works for me in a leopard, and might work in SL.

 

Also, are you using version F6 of the bios?

LegacyHDA.kext.zip

Share this post


Link to post
Share on other sites
If i have a working dsdt.aml with sound i would like to make a bootable USB Stick with sound working settings to boot and install from. I will let you know if i can deal with elitee's dsdt.aml...

nice!

 

I've prepped a boot USB image with all the stuff in it, that I could find out. But it kernelpanics with a USB kext error at boot time. I could imagine SL dont like getting injected from USB when booting the first time after install?! Anybody knowing anything in detail here?

 

I will upload an image of my (not working) usb booter tomorrow. Its attached to my lab computer, not at my homeplace.

Share this post


Link to post
Share on other sites
Guest Snowski

Sure thing:

 

- fakesmc => faster boot time (doesnt have to wait for dsmos anymore), replaces dsmos!

- IOAHCIBlockStorageInjector => Fix orange (external) icons

- NullCPUPowerManagement => Replaces AppleIntelCPUPowerManagement

- OpenHaltRestart => Reboot/Shutdown fix

- PlatformUUID => Adds proper id for boot partition (edit this one with your own UUID)

- SleepEnabler => fix for sleep and now iTunes lag for 8800GT (and others)

 

I've asked Pista to add the Lag fix to the sleepenabler kext. The lag is much less in Snow but still there so this kext has a fix for it.

 

✔ my guide (in sig) if needed

 

Good luck n have fun!

SL_64bit_Kexts.zip

Share this post


Link to post
Share on other sites
Sure thing:

 

- fakesmc => faster boot time (doesnt have to wait for dsmos anymore), replaces dsmos!

- IOAHCIBlockStorageInjector => Fix orange (external) icons

- NullCPUPowerManagement => Replaces AppleIntelCPUPowerManagement

- OpenHaltRestart => Reboot/Shutdown fix

- PlatformUUID => Adds proper id for boot partition (edit this one with your own UUID)

- SleepEnabler => fix for sleep and now iTunes lag for 8800GT (and others)

 

I've asked Pista to add the Lag fix to the sleepenabler kext. The lag is much less in Snow but still there so this kext has a fix for it.

 

�" my guide (in sig) if needed

 

Good luck n have fun!

 

Great, Thanks!

Will try it in the afternoon CET :wacko:

Share this post


Link to post
Share on other sites

@Snowski

 

How did you get sound to run? Do you have a patched DSDT.aml or another method?

If, could you pls share? Bur only if the DSDT.aml is without Graphic Patch.

Share this post


Link to post
Share on other sites

Well, I'm using my Presonus Firewire 1394 for sound now which has better quality but no surround. It worked from the first boot and I've kind of sticked with it.

 

I'm also waiting for 64bit support for the KX drivers which are also better quality and have 5.1 analog sound.

 

The onboard ALC889a is disabled (and has been for a long time) unless I find the proper method/kexts to support 5.1.

 

You should check the other "ALC889A" thread m8

 

Good luck!

 

ps. just found my old account back so back to my original nick

Share this post


Link to post
Share on other sites
Hi Ximekon, if i am right, i think the ALC888 is the right one for the GA-EP35-DS3 and the ALC889a is for the GA-EP45-DS3....

I would like to get the DSDT.aml for both boards with patched sounds because I have both of these ;)

 

BR,

derpuma

 

to make things a little clearer:

 

Gigabyte EP35 Series

 

Gigabyte EP35 DS3 (get latest BIOS F4 here)

  • Northbridge Intel P35
  • Southbridge Intel ICH9
  • Audio ALC889a
  • LAN Realtek RTL8111B

...

(complete list has gone here: http://www.incomplete-news.com/?p=2512)

...

 

Depending on the audio chipset (ALC889a or ALC888), I suppose with that table we might be able to create two universal kext sets for the whole EP35 shabang and then two different boot disks.

 

For the matter of completeness the same applies here to the EP45.

 

...

(full list has gone here: http://www.incomplete-news.com/?p=2512)

...

 

// I am gonna sort them later on, sorry I got so much stuff to do on work right now.

// sadly table tags are not supported here on insanely weather directly via html nor via bbcode :-(

Share this post


Link to post
Share on other sites
Tried it. But I got no sound in SL, but a KP after a few seconds...

 

You can have a look at it or try it if you want to....

 

uploaded edited *.dsl (with no GTX260) and recompiled *.aml (with no GTX260) + iaslMe

No errors in compilation but no success in SL to get sound fixed...

 

Same here... no sound in SL but my system profiler says my sound is set to alc889. Anybody have a patched

DSDT for:

 

Gigabyte EP35 DS3L

  • Northbridge Intel P35
  • Southbridge Intel ICH9
  • Audio ALC888
  • LAN Gigabit RTL8111/8168B

Share this post


Link to post
Share on other sites
Same here... no sound in SL but my system profiler says my sound is set to alc889. Anybody have a patched

DSDT for:

 

Gigabyte EP35 DS3L

  • Northbridge Intel P35
  • Southbridge Intel ICH9
  • Audio ALC888
  • LAN Gigabit RTL8111/8168B

 

try the most powerful dsdt patcher by Koalala: http://www.insanelymac.com/forum/index.php?showtopic=142434 (ms windows only)

it looks like it can add alc889a support. (note: dont name the source amlfile dsdt.aml, but name it like sourcedsdt.aml. you would get weird errors).

Share this post


Link to post
Share on other sites

I've modded my dsl file for ALC889A by comparing with the above (GA-EP35-DS3) but iasl Me doesnt seem to compile an aml file.

 

1 error

 

/Users/Snow/Downloads/DSDT_Sound_GA-EP35-DS3/dsdt.dsl  5046:					 DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Error	4063 -											   Object does not exist ^  (DTGP)

Share this post


Link to post
Share on other sites

So, i installed WINXP under Virtualbox to use ACPI Patcher 0.2 Beta5...

 

I made my own DSDT.aml for Graphics, Network and Sound. Made the CMOS Fix with *.dsl and compiled bach to *.aml. I deleted my EFI String for Graphic and Network from com.apple.boot.plist!

 

Board GA-P35-DS3 REV 2.0

Graphic works, LAN Works, Sound doesn't

 

Arrrrrghhhhhh - dont know what is wrong in my setup. I used tmongkols LegacyHDA.kext for 889a (tried all of them)...

 

Question: Maybe I have to integrate the kexts form E/E to Extensions.mkext???

Share this post


Link to post
Share on other sites

GA-XX35-DS3R works here with the netkas fakesmc (its a gem!)

 

Check his website, as you don't need two of the old kexts now using this.

 

Aslo using netkas 102 beta loader

 

Sound work out of the box, as well as network.

 

8800GTS needed the EFI string I used on Leopard and all was good there too.

 

Still get odd panic, but not had chance to trace the fault .

Share this post


Link to post
Share on other sites

UPDATE: Everything works now! I added ALCinject.kext and patched AppleHDA.kext to S/L/E and now sound works! :)

 

Can anyone confirm DSDT.aml Sound with a ALC889a???

Share this post


Link to post
Share on other sites
UPDATE: Everything works now! I added ALCinject.kext and patched AppleHDA.kext to S/L/E and now sound works! :P

 

Can anyone confirm DSDT.aml Sound with a ALC889a???

 

well done, dude, congratulations. sound is and was always a strange thing to get working from preboot environments.

is everybody's system stable now?

 

please everybody: if your system is stable by now please post your kexts and your dsdt.aml with a little explanation.

 

kudos, x!

Share this post


Link to post
Share on other sites

I will install my Software and work with SL.

Right now I have no KP in -x32 Mode! Fine for me right now.

After I tested my Sys with Software I will Post my Kexts and DSDT.aml

 

One thing I found out: I can not Install Chameleon RC1 or RC2 under SnowLeo!

Install fails... The Same thing under 10.5.6 works fine with the same disk/partition.

Can anyone agree with that error?

Share this post


Link to post
Share on other sites

@ximekon:

 

GIGABYTE GA-EP45-UD3R is completely the same as:

 

Gigabyte EP45 UD3P

 

* Northbridge Intel P45

* Southbridge Intel ICH10R (Raid)

* Audio ALC889a

* LAN Realtec 8111C

* Firewire IEEE 1394 Controller

 

(except that it is less expensive, by having only one PCIe x16 video card slot)

Share this post


Link to post
Share on other sites

for further references when cleaning up this thread later on:

 

kexts for Gigabyte EP45-DS3 (by Kjell Amund) / without ALC889A sound it seems.

http://www.speedyshare.com/691480739.html

 

Originally found here...

 

 

@richtig: thanks I'm gonna add your board...

 

S/L/E Kext's for GA-P35-DS3 Rev. 2.0

 

I use ALCInject.kext and Original SL AppleHDA.kext + patched DSDT.aml with Soundpatch ALC889a + HDEF - no LegacyHDA.kext in E/E - Sound works even after some reboots!

please upload to another place again. as rapidshare allows only 10 anonymous downloads the files are not accessible anymore :-(

try megaupload or create a free collectors account on rapidshare, please.

 

Thanks in advance, x!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×