Jump to content
Lt. Xenodite

Silicon Image Sil5723 "Drive Xpert" RAID0 on ASUS P5Q Pro

9 posts in this topic

Recommended Posts

I have vanilla Leopard 10.5.7 installed on my SSD. Wanting to be able to access my RAID array from Leopard, I tried switching the array from the Intel ICH10R controller to the Silicon Image Sil5723 controller, which, according to this, this, and this, should need no drivers and should be completely transparent to the operating system. Unfortunately, my Leopard install does not detect the array (not even in Disk Utility), even though it needed no driver installation in Windows.

 

Does anyone know how to fix this?

 

Specs:

ASUS P5Q Pro

2x2GB DDR2-1066

XFX Radeon 4870

Various hard drives

 

Thanks.

Share this post


Link to post
Share on other sites
Advertisement

I have leopard running FROM the 2-disk array attached to the DriveXpert controller.

 

I seem to remember reading at the time of setting up this install that the DriveXpert array appears as an IDE (ie, non-SATA) drive to the operating system.

 

That's why you need some kind of driver to be able to see it. I think AppleVIAATA.kext might be it, but I am not sure.

Share this post


Link to post
Share on other sites

Lt. Xenodite, can you tell me if efoos's solution worked? I have a P5Q Turbo board that I need to turn into a hackintosh. I want the drive that the OS is running from to be fast which is why i'm thinking of getting 2x 500gb hard drives and installing them into the Sil5723 SATA ports and running it in RAID0.

 

If anyone has any experience with Asus's Drive Xpert technology, please let me know ;) Thanks!

 

PS: I was also thinking, in addition to the Silicon chip that I want to run 4x 1TB drives in RAID5 on the Intel ICH10 chip, will this be possible too?

Share this post


Link to post
Share on other sites
Nobody knows? Really? :)

 

asus drive xpert configured in normal mode

only the orange port works

 

i connected an hd with mac osx installed

 

chameleon 2 rc4 booting sees the hd and i can select

but the startup stalls...

and if i start with another hd, the hd connected to the orange port xpert is not seen by the system.

 

i just think is a question of a driver for the silicon chip 5723...

until now no luck...

Share this post


Link to post
Share on other sites

Still no solutions? I want have 2 backup HD in a RAID-1 configuration accessible (r+w) from SL and W7.

My SL'HD is controlled by ICH10.

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×