Jump to content
InsanelyMac Forum
Pasa Yildirim

HP Compaq 8710p guide

Recommended Posts

Hello

 

I'm trying to install the iAtkos s3 Snow Leopard 10.6.3 intel on my 8710p laptop and I got some troubles I can't solve.

 

Like you described here, I got the black screen problem and then (5 minutes) the system doesn't start (several messages are printed), 99% sure it's a 320 NVS driver issue.

 

I would like to copy your NVinject.kext into my Extensions folder, I thought it could work, but I can't write on the hfs+ partition using the terminal from the install CD or with Ubuntu by mounting the hfs partition, because it is in readonly.

 

Already tryed other version (iDeneb 10.6.1 / 10.6.2) -> same problem. And I tried Mac OSX Snow Leopard Retail DVD /w Empire EFI 1.08 non-legacy like described here but the Retail DVD didn't boot with Empire.

Share this post


Link to post
Share on other sites
Advertisement
Hello

 

I'm trying to install the iAtkos s3 Snow Leopard 10.6.3 intel on my 8710p laptop and I got some troubles I can't solve.

 

Like you described here, I got the black screen problem and then (5 minutes) the system doesn't start (several messages are printed), 99% sure it's a 320 NVS driver issue.

 

I would like to copy your NVinject.kext into my Extensions folder, I thought it could work, but I can't write on the hfs+ partition using the terminal from the install CD or with Ubuntu by mounting the hfs partition, because it is in readonly.

 

Already tryed other version (iDeneb 10.6.1 / 10.6.2) -> same problem. And I tried Mac OSX Snow Leopard Retail DVD /w Empire EFI 1.08 non-legacy like described here but the Retail DVD didn't boot with Empire.

 

don't use nvinject with snow leo. just use built-in chameleon GraphicsEnabler=Yes.

 

P.S. slow boot = usb problems, because usb irq'a are used by hpet. patch dsdt and add three irqs to hpet (0, 2 and 8).

Share this post


Link to post
Share on other sites
don't use nvinject with snow leo. just use built-in chameleon GraphicsEnabler=Yes.

 

P.S. slow boot = usb problems, because usb irq'a are used by hpet. patch dsdt and add three irqs to hpet (0, 2 and 8).

 

Thanks !

 

I thought I tried every kind of install for the graphics drivers.

Do I have to install chameleon Bootloader too ? Or it's not necessary to install both ?

Share this post


Link to post
Share on other sites

Ok, I tried again, enabling only GraphicsEnabler and leaving everything else at default.

 

Still the same : when I boot, after 5 minutes of black screen, got several messages :

npvhash=4095

Darwin Kernel Version 10.3.0: Fri Feb 26 11:57:13 PST 2010; root:xnu-1504.3.12~1/RELEASE_X86_64

vm_page_bootstrap: 501012 free pages and 23276 wired pages

kext submap [0xffffff7f80600000 - 0xffffff8000000000], kernel text [0xffffff8000200000 - 0xffffff8000600000]

standard timeslicing quantum is 10000 us

mig_table_max-displ = 73

 

and the boot process stops here

Share this post


Link to post
Share on other sites

hm, that' weird ...

 

please try to use retail version (ive used 10.6.0) with empireefi (if you dont know how to make own chamelon cd). empireefi works, but you have to use older version of it (check prasys pages, try all of them ;) ). i cannot help you with custom kernels (embedded with distros like iatkos/ideneb).

Share this post


Link to post
Share on other sites
hm, that' weird ...

 

please try to use retail version (ive used 10.6.0) with empireefi (if you dont know how to make own chamelon cd). empireefi works, but you have to use older version of it (check prasys pages, try all of them ;) ). i cannot help you with custom kernels (embedded with distros like iatkos/ideneb).

 

 

Could you write some tips for installing the Snow Leopard on the 8710p, since you have already dealt with it?

(Im getting stuck at the post-install black screen :wacko: )

Share this post


Link to post
Share on other sites

Ok, i have re-re-re-reinstalled iAtkos v7 again, and solved my problem by removing NVDAResman.kext due to windows not redrawing while dragging, and solved the resolution issue by editing

 

/Library/Preferences/SystemConfiguration/com.apple.Boot.plist and adding the lines:

 

<key>Graphics Mode</key>

<string>1280x1024x32</string>

 

Also by applying the latest security patch the system shows a black screen..?!

 

Everything else works pretty good :wacko:

 

What do you think is the issue with the boot time? Shutdown goes quite fast (under 5 sec. for sure).

 

 

Thanks if it wasn`t for you first post, i wouldnt give iAtkos a chance :)

Share this post


Link to post
Share on other sites
Ok, i have re-re-re-reinstalled iAtkos v7 again, and solved my problem by removing NVDAResman.kext due to windows not redrawing while dragging, and solved the resolution issue by editing

 

/Library/Preferences/SystemConfiguration/com.apple.Boot.plist and adding the lines:

 

<key>Graphics Mode</key>

<string>1280x1024x32</string>

 

Also by applying the latest security patch the system shows a black screen..?!

 

Everything else works pretty good :)

 

What do you think is the issue with the boot time? Shutdown goes quite fast (under 5 sec. for sure).

 

 

Thanks if it wasn`t for you first post, i wouldnt give iAtkos a chance :)

 

leopard is the issue :)

 

switch to SL and fix dsdt, then youll get nice boot time. forget about iatkos & distros :)

Share this post


Link to post
Share on other sites
leopard is the issue :)

 

switch to SL and fix dsdt, then youll get nice boot time. forget about iatkos & distros :)

 

 

Any clue where to start? Did you manage to install it on HP 8710p, and are you having any issues with it?

Share this post


Link to post
Share on other sites

you need to 1) apply dsdt fix, set HPET irq's to 0, 2 and 8 - or - 2) delete applehpet.kext (only iff you have nullcpupm, or appleintelcpupm will panic)

 

this is because usb irqs are conflicting with hpet's :D

Share this post


Link to post
Share on other sites

Tanks for the reply, i've done it a bit differently

 

I just installed the retail SL, myHack and updated it to 10.6.5, then i did the following

 

1. download the OSX 10.6.4 combo update.

2. download Pacifist

3. download kext helper b7

4. Open The OSX 10.6.4 combo update with Pacifist

5. drag over the following files to the desktop, AppleUSBAudio.kext, AppleUSBMultitouch.kext, AppleUSBTopCase.kext, IOUSBFamily.kext, IOUSBMassStorageClass.kext, AppleUSBDisplays.kext.

I know you probably dont need all of these, but i downgraded all of these kexts and all seems to work fine.

6. open up Kext Helper b7 and drag all kext into the app, put in your password, all should be good.

7. reboot.

 

http://www.insanelymac.com/forum/index.php?showtopic=234474

 

Everything else works perfectly :)

Share this post


Link to post
Share on other sites
you need to 1) apply dsdt fix, set HPET irq's to 0, 2 and 8 - or - 2) delete applehpet.kext (only iff you have nullcpupm, or appleintelcpupm will panic)

 

this is because usb irqs are conflicting with hpet's :)

 

 

Hi, I read that you have an hp 8710p and you've successfully installed mac osx.

Could you help me? I have a 8710p and I want to install snow, but can not find a solution.

 

Could you tell me how you have installed?

 

sorry for my English I am Spanish and I translated with google.

 

thank you very much.

 

my email is: alberto@manharris.com

 

It is very important to me

 

Tanks for the reply, i've done it a bit differently

 

I just installed the retail SL, myHack and updated it to 10.6.5, then i did the following

 

1. download the OSX 10.6.4 combo update.

2. download Pacifist

3. download kext helper b7

4. Open The OSX 10.6.4 combo update with Pacifist

5. drag over the following files to the desktop, AppleUSBAudio.kext, AppleUSBMultitouch.kext, AppleUSBTopCase.kext, IOUSBFamily.kext, IOUSBMassStorageClass.kext, AppleUSBDisplays.kext.

I know you probably dont need all of these, but i downgraded all of these kexts and all seems to work fine.

6. open up Kext Helper b7 and drag all kext into the app, put in your password, all should be good.

7. reboot.

 

http://www.insanelymac.com/forum/index.php?showtopic=234474

 

Everything else works perfectly :(

 

 

Hi, I read that you have an hp 8710p and you've successfully installed mac osx.

Could you help me? I have a 8710p and I want to install snow, but can not find a solution.

 

Could you tell me how you have installed?

 

sorry for my English I am Spanish and I translated with google.

 

thank you very much.

 

my email is: alberto@manharris.com

 

It is very important to me

Share this post


Link to post
Share on other sites
Hi, I read that you have an hp 8710p and you've successfully installed mac osx.

Could you help me? I have a 8710p and I want to install snow, but can not find a solution.

 

Could you tell me how you have installed?

 

sorry for my English I am Spanish and I translated with google.

 

thank you very much.

 

my email is: alberto@manharris.com

 

It is very important to me

 

 

 

 

Hi, I read that you have an hp 8710p and you've successfully installed mac osx.

Could you help me? I have a 8710p and I want to install snow, but can not find a solution.

 

Could you tell me how you have installed?

 

sorry for my English I am Spanish and I translated with google.

 

thank you very much.

 

my email is: alberto@manharris.com

 

It is very important to me

 

You should read a bit on this forum,

I've installed iAtkos v7, then made a partition and mounted the SL retail iso on it using disk utility, then used empireEfi to boot SL and installed myhack.

 

Again you should read for step by step instructions somewhere ond this forum (search)

Share this post


Link to post
Share on other sites

After I've installed Leopard last year but but soon deinstalled again due to the long boot problem, I decided to try it again, since it seems to work pretty well now :) .

 

I'm wondering if I should just follow Ludens' guide in this post. Since the 8710w and 8710p are pretty much the same, this should work for 8710p as well. Seems like in 10.5.8 everything but Wifi works! However, in 10.6.x Wifi, Firewire, wake from hibernate and Bluetooth won't work.

 

So it looks like Leopard would be the better choice for now (Also he says that the Ricoh Cardbus kext would fix the long boot problem, while Pasa Yildrim figured out it is because of USB and fixable by patching the DSDT - or does that just differ from the OS's?)

 

unicredit, what exactly is working for you now?

I just installed the retail SL, myHack and updated it to 10.6.5, then i did the following

 

1. downloadgrey_loader.gif the OSX 10.6.4 combo update.

2. downloadgrey_loader.gif Pacifist

3. download kext helper b7

4. Open The OSX 10.6.4 combo update with Pacifist

5. drag over the following files to the desktop, AppleUSBAudio.kext, AppleUSBMultitouch.kext, AppleUSBTopCase.kext, IOUSBFamily.kext, IOUSBMassStorageClass.kext, AppleUSBDisplays.kext.

I know you probably dont need all of these, but i downgraded all of these kexts and all seems to work fine.

6. open up Kext Helper b7 and drag all kext into the app, put in your password, all should be good.

7. reboot.

 

http://www.insanelymac.com/forum/index.php?showtopic=234474

 

Everything else works perfectly smile.gif

Just like it is working for Pasa Yildrim, so just sleep and SDHCI, wifi missing, or is it even better?

 

I was going to get the Atheros AR5BXB72 and install it in my 8710p with a modded BIOS that has the whitelist removed. Then, if Ludens guide will work, it really should function properly.

Do you guys have some more information regarding DSDT patching for the 8710p? Can you just apply standard fixes for Compaq models to the 8710p?

 

I hope you can clear some things up for me ^_^

Share this post


Link to post
Share on other sites
After I've installed Leopard last year but but soon deinstalled again due to the long boot problem, I decided to try it again, since it seems to work pretty well now :hammer: .

 

I'm wondering if I should just follow Ludens' guide in this post. Since the 8710w and 8710p are pretty much the same, this should work for 8710p as well. Seems like in 10.5.8 everything but Wifi works! However, in 10.6.x Wifi, Firewire, wake from hibernate and Bluetooth won't work.

 

So it looks like Leopard would be the better choice for now (Also he says that the Ricoh Cardbus kext would fix the long boot problem, while Pasa Yildrim figured out it is because of USB and fixable by patching the DSDT - or does that just differ from the OS's?)

 

unicredit, what exactly is working for you now?

 

Just like it is working for Pasa Yildrim, so just sleep and SDHCI, wifi missing, or is it even better?

 

I was going to get the Atheros AR5BXB72 and install it in my 8710p with a modded BIOS that has the whitelist removed. Then, if Ludens guide will work, it really should function properly.

Do you guys have some more information regarding DSDT patching for the 8710p? Can you just apply standard fixes for Compaq models to the 8710p?

 

I hope you can clear some things up for me :)

 

Hi, i havent patched any DSDT, really the only true way is by trying and trying, ive combined several guides, it really took me 2 week figuring out my way. I took Pasa's steps, then ludens to install SL.

I am currently using SL 10.6.5! Everything works except ONE usb port on the right side and wifi is not available.

PS. i just hope not to crash the system otherwise its hell all over again :P

Share this post


Link to post
Share on other sites

Hello Everybody !

 

First, I need to thank Pasa Yildirim for is powerful explanations.

 

I wanted to boot 3 operating system : Mac OS X (Leo 10.6.7) / Windows Seven and Linux Ubuntu. After 3 days, it finally works great.

 

I would like to complete Pasa Yildirim explanations.

 

1) Boot with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. Install OS X and do the partition table with the GUID option. Create 2 partitions : OS X (hfs), Windows (Fat 32) and some free space for Ubuntu

 

2) Install Windows. You will need to format the partition again.

 

3) Install Ubuntu. Use gptsync in order to make windows boot again. In a terminal : type "gptsync /dev/sda" after having it installed

 

4) Use [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to start OS X. Update OS X to 10.6.7 Combo Update, before reboot, start [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. Put your patched DSDT on your desktop. Choose the appropriate option in [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] Installer for enabling your DSDT. Install FakeSMC, VoodooHDA, VoodooPS2 and AppleIntelE1000e from [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url].

Share this post


Link to post
Share on other sites

Hi, I already used patched DSDT and FakeSMC and my 8710p still knows only 2 "fan modes"...something like 20-40%fan and 100%...when CPU goes under 40C it still runs cca 20-40fan..

Share this post


Link to post
Share on other sites

and what about drivers? need to load new one(which i dont have)? I wanna make just "update"..

or did u make some DSDT update? Im using your DSDT which is in this topic...

thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×