Jump to content
mrjoe

how to get 9800gt working in os x

9 posts in this topic

Recommended Posts

I've tried nvinject installer v52 for 512mb / vanilla, that didn't work. I'm a noob to efi studio, so I need a little help on that (yes I did google search extensively, and couldn't find a tutorial). I also have Chameleon v2 rc2 installed, which supposedly detects your video card, but I still can't change resolution from default 1024*768!

 

I haven't tried NVIDIA 9000 Series Driver v2, but I'll get around to it as soon as I can.

 

Has anyone else tried to get 9800gt working?

 

 

BTW System Profiler detects the card as a 512MB card and Quartz (BUT NOT QE) is enabled. CI is "software", which is also bad.

Share this post


Link to post
Share on other sites
Advertisement

The problem is, I don't know how to add an efi string. However, I've tried with efi studio to modify the com.apple.boot.plist file and insert the big hex string. I used the 8800gt 512mb string.

Share this post


Link to post
Share on other sites

All right I removed 8800GT string and installed the GeForce 9 series installer pkg, which got me 1680*1050 resolution. HOWEVER my QE is still not working (however, quartz is). Please help? Should I go change it back to 8800GT?

Share this post


Link to post
Share on other sites

You can try //code.google.com/p/osx86tools/

 

Click add efi string/boot flag

Click GFX string icon

Scroll down and choose Nvidia 9800 gt

Click icon for import string to boot editor

click apply to changes to apple.boot.plist

 

reboot

Share this post


Link to post
Share on other sites

I have heard that that method works; however, instead I went ahead and installed, in this order,

 

1) The Nvidia 9 Series Drivers v2

2) nvInject v52 pkg

 

A little bit about my situation before my first boot up: I had no video working, whatsoever so I went into single user mode and deleted NVDAResman.kext and started up fine.

After modding efi strings nothing worked.

After installing nvinject nothing worked AT FIRST.

 

So then I installed nv 9 series drivers, which helped me get all my screen resolutions. Then came nvinject (reinstalled), and after that I had QE/CI. Then everything worked.

Share this post


Link to post
Share on other sites

Hi,

I have an nVdia 9800 GT too, and I've tried everythings... nothing work.I'm stuck with the resolution at a low resolution...

Can you give me some tips, please ?

I'm desperate... :)

Share this post


Link to post
Share on other sites

Hi all guys.

 

I'm on a 10.6 with dsdt patched, using

GraphicsEnabler=yes 
  Graphics Mode=1680x1050x32

My boot is iFabio's Chameleon rc5.pkg

 

I got NO kext for video enabling in /Volumes/Chameleon /E/E

 

QE looks like enabled (top bar transparency on and toast working)

I got only a problem: if i change resolution in sys pref, the screen becomes blu and i need to reboot and sometime to edit com.apple.Boot.plist's "Graphics Mode" option before the monitor works again.

 

Does anyone knows a way to fix this? Do i need to revert to Efi string?

 

I made my com.boot.plist before to install new iFabio's boot.

I had the 10.6 up with manual boot installation (Cham 2.0 rc3), dsdt & com.apple.Boot.plist manual editing.

When i was patching the dsdt with kolala's patcher i used video tab with nvidia 9800gt using the ioregistryexplorer's port and so.

But it wasn't working, it was recognized as an nvidia but 32 Mb only (I got 1gb vcard).

 

So i updated boot disk with iFabio's boot and enabled "Graphics Enabler" option.

Now the vcard is recognized in sys profiler and all works. But, as said before, I can't change screen res.

 

Any of you solved this before??

 

Thanks all for your effort.

 

Dan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×