Jump to content
Onixs

[UPDATED) PC EFI v10.1 with Source is OUT! Leopard & Snow Compatible

95 posts in this topic

Recommended Posts

hi proengin;

 

where do you get these kexts;dsmos (x64), nullcpupowermanagement (x64), OpenHaltRestart (x64), PlatformUUID (x64)

 

Thanks

Share this post


Link to post
Share on other sites
Advertisement

proengin i also run in 64 bit mode with vanilla appledecrypt64,UUID64,Open_halt64,nvinject64, cpupowermanagment i use vanilla it works good.

do you have hibernate? Suspend to ram works excellent but any tries to hibernate fails. instead hibernate work suspend to ram.

Share this post


Link to post
Share on other sites

Can someone post here the 64Bit Versions of dsmos64 / appledecript64 UUID64 ,...64 ?

I have problem because dsmos cant loaded (rights ok). I get error for loading dsmos and so wait for ever for dsmos... running Snow Leo A354.

Share this post


Link to post
Share on other sites

Hi Nour,

 

You can find them here:

 

http://heliacal.net/~solar/mac/

 

The owner of above link has also written a guide for Chameleon 2.0 RC1 SL install guide here:

 

http://www.projectsnow.net/index.php?/topi...d-32-or-64-bit/

 

 

Hope you will find it useful.

 

 

hi proengin;

 

where do you get these kexts;dsmos (x64), nullcpupowermanagement (x64), OpenHaltRestart (x64), PlatformUUID (x64)

 

Thanks

Share this post


Link to post
Share on other sites

Works for me.

Running SW RAID. copied boot to disk0s3 and disk1s3.

 

kernel ERROR: FireWire unable to determine security-mode; defaulting to full-secure.

has gone and boot seems slightly faster.

 

 

D.

 

**EDIT**

 

Have any other gigabyte users tried this method on projectsnow ?

Does EFI 10 and the kexts used in this guide get passed the BIOS corrupting issues gigabyte MBs encounter when using snow Boot and EFI 9 ???

 

**EDIT**

Share this post


Link to post
Share on other sites

WOW!!! I can't wait to try this when I get home. I'm gonna try booting Snow Leopard on my PC right away (its an intel pentium dual core).

Share this post


Link to post
Share on other sites

i just updated boot file. and nothing. OS don't booting now, just some strings is running(about boot booth1 or something) and then reboot. what's the problem?

Share this post


Link to post
Share on other sites
i just updated boot file. and nothing. OS don't booting now, just some strings is running(about boot booth1 or something) and then reboot. what's the problem?

are you used before chameleon 1 ? if this you try install chameleon2 then replace file boot.

Share this post


Link to post
Share on other sites
Hi Nour,

 

You can find them here:

 

http://heliacal.net/~solar/mac/

 

The owner of above link has also written a guide for Chameleon 2.0 RC1 SL install guide here:

 

http://www.projectsnow.net/index.php?/topi...d-32-or-64-bit/

Hope you will find it useful.

 

THANKS for the DL LINK of the needed 64 Bit .kext SNOW Leo (dsmos & Co).

Works now :rolleyes: (even ATI 3850 , like all ATIs isnt good for Snow Leo until now)

Share this post


Link to post
Share on other sites
SNOW Leo (dsmos & Co).

Works now :D (even ATI 3850 , like all ATIs isnt good for Snow Leo until now)

how did you manage to get your ati card working in snow?

i couldn't manage to get my 3870 working in either 32 or 64bit mode, not even booting to GUI, let alone QE/CI.

tried many combination:

- injector with default dsdt

- no injector with patched dsdt

- device property string in boot.plist with default dsdt

none of it work - when booting it halts on "Device found in slot 1".

 

btw, in leopard my 3870 wouldn't work with netkas' natit (using lamna framework) - it only works with either triakis or megadolon framebuffer.

Share this post


Link to post
Share on other sites

I had deep sleep (hibernate) with PC EFI v9 but with v10, deep sleep is gone... same with chamelon... is there a way to get it back?

Share this post


Link to post
Share on other sites

Hi i've downloaded this and i have to say reinstalled mac on my laptop to test it. and it sure makes my hackingtosh fly. I also downloaded the sources is there a way i can make a package from the sources so i can put it as the bootloader for DVD?

Share this post


Link to post
Share on other sites

hey i've got it working in 64bit :happymac:

Strange things though, first my cpu info says 3.0ghz 1333fsb when its only 2.2ghz 800fsb however i've checked it with cpu-x and its the same?!? is snow leo overclocking my cpu? also it doesn't look like there are 64bit x3100 kexts yet.

works better in 32bit but that kind of defeats the point!

Share this post


Link to post
Share on other sites

Guess...

 

PC EFI v. 10 made the machine sleep and.....

 

WAKING UP, by a short press on the power button.

 

Great improvement.

 

It's just mode 0 sleep, hibernate gives me an instant kernel panic and CMOS checksum error,

but another great step towards perfection.

Share this post


Link to post
Share on other sites
Have any other gigabyte users tried this method on projectsnow ?

Does EFI 10 and the kexts used in this guide get passed the BIOS corrupting issues gigabyte MBs encounter when using snow Boot and EFI 9 ???

 

BIOS still corrupting with Snow A380, PC EFI v10 and Cham' 2

Also getting CPU related KP after running for 5 mins or so. No more detail, got pi$$ed off and scrubbed drive.

 

I give up for now!

Share this post


Link to post
Share on other sites
BIOS still corrupting with Snow A380, PC EFI v10 and Cham' 2

Also getting CPU related KP after running for 5 mins or so. No more detail, got pi$ed off and scrubbed drive.

 

I give up for now!

 

fo reals, Gigabyte BIOS still messed up with EFIv10.?

 

Heard that that nasty KP can be fixed by turning off spotlight

Share this post


Link to post
Share on other sites

hi

Does this require Chameleon RC2? I can't get it to even boot with Chameleon v.1. I have DSDT.aml patched and everything. My hackintosh is GA-p35-ds3p running vanilla kernel.

 

thanks

Share this post


Link to post
Share on other sites

good boot with my acer 5930g and 10.5.7 chameleon 2

 

thanks

Share this post


Link to post
Share on other sites

Hello guys, why is it Safari download executable binary files as text file? Having this problem download V10 boot(binary file) in first page.

Share this post


Link to post
Share on other sites

Hi guys,

 

You've mentioned that "full-secure" error message of FireWire is solved using this boot file.

How exactly can I achieve that?

 

I've installed it, running fine but "full-secure" still pops up during boot.

 

Any suggestions?

 

cheers,

mentorek

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×