Jump to content
Donk

VMware Mac OS X Guest Package for ESX, Workstation, Player, Server and Fusion

2,213 posts in this topic

Recommended Posts

Hi Donk, first thank you very much for the awesome instructions.

 

However, I am having problems with my Mouse, the Keyboard works fine. During Leopard installation when the graphical window pops up I simply can´t move with the mouse and proceed with the installation.

I have tried various VMWare config file settings and used a PS/2 and USB Mouse but the result is always the same.

In attached screenshot you can see reocuring PS/2 Adapter/Driver issues.

 

I am using Workstation 6.5 (with USB support enabled), hosting on Core2 Vista SP2, Guest OS is Leopard 10.5.6

 

Many thanks in advance!

ss

post-455478-1247228221_thumb.jpg

MAC_OS_vmx.txt

MAC_OS_vmx.txt

vmware.log.txt

Share this post


Link to post
Share on other sites
Advertisement
Hi Donk, first thank you very much for the awesome instructions.

 

However, I am having problems with my Mouse, the Keyboard works fine. During Leopard installation when the graphical window pops up I simply can´t move with the mouse and proceed with the installation.

I have tried various VMWare config file settings and used a PS/2 and USB Mouse but the result is always the same.

In attached screenshot you can see reocuring PS/2 Adapter/Driver issues.

 

I am using Workstation 6.5 (with USB support enabled), hosting on Core2 Vista SP2, Guest OS is Leopard 10.5.6

 

Many thanks in advance!

ss

 

This work is for vanilla retail Leopard it looks like you are using iPC. There is a conflict between the extensions on the darwin.iso and those from the iPC image. As I mentioned I don't support anything other than retail Leopard DVD due to this problem. Sorry I can't help here. Is there a reason why you need iPC?

 

Hello Donk. Thank you very much for this. I sooooo love it!

 

It worked like a charm, but I cannot access internet from within MacOS.

 

I'm running windows 7 x64 rc. VM seems to be able to resolve hostnames though.

 

 

Any ideas?

 

Some random infos that might be helpfull:

Firewalls are deactivated. I'm behind a DSL router using Intel WLAN 5300. VMWare is using NAT and configured as E1000.

 

Cheers :)

 

What VMware product and version are you using, as I believe there are issues running on Windows 7 currently.

Share this post


Link to post
Share on other sites

I think I know the answer to this but hey I have to ask anyway... I have an old nostalgic game (OIDS) that I want to play inside VMware, but it complains of no OpenGL capability. I guess there is no way to emulate openGL from inside VMware? well, just asking. otherwise this is simply amazing & working fantastic. ;)

Share this post


Link to post
Share on other sites
Workstation 6.5

 

I am pretty sure that NAT does not currently work on Windows 7 with Workstation 6.5. You can try bridged or see of you can get on the Workstation beta program, which does work with Windows 7.

 

I think I know the answer to this but hey I have to ask anyway... I have an old nostalgic game (OIDS) that I want to play inside VMware, but it complains of no OpenGL capability. I guess there is no way to emulate openGL from inside VMware? well, just asking. otherwise this is simply amazing & working fantastic. :D

 

Sorry no OpenGL support.

Share this post


Link to post
Share on other sites

Ok, I try to install the DVD, but I get:

 

EBIOS read error: Device timeout

Block ###### Sectors #

 

Any ideas?

 

Installing in vSphere ESX4, on a Dell 2950 (2xQuadCore)

Share this post


Link to post
Share on other sites

esx 4.0 update breaks leopard!

 

 

hmmm,

after patching esx 4 with the latest patchbundle now build (175625) leopard does not boot anymore!

 

error:

operating system not found!

Share this post


Link to post
Share on other sites
Ok, I try to install the DVD, but I get:

 

EBIOS read error: Device timeout

Block ###### Sectors #

 

Any ideas?

 

Installing in vSphere ESX4, on a Dell 2950 (2xQuadCore)

 

Fixed it, I just changed from darwin-64 to "darwin"

Share this post


Link to post
Share on other sites
esx 4.0 update breaks leopard!

 

 

hmmm,

after patching esx 4 with the latest patchbundle now build (175625) leopard does not boot anymore!

 

error:

operating system not found!

After my installation, I upgraded ESX4 and now have the same issue. I think the IDE driver has changed...

Share this post


Link to post
Share on other sites

Im guessing VMWare doesn't like .dmg's.

 

Anyway of converting it to an .iso? Im using TransMac to extract the files now, should I just recomplie them as an .iso?

Share this post


Link to post
Share on other sites
Im guessing VMWare doesn't like .dmg's.

 

Anyway of converting it to an .iso? Im using TransMac to extract the files now, should I just recomplie them as an .iso?

 

Try this, http://vu1tur.eu.org/tools/, although cannot say how well it works as only ever converted on Mac.

 

esx 4.0 update breaks leopard!

 

 

hmmm,

after patching esx 4 with the latest patchbundle now build (175625) leopard does not boot anymore!

 

error:

operating system not found!

 

I think it updated the tools, but I don't have access to my test machine. Suggest you re-run the installation script from my package.

Share this post


Link to post
Share on other sites
Try this, http://vu1tur.eu.org/tools/, although cannot say how well it works as only ever converted on Mac.

 

 

I managed to do it using TransMac.

Right click on the image and expand to an iso

 

All installed.

 

Is there anyway to change the resolution from the standard x768?

Share this post


Link to post
Share on other sites
I managed to do it using TransMac.

Right click on the image and expand to an iso

 

All installed.

 

Is there anyway to change the resolution from the standard x768?

 

RTFM! :D

Share this post


Link to post
Share on other sites
RTFM! :wacko:

 

Lol sorry, should have mentioned that I can't get to the SystemConfiguration folder. Its hidden and I can't use Terminal since I dont understand what im doing in it ;)

Share this post


Link to post
Share on other sites
why you don't try to install osx86 on virtualbox? it's opensource so you can adapt the software...

 

Because I want to use it on VMware! Anyway there would need to be quite a lot of changes to VirtualBox and at a very low level in the emulation part of the code. Also the OSE version is missing important features like USB, which is probably going to be essential to making it work.

Share this post


Link to post
Share on other sites

Is there any reason the iPhone SDK won't mount. It says "reason unknown" I guess its something to do with VMWare or the dmg is corrupt.

 

Just wondering if theres something stopping it because its emulated. All other dmgs mount and install fine though..

Share this post


Link to post
Share on other sites
Is there any reason the iPhone SDK won't mount. I guess its something to do with VMWare or the dmg is corrupt.

 

Just wondering if theres something stopping it because its emulated. All other dmgs mount and install fine though..

 

Mounts fine for me. Check your download.

Share this post


Link to post
Share on other sites

Hi!

Thanks for the package! I'm running VMware Worskstation 6.5.2 on Windows and I get this error in terminal prompt when following your Mac instructions (you can see the steps prior).

 

nobodies-computer:~nobodies$ chmod +x /Users/nobodies/Desktop/vmware-darwin-200/setup.sh

nobodies-computer:~ nobodies$ sudo /Users/nobodies/Desktop/vmware-darwin-200/setup.sh --install

 

WARNING: Improper use of the sudo command could lead to data loss

or the deletion of important system files. Please double-check your

typing when using sudo. Type "man sudo" for more information.

 

To proceed, enter your password, or type Ctrl-C to abort.

 

Password:

VMware ISO Signature Creator 2.0.0

==================================

Running on Darwin and using /Library/Application Support/VMware Fusion/isoimages

Backing up files

cp: /Library/Application Support/VMware Fusion/isoimages/*.pub: No such file or directory

 

I know this is prob a simple noob mistake but I'd really appreciate your help!

Share this post


Link to post
Share on other sites

I've englarged my vdisk by using vmware-vdiskmanager -x 20GB myDisk.vmdk, and am now going into disk util to expand. However it says that the partition is too small. Im trying to expand it from 16GB to 25GB.

 

I've also tried merged it using the Terminal command sudo diskutil mergePartitions "Journaled HFS+" New disk1s1 disk1s2 however I am having no such look with either method.

 

Any ideas on how to expand the partition?

Share this post


Link to post
Share on other sites
Hi!

Thanks for the package! I'm running VMware Worskstation 6.5.2 on Windows and I get this error in terminal prompt when following your Mac instructions (you can see the steps prior).

 

 

 

I know this is prob a simple noob mistake but I'd really appreciate your help!

 

You don't run the setup program in the guest only on the host. I assume you have done this already to install Leopard into VMware.

Share this post


Link to post
Share on other sites
I've been away for several days, any new theories on the Q6600 issues?

 

Sorry I had no feedback to help on this one, so no progress.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×