Jump to content
mardurhack

[Guide] Hackintosh on HP 550 Notebook

220 posts in this topic

Recommended Posts

Hi, guys!

 

I have a not working USB ports after installation iPC 10.5.6 Final on my HP550.

Run with -v give message: "AppleUSBEHCI: unable to initialize UIM"

 

if i select PowerManagement during installation, then, after installation, USB not work, but fan work perfectly (as in Windows)!

If i not select PowerManagement during installation, then, after installation, USB work, but fan not work!

if i select VoodooPower during installation, USB not work, fan not work.

 

I tryed to install IOUSBFamily.kext by Slice. No effect.

I tryed to install iPC 10.5.6 without PowerManagement and install PowerManagement.bundle using KextHelper after installation. No effect for fan.

I tryed to update iPC to 10.5.7, to 10.5.8, remove AppleIntelCPUPowerManagement.kext. No effect.

I tryed to install iDeneb 10.5.7, iAtkos 10.5.7, INSTAhackintosh 10.5.7. USB work, fan not work.

 

 

As a result: if fan work, USB not work. If USB work, fan not work. Why? :(

 

 

My HP550 configuration is following:

CPU: Core2Duo T5670 1.8Ghz

Video: Intel CMA x3100, device id is 2a12

ROM Date: 02/25/2009

ROM BIOS Version: F.06

 

 

P.S.: Sorry for my poor English

Share this post


Link to post
Share on other sites
Advertisement

Hi all!

 

Im newbie in installation mac os on pc...otherwise i want to do that.....

 

So Plz...HELP ME

 

I have notebook HP 550 ...& original Mac OS Snow Leopard installation disk

 

Configuration:

CPU Mobile DualCore Intel Core 2 Duo T5470

MB Chipset Intel Crestline GME965 (BIOS Compaq 06.20.08)

VGA Mobile Intel? 965 Express Chipset Family (Intel GMA x3100 acceleration) ID 21A2

Sound Analog Devices AD1981HD @ Intel 82801HBM ICH8M

IDE Intel? ICH8M 3 port Serial ATA Storage Controller 2828

HDD Fujitsu MHZ2120BH G2 (Sata 2)

Lan Intel? 82562GT, WiFi Intel? Link 4965AG, Bluetooth

 

I have notebook running OSX 10.5.6 IPC

Everything is working fine, screen sound , vga , usb powermanagent etc.

and now i am installed snow leopard 10.6.1 Retail snow leopard and get all working

as sound,vga,lan,usb

and me installed chameleon 2 rc3

amd wants my laptop to boot from chamleon direct

with out using and cds ?

 

can any one attach the working EXTRA FOLDER FOR MY LAPTOP

PLEASE ANY ONE CAN HELP ME TO MAKE BOOT LOADER FOR SNOW WORKING

 

THANKS

Share this post


Link to post
Share on other sites

I have problems with the USB, wifi and sleep. It isn't working for me on 10.5.6. Please help. What should i do? USB and wifi are the most important. How can i fix it?

Share this post


Link to post
Share on other sites
I have problems with the USB, wifi and sleep. It isn't working for me on 10.5.6. Please help. What should i do? USB and wifi are the most important. How can i fix it?

if you want your usb to work... you should delete from s/l/e/AppleHPET.kext (i don't know why but it works)

Share this post


Link to post
Share on other sites

I've got 6720s with Celeron and finally almost everything works. Installed iPC 10.5.6 with help of this great guide..

I had to update to 10.5.8 on Software Update because I needed the newest Safari. The only thing that was not working after reinstalling kexts was my 6720s' fan..

 

This is how I got my fan working:

 

 

from iPC 10.5.6 DVD..

 

1. Installed Disablers > AppleCPUmanagement disabler kext

2. Reinstalled PowerManagement package

3. Installed VoodooPower.kext

 

Im not sure which one fixed my issue but fan is now working out of the box.

 

However, i am still getting this strange random X3100 problem: white and grey screen after booting. Someone solved it? My x3100 kext versions are 1.5.44.

Share this post


Link to post
Share on other sites

Nice to know about fan solution there. I used to have HP 6720s (see signature) and , yes, occasionally I had the same issue with the screen. I think that it is a pure hardware thing related with the temperature. I'm not sure on this.

Share this post


Link to post
Share on other sites

Could it be something related to laptop's temperature? I've read about that in the past..

Weird that one of the boot flags (-v, -s, -f, -x) usually does the trick. Sometimes you have to reboot like 10 times before it works..

Share this post


Link to post
Share on other sites

It usually needed several times to me. Three times maximum. So, you should check your installation step by step. Maybe you're missing something. Use my thread on HP 500 (same laptop, se signature) and post back. I'll do my best to help. juanerson is most involved guy on temp issues. Check his posts about native speed step. Maybe you''l get some new idea.

Share this post


Link to post
Share on other sites

Okay. I reinstalled x3100 kexts from DriverPackage_HP550 (10.5.6 folder) and now it's working perfectly. Haven't got any white screens after that!

 

Do you guys think installing the x3100 kexts last after everything else would solve white/grey screen problem? However, I'll keep in touch about the issue in case it recurs.

Share this post


Link to post
Share on other sites
Okay, worked fine until first white screen. I got enough, gave up and now I'm on W7 which at least works properly..

 

(UP) - Well could be a hardware problem! I believe the white screen appears because of a temperature problem. Could be a system overheat which causes the turning off of the CPU and, eventually, a white screen. Why don't you try to monitor CPU temperature in the meanwhile?

 

PS: I would like to know if someone has got a FULLY WORKING OSX on a HP 550. And if has been found any improvements I'd be glad to put it into the first post :) Oh and by the way: if you need help I haven't escaped yet! :)

Share this post


Link to post
Share on other sites

THANKS TO GPRINCE, WITH U FB FILE I CAN WORK FINE WITH HP COMPAQ 610, AND ITS {censored} X3100 2A12, I TRY IT ALL KEXT I FOUND ON WWW, AND I EXPENDED MORE THAN 3 MONTHS TRYING TO MAKE SCRIPTS AND OTHERS THINKS USELESS, THANKS ALOT

 

I VERY HAPPY WITH MY HP610, AND TRAKTOR PRO SCRATCH AND TWO TECHNICS 1210,

WORKS FINE WITH A LOT OF APPS,

 

THANKS AGAIN!

Share this post


Link to post
Share on other sites
THANKS TO GPRINCE, WITH U FB FILE I CAN WORK FINE WITH HP COMPAQ 610, AND ITS {censored} X3100 2A12, I TRY IT ALL KEXT I FOUND ON WWW, AND I EXPENDED MORE THAN 3 MONTHS TRYING TO MAKE SCRIPTS AND OTHERS THINKS USELESS, THANKS ALOT

 

I VERY HAPPY WITH MY HP610, AND TRAKTOR PRO SCRATCH AND TWO TECHNICS 1210,

WORKS FINE WITH A LOT OF APPS,

 

THANKS AGAIN!

 

GOOD! To know that this guide has effectively helped someone! :( Thanks again to GPrince to have been the best support for the Snow guide!

Share this post


Link to post
Share on other sites

Hello guys! First I wanted to say YOU ARE AWESOME and you do a great thing here!

I used this guide to install 10.5.6 on my hp 550 but I faced some problems that I couldn't just ignore (overheating, some screen issues at the boot process and the trackpad)

So now I use win7 but after 2 months of using mac os I just can't look at any Windows OS, even if it's the best in the whole universe..

Now I really would like to see Snow Leopard running on my crappy pc but it's really complicated. I've read maybe all of what's written here for SnowLeo on 550 but it's really hard for me to understand 'remove your hdd' and things like this.

I know I can google it but please if somebody can make some guide like the 2nd part of this one here it's going to be really cool. I know I ask too much but I will be grateful if you help me even just a little bit :rolleyes:

PS: Can I use iPC 10.6 .. ?

cheers from Bulgaria

Share this post


Link to post
Share on other sites

Just upgraded to t2390 (best dual core to replace the celeron M on this notebook. Found at 20$ on eb@y, noticeable faster (+40%)

I am very happy about this!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×