Jump to content
macita

Omnisphere not providing challenge code

9 posts in this topic

Recommended Posts

Set your primary network card as en0, most of software seial make calculation up the mac adress and not only of your en0 network card!

Share this post


Link to post
Share on other sites
Advertisement

I did it, and autorized my Omnisphere (works fine), but Internet doesn't work. Then I returned original NetworkInterfaces.plist and after reboot Omnisphere again ask for autorization. 

 

How to make Internet work with changed NetworkInterfaces.plist?

 

PS I'm on hackintosh. 

Share this post


Link to post
Share on other sites

finally i solved this with a great help of knobsi

 

first edit your NetworkInterfaces.plist and Set your primary network card as (en0)

 

then go to your network settings in the pref panes and activate the "new" (en0)

Share this post


Link to post
Share on other sites

Hello guys

I've the same problem, I tried to understand what you suggest but I can't!

 

Can you explain better the procedure?

 

Attached my NetworkInterfaces.plist file

 

thank you

Share this post


Link to post
Share on other sites

Try to make your primary NIC defaulting to the bsdname en0 with a hackintosh you can try setting Chameleon's EthernetBuitin=Y flag. Removing the .plist file 'reshuffles' all your interfaces again  @ reboot so they get re-assigned new names.

Share this post


Link to post
Share on other sites

Hi,

I still don't get it. It probably seems obvious when you are a computer savvy but if you are not, your procedures are quite cryptic (with all due respect, of course).

See files attached to get my plist and network settings.


This is what I tried before I start the authorization :
-> I tried normally with my wi-fi active, no ethernet cable, connected and not connected to internet
-> I tried with my wi-fi inactive, with ethernet cable, connected and not connected to internet
-> I tried to get rid of the NetworkInterfaces.plist file and reboot
-> I tried to edit the BCM5701Enet to en0 in the NetworkInterfaces.plist file

-> I tried to make my airport connection as en0 and the BCM5701Enet as en1 in the NetworkInterfaces.plist file and reboot (which seems what you are suggesting as now, even with my airport active and no internet cable, the system settings falsely consider my ethernet as active and being my internet provider).

None of this worked, still an empty challenge code.

What do I do wrong?

Thank you.

 

Sanstitre1.jpg

Sanstitre2.png

Edited by baylock

Share this post


Link to post
Share on other sites
On 7/14/2018 at 1:57 PM, baylock said:

Hi,

I still don't get it. It probably seems obvious when you are a computer savvy but if you are not, your procedures are quite cryptic (with all due respect, of course).

See files attached to get my plist and network settings.


This is what I tried before I start the authorization :
-> I tried normally with my wi-fi active, no ethernet cable, connected and not connected to internet
-> I tried with my wi-fi inactive, with ethernet cable, connected and not connected to internet
-> I tried to get rid of the NetworkInterfaces.plist file and reboot
-> I tried to edit the BCM5701Enet to en0 in the NetworkInterfaces.plist file

-> I tried to make my airport connection as en0 and the BCM5701Enet as en1 in the NetworkInterfaces.plist file and reboot (which seems what you are suggesting as now, even with my airport active and no internet cable, the system settings falsely consider my ethernet as active and being my internet provider).

None of this worked, still an empty challenge code.

What do I do wrong?

Thank you.

 

There are the steps I followed to fix the issue of Omnisphere showing a blank Challenge Code field:

1. Using Clover Configurator, mount the system's EFI partition under Tools > Mount EFI

2. Go to Finder -> EFI -> CLOVER -> edit config.plist with any text editor, search for "<key>Boot</key>": in the "string" field of its arguments EthernetBuiltIn=yes should be added, i.e. something like

<key>Arguments</key>
        <string>dart=0 EthernetBuiltIn=yes</string>

then save and close.
2. Alternatively, open EFI/CLOVER/config.plist with Clover Configurator. In the Boot section a new boot key-value pair needs to be added:
3. Right-click the list of boot arguments to add any of the boot arguments presented by the context menu
4. Edit the newly inserted entry by double-clicking it. It should say EthernetBuiltIn=yes
5. Remove the file /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
6. In System Preferences > Network, remove the PAN Bluetooth (if any) connection type
7. Reboot. The NetworkInterfaces.plist file will be re-created with the "correct" ordering (Ethernet should be interface en0)
8. Internet won't probably work. Go to System Preferences > Network, remove the Ethernet connection and re-create it via the "+" button.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×