Jump to content
jiminy cricket

P5Q PRO Turbo - modded bios?

74 posts in this topic

Recommended Posts

There were many modded bioses posted by juzzi in this thread last November: http://www.insanelymac.com/forum/index.php?showtopic=136586

 

I sent him an email asking if he could do one for the P5Q PRO Turbo. If he's not able, how hard would it be to mod the bios? I have the code that needs to be changed, seems pretty straightforward.

 

Has anyone else gotten OSX to work on a P5Q PRO Turbo somehow? I should've investigated this before buying the board - every other P5Q has a bios mod but this one!

Share this post


Link to post
Share on other sites
Advertisement

Only problem is you can't get both cores working without a modded bios. I'm trying to modify one myself but am having some problems :\

Anyone else have success with this board?

Share this post


Link to post
Share on other sites
Only problem is you can't get both cores working without a modded bios. I'm trying to modify one myself but am having some problems :\

Anyone else have success with this board?

 

I have a lot of problem with this board. I've tried a several different versions of OSx86 but haven't got none to work. All though, I'm new to this scene, maybe I'm doing something wrong?

 

What versions do work fine on this board? :)

Share this post


Link to post
Share on other sites
This board has a little different 1B module.

I have modified it but cannot test it since i don't have the board.

SOmebody please try and give feedback.

Hope this helps you all.

I have attached the file.

 

I tried it, but it said it had the wrong ID-key for this motherboard.

Could be since I've got a P5Q Turbo (not pro).

 

So if someone know a modded bios made for the regular P5Q, I'd be thankful a thousand times!!!

Share this post


Link to post
Share on other sites
I tried it, but it said it had the wrong ID-key for this motherboard.

Could be since I've got a P5Q Turbo (not pro).

 

So if someone know a modded bios made for the regular P5Q, I'd be thankful a thousand times!!!

Here i mooded this.

Included are DSDT fix and slic 2.1 table.

File attached.

Please give feedback

p5qshaumux_turbo_0401_slic_dsdt.zip

Share this post


Link to post
Share on other sites
Here i mooded this.

Included are DSDT fix and slic 2.1 table.

File attached.

Please give feedback

p5qshaumux_turbo_0401_slic_dsdt.zip

 

Thanks a lot! It works like a charm :(

Got all the way to the apple-logo this time! Alltough, I couldn't reach in to the installer for some reason.

I should look up some boot commands i guess.

 

Thanks again!

Share this post


Link to post
Share on other sites
Thanks a lot! It works like a charm :(

Got all the way to the apple-logo this time! Alltough, I couldn't reach in to the installer for some reason.

I should look up some boot commands i guess.

 

Thanks again!

Try the -v command

Share this post


Link to post
Share on other sites
Thanks a lot! It works like a charm :)

Got all the way to the apple-logo this time! Alltough, I couldn't reach in to the installer for some reason.

I should look up some boot commands i guess.

 

Thanks again!

 

 

Did you mod the BIOS for the P5Q Pro Turbo? If so can you please post it!

Share this post


Link to post
Share on other sites
Did you mod the BIOS for the P5Q Pro Turbo? If so can you please post it!

 

Look at post no. 5 in this thread.

It has the DSDT fix but doesn't include the slic 2.1 table for win 7 offline activation

Share this post


Link to post
Share on other sites

Hello, I came into possession of this motherboard (P5Q Pro Turbo), but I don't understand if the modified bios of this thread works well or not.

On this mainboard I mount an Intel Core2Duo E6600 and wanted to know, with this bios I can do it perfectly recognized by Leopard?

The LAN and audio working properly?

Has anyone tried to install and use SnowLeopard?

Thanks

Share this post


Link to post
Share on other sites
Hello, I came into possession of this motherboard (P5Q Pro Turbo), but I don't understand if the modified bios of this thread works well or not.

On this mainboard I mount an Intel Core2Duo E6600 and wanted to know, with this bios I can do it perfectly recognized by Leopard?

The LAN and audio working properly?

Has anyone tried to install and use SnowLeopard?

Thanks

The modified bios changes the dsdt a little without which OSX will not boot on these boards.

For lan and audio you will need to install proper kexts.

Share this post


Link to post
Share on other sites
Dear Shaumux! I have this motherboard. In september 2009 we get a new version bios on P5Q Pro Turbo, version 0602. May be you modded it for Mac Os? Many many thankssssss! Sorry, i have a bad English.....

 

 

http://rapidshare.de/files/48536043/P5Q-PR...O-0602.rar.html

Here you go.

Includes SLIC 2.1

Mac Fix and SLI certificate to enable sli(you would still need modified driver or hal.dll in windows)

P5Q_PRO_TURBO_0602_SLIC_MAC_SLI_shaumux.zip

Share this post


Link to post
Share on other sites
Here you go.

Includes SLIC 2.1

Mac Fix and SLI certificate to enable sli(you would still need modified driver or hal.dll in windows)

 

 

 

Many thankssssssss!!!!!!

 

I will test it after 5-6 days, and I send feedback to you. :)

Share this post


Link to post
Share on other sites
Here you go.

Includes SLIC 2.1

Mac Fix and SLI certificate to enable sli(you would still need modified driver or hal.dll in windows)

 

It works perfectly ! Im successfully installed 10.6 Snow Leopard (by Den, not retail), audio starts working with VoodooHDA, motherboard with kext (google it) but i cant run videocard, after installing NVInject 1gb i cant login. When im typeing my password at login and press "Log in" it back again and again. Im already tryed to reset password from install disc - no results.

Share this post


Link to post
Share on other sites

So you can install SL on your motherboard P5Q pro Turbo ! Good news, because with this mod i can't ...

 

it is writting EBIOS read error: Error 0x01

Block 7563104 Sectors 64

 

If you have an idea ..? That's 3 months i have this PC for nothin ;-)

If someone could savec me ..?

 

Thx

Share this post


Link to post
Share on other sites
Hi!

Shaumux, all works fine on retail Snow & retail Leo & Win 7 multiboot. Thanks!!!

 

Hello, Could you please teach me how you work out to install 10.6 on you system? I have P5Q pro turbo just like you do, i try to boot using Chameleon RC3 658 but it didn't went through to the install page. Could you tell me your instructions?

Share this post


Link to post
Share on other sites
Hello, Could you please teach me how you work out to install 10.6 on you system? I have P5Q pro turbo just like you do, i try to boot using Chameleon RC3 658 but it didn't went through to the install page. Could you tell me your instructions?

I have a P5Q deluxe board.

I have written instructions about how to install on it but i guess they should mostly be valid for you too.

Here they are

Share this post


Link to post
Share on other sites
I have a P5Q deluxe board.

I have written instructions about how to install on it but i guess they should mostly be valid for you too.

Here they are

 

How do u set up the bios?

What i did to install Chameleon is using a pkg file. did you do it manually? as long as i see the Chameleon logo, it gave me kernel panic screen ><

I didn't change smbios.plist and PlatformUUID.kext. Will it be the reason ?

Can i use smbios.plist and PlatformUUID.kext attached from you P5QD post?

Share this post


Link to post
Share on other sites
How do u set up the bios?

What i did to install Chameleon is using a pkg file. did you do it manually? as long as i see the Chameleon logo, it gave me kernel panic screen ><

I didn't change smbios.plist and PlatformUUID.kext. Will it be the reason ?

Can i use smbios.plist and PlatformUUID.kext attached from you P5QD post?

It may work with those.

You can try.

Also try booting with -v or -v -f

You'll be able to see what's the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×