Jump to content

AHCI and IDE different boot errors?


subjekt
 Share

1 post in this topic

Recommended Posts

I recently updated my Kalyway install to 10.5.5, everything was running smoothly, apart from I couldn't get QE running on my ATI X1950pro. I was using the Natit.kext, but this didnt supprt QE, so tried Bronjas. QE was supported but my resolution was not.

 

So i edited the com.apple.Boot.plist and added thE grahics string for 1680 x 1050, but to no avail. So changed the plist backto the original values

 

I then downloaded an app called 'displayconfigx', which alowed me to create any resolution and 'install' these to my system. After doing this, i cannot boot. I have now reinstalled the natit.kext via terminal, and set the permissions ( chmod and chown) but still get errors in-v. And cant get past spinning apple screen, not even in safe mode.

 

2 strange things are happening. When my BIOS is set to AHCI, which it always has been for my Hackintosh, i get the cannot find IOAHCIBlockStorage extension error. I have reinstalled this kext in terminal by installing the IOAHCIFamily.kext which it is a part of, but still nothing.

 

When my BIOS is set to IDE (enhanced) I get a sandbox_init error and then could not set mach lookup policy for (and then a number of kexts, mainly MDNSResponder).

 

Whycanti reinstall the AHCIkext, or why isnt it recognising it? And is this even the reason it's not booting?!!!What did that display app do to my system!?!?!

 

Cheers guys.

Link to comment
Share on other sites

 Share

×
×
  • Create New...