Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
cinorhc

VoodooHDA

364 posts in this topic

Recommended Posts

where can i get 0.2.2 ?

 

Go here......

Share this post


Link to post
Share on other sites

Works with ALC662 on P5KPL, gives 2 speaker output, headphones also work connected to the front panel, no info on the System Profiler though.

 

Keep up the good work Voodoo Team, cos this might be a breaktrough !

 

Thanks !

Dump.rtf

Share this post


Link to post
Share on other sites

works on the system in my sig BUT i can only test 2 speaks out on the back panel, i dont have a front panel and no mic to check it with

Share this post


Link to post
Share on other sites

just tested it on my adi988, and it works but have not tested other inputs/outputs. will post especially if i can test the spdif or optical inputs.

 

cheers to the dev team. :c

Share this post


Link to post
Share on other sites

I am still using version 2.1 on my HP Mini + no mic (btw really thanks, great job voodoo team!).

Version 2.2 doesn't work fine with me since on my HP volume is controlled by PCM and with 2.2 I cannot select PCM as an output source.

Share this post


Link to post
Share on other sites

Tried VoodooHDA.kext v0.2.2 on my Asus P5N32-E SLI Plus MOBO with Asus SupremeFX Audio Card (with AD1988b audio codec) and find that Mute is now working.........autoswitching between speakers (unknown) on rear port and headphones on front port is still not working....not able to test SPDIF-out......

Share this post


Link to post
Share on other sites

i like it. been using appleHDA on the P5W DH and until now haven't been able to change the volume on the optical out. now i can. i've lost the second line out but since i don't use that it's of no real concern for the moment. nice work.

Share this post


Link to post
Share on other sites

noticed something interesting with mine, i can control the volume on the keyboard but when i mute it it shows that its muted but isnt really muted, never had this issue with the azalia kext but no biggie

Share this post


Link to post
Share on other sites

Result for 0.2.2 with ALC662:

 

Much better than the previous version in terms of sound quality (but patched AppleHDA is still better). Also no more sound stuttering.

 

Rear Mic: NOT working

Rear Line-in: NOT working

Rear Line-out: Working Well

 

Front Headphone: Speakers OK / Mic not working.

 

Auto switching works.

DUMP.txt

Share this post


Link to post
Share on other sites

1st: thanks for your intensive work! now i'm testing 4th version

 

in ACER 5930g

in attached the codec#0

is alc888/s/t with front stereo, rear stereo, subwoofer output and jack HP

as input there are a frontal mic stereo, a mic in jack

and a line in jack, spdif out and hdmi

 

with your last release I have frontal speaker ok, HP ok with auto switching, mic ext ok but no mic frontal internal.

 

with your 3 release (with a lot of entry in the mixer)

i saw that pcm0 - mixer 0 I can manage mic ext. and if i raise mixer 1 i hear a big noise.. but mic 1 doesn't match with internal mic

 

thanks!

ugo

Share this post


Link to post
Share on other sites

i'm tryin on my ALC260 but there's no sound out of my notebook speaker. but when i'm tryin external speaker the sound came out but it's to low...i'm must full 100% volume to hear sound came out from my ext speaker. can anyone explain it to me ???

 

thanks

Share this post


Link to post
Share on other sites

Thx a lot for voodoo team's hard work. But the precompiled kexts (2.1 & 2.2) don't work with my 1986a ICH7 M of Lenovo Tianyi F40. Wondering whether I must compile the kext with xcode myself?

 

Here I upload my dump codec of my lenovo Tianyi F40 laptop for your study. THX

codec.txt

Share this post


Link to post
Share on other sites

This is the 0.2.2 modified version for my eeePC 1000H should work too on other eeePCs:

 

--> http://thireus.dareyourmind.net/VoodooHDA_By_Thireus.zip EDIT: Check this thread: http://ipis-osx.wikidot.com/forum/t-152367...udio-in-working

 

Install: You do have to delete appleazaliaaudio.kext and remove audiee from your login items for this to work. Then use Kext Helper to install the provided kext. Reboot, and enjoy!

 

Changelog:

 

22/04/09: v.3

 

r8 build

 

r8: Added improved port descriptions (VHDAEngine.h changed in r6)

r7: Removed personal settings from earlier commit

r6: Support for hints in Info.plist

 

18/04/09: v.2

 

Fixed: When you first want to mute the volume, and then get the sound back from the speakers it seems we need to play a bit with the volume so the sound will come back. But this happens only once after a boot :(

 

18/04/09: v.1

 

---------

 

This is the 0.2.2 modified version for my eeePC 1000H should work too on other eeePCs.

 

What I did was just to set 100 to some default volume values which were 0 into the Tables.c file of the last VoodooHDA source code.

 

For those who want to edit them to find a better configuration (as mine was a bit ramdom :D ) just have a look at the end of the Tables.c source.

 

Here is my own modified version:

 

99, // SOUND_MIXER_VOLUME

50, // SOUND_MIXER_BASS

50, // SOUND_MIXER_TREBLE

99, // (was 75) SOUND_MIXER_SYNTH

99, // (was 75) SOUND_MIXER_PCM

99, // (was 75) SOUND_MIXER_SPEAKER

0, // (was 75) SOUND_MIXER_LINE //Thireus was 0 //doesn't work

0, // SOUND_MIXER_MIC //Thireus was 0 //doesn't work

90, // SOUND_MIXER_CD

0, // [?] SOUND_MIXER_IMIX //Thireus was 0 //doesn't work

0, // [?] SOUND_MIXER_ALTPCM //Thireus was 0 //doesn't work

99, // SOUND_MIXER_RECLEV //Thireus was 0

0, // SOUND_MIXER_IGAIN //Thireus was 0

50, // SOUND_MIXER_OGAIN

0, // (was 75) SOUND_MIXER_LINE1 //Thireus was 0 //doesn't work

0, // [?] SOUND_MIXER_LINE2 //Thireus was 0 //doesn't work

0, // [?] SOUND_MIXER_LINE3 //Thireus was 0 //doesn't work

99, // [?] SOUND_MIXER_DIGITAL1 //Thireus was 0

99, // [?] SOUND_MIXER_DIGITAL2 //Thireus was 0

99, // [?] SOUND_MIXER_DIGITAL3 //Thireus was 0

99, // [?] SOUND_MIXER_PHONEIN //Thireus was 0

99, // [?] SOUND_MIXER_PHONEOUT //Thireus was 0

99, // SOUND_MIXER_VIDEO

0, // [?] SOUND_MIXER_RADIO //Thireus was 0

0 // (was 75) SOUND_MIXER_MONITOR //Thireus was 0

 

Feel free to download the last source code and edit it:

 

svn co http://voodoohda.googlecode.com/svn/trunk/ voodoohda-read-only

 

I repeat, I just did a random edit of this file!

 

**On my 1000h, only mono works well for both microphones (the one in front of the eee, and the jack on the left of the computer). There is too much noise for my taste but I'm sure there is an alternative to reduce noise :) **

 

I've also a little issue with my modified version:

 

[FIXED] **When you first want to mute the volume, and then get the sound back from the speakers it seems we need to play a bit with the volume so the sound will come back. But this happens only once after a boot ;) **

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×