Jump to content
marionez

Realtek ALC1200 ICH10 working kext on Yosemite 10.10 from 10.6+

579 posts in this topic

Recommended Posts

This doesn't happen here, I think that could even be a software problem, are you maybe resuming some song from pause? There's an effect, like that you're speaking, if I leave the pause from a high volume song, but it's really quite.

Share this post


Link to post
Share on other sites
Advertisement

hi! that bump that dream sequencer is describing is happening on my hackintosh too... its more like a screech though.

 

If for example im just browsing the net and when a program suddenly makes a sound... it produces something like a short screech/bump whatever before the normal program sound.

 

by the way my mobo is asus p5ql-em with alc1200 according to the manual and using the slim version.

 

and thank you so much for your hard work marionez. ^^ <3

Share this post


Link to post
Share on other sites

That's quite strange, this doesn't really happen here. Firstly you can carefully check your extension folder. Many times I had some old kexts that was the point of the problem. You can try to remove applehda hdaenabler alc* (check your *), then reinstall slim version with kexthelper and reboot.

 

If this won't work, I have to check your own codec dump, in that way we can see if there's something different. Maybe this has something to do with misc verb parameter.

Share this post


Link to post
Share on other sites

I can confirm that happening too. It 's like after a period of inactivity the audio system turns off and when a sound needs to be reproduced it wakes up. Like turning on the computer with the speakers on. When the audio card is enabled you hear a "click" noise. I believe that's the reason of this.

Share this post


Link to post
Share on other sites

Ive installed your slim drivers on my laptop. the audio device now detects in the hardware profile. but not in the system properties. im kind of stumped now.

Share this post


Link to post
Share on other sites
hi marionez, i tried the SLIM driver and it works but it bumps my speakers everytime it starts a sound.

for example, i'm in silence, i click on a song, it produces a little bump noise and then starts the song.

 

it happens to you?

 

It was happening if I set my system to be iMac5,1, for example. However, it was gone if I set it to be MacPro3,1.

Share this post


Link to post
Share on other sites

Riepilogo hardware:

 

Nome modello: iMac

Identificatore modello: iMac8,1

Velocità processore: 3.87 GHz

Numero di processori: 1

Numero totale di nuclei: 2

Cache L2: 6 MB

Memoria: 4 GB

Velocità bus: 1.6 GHz

Versione Boot ROM: IM81.00C1.B00

Numero di serie (sistema): SOMESRLNMBR

 

 

ok, you're right.

 

how can i change it? i have to edit applesmbios?

Share this post


Link to post
Share on other sites

You should edit your /Extra/smbios.plist

Tkmongol, thanks I think you're right.

I tried to set iMac and I had that poff sound, setting back MacPro sound is ok.

Share this post


Link to post
Share on other sites

It's strange,

 

After I install these drivers it finds my device but there are no available devices.

 

If I go back to an old alcinject method it works.

 

Anyone have any ideas what would cause this?

 

Thank you,

 

William

 

post-393081-1243715285_thumb.png

Share this post


Link to post
Share on other sites

I flash P5Q PRO BIOS which is modified by Juzzi

http://www.insanelymac.com/forum/index.php?showtopic=136586

 

XxX 10.5.6 Final DVD

 

VGA is nVidia 9600 (This one drive me crazy a month)

So I installed nVidia 9000 seires Driver v2 and XDarwin Nvidia install.

And

 

*OpenHaltRestart.kext

*Asus_P5Q_PRO_JC_Marvell_6111_AppleVIAATA.kext.zip

*Asus_P5Q_PRO_JC_AHCIFix.1.3_cVaD.dmg.zip

*AttansicL1eEthernet.kext.zip

 

Everything wok fine BUT

 

I try so many way to solve my P5Q SE/R audio problem but still in vain.

 

1. I removed any "audio" or "HDA" .kext in my /System/library/extension/

such as ALCinjector.kext AppleHDA.kext ALC1200fix.kext

even those

* SM56KUSBAudioFamily.kext

* AppleFWAudio.kext

* AppleOnboardAudio.kext

* IOAudioFamily.kext

 

2. I use OSX86tools to install the ALC1200_SLIM.zip.

 

3. Reboot with -v -x

 

4.When the system boot

 

I get

 

kernel[0]: Sound assertion "0 != setupHostInterrupt ()" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDAController/AppleHDAController.cpp" at line 253 goto Exit

 

PS:

But in this topic

 

kizwan say: "Never mind, this error occurs if ACPIFIX installed."

 

 

5. But the system still show below message

nothing happen, no audio icon show up. no audio device

 

Intel High Definition Audio:

 

Device ID: 0x104382FE

Audio ID: 12

Available Devices:

 

empty

empty

empty

empty

 

 

I fight 2 weeks for this issue. Please help me.......

 

Thanks thanks thanks thanks...

 

BTW, How to dump the audio device info?

Share this post


Link to post
Share on other sites
It's strange,

 

After I install these drivers it finds my device but there are no available devices.

 

If I go back to an old alcinject method it works.

 

Anyone have any ideas what would cause this?

 

Thank you,

 

William

 

post-393081-1243715285_thumb.png

Socrates you have 2 drivers installed in your Extensions folder, this can't work. Clean your extensions folder and reinstall the driver. Your mobo model?

 

Albert the sound assertion is not a problem, can't understand why you removed those:

* SM56KUSBAudioFamily.kext

* AppleFWAudio.kext

* AppleOnboardAudio.kext

* IOAudioFamily.kext

 

I think you'd better recovering from combo 10.5.6 update (if you're on 10.5.6 and not on 10.5.7).

Share this post


Link to post
Share on other sites

thanks marionez !!

 

I reinstall all *audio*.kext back to the system, but still not work.

 

I dump the audio code and attach with this post.

 

Please give me some idea.

 

-------

 

BTW I reinstall ALC1200_1056.zip to my MAC.

 

When booting there is one more error message

kernel[0]: Sound assertion "0 != setupHostInterrupt ()" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDAController/AppleHDAController.cpp" at line 183 goto Exit

 

What happen here?

 

 

 

 

========after 10 min==============

 

 

wait wait wait...

 

I cry after all....

 

The tear drop with happiness.

 

I heard the mp3 from my Z5500 with coax digital output now.

 

Every work perfect!!!!

 

Thanks again marionez !!

 

Thanks you.

 

But I still don't understand what happen here, how suddenly it work.

codec.txt

Share this post


Link to post
Share on other sites

Hello all,

 

I am currently running on AppleHDA.kext on Asus P6t and having sleep / shutdown / Wake issues.

 

Sleep: may not sleep after first sleep. first sleep / wake works fine

Shutdown: Sometimes kernel panic, box light still on , cpu still spinning

Wake: Can only wake up first time, second time it sleeps. Wake fails with monitor going black

 

 

Are these signs of bad audio? Will the kext in this thread help ?

 

thanks

Share this post


Link to post
Share on other sites

Hi All

 

Anyone else having problems with sound input after update to 10.5.7? I've tried importing plists from 10.5.6 slim kext to 10.5.7 AppleHDA but only input working is now Rear Mic. Line In shows up in System Prefs but does not seem to be active (no changes in volume levels when sound coming in).

Share this post


Link to post
Share on other sites

You would work on 10.5.7 info.plist directely.

 

I can't figure out why can't get input working, but seems like with this 10.5.7 shutd/reb is more reliable.

Anyway we have verbs and input scheme, now I think we have just to try some new settings good for 10.5.7, I've not so many time to work on this, so help is very appreciated, I already spent much.

 

Things to check:

Pathmaps and Layouts inside AppleHDA.kext/Contents/PlugIns/AppleHDAPlatformDriver.kext/Info.plist

Verbs inside AppleHDA.kext/Contents/PlugIns/AppleHDAController.kext/Contents/Info.plist

 

I would think that verbs are not the problem.

ALC1200_1057.zip

Share this post


Link to post
Share on other sites

Marionez

 

I've also spent hours on this! Have found that line in shares same input/mixer as rear mic (see attachment) and have set up pathmaps exactly as in this picture. My Asus ALC1200 codec is parsed as ALC888 but you'll see the Nodes (Pin Associations) in the picture are the same as yours. All works great except for LineIn and FrontMic (shows up as 'None' in System Profiler). I can only think it's to do with MuteGPIO values, have tried loads of different combinations with no success. I agree verbs are unlikely to be the cause, I've been using ones which are virtually identical to yours.

 

The AppleHDA.kext has always been a pain in the a**e, if only it was more universal like otherHDA drivers. VoodooHDA is heading in the right direction (great work) but has a way to go with inputs!

post-11298-1244060001_thumb.png

Share this post


Link to post
Share on other sites
Socrates you have 2 drivers installed in your Extensions folder, this can't work. Clean your extensions folder and reinstall the driver. Your mobo model?

 

 

I've searched through my extensions folder for hours now, I do not have any other audio drivers. However, I do seem to have two Audio Devices:

 

00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] (The ALC1200)

01:00.1 Audio device [0403]: ATI Technologies Inc Radeon HD 3870 Audio device [1002:aa18] (The audio controller for my video card's HDMI output)

 

I am using an M3A78-T motherboard, and an ATI HD3850.

Share this post


Link to post
Share on other sites
You would work on 10.5.7 info.plist directely.

 

I can't figure out why can't get input working, but seems like with this 10.5.7 shutd/reb is more reliable.

Anyway we have verbs and input scheme, now I think we have just to try some new settings good for 10.5.7, I've not so many time to work on this, so help is very appreciated, I already spent much.

 

Things to check:

Pathmaps and Layouts inside AppleHDA.kext/Contents/PlugIns/AppleHDAPlatformDriver.kext/Info.plist

Verbs inside AppleHDA.kext/Contents/PlugIns/AppleHDAController.kext/Contents/Info.plist

 

I would think that verbs are not the problem.

 

@marionez

 

change 01871c50 01871d98 01871ea1 01871f01 to 01871c50 01871d98 01871ea1 01871f90

 

You should get Internal microphone, not none if you are using 1.6.8a3 AppleHDA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By DoZe
      Hi :0)
       
      Hope As usual a perfect matching DSDT for this good Laptop.
       
      Regards, Ray
       
       
      SendMeStudiMac.zip
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By Mieze
      A New Driver for Realtek RTL8111
       
      Due to the lack of an OS X driver that makes use of the advanced features of the Realtek RTL81111/8168 series I started a new project with the aim to create a state of the art driver that gets the most out of those NICs which can be found on virtually any cheap board on the market today. Based on Realtek's Linux driver (version 8.035.0) I have written a driver that is optimized for performance while making efficient use of system resources and keeping the CPU usage down under heavy load.

      Key Features of the Driver
      Supports Realtek RTL8111/8168 B/C/D/E/F/G found on recent boards. Support for multisegment packets relieving the network stack of unnecessary copy operations when assembling packets for transmission. No-copy receive and transmit. Only small packets are copied on reception because creating a copy is more efficient than allocating a new buffer. TCP, UDP and IPv4 checksum offload (receive and transmit). TCP segmentation offload under IPv4. Support for TCP/IPv6 and UDP/IPv6 checksum offload. Fully optimized for Mountain Lion (64bit architecture) but should work with Lion too. As of now there is no support for Snow Leopard but it can be added if someone will create the necessary patches. Supports Wake on LAN. Support for Energy Efficient Ethernet (EEE) which can be disabled by setting enableEEE to NO in the drivers Info.plist without rebuild. The default is YES. The driver is published under GPLv2.  
      Limitations
      As checksum offload doesn't work with jumbo frames they are currently unsupported and will definitely never be. No support for 32bit kernels.  
      Installation
      Before you install the driver you have to remove any installed driver for RTL8111/8168.
      Goto /S/L/E and delete the old driver (Lnx2mac, AppleRealtekRTL8169, etc.). Recreate the kernel cache. Open System Preferences and delete the corresponding network interface, e. g. en0. If you forget this step you might experience strange problems with certain Apple domains, iTunes and iCloud later. Reboot. Install the new driver and recreate the kernel cache. I recommend to use Kext Wizard or a similar utility for the installation. Reboot Open System Preferences again, select Network and check if the new network interface has been created automatically or create it manually now. Configure the interface.  
      Help - I'm getting kernel panics!
      Well, before you start complaining about bugs after you upgraded macOS and ask me to publish a driver update, you should first try to resolve the issue on your own by cleaning the system caches.
      As the driver uses macOS's private network driver interface, which is supposed to be used by Apple provided drivers only, you might run into problems after an OS update because the linker may fail to recognize that IONetworking.kext has been updated and that the driver needs to be linked against the new version (Apple provided drivers avoid this problem because they are always updated together with IONetworking.kext). As a result, the linking process produces garbage and the driver may call arbitrary code when trying to call functions from IONetworking.kext. This usually results in unpredicted behavior or a kernel panic. In order to recover from such a situation, you should clean the System Caches forcing the linker to recreate it's caches:
      Delete all the files in /System/Library/Caches and it's subdirectories but leave the directories and the symbolic links intact. This is very important! Reboot. Recreate the kernel cache. Reboot again.  
      Troubleshooting
      Make sure you have followed the installation instructions especially when you have issues with certain domains while the others are working fine. Use the debug version to collect log data when trying to track down problems. The kernel log messages can be found in /var/log/system.log. For Sierra and above use "log show --predicate "processID == 0" --debug" in order to retrieve kernel logs. Include the log data when asking for support or giving feedback. I'm an engineer, not a clairvoyant. Check your BIOS settings. You might want to disable Network Boot and the UEFI Network Stack as these can interfere with the driver. Double check that you have removed any other Realtek kext from your system because they could prevent the driver from working properly. Verify your bootloader configuration, in particular the kernel flags. Avoid using npci=0x2000 or npci=0x3000.  In Terminal run netstat -s in order to display network statistics. Carefully examine the data for any unusual activity like a high number of packets with bad IP header checksums, etc. In case auto-configuration of the link layer connection doesn't work it might be necessary to select the medium manually in System Preferences under Network for the interface. Use Wireshark to create a packet dump in order to collect diagnostic information. Keep in mind that there are many manufacturers of network equipment. Although Ethernet is an IEEE standard different implementations may show different behavior causing incompatibilities. In case you are having trouble try a different switch or a different cable.  
      FAQ
      How can I retrieve the kernel logs? In Terminal type "grep kernel /var/log/system.log". I want to disable Energy Efficient Ethernet (EEE) but I don't know how? Take a look at the driver's Info.plist file. There you will find an option named <key>enableEEE</key>. Change its value from <true/> to <false/>. Don't forget to recreate the kernel cache after changing the value. WoL from S5 doesn't work with this driver but under Windows it's working. Is this a driver bug? No it isn't, the driver is working as it should because OS X doesn't support WoL from S5.  
      Current status
      The driver has been successfully tested under 10.8.x and 10.9 with the B, C, D, E, F and G versions of the RTL8111/8168 and is known to work stable on these devices.  
      Changelog
      Version 2.2.2 (2018-01-21) Force ASPM state to disabled/enabled according to the config parameter setting. Requires 10.12 or newer. Version 2.2.1 (2016-03-12): Updated underlying linux sources from Realtek to 8.041.00. Added support for RTL8111H. Implemented Apple’s polled receive driver model (RXPOLL). Requires 10.11 or newer. Support for older versions of OS X has been dropped. Version 2.0.0 (2015-06-21): Uses Apple's private driver interface introduced with 10.8. Supports packet scheduling with QFQ. Please note that 2.0.0 is identical to 2.0.0d2. Only the version number has changed. Version 1.2.3 (2014-08-23): Reworked TSO4 and added support for TSO6. Version 1.2.2 (2014-08-44): Added an option to disable Active State Power Management (ASPM, default disabled) as ASPM seems to result in unstable operation of some chipsets. Resolved a problem with Link Aggregation after reboot. Added a workaround for the multicast filter bug of chipset 17 (RTL8111F) which prevented Bonjour from working properly Version 1.2.0 (2014-04-24): Updated underlying linux sources from Realtek to 8.037.00. Improved interrupt mitigate to use a less aggressive value for 10/100 MBit connections. Version 1.1.3 (2013-11-29): Improved transmit queue handling made it possible to reduce CPU load during packet transmission. Improved deadlock detection logic in order to avoid false positives due to lost interrupts. Version 1.1.2 (2013-08-03): Improved SMB performance in certain configurations. Faster browsing of large shares. Version 1.1.0 (2013-06-08): Support for TCP/IPv6 and UDP/IPv6 checksum offload added (can be disabled in Info.plist). Maximum size of the scatter-gather-list has been increased from 24 to 40 segments to resolve performance issues with TSO4 when offloading large packets which are highly fragmented. TSO4 can be disabled in Info.plist without rebuild. Statistics gathering has been improved to deliver more detailed information (resource shortages, transmitter resets, transmitter interrupt count). The interrupt mitigate settings has been changed to improve performance with SMB and to reduce CPU load. Configuration option added to allow for user defined interrupt mitigate settings without rebuild. Version 1.0.4 (2013-05-04): Moved setLinkStatus(kIONetworkLinkValid) from start() to enable(). Cleaned up getDescCommand(). Version 1.0.3 (2013-04-25): The issue after a reboot from Windows has been eliminated. Version 1.0.2 (2013-04-22): Added support for rx checksum offload of TCP and UDP over IPv6. Version 1.0.1 (2013-03-31): Improved behavior when rx checksum offload isn't working properly. Adds the chipset's model name to IORegistry so that it will show up in System Profiler.  
      Known Issues
      There are still performance problems with regard to SMB in certain configurations. My tests indicate that Apple's Broadcom driver shows the same behavior with those configurations. Obviously it's a more general problem that is not limited to my driver. WoL does not work in certain configurations. Old systems with 3 and 4 series chipsets exhibit performance issues in recent versions of macOS because there is no optimized power management for these systems in macOS anymore as Apple dropped support for the underlying hardware a long time ago. In case you are affected, please upgrade your hardware or find an alternative solution because I have no plans for a workaround. Sorry, but I don't think that it's worth the effort.  
      Getting the driver
      The source code can be found here: https://github.com/M...driver_for_OS_X There is also a pre-build binary for Mavericks and Yosemite: https://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/  
      Building from Source
      I'm using XCode 4.6.3 for development. You can get a free copy of XCode after becoming a member of the Apple developer program. The free membership is sufficient in order to get access to development tools and documentation.
    • By kevin_1351
      tl;dr: VirtualSMC causes me a flood of log messages and correlated cpu spikes. FakeSMC doesn't.
       
      Hi, I have almost finalized my Huawei Matebook X Pro Opencore setup and everything is working very well besides wifi/bt ofc (which is about to change).
       
      However, I noticed how the cpu usage sometimes went up a little and when looking at the Console I could see a never-ending flood of:
      default 14:05:05.983292+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:05.982975+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:05.982996+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.985932+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.985949+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.986134+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:39.426574+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:39.426729+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:39.426585+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431085+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431097+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431246+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:42.433068+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:42.433227+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:42.433078+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434453+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434465+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434622+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:44.436155+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:44.436166+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0  
      As you can see, multiple of these per second. Another guy with the same computer is also having this issue and posted a dsdt change to fix it. This fix didn't solve anything though
      He tried to limit the Notify call by implementing a state change requirement before calling Notify.
       
      Here is the original acpi:
      Scope (_SB) { Device (LID) { Name (_HID, EisaId ("PNP0C0D") /* Lid Device */) // _HID: Hardware ID Method (_LID, 0, NotSerialized) // _LID: Lid Status { Local0 = One Local0 = ^^PCI0.LPCB.EC0.RPIN (0x05, 0x06) If ((Local0 == 0x55)) { Local0 = Zero } Else { Local0 = One } ^^PCI0.GFX0.CLID = Local0 Return (Local0) } } Device (PWRB) { Name (_HID, EisaId ("PNP0C0C") /* Power Button Device */) // _HID: Hardware ID Method (_STA, 0, NotSerialized) // _STA: Status { Return (0x0B) } } } Scope (_SB.PCI0.LPCB.EC0) { Method (_Q81, 0, NotSerialized) // _Qxx: EC Query, xx=0x00-0xFF { Local0 = ^^^^LID._LID () If ((Local0 == Zero)) { ADBG ("LID-OFF") SGOV (0x02030009, Zero) SGOV (0x02060000, Zero) } Else { ADBG ("LID-ON") SGOV (0x02030009, One) SGOV (0x02060000, One) Notify (ALSD, 0x80) // Status Change } Notify (LID, 0x80) // Status Change } } Which he changed to: 
      Scope (_SB) { Device (LID) { Name (_OLD, One) // assuming everything else.. the lid should start open? Name (_HID, EisaId ("PNP0C0D") /* Lid Device */) // _HID: Hardware ID Method (_LID, 0, NotSerialized) // _LID: Lid Status { Local0 = One Local0 = ^^PCI0.LPCB.EC0.RPIN (0x05, 0x06) If ((Local0 == 0x55)) { Local0 = Zero } Else { Local0 = One } Return (Local0) } } Device (PNLF) { Name (_HID, EisaId ("APP0002")) // _HID: Hardware ID Name (_CID, "backlight") // _CID: Compatible ID Name (_UID, 0x0A) // _UID: Unique ID Name (_STA, 0x0B) // _STA: Status } Device (PWRB) { Name (_HID, EisaId ("PNP0C0C") /* Power Button Device */) // _HID: Hardware ID Method (_STA, 0, NotSerialized) // _STA: Status { Return (0x0B) } } } Scope (_SB.PCI0.LPCB.EC0) { Method (_Q81, 0, NotSerialized) // _Qxx: EC Query, xx=0x00-0xFF { Local0 = ^^^^LID._LID () If ((Local0 == Zero)) { ADBG ("LID-OFF") SGOV (0x02030009, Zero) SGOV (0x02060000, Zero) } Else { ADBG ("LID-ON") SGOV (0x02030009, One) SGOV (0x02060000, One) Notify (ALSD, 0x80) // Status Change } If ((^^^^LID._OLD != Local0)) { Notify (LID, 0x80) // Status Change ^^^^LID._OLD = Local0 } } } Besides me not seeing any reason to declare _OLD in LID. The idea itself shouldn't be too bad right? Well, as I said, his fix didn't work.
       
      In fact, to prove that Method _Q81 doesn't have anything to do with the issue at all, I created a Clover/Opencore patch to change _Q81 to XQ81. This resulted in my lid not working at all of course, but the log flooding still persisted!
      So _Q81 doesn't have anything to do with the issue afaik.
       
      Now, further Google searches led me to a chinese post where he tied the issue to VirtualSMC. And indeed, by migrating to FakeSMC the issue is no more.
       
      Unfortunately, I'm very fond of VirtualSMC for various reasons. So I would very much like to keep it. If not I'd have to implement the old way of doing Battery monitoring etcetc. Which isn't very elegant and update proof as it requires DSDT patching.
       
      So, I do believe that the issue may very well be in the DSDT code, perhaps in the ambient light part. I'm not very skilled at this and just started studying the ACPI spec 3 days ago.
       
      Could someone please help me out? Thanks a lot in advance
       
       
      origin.zip
      OC.zip
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
×