Jump to content
marionez

Realtek ALC1200 ICH10 working kext on Yosemite 10.10 from 10.6+

579 posts in this topic

Recommended Posts

Ok I think I got it! :)

Device informations:

Realtek ALC1200

00:1b.0 Audio device [0403]: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller [8086:3a3e]

Device ID: 0x3a3e8086

You can find ALC1200 on:
Asus P5Q tested ok
Asus P5Q3 tested ok
Asus P5Q-EM tested ok
Asus P5Q-VM tested ok
Asus P5QL-EM tested ok
Asus P5Q-Pro tested ok
Asus P5Q-SE tested ok
Asus P5Q-SE/R tested ok
Asus P5E3 PRO tested ok
Asus P5Q-C tested ok
Asus P6T tested ok
Asus P6T-SE tested ok
Asus P5QL-PRO tested ok
Asus P6T deluxe
it's an AD2000b!
Asus M3A78-EM it's an ALC888!
Asus P5N7A-VMtested ok
Asus P5QL-E tested ok
Asus M3N78-EM tested ok
Asus M3A-H/HDMI
Asus M3A78-T
Asus M3A78 PRO
Asus P2-M3A3200
Asus M3N78-EM
Asus P2-M3A3200
Gygabyte GA-EP43-S3L tested ok
Gygabyte GA-EP43-DS3L tested ok
MSI P45 NEO3-FR tested ok
MSI P43 tested ok

GA-945GCMX-S2 tested ok

 

Please signal errors, and missing motherboard (or laptop??) models ;)

==================================================


Howto install:
- choose and download kexts pack for ALC1200
- remove VoodooHDA ALCinjector.kext AppleHDA.kext (don't remove this if you're installing legacy version) ALC1200fix.kext and any audio kext you could have installed in /Extra or in /System/Library/Extensions
- unpack the zip file
- run kexthelper
- install kexts
- reboot


Obviously backup kexts you need.

====Q/A====
Q: What happens when I commit an update, for example from 10.6.1 to 10.6.2?
A: You must reinstall those hacked kexts, because the update overwrite the vanilla hacked applehda kexts.
Should even happens that the update doesn't overwrite the old applehda kext driver, so in this case, you don't need to reinstall.

Q: I'm experiencing pop sound, how can I solve this?
A: Try setting your hack as MacPro3,1 in /Extra/smbios.plist

===========

==================== MAVERICKS 10.9 AND MOUNTAIN LION 10.8 ==========================
Only DSDT method.

ALC1200_lm_108.zip
- edit DSDT pointing to 12 (hex 0C) layout ID, as on the HDEF text file attached
- install AppleHDA.kext attached
- cache rebuild
- reboot

;)

this is from my dsdt (Asus P5Q with E8400 and 4GB ram) so you can understand where you have to put the hdef code. DSDTEditor is recommended. Edit your DSDT, don't use mine.
dsdt.zip

these are the xmls needed for our ALC1200 to work right
layout_and_platforms.zip

==================== MAVERICKS 10.9 AND MOUNTAIN LION 10.8 ==========================

==================== SNOW LEOPARD and LION ==========================
**First method**: with DSDT Injection, patched AppleHDA, and NO HDAenabler attached.
AppleHDA_ALC1200_HDEF.zipremove AppleHDA.kext from /S/L/E and install this after dsdt edit.
HDEF code is attached in the zip pack, put the HDEF code in:
- SCOPE _SB
-- Device PCI0
--- Device HDEF

**Second method**: easier, no quality differences: with HDAEnabler and no DSDT editing.
[latest] ==> ALC1200 for Lion 10.7 and Snow Leopard 10.6.3, 10.6.4, 10.6.5
ALC1200_1063.zip
==================================================

older 10.6x versions:
- SL 10.6.2 modded kexts
ALC1200_1062.zip
- Snow Leopard 10.6.0 and above ALC1200 audio kext:
ALC1200_106.zip

==========OLD STUFF==========
ALC1200 driver for 10.5.x :
I think latest ALC1200_SLIM version could be considered "final", I'm running 10.5.6 and I'm working on this OSx version.
For previous OSx version you can try installing only the ALC1200fix and the HDAEnabler from ALC1200_1056LINEIN version and see if that works.
The other ALC1200 kext versions out on the forum are old and I think can even cause some shutdown/reboot issue.
This driver doesn't work with ALCinjector.

- SPDIF coaxial Digital Out working
- Headphone working
- Line in is working only in the slim and line-in version, read notes down this post

-----------

Works on 10.5.7, just download and reinstall the driver.
Choose driver version, I think best choice is the slim version:
1. Update (4th june 2009) slim version from 10.5.7 applehda with: green line out, headphones, rear mic, line in and spdif out
I removed not needed verbs for multiple channel output (I don't need them)
ALC1200_1057_SLIM.zip 4th june 2009 10.5.7 version [latest]

----
ALC1200_SLIM.zip[/b] 19th april 2009 10.5.6 version (discontinued)
2. Normal version with no line-in, you can switch between front/rear mic without any trouble
ALC1200_1056.zip

3. This is a beta version with all three input working, line-in, front mic and rear mic, front-mic has some trouble :P
This version works but if you switch between inputs, front mic stops working (only for that session obviously, if you reboot it works). This happens because ALC1200 has 1 digital mixer node for 2 channel (linein and front mic) instead of one, so if you come back from line-in input, to front mic, front mic stops working.
At the moment I would think this driver can't manage thing like this, so I don't know if we could have a better driver than this.
Anyway I wanted a working line in and if you select this and use it, that works, so if you need line-in you should use this version. ;)

Update (14th april 2009) with RCA spdif in "about this mac"


Update (17th april 2009) removed ALC1200fix.kext from the pack

If you're updating your driver, in order to install this, remove ALC1200fix.kext from your extension folder, then install this with kexthelper.
Now in sound preference there's no (useless) "Internal speaker" "Built in" for input and output.
post-303759-1239643716_thumb.jpg

==================================================

Thanks the whole forum, especially this thread, TheKing and Taruga ;)
Removed verbs they're too large.

This is how looks like About this mac:
post-303759-1239380116_thumb.png

You're lucky,
enjoy it!!
:)

Share this post


Link to post
Share on other sites
Advertisement

The main difference is that ALCinjector is not needed, so you're running a clean vanilla AppleHDA kext from latest 10.5.6 update just modded for ALC1200.

On the other hand this driver has potential to be fully working. Line-in could be on the to-do-list, I've not so many time to spend, but I'll try.

Share this post


Link to post
Share on other sites

marionez

 

thanks this solved my restart, shutdown and sleep issues on my p5q em. sleep is working perfect and still testing the restart shutdown. audio works good. everything on the motherboard works (except the x4500 graphics, got a cheap 9500 GT)

 

 

 

Thank you for taking the time and sharing!!

Share this post


Link to post
Share on other sites

Oh my ... marionez!

I love you!

Woooozaaa... I could jump around in circles!

I have a 100% working PC now!

 

This solved theshutdown issue!

 

Wohooo

Share this post


Link to post
Share on other sites
Howto install:

- remove ALCinjector.kext AppleHDA.kext and his friends from /System/Library/Extension

- remove /System/Library/Extension.mkext (not needed at all)

- unpack the zip file

- run kexthelper

- install kexts

- reboot

did anyone try to install on /Extra/Extensions?

 

this solved my restart, shutdown and sleep issues on my p5q em. sleep is working perfect and still testing the restart shutdown. audio works good. everything on the motherboard works (except the x4500 graphics, got a cheap 9500 GT)

 

weird...

 

i got errors about HDAEnabler not loading/duplicate, never had sleep issues tho

 

P5Q-EM

Core2Quad Q6600

4GB RAM

NVIDIA GeForce 8800GT 512MB

 

Mustang Sally, (since we have the same mobo), how do you install the custom kexts?

 

/Extra/Extensions to keep your system vanilla?

or in /System/Library/Extension?

Share this post


Link to post
Share on other sites

Kexthelper install kexts in /System/Library/Extension remove those audio kexts you installed on the other thread in /Extra/Extensions ;)

 

Happy to see that works :)

Share this post


Link to post
Share on other sites

I thought you should all know that Marionez' kext for the ALC1200 kext is a twofer (two for one). Not only does it work perfect, near as I can tell, but it also dramatically improved the sleep function. The old sleep fix seemed to simply kill the machine immediately whereas now it actually seems to go to sleep properly. My Hackintosh light even blinks to show it is in sleep mode, which it did not with the other 'fix'.

 

Nice work marionez!!!!!!!!!

 

By the way Marionez, my network won't come back up after sleep. Do you know of any vanilla fix for this that does not involve fixed IPs?

 

Thanks and keep on rockin!

Share this post


Link to post
Share on other sites
Kexthelper install kexts in /System/Library/Extension remove those audio kexts you installed on the other thread in /Extra/Extensions :blink:

kexthelper sure does put them in /System/Library/Extensions, i just wondered if there's a way to stay vanilla

 

anyway, it seems that your pack needs to reside in /System/Library/Extensions

 

i tried running it from /Extra/Extensions with vanilla kexts @ /System/Library/Extensions and it'd barf out several errors, ending up in sound not working

 

---

confirming that it also works with Asus P5Q-EM:

 

on a fresh vanilla install, removing the original AppleHDA.kext and installing marionez 3-kext pack with kexthelper, looks like it's working ok

 

post-404685-1239473986_thumb.pngpost-404685-1239473995_thumb.png

post-404685-1239474011_thumb.png

---

 

by inspecting the logs i see that it still complains @ boot time, though it does work once logged-in:

11/04/09 7:53:50 PM	kernel	Class "HDAEnabler" is duplicate	
11/04/09 7:53:50 PM	kextd[18]	kmod_control/start failed for com.kext.HDAEnabler; destroying kmod	
11/04/09 7:53:50 PM	kernel	Duplicate class	
11/04/09 7:53:50 PM	kextd[18]	a link/load error occured for kernel extension /System/Library/Extensions/HDAEnabler.kext

 

again this is a vanilla install so i find it really weird since there's only one instance of HDAEnabler

 

(no nagging from me, just thought to give some feedback :) )

Share this post


Link to post
Share on other sites

You're right there's a duplicate of HDAenabler! I'm going to update the #1 post kext pack

 

I even attached a line-in version, is not working very well, but it could be a good beta version, there's some trouble switching between inputs. I think I set a wrong mixer node, but I'll work on it later.

 

http://www.insanelymac.com/forum/index.php...st&id=48413

Share this post


Link to post
Share on other sites

Hi!

 

I have new idea for Realtek 1200 audio driver.

 

Briefly:

Audio works cool with digital output, but i can't volume level up or down in preferences/sound settings.

I can't setting digital output.

In any application i can modified volume level!

 

I have new DTS music and iTunes play the soungs in static, this is fake!

Here is link from Apple:

support.apple.com/kb/TA47850?viewlocale=en_US

 

 

I have Logitech Z5500 sound system. In system is DTS decoder.

 

My discovery is with VLC i can play DTS music, but this is not elegant:)

 

I think with driver is a problem.

Share this post


Link to post
Share on other sites

OMG, my English is not that good, but it's quite difficult to understand what you wrote... could be even nice placing some "please" "thanks", you're not going to pay for this driver :P

 

The issue: Digital Out works but you can't set the volume, right?

I've never used a digital coax connection, is there a volume control? Maybe not in osx.

I would think that audio signal is sent in digital then you set the volume on your audio system.

But this could be a wrong though, I definetely don't know about it.

I don't think it's a specific driver issue, read this: http://www.insanelymac.com/forum/index.php?showtopic=102786

 

I thought you should all know that Marionez' kext for the ALC1200 kext is a twofer (two for one). Not only does it work perfect, near as I can tell, but it also dramatically improved the sleep function. The old sleep fix seemed to simply kill the machine immediately whereas now it actually seems to go to sleep properly. My Hackintosh light even blinks to show it is in sleep mode, which it did not with the other 'fix'.

 

Nice work marionez!!!!!!!!!

 

By the way Marionez, my network won't come back up after sleep. Do you know of any vanilla fix for this that does not involve fixed IPs?

 

Thanks and keep on rockin!

 

Great, click on ATL1E link in my signature and download latest version, this works even after sleep :(

Share this post


Link to post
Share on other sites

the new audio driver works for my p5q-pro!

 

it completely solve my shut down issue, because, when I did my install I did install every new driver one by one and noted that that was the old alc driver cause the shutdone issue! so glad to have 100% worked

Q9450-8g 800 ddr2-ATI 4870-Vertex system.

Share this post


Link to post
Share on other sites

Everythings work fine with new ALC1200_1056 package!

Realy nice work Marionez :P

 

The digital output work quite perfect.

I will ask little things:

 

With QuickTime and VLC work DTS or AC3 :thumbsup_anim:

But with iTunes work not the DTS, only static sound coms out.

Have you got a idea for this problem?

 

Nice work the new AttansicL1 driver. After sleep works fine, but sleep don't work only 2 sec.

Share this post


Link to post
Share on other sites

Fecso I started mixer on windows and I confirm that there's no SPDIF volume available.

About iTunes and dts track I can't help, I hope some other could, but maybe this is not the right thread.

 

About line in: This version works but if you switch between inputs, front mic stops working (only for that session obviously, if you reboot it works). The problem is that in ALC1200 there's one digital mixer node for 2 channel (linein front mic) instead of one, so if you come back from line-in choose to front mic, front mic stop working.

At the moment I would think this driver can't manage thing like this, so I don't know if we could have a better driver than this.

Anyway I repeat I wanted a working line in and if you select this and use it, that works, so if you need line-in you should use this version. :P

Share this post


Link to post
Share on other sites
Fecso I started mixer on windows and I confirm that there's no SPDIF volume available.

About iTunes and dts track I can't help, I hope some other could, but maybe this is not the right thread.

 

Potentially stupid observation (in that I am stupid):

 

Can you control digital volume at the source? I have some high end audio gear and volume can only be controlled at the amp because there is no way to 'reduce' a digital signal, it is either on or off. It's not like analog.

 

Again I am not sure of how it works on pc's because I don't have gear to test.

 

 

 

 

Great, click on ATL1E link in my signature and download latest version, this works even after sleep :P

 

Network now comes back after sleep, absolutely OUTSTANDING and a big THANK YOU!!!!

 

It may have even fixed the random shut down issue. I was able to recreate the shut down problem by doing sleep, wake up, shut down. Now it seems to work fine but I will confirm after some more tests.

 

Cheers!

Share this post


Link to post
Share on other sites

Atta great work, marionez! Kudos to you! I almost given hope for my sounds and line-in. Now I'm happier than before! :)

Share this post


Link to post
Share on other sites

Thanks a million Marionez for your excellent work & effort for the new audio driver! it really makes everyone of us happy! ;)

 

However, anyone of you confirmed that 8 channel audio works?

Share this post


Link to post
Share on other sites

Great ;)

About 8 channel I think this wouldn't work, this is an AppleHDA patched and I don't know about any iMac with 8 channel output. Maybe the best (and quite expensive) way to have a splitted audio is the spdif out in a spdif sound system.

Consider with this driver you have to choose one output between those you have, 8 channel it's very different.

Anyway perhaps someone could help this and maybe feedback about it.

 

update: these above was wrong, read this: http://www.insanelymac.com/forum/index.php?showtopic=87336

 

I tested VodooHDA driver and is not working, there's no input working.

Share this post


Link to post
Share on other sites

Oh sorry there is an issue

 

from my P5Q-Pro mobo, it comes with the coaxial SPDIF output so, it is not a optical digital output. So I can;t get the digital out functioning as the kext I guess was being modified to with optical output, is that any chance to create a version that suit for ALC2000 with coaxial digital output interface?

 

thanks

Share this post


Link to post
Share on other sites
This ALC1200 can't suite with ALC2000, that has different codec dump.

If you want to give me a codec dump we can try to create a driver that suite with ALC2000: http://www.insanelymac.com/forum/lofiversi...php/t46378.html

 

Don't care about what is written in about this mac :P

 

 

sorry That was a typo, should be ALC1200, i have p5q pro as wel

 

not sure why mine one is not working....

 

thanks for your help,

Share this post


Link to post
Share on other sites

Yes it works, in this moment I'm playing mp3 with iTunes on the Digital Output (you've to choose this in system preferences - sound preferences - output), connected the ALC1200 spdif out on my external usb audio card spdif in, and with garageband I'm monitoring the usb audio card output, quite difficult to explain, but works very well... :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://tinyurl.com/rkqmpd9
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By Tristana
      Hello, and thank you for your help!
       
      Ever since installing my new Sapphire Radeon Pulse RX580, I've been having issues with audio freezing up for the whole system- seemingly the coreaudiod process crashing / my USB audio interface not working. It feels random but seems to correlate with playing youtube videos, streaming audio in Finder, playing sound files from chat clients like Telegram/Discord and such. The system otherwise works as normal, with only audio related functions breaking. Sometimes instead of a full freeze / crash, the sample rate of audio will just drop significantly, causing a lot of aliasing.
      I followed this guide here, though it is outdated and some KEXTs have been merged with WhateverGreen. The shikigva=4 & -rad4200 boot arguments weren't available in WhateverGreen so I didn't add any boot arguments.
      https://hackintosher.com/guides/fix-rendering-issues-fcpx-high-sierra/
       
      My issue was not fixed by this. I also learned that USBInjectAll hadn't been given a custom SSDT and so I made one, which I have included at the end of this post. I also disabled the 15 port patch which had been left on. My USB ports now show up properly (though I've excluded my mobo's type-c port to meet the 15 port limit). My audio issues still have not been fixed, though.

      On High Sierra, the crash was irrecoverable- opening sound in system prefs just froze up, and I have to reset the system to get audio back. In Catalina, I seem to be able to choose a different audio device then go back to my external interface to reset the driver and get sound back.

      Thank you for any help / ideas you can offer!

      UPDATE: Issue still persists. I'm now using a USBPorts.kext created by Hackintool and have updated my list of current kexts below.

      System:

      Kexts:


       
       
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By Kailash
      I successfully managed to install Hackintosh on my Lenovo Ideapad 520 but now I don't have audio, brightness control feature or battery indicator. My audio driver is an ALC230. I am new to all this. What do I do to solve this? I have attached my EFI files below.
      EFI.zip
×