Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Launchctl not passing start|stop parameter to wrapper script

1 post in this topic

Recommended Posts



I'm trying to create a plist that calls a shell script wrapper. I've verified that launchctl is calling my shell script, but it never passes the 'start|stop|restart' argument. All the wrapper-script example on the net use the RunService method (in /etc/rc.common).


How do I write my plist and/or run launchctl, such that it actually passes the $1 parameter necessary to get RunService to work?


My plist looks as follows:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "


<plist version="1.0">






















tux-launchd.sh looks as follows





source /etc/rc.common


echo "Param-count: $#"


StartService() {

echo "start"



StopService() {

echo "stop"



RestartService() {

echo "restart"



RunService "$1"




When I look in my log files (/Library/TuxHub/jail/home/tux/logs/launchd.stdout)

All I see is

Param-count: 0

Param-count: 0

Param-count: 0

Param-count: 0

Param-count: 0



Thanks in advance



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.