Jump to content

problem dualbooting vista and leo4all v3


3 posts in this topic

Recommended Posts



okay, so, a year ago i was trying to make a dualboot between my xp and osx (used leo4all v2 back then). it worked well, but i don't really remember the kext's i checked at the installation, nor how i made the partition for it. so, i decided to do it again. as i didn't remember the distro i was using, i got the first one i saw (iPC osx86 something..). okay, after the installation i got "boot() : error", couldn't boot into my xp. i BARELY fixed it, actually, i installed another windows on my broken one, so that i had 2 windows folders on my C:/. "WINDOWS" and "WINDOWZ", i did that, because i didn't want to format it, and loose all my files. so i bought a few dvd-rw's and burned all the files and installed vista instead of xp. i gotta say vista is much better for dualbooting now. okay, after the vista was installed, i wasn't gonna give up. i found my old account on the insanelymac's forum with all the topics and posts i did, and i found that i was using leo4all v2 back then. ok, i grabbed the latest version, which is leo4all v3. burned it. and now was the time i split my hdd and make a new partition for osx. and i don't know how to do that the proper way. should i get the acronis director and do it there? or should i get partition magic and do it there? or can i just do it with diskpart? well, actually, i was doing all this following this method/tutorial (

), which is:


1) open up the disk management (my computer -> manage)

2) shrinked the volume

3) set the partition size to 25GB

4) now it's showing me "Unallocated space", so i click and select "New Simple Volume"

5) i named it "Mac OS X", and checked the "Quick Format" and "File and Folder Compression", however, i did not change the NTFS to FAT32, as the he didn't do it either, but i knew i should have. (i did this with FAT32 later on, but it didn't help)


6) now i what i did is Start -> Run and typed "diskpart"

7) list disk

8) select disk 0

9) list part

10) select part 2 (the new partition i made for osx)

11) active


that's it. is this a good way to do this or NOT? i believe i was making the partition last year a different way. only with diskpart and using the create part id=af or something.


ok, now i restarted my pc and booted with cd/dvd and the install pops out, i did all like it's showed in the video, nothing special there, until i reached the Customize button, i clicked it, and.. i checked the kernel 9.2.0 (was already checked), sound kext, nfroce (internet) kext, nvidia kext, amd fix (was also already checked), however i did not select any of those AppleSMBIO or something, what is it exactly? it also had 0 kb, like it's empty or something. that's about it. i clicked install. (i did skip the verify). the installation went successfully. rebooted the pc and the first time i did this with vista it was showing HFS+ partition error (something like that), and i couldn't get into Vista nor the OSX installation continued. however i put the Vista installation disc in, and fixed it like it shows in the video. ok, so i rebooted my pc, and the HFS+ partition error was gone, however, i had the option to switch between vista AND osx, i could choose one of those to log in. as i had that, i tried to enter osx again, i thought i fixed it at the moment, as i clicked the osx hdd, it was running all this text (-v?). i was leaving it to do that for 2h hours but it kept doing the same error all over again. something like this:


CODE SIGNING: cs_invalid_page: p=176[update_dyld_shar] clearing CS_VALID

localhost rpc.statd[177]: can't open statd.notify pidfile: Invalid argument (22)


okay, i tried to find how to fix this, and i typed down to my notes that i should try to type "rd=disk0s1 -F" in the Darwin window next time. so i did, and a window popped out with the apple logo and it said that i should restart my pc. okay, that didn't work, so i tried just typing "-F", again, apple logo popped out but this time it had this circle circling down below it, like in the core installation, but i realised that's the same (-v) thing, only with the picture. so i failed, again. so my question is HOW do i create the partition for my osx the proper way? was my way OK? and how do i fix this CODE_SIGNING thing etc.? after the main installation of osx, and after the rebooting it just goes either HFS+ partition error and after fixing it the CODE_SIGNING thing. how do i fix this? so that it continues the install?




CPU: DualCore AMD Athlon 64 X2, 2800 MHz (14 x 200) 5600+

Motherboard: Gigabyte GA-M57SLI-S4 (2 PCI, 3 PCI-E x1, 2 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN, IEEE-1394)

HDD: SAMSUNG SP2504C (250 GB, 7200 RPM, SATA-II)

STORAGE: NVIDIA nForce 590/570/550 Serial ATA Controller

Sound: Realtek HD Audio

Video: NVIDIA GeForce 7600 GS (512 MB)



Link to comment
Share on other sites

okay, so i tried again.


deleted the osx partition. created a new one via the disk management, but i didn't use diskpart and make it active.

booted into the dvd, erased the disc (mac os journalised), didn't check anything in Customize (only the defaults), and clicked install.

and i didn't have HFS+ partition error this time. i pressed F8 and in the Darwin typed -s. and what i got is: STILL WAITING FOR ROOT DEVICE.




edit: wow, this really comes all the way around to the same problem i had year back.

topic - http://www.insanelymac.com/forum/index.php...mp;#entry697606

Link to comment
Share on other sites

just now tried again. this time i DID select few things in the Customize.


- Old nforce chipset driver

- Kernel 9.2.0 (checked by default)

- ALC883

- AMD fix (checked by default)


everything went smooth, the installation was ok, no HFS+ partition errors after.

okay, now when i tried -s in the Darwin boot i got this:


Root device is mounted read-only

if you want to make modificiations to files


/sbin/fsck -fy

/sbin/mount -ua


if you wish to boot the system




what the hell? okay, at least i could type something now. and i'm supposed to write the following here:


fdisk -e /dev/rdisk0

flag 1




but when i tried to write the "fdisk -e /dev/rdisk0", it said that it couldn't find it and it showed a totally different directory or something.. so i didn't bother.

i rebooted the pc and tried again, wrote -s, and this time i typed exit so that it boots. yeah, well.. and what i got? the same old:


CODE SIGNING: cs_invalid_page: p=176[update_dyld_shar] clearing CS_VALID

localhost rpc.statd[177]: can't open statd.notify pidfile: Invalid argument (22)


repeating, repeating and repeating. it goes infinitely.


and btw now i'm following this guide (http://dailyapps.net/2008/03/hack-attack-dual-boot-leopard-and-windows-vista/), only Leo4All v3 instead of the iATKOS.


oh and one more thing, so that i get it clear.





so, i guess instead of writing rdisk0 everywhere, i need to write rdisk0s2, because the OSX is on my SECOND partition, right?




Link to comment
Share on other sites


  • Create New...