Jump to content
lukamar

[GUIDA] Installare (Snow) Leopard RETAIL su HD MBR

75 posts in this topic

Recommended Posts

Guest James.1979
James.1979 che bootloader hai installato?

Sulla penna USB ho installato il Chamaleon 2. Non so proprio come muovermi ora. Grazie!

Share this post


Link to post
Share on other sites
Advertisement

Devi installarlo anche nella partizione dove hai installato leo. Per farlo boota col cd di boot-132 caricando leo installato nell'hd. Come una normale retail insomma.

Share this post


Link to post
Share on other sites
Guest James.1979
Devi installarlo anche nella partizione dove hai installato leo. Per farlo boota col cd di boot-132 caricando leo installato nell'hd. Come una normale retail insomma.

Eh lo so che bisogna installarlo anche in mac installato, almeno questo dai :P . Cmq essendosi rovinato l'unico cd riscrivibile di cui dispongo attualmente, ho optato avviando la iatkos v7 e installando solo il chamaleon 2. Tutto ok. Solo che ancora non carica.

 

 

Praticamente...

 

Installo dalla penna USB (esce messaggio di installazione non riuscita)

 

Avvio jatkos v7 da un altra penna USB e installo il chamaleon v2

 

Carico con -f -v ma non parte si blocca ad AppleUSBAudio (e delle altre scritte che ora mi sfuggono).. spero di risolvere eliminando questo kext dal DVD(usb) di leo (provo prima da windows) e reinstallo. Fortunatamente l'installazione ci mette veramente poco. tempo di una sigaretta e la trovi installata :( !

 

 

 

Saluti, James

Share this post


Link to post
Share on other sites
Guest James.1979

Finalmente parte la retail ragazzi... wow che emozione :D , ma purtroppo sono fermo alla schermata di benvenuto che carica di continuo quando scelgo di non eseguire nessun trasferimento di dati da un mac vecchio. Talmente delle tante volte che ho provato la/le procedure (risultato di svariate ricerche) l'ho imparata a memoria in 5 minuti. Faccio così alla lettera:

 

/sbin/fsck -fy

 

 

/sbin/mount -uw /

 

Passwd root (qui non mi lascia proseguire in quanto non mi acccetta la password non so per quale assurdo motivo.. ho provato diverse combinazione ma non ne vuole proprio sapere purtroppo

 

touch /var/db/ .AppleSetupDone /

 

reboot

 

Non so x quale assurdo motivo non vuole funzionare quel maledetto comando :(

 

Cmq lo so che è agosto e quasi tutti siete in vacanza (beati voi) ma dai se vi trovate di passaggio e leggete datemi qualche risposta..ve ne sono grato

Share this post


Link to post
Share on other sites
Guest James.1979

Niente da fare caxxo.. non riesco a bypassare questa maledetta schermata della creazione utente, la quale si riavvia sempre spuntando la casella di nn trasferimento di nessun dato dal vecchio mac. Non mi accetta in nessun modo il comando Passwd root e quindi non entrando come root non mi fa modificare il file AplleSetupDone.

 

Ho provato mille volte con mille combinazioni diverse per la password senza alcun successo. Qualcuno pratico della modalità -s oppure che so del terminale ha qualche idea alternativa? Come potrei dirgli che mi deve far modificare AppleSetupDone?? Sono stressato è da ieri che provo e qui nessuno risponde più :)! Che tristezza sta retail! Forse sono destinato a non poterla avere, mi spiace davvero. Caspita ero a un soffio dalla fine. Peccato.

Share this post


Link to post
Share on other sites

hai provato a cmbiare le password dal dvd di installazione?

 

Edit: per la cartella desktop questa notte provo poi faccio sapere....

Share this post


Link to post
Share on other sites
Guest James.1979
Niente da fare caxxo.. non riesco a bypassare questa maledetta schermata della creazione utente, la quale si riavvia sempre spuntando la casella di nn trasferimento di nessun dato dal vecchio mac. Non mi accetta in nessun modo il comando Passwd root e quindi non entrando come root non mi fa modificare il file AplleSetupDone.

 

Ho provato mille volte con mille combinazioni diverse per la password senza alcun successo. Qualcuno pratico della modalità -s oppure che so del terminale ha qualche idea alternativa? Come potrei dirgli che mi deve far modificare AppleSetupDone?? Sono stressato è da ieri che provo e qui nessuno risponde più :( ! Che tristezza sta retail! Forse sono destinato a non poterla avere, mi spiace davvero. Caspita ero a un soffio dalla fine. Peccato.

 

Se può servire a qualcuno, ho risolto così

Share this post


Link to post
Share on other sites
Ciao, nessuno ti risponde perchè nessuno l'ha fatto dalla 10.5.4, se iniziavi a scaricare la 10.5.6 qundo te l'avevo detto io, ora avresti già finito.

 

lukamar, ti ho risposto in PM, ho cancellato i miei post in quanto facevano solo confusione.....

Aspetto di provare con la 10.5.6

Ciao e grazie

Share this post


Link to post
Share on other sites

bhè che dire... sarà la grande sfiga che mi perseguita da quando o posato i piedi in questa valle di lacrime ma non riesco ad andare oltre al comando

/Applications/TextEdit.app/Contents/MacOS/TextEdit /Users/Luca/Desktop/OSInstall/Distribution

che apre textedit ma da terminale poi non posso più far altro, mi esce da bash e anche se digito comandi non succede nulla... mi da un errore ora riprovo e casomai lo posto se non riesco ancora.

P.s. domanda cretina: la stringa se la cancello "manualmente" e poi salvo, mi va lo stesso?, poi come concludo da terminale , gli ultimi due comandi:

cd ~/Desktop/OSInstall/

xar -cf ./OSInstall.mpkg *

non ottengo risultati......

P.s. per lukamar: era 10.5.6 il link?

ciao e grazie

Share this post


Link to post
Share on other sites

Ciao, si 10.5.6.

Con questa versione non serve che apri il textedit perchè puoi direttamente sostituire l'OSInstall postato. Se hai così tanti problemi ad usare il terminale, leggiti la guida in inglese da cui ho preso spunto, e usa il metodo suggerito lì che fa meno uso del terminale.

Share this post


Link to post
Share on other sites

no no io sono molto testardo..... insisterò col terminale, anzi sto cominciando a "studiare" un po di unix

Mi bastava sapere che fosse la 10.5.6

.... praticamente salto il comando che apre il text edit e vado avnti con gl'altri, sostituendo il pacchetto, "graficamente"?!

ok non rompo più le balle e provo... cercherò di capire la guida in inglese... e vado ad accendere un cero in chiesa...hahaha

ciao e grazie

Share this post


Link to post
Share on other sites

AGGIORNAMENTO (13/9/09): La procedura è valida anche per Snow Leopard, l'unica differenza è l'intervento da fare nella stringa, lo troverai al punto 2. Questo aggiornamento sostituisce il precedente, e l'intervento torna necessario e sufficiente solo nella riga incriminata, non sono necessarie altre modifiche aggiuntive. In ogni caso posto l'OSInstall per Snow Leopard modificato e testato da me.

Share this post


Link to post
Share on other sites

Ciao.

Non sò se è stato detto, non ho letto tutto perchè diciamo risento ancora dell'alcool di ieri sera e quindi sono ancora un pò cotto.

Mi chiedevo che differenza c'è tra installare in GUID o in MBR?

 

Premesso che se si installa in MBR puoi avere anche Windows sul solito HD.

 

Ci sono svantaggi di velocità del sistema, apparte il boot che ho letto ?

 

Grazie mille per la risposta.

Ciaooo.

Share this post


Link to post
Share on other sites
Uguale, forse pure il boot in realtà non ne risente.

 

Perfetto...

Allora penso proprio che presto proverò a installarla sopra il vecchio LEOPARDO e sul mio disco Interno.

Grazie mille per la risposta.

Ciau.

Share this post


Link to post
Share on other sites

Ragazzi, scusatemi, ma non mi è chiara la parte C quando si digitano i comandi da terminale. Creo la cartella OSInstall, poi apro il terminale, copio quel comando lo incollo, premo invio e non succede nulla (almeno credo)

Share this post


Link to post
Share on other sites

La guida dice che la procedura è valida anche per Snow Leopard ma volevo comunicare che a me non ha funzionato.

Ho modificato l'immagine .dmg di snow con L'OSInstall postato, poi ho seguito la guida per installare la retail ma purtroppo l'installazione non si avvia nemmeno con le cannonate.

Ho anche postato una richiesta di aiuto in questo topic: http://www.insanelymac.com/forum/index.php?showtopic=186797 ma per ora nessuno è riuscito a darmi un suggerimento che funzionasse.

Share this post


Link to post
Share on other sites
Ragazzi, scusatemi, ma non mi è chiara la parte C quando si digitano i comandi da terminale. Creo la cartella OSInstall, poi apro il terminale, copio quel comando lo incollo, premo invio e non succede nulla (almeno credo)

 

Come faccio a vedere se l'operazione "parte C" della guida sia andata a buon fine ???

Share this post


Link to post
Share on other sites

Salve a tutti,

Recentemente ho avuto l'idea malsana di installare SL da retail su un hd partizionato. Allora ho sostituito il file osinstall nella iso con quello scaricato qui per snow leopard usando transmac e rimasterizzato su un DL. Ho preparato il mio boot321 con kext fixato per ich9.SI avvia. Vedo l'HD e le partizioni ma purtroppo niente MBR... mi costringe al GUID.

Domande:

1) Ho forse la retail sbagliata... come faccio a controllare la versione?

2) Vi è modo di testare quella parte di installazione da osx prima di masterizzare il dvd?

3) Ho provato con molto successo a copiare il dvd su HD esterno con l'utility disco e poi installandoci su Chameleon per installare tutto da HD. Addirittura ho un hd esterno con 3 partizioni che installano rispettivamente la 10.5.7, la 10.5.8 e la 10.6.2 TUTTE Funzionanti.

L'unico dvd con cui non mi funge questo metodo è la retail, che dopo il caricamento con la mela mi finisce in una schermata grigia con il puntatore del mouse e basta. Qualcuno sa per caso il perchè?

Grazie in anticipo un grosso abbraccio.

Share this post


Link to post
Share on other sites

scusate la domanda... ma non sono espertissimo per certe modifiche!

 

se posseggo la versione 10a432 e sostituisco l'OSinstall con quello postato non devo fare nient'altro per installare su MBR, giusto?

Share this post


Link to post
Share on other sites

Ho seguito la guida, ma al punto C, quando tento di sostituire il file da terminale mi viene restituito il seguente errore:

-bash: DVD/System/Installation/Packages/: No such file or directory

 

Io sto usando un'immagine dmg creata in read/write come da guida, non sto usando il DVD insomma.

 

Come posso risolvere ?

Grazie

Share this post


Link to post
Share on other sites

Ho una domanda, se quando vado a installare la mia immagine patchata invece di usare la guida postata da te uso questa, che ha sempre funzionato in passato, solo che invece di fare una partizione guid ne faccio una mbr, può funzionare?

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×