Jump to content

10.5.6 - 7600GS and ALC888 Headache


2 posts in this topic

Recommended Posts

I installed Mac OS Leopard Retail 10.5.0. I installed an EFI bootloader via EFIStudio 1.1. I put nvInject on the EFI Extension folder and on reboot, I had resolutions, Quartz, and Core Image. I added AppleSMBIOS from a forum post on here in the same folder and it worked fine. I didn't try audio at this point.

 

I updated to Leopard 10.5.6 via Apple software update as well as all other updates available as of March 14, 2009.

 

On reboot, I still had resolutions, but I lost Quartz and Core Image acceleration. I tried Titan, Natit, nvKush, and Leopard Graphics Update 1.0 (found on same site as nvKush) with no change, so I went back to nvInject. The Device IDs (pulled from System Profiler) are:

Chipset Model: GeForce 7600 GS

Type: Display

Bus: PCIe

PCIe Lane Width: x4

VRAM (Total): 256 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0392

Revision ID: 0x00a1

ROM Revision: NVinject 0.2.1

 

This is when I decided to tackle audio. I tried using the HDA patcher tool with a Linux codec dump and it gave me outputs, but no sound. I deleted AppleHDA and downloaded AppleAzaliaAudio.kext and put it in my Extension folder. I edited it with my device IDs and audio hub id which are as follows:

0x27d88086 - Intel ICH7 HD Audio Hub

0x10ec0888 - Realtek ACL888 Audio

 

No matter which version or copy of AppleAzaliaAudio I use, I get no outputs in Preferences or on the Audio/MIDI tool. I don't care about input, but I just would like sound.

 

I used OSx86 tool to dump PCI/DEVIDs and attached the resulting file in case it helps. My motherboard is a 775i945gz.

lspci.txt

post-3472-1237168508_thumb.png

Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...